%%ItemTitle%%

See Also
ActiveInstall Online Documentation Send Feedback on this topic.

Introducing ActiveInstall

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Welcome to ActiveInstall Help!

This Help File is provided to assist you in getting to know your way around ActiveInstall. The help file is broken down into the following areas:

Help Categories:

  • Introducing ActiveInstall - This section.
  • Getting Started - A brief introduction and tutorial on how to get up and running quickly.
  • User Guide - Detailed information presented in a per screen format to make finding the information you need as easy as possible.
  • ActiveInstall IDE Reference - A complete guide to the IDE
  • ActiveInstall Extensibility - Your guide to extending ActiveInstall
  • Tutorials & Walkthroughs - To help you get started...
  • Contact Information - How to reach us.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

What Is ActiveInstall

ActiveInstall Professional was designed from the ground up to be a Windows Installer installation developers dream come true. Using our unique approach, ActiveInstall acts as a companion to Windows Installer (not a wrapper), gently educating the user and quickly pointing out potential problems along the way. Our inline documentation is concise and accurate with abundant links to Windows Installer documentation for more research.

The ActiveInstall Advantage

What does it take to build a Windows Installer Package Authoring Tool that doesn't suck, is easy enough for inexperienced users, yet provides all the power and flexibility that even the most advanced developers could ever want? We asked ourselves this question over and over during the design and development of ActiveInstall. A few key concepts came out of this question that we'd like to share with you:

  • Early Problem Detection - Spending hours, days or even weeks developing an installation only to find dozens or hundreds of validation errors is just unnacceptable. A better solution is to validate while you work.
  • "100%" Solution - As an "Advanced" tool, it must provide complete support for all Windows Installer features without the use of a raw table editor.
  • Learn on the Fly - Considering the vast complexities of Windows Installer, it must provide a gentle introduction to key concepts with quick access to more complex features.

The actual list of design goals for ActiveInstall is much longer, but as you can see from these few items, we id not set out to build a clone of any other tool on the market. Our unique approach is one which embraces Windows Installer Technology, rather than acting as a wrapper around it.

Partial Feature List:

  • Powerful IDE - Task oriented and keyboard friendly user interface is a joy to work with. Collapse or hide or rearrange tool windows, work in several areas at once with our multi-document interface, context-sensitive help for ActiveInstall and Windows Installer embedded at every step.
  • No Proprietary Technology - Sleep better at night knowing your installation is built on pure Microsoft technology. No proprietary scripting languages to learn or support.
  • 100% Windows Installer - Leverage the full power of Windows Installer in a rich friendly user interface without ever having to resort to a "Table Editor".
  • Early Problem Detection - While you're busy entering data, ActiveInstall is busy validating it. Our early problem detection system lets you know when something is wrong as soon as you enter it! No more running validation two hours before release only to find 226 errors!
  • Visual Basic for Applications - Customize every aspect of ActiveInstall using this industry standard programming language and award-winning development environment. Incorporate custom dialogs, enhance existing functionality and add new features.
  • COM Add-Ins - Extend ActiveInstall through the use of custom built add-ins. Hook into the UI and insert your own interface elements, Menu Commands, etc...
  • Automation Interface - Access the same object model that ActiveInstall uses internally from any COM enabled programming language. Over a thousand Properties and Methods for you to work with!
  • Dialog Editor - Our true to life dialog editor is so realistic, you'll forget your looking at an editor and not the real dialog!
  • Deployment Options - Build standard .msi files, Setup.exe launchers, single file Self-Extractors or even downloads that stream files from the internet only when/if they're needed!
  • Latest Technologies - Windows XP, .NET, and 64-Bit Apps are no problem!
  • Templates - Create template projects with the look and feel you want for your project, or common functionality and use them over and over!
  • Digital Signatures - Sign your installations so you can distribute with confidence and give your customers piece of mind!
  • LZX Compression - Utilize LZX compression to make sure your installations are as small as possible.
  • Source Code Control Integration - Protect and share your installation projects with our powerful Source Control Integration features.
  • Component Export Wizard - Export Components from ANY .msi file to create a new Merge Module.
  • Dynamic File Linking - Dynamically include any number of files at build time using power filter masks.
  • Registry File Merge - Include the contents of a .reg file in your project at build time.
  • Quick Build Settings - Take control of the build process by controlling whether full validation is done, files are packaged, etc... Great for debugging!
  • Product Configurations - Exclude features or override project settings. Perfect for "Lite" or "Trial" software.
  • Custom Tables - Define and edit custom tables for inclusion in the build output. Perfect for creating reusable Custom Actions (have you seen our website...).
  • Post-Build SQL - Execute SQL statements against the final .msi during the build process with our powerful Post-Build SQL statements.
  • Build Archives - Never "lose' another build again. Build archives automatically compress and store build output along with timestamp, notes, and the number of errors/warnings. You control when builds are archived through configurable user settings.
  • Patch Builder - Create small binary patches to distribute to customers.
  • Command Line Builds - Use our command line build utility to drive ActiveInstall from the command line, nmake, or any other automated build system. Full output is sent to StdOut and can be filtered.
  • FREE SUPPORT - Standard support is provided free of charge to all users. One business day response time is guaranteed! Premier support is available for mission critical one-hour response time 24 hours a day, 7 days a week!
  • Online Resources - Access a wealth of FAQ's, tutorials, and knowledge base articles on our website. Learn from peers in our Community Message Board.
  • Windows XP Certified
  • Much, much more...


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Whats New?

ActiveInstall (the company) is committed to meeting the needs of each and every one of our customers. We know that in today's busy IT World, that sometimes you may not feel that your opinion matters or that no one will really listen to what you think. In our case, that just not true. We value the feedback of each and every customer, and promise you a frank and honest reply, but not before we do a through analysis of the value and merit of your suggestion.

If you have an idea of how we can improve ActiveInstall, don't be shy, let us know! Most importantly, never assume someone else has already suggested that. Much of our decision about whether to implement a new feature is based on popular opinion, so the more people we hear it from, the more likely we are to implement it.

Send your feedback and suggestions to:

feedback@activeinstall.com

Version 1.0 (Build 622) Feb-10-2003

Initial release.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

System Requirements

For optimal performance of ActiveInstall, we recommend:

  1. Microsoft Windows 2000 or greater operating System.
  2. A partition on a hard disk drive with approximately 500MB of available free space for a complete installation, including all documentation, Merge Modules and sample files. Also, an additional 10 MB of disk space may be required on the System partition (where the Windows\System folder resides), depending on the situation.
  3. At least 128 MB of memory is the minimal requirement. For optimal performance we recommend 512 MB.
  4. A processor that can offer power comparable with a Pentium III 500Mhz is the minimal requirement. For best performance we recommend a processor that can offer power comparable to a Pentium III 1.0 Ghz.
  5. Internet Explorer 5.0 or later.
  6. Screen resolution of at least 1024x768 with 32-bit color.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

License Agreement

End-User License Agreement for products of ActiveInstall Corporation

IMPORTANT: Please read this software license agreement carefully before using this software. By using this Software, you agree to be bound by the terms and conditions stated below. If you do not agree with the terms of this license, promptly delete the Software from your system.

SOFTWARE SUPPLIERS. For purposes of this End-User License Agreement, the SOFTWARE SUPPLIERS are ActiveInstall Corporation and all parties providing ActiveInstall Corporation with software components for inclusion in or with ActiveInstall's software products. The SOFTWARE SUPPLIERS are owners of copyrights and other proprietary rights in the enclosed licensed Software and Documentation. Title to the Software and Documentation remain with the SOFTWARE SUPPLIERS, and does not pass to the Licensee or other parties.

1. License. You may use the Software on only one computer per license purchased. You may copy the Software for backup purposes only. You may distribute it freely as long as the distribution makes use of the originally provided self-installer from ActiveInstall Corporation and that the software is distributed freely. No resale or commercial exploitation of any kind is permitted without the express written permission of ActiveInstall Corporation. The rights and limitations under this Agreement shall transfer to any party in receipt of the Software.

2. Restrictions. You may not use, copy, modify, or transfer the Software, or any copy, in whole or in part, except as expressly provided for in this Agreement. You may not reverse engineer, reverse compile, disassemble, or decompose the Software. You may not rent, lease, loan, resell, distribute, or network the Software. You may not use any portions of the Software separately from the entire set of Software. You may not use the product beyond its intended evaluation deadline or expiration date, if any.

3. Termination. The License is in effect until terminated. The License will terminate automatically if you fail to comply with the limitations described herein. On termination, you must destroy all copies of the Software and Documentation.

4. Guaranty and Disclaimer or Warranty for purchased copies. THE SOFTWARE SUPPLIERS warrant to the original Licensee that the media on which the Software is recorded is free from defects in materials and workmanship under normal use and service for a period of ninety (90) days from the date of delivery as evidenced by a copy of the receipt and/or shipping papers. Further, THE SOFTWARE SUPPLIERS hereby limit the duration of any implied warranty on the media to the period stated above. Some states do not allow limitations on duration of an implied warranty, so the above limitation may not apply to you. If the Software was provided to you electronically, the above limitation does not apply to you.

EXCEPT FOR THE FOREGOING, THE SOFTWARE AND ACCOMPANYING WRITTEN MATERIALS (INCLUDING INSTRUCTIONS FOR USE) ARE PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND. FURTHER, THE SOFTWARE SUPPLIERS DO NOT WARRANT, GUARANTEE OR MAKE ANY REPRESENTATIONS REGARDING THE USE OR THE RESULTS OF THE USE, OF THE SOFTWARE OR WRITTEN MATERIALS IN TERMS OF CORRECTNESS, ACCURACY, RELIABILITY, CURRENTNESS OR OTHERWISE. THE ENTIRE RISK AS TO THE RESULTS AND PERFORMANCE OF THE SOFTWARE IS ASSUMED BY YOU. IF THE SOFTWARE OR WRITTEN MATERIALS ARE DEFECTIVE YOU, AND NOT THE SOFTWARE SUPPLIERS OR THEIR DEALERS, DISTRIBUTORS, AGENTS OR EMPLOYEES, ASSUME THE ENTIRE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

5. Limitations of Remedies. THE SOFTWARE SUPPLIERS' entire liability and your exclusive remedy as to the media (if applicable in your circumstance) shall be replacement of the media that does not meet THE SOFTWARE SUPPLIERS’ limited warranty and which is returned to THE SOFTWARE SUPPLIERS in good condition with a copy of the receipt or warranty. If a failure of the media has resulted from accident, abuse or misapplication, THE SOFTWARE SUPPLIERS shall have no Responsibility to replace the media or refund the purchase price. Any replacement media will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer.

THE ABOVE ARE THE ONLY WARRANTIES OR ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE, THAT ARE MADE BY THE SOFTWARE SUPPLIERS ON THIS PRODUCT. NO ORAL OR WRITTEN INFORMATION OR ADVICE GIVEN BY THE SOFTWARE SUPPLIERS, ITS DEALERS, DISTRIBUTORS, AGENTS OR EMPLOYEES SHALL CREATE A WARRANTY OR IN ANY WAY INCREASE THE SCOPE OF THIS WARRANTY AND YOU MAY NOT RELY ON ANY SUCH INFORMATION OR ADVICE. THIS WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHER RIGHTS, WHICH VARY FROM STATE TO STATE.

NEITHER THE SOFTWARE SUPPLIERS NOR ANYONE ELSE WHO HAS BEEN INVOLVED IN THE CREATION, PRODUCTION OR DELIVERY OF THIS PRODUCT SHALL BE LIABLE FOR ANY DIRECT, INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES (INCLUDING DAMAGES FOR LOSS OF BUSINESS PROFITS, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION AND THE LIKE) ARISING OUT OF THE USE OF OR INABILITY TO USE SUCH PRODUCT EVEN IF THE SOFTWARE SUPPLIERS HAVE BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

6. Government License. The Software is a commercial item, as that term is defined at 48 C.F.R. 2.101 (OCT 1995), consisting of commercial computer software and commercial computer software documentation, as such terms are used in 48 C.F.R. 12.212 (SEPT 1995), and is provided to the U.S. Government only as a commercial end item. Government end users acquire the Software and Documentation under the following terms: (I) for acquisition by or on behalf of civilian agencies, consistent with the terms set forth in 48 C.F.R. 12.212 (SEPT 1995); or (ii) for acquisition by or on behalf of units of the Department of Defense, consistent with the terms set forth in 48 C.F.R. 227.7202-1 through 227.7202-4 (JUNE 1995).

ActiveInstall is a trademark of ActiveInstall Corporation.

Other product or brand names mentioned are copyrights, trademarks or registered trademarks of their respective holders.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Document Conventions

In order to help you to get the most out of ActiveInstall's documentation, we have prepared this document to introduce some concepts used when creating the documentation.

Windows Installer

Microsoft's documentation for Windows Installer spans over 1500 pages and provides a wealth of information ranging from high-level concepts to low-level code examples. Rather than attempting to duplicate that type of information with our own, we've chosen to augment rather than replace. For each distinct feature of Windows Installer, ActiveInstall's documentation aims to provide:

  • Brief overview of the feature
  • How to use the feature in ActiveInstall
  • Tips on using the feature effectively
  • Clarification of common misconceptions or ambiguities
  • Links to more detailed information in the Windows Installer documentation

Bold Formatting

Throughout the documentation, you will notice the liberal use of bold text. This style of formatting is loosely applied to important words and phrase throughout the docs to help draw your attention to key words or important phrases. This technique allows you to more easily skim over a page and locate the type of information you are looking for.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Getting Started

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Getting Familiar with the IDE

The ActiveInstall IDE (Integrated Development Environment) is designed to provide the best possible environment to develop in while providing quick access to the tools and features you use the most.

Project Explorer Pane

The Project Explorer pane provide the primary mechanism for navigating the various views available to you in your installation projects.

Feature Explorer Pane

The Feature Explorer pane is a powerful view which allows to easily inspect the hierarchical relationship of Features and Components in your projects. Selecting any component in the Feature Explorer loads a quick snapshot of all the elements within your project which are associated with that Component.

Help Contents Pane

The Help Contents pane provides a partial contents listing for commonly used documentation.

Dynamic Help Pane

The Dynamic Help pane display contextually-driven links to valuable help topics based on the current view you are working with. Links are provided to ActiveInstall topics for quick-reference, and to the Windows Installer SDK documentation for more complete discussion of Windows Installer topics.

Output Pane

The Output pane displays important information during the build process.

Alerts Pane

The Alerts pane displays any alerts which currently exist in your project.

Tasks Pane

The Tasks pane allow you to quickly and easily manage tasks related to the development of your installation project.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Working with Projects

ActiveInstall projects interact with your development system fairly rigorously during the authoring process. Since project are not completely self-contained in a single-file, it is important to understand how a project works and the issues that affect a projects portability.

Project Contents

ActiveInstall Projects are made up of the following elements:

  • ActiveInstall Project File - An XML-based file containing configuration data for the project and binary data containing any VBA-related macros or settings used in the project.
  • Source Files - The project file itself holds pointers to the source files that will be installed by your project once it is compiled into an installation package.
  • Resource Files - The project also holds pointers to resources used by your project. This can be images used in dialogs, icons used for shortcuts, of custom executables or scripts used by Custom Actions.
  • Merge Modules - The project file also holds pointers to any Merge Modules you have indicated you would like included in the build process.
  • Build Output - During the build process, a directory structure is created and used to store the compiled project output, log files, and supporting files used by your installation.

Portability

The term portability refers to the ability to move a project from one location to another. The move may be to a different directory on the same computer or to a completely different computer.

Due to the fact that the file used by your project are not stored in the project file, some issues can arise as a result of moving a project from one location to another.

Moving Project Files on the Same Computer

Generally speaking, this is the least problematic situation to deal with. Since the full path to all external files are saved in the project, the project will operate normally after being moved. If the project is moved to a new location without the output folders, new folders will be created in the projects new location.

NOTE: If build folders exist in the new location, existing data may be lost during the build process.

Moving External Files or Moving the Project to a Different Computer

It is quite likely that you may need to change the location of some files used by your project, or move the project to a different computer. In cases where it is just one or two files, the problem is easily remedied by simply updating the location of the file in your project. In other cases, where entire directory structures have changed, the problem can be more complex to deal with.

ActiveInstall addresses this through the use of Path Variables. A Path Variable is a variable used to represent a physical location on disk. By using Path Variables, ActiveInstall stores the variable name wherever possible instead of the actual path. When directory locations change, you can simply redefine the value (location) of affected path variables.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Working with Templates

Templates are pre-defined starting points for new projects. ActiveInstall provides some basic default templates for your use, but also allows you to define templates of your own.

You can use templates to:

  • Provide a standard UI with company logo, layouts, etc... for all your projects
  • Provide functional templates for specific project types like Web Site deployments, etc...
  • Provide base components for a product line
  • and just about anything else you can think of...

Using Templates

Using a template is simple:

  1. Invoke the New Project Dialog by selecting New Project... from the File menu.
  2. Select one of the available templates and click OK.
  3. Enter the requested details in the Open Template Dialog.
  4. Click OK to close the dialog.

Your new project will be created at the location specified and opened for you to begin working!

NOTE: The Product Code, Package Code and Upgrade Code for the new project are automatically changed for you.

About Templates

ActiveInstall templates are simply copies of project files saved to a special location. When creating a new project from a template, the user is prompted for some information about the new project, including where it should be created. The template is copied to the new location, updated with the information provided by the user, and opened. All data that existed in the template now exists in the new project.

Creating Your Own Templates

To create your own template:

  1. Carefully examine the project file you want to save as a template. Often times it is desirable to remove some application specific data prior to saving the project as a template. Remember that everything in the template becomes a part of the new project!
  2. Save the Project to your current Templates Folder by selecting Save As... from the File menu. By default the location of the Templates Folder is "C:\Program Files\ActiveInstall Corp.\ActiveInstall Professional\Templates\".
  3. Close the Project by select Close Project from the File menu.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Working with Source Control

ActiveInstall integrates closely with popular Source Control providers like Microsoft Visual SourceSafe. Working with a Project under Source Control is quite easy, but this topic should assist you in getting your project setup and properly configured.

Adding a Project to Source Control

To add a project to Source Control:

  1. From the File menu, select Add to Source Control...
  2. In the Add to Source Control Dialog, select the project you would like to add your project to, or click the New Project... button to create a new project.
  3. Click the OK button.

Checking a Project In

To Check-Out a Project already under Source Control:

  1. From the Tools menu, select Source Control then Check-In...
  2. In the Check-In Dialog, enter any comments you would like to add to the Check-In record stored in SourceSafe.
  3. Click OK.

Checking a Project Out

To Check-In a Project already under Source Control:

  1. From the Tools menu, select Source Control then Check-Out...
  2. In the Check-Out Dialog, enter any comments you would like to add to the Check-Out record stored in SourceSafe.
  3. Click OK.

Opening a Project From Source Control

To open a Project that is currently stored under Source Control:

  1. From the File menu, select Open From Source Control...
  2. In the Open Project From Source Control Dialog, select a local path for the Project by clicking the Browse... button.
  3. Select the Source Control Project which contains the ActiveInstall Project you want to open.
  4. Click OK.

NOTE: ActiveInstall does not support saving more than one ActiveInstall Project in a single Source Control Project.

Notes:

  • ActiveInstall manages it's project file only in SourceSafe. All other files related to your project must be managed elsewhere.
  • ActiveInstall logs into Source Control using the current users credentials. To specify a username and password, see the Source Control tab in the Options dialog which can be opened by selecting Options... from the Tools menu.
  • ActiveInstall uses the default Source Control Database specified in the user's settings. To specify an alternate database, see the Source Control tab in the Options dialog which can be opened by selecting Options... from the Tools menu.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Importing MSI Files

ActiveInstall allows you to create a new Project by importing an existing Windows Installer database. This feature provides you with the ability to:

  • Quickly convert your projects created with another application to ActiveInstall
  • Learn how other Windows Installer package work by importing them into a 'friendly' environment and inspecting the contents.
  • Extend the capability of an existing package by importing it, making changes, then deploying the updated version.

Import an Existing Windows Installer Package

  1. From the File menu, select Import Windows Installer Package....
  2. Browse to the .msi file you want to import.
  3. In the Import Wizard, select a path for the new project and data files.
  4. Click Next, providing any other requested details.
  5. Observe the output messages as the import progresses.

When the Import process has completed, the newly created project will automatically be opened for you.

NOTE: Output messages can 'zip' by quite fast, so if you miss something or just want to review the results of the import, you can find an import log file in the data directory of the folder you created the new project in. The file will be named Import.log.

Notes:

  • You can import .msi files regardless of the compression used. If files are automatically extracted from internal or external .cab files as needed.
  • Source Paths for all files and resources will be set to the location they are extracted to, which is a subdirectory below the project file.
  • ActiveInstall does not currently support importing Merge Modules or any other file type other than valid .msi files.

WARNING! WARNING! WARNING!

The resulting project is only as good as the .msi you import. Much of the data is 'scrubbed' during the import process, but errors can and will result if the quality of the file being imported is less than desirable. It is highly recommended that you run the full Windows Installer validation suite against the .msi file prior to importing it.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Command Line Builds

ActiveInstall provides two mechanisms for building projects outside the IDE. The specific option you choose depends on your particular needs. Both techniques are described below:

Option 1: AICmdLin.exe

AICmdLin.exe is a Console Application that internally uses ActiveInstall's automation interface to perform a build. Output from the build process can optionally be sent to the stdout stream through the use of optional flags as described below:

AICmdLin.exe Options:

AICmdLin.exe <ProjectFile> <BuildConfig> [/nologo] [/E] [/W] [/?]

  • The first argument is the full path to the Project File to be built. Remember, long file names with spaces must be quoted.
  • The second argument is the name of the Build Configuration to use. The default value is "Default".
  • The Following options can be specified in any order, anywhere on the command line:
    • /? - Show Help
    • /nologo - Suppress the standard header (copyright message) from appearing
    • /E - Send all errors to stdout
    • /W - Send all warnings to stdout

Return Values:

  • 0 - Success
  • 1 - No Action
  • 2 - Failure

NOTE: The build process makes every effort to complete regardless how many errors or warning are issues. The return value indicates if the process completed, and not whether the build was error-free.

Option 2: Scripting

supports doing command-line builds through it's automation interface which provides a much more robust mechanism for specifying options and pre-build settings than alternative methods. This technique can also be used to 'drive' ActiveInstall from automated build systems or nmake scripts. The following VBScript code demonstrates a simple example of opening and building a project from a script:

'Declare an instance of ActiveInstall
Dim oAI As ActiveInstall.Application
'Create the instance
Set oAI = New ActiveInstall.Application
'Make sure the UI stays hidden
oAI.Visible = False
'Open 'er up...
oAI.OpenProject ("C:\MyProject.aix")
'The Build method takes the name of the Build COnfig to use...
If oAI.Project.Build("Default") Then
    'In the real world you'll want to do something else
    'to indicate the status of the build...
    MsgBox "Success!"
End If

To utilize this script from the command line or from nmake, we would just save the script to a file and execute the script using WScript.exe which is a utility which allows scripts to be run from the commandline. For example:

wscript //nologo "c:\MySample\AIBuild.vbs"

As you can see, this technique allows you quickly configure a command-line build, yet allows tremendously more flexibility than traditional methods involving a series of special arguments.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Getting Started

We've prepared some quick and easy lessons to get you familiar with basic tasks and getting around the ActiveInstall IDE. Each lesson takes just a few minutes to complete and is a great starting point for more complex samples.

  • Walkthrough: Creating a Basic Installation
    In this walkthough, you'll get a crash course in all the basic steps required to create a new project, add files, create shortcuts and file associations and compile it to a fully functioning msi file!
  • Walkthrough: Searching the Target System
  • Walkthrough: Creating Launch Conditions
  • Walkthrough: Implementing a Custom Action to Launch Installed Program
  • Walkthrough: Installing Assemblies
  • Walkthrough: Searching the Target System


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Path Variables Overview

The Path Variables Manager is used to mange variables used to represent physical paths to specific diretories on one or more development systems.

Path Variables are an important aspect in the overall development lifecycle. For example, it is reasonable to expect that at some point, the location of the files used in your installation may change locations from one directory to another. For example, they may have been located in sub-directories of "C:\Marketing\Dev\Project 1\" when you intitially created your project. If at some point you moved the root development directory to "C:\Dev\Project 1\" you have a real issue to contend with since the source path to each file in your installation would have to be updated one at a time. Path Variable allow you to map a directory to a physical path and only store the name of the path variable instead of the actual path. ActiveInstall then resolves the path variable to the full path as needed based on the current value of the path variable. So, if you had initially created a path variable called "<Root>" which mapped to "C:\Marketing\Dev\Project 1\", then all you would have to do is change the value of "<Root>" to "C:\Dev\Project 1\" and your project will continue to work seamlessly!

Path Variables also prove very useful in team environments where multiple developers may work on a single project, but have source files in separate directory structures. Upon beginning to work with the project, each developer simple has to update a Path Variable or two with values specific to their system configuration.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing Path Variables

The Path Variables Manager allows you to view and configure Path Variables for use in your project.

Adding Path Variables

  1. In the Project Explorer, click Path Variable Manager to display the Path Variable Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Path Variable Details Dialog.
  3. Enter details for this Path Variable as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Path Variables

Edit a Path Variable by simply double-clicking on a row in the Path Variable Manager or by clicking the Edit button on the options panel.

Deleting Path Variables

  1. In the Path Variable Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Path Variable Field Reference

The table below details each field that makes up a Path Variable record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this Path Variable.
Value | Y | Specifies the current value being used by ActiveInstall to resolve paths to physical locations on the development system.
Type | N/A | Specifies whether the Path Variable is System(Read-Only) or User-defined.

Note:

  • Icons are a form of package Path Variable as well, but unlike Binary and Stream Path Variables, are managed at the point in the project where they are used. This approach allows ActiveInstall to dynamically 'extract' icons from other files at build time, rather than including the entire file.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Releases Overview

The Release Manager is used to mange the following types of Release configuration related data:

Build Configurations

Build Configurations are a group of setting that are applied at build time to control how the project is physically built. These items allow control over the type of compression used, whether a Setup.exe if required, etc.

Read More...

Product Configurations

Product Configurations are a group of settings that allow you alter the content of the installation once it is built. You can for example, change the product name, or exclude certain features from being included.

Read More...


%%ItemTitle%%

Managing Build Configurations

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Build Configurations Overview

Build Configurations are settings used to control the behavior of the build process and how the final installation should be packaged. The ability to create multiple Build Configurations allows you to have different builds for different combinations of Product Configurations, compression settings, Setup.exe types, etc...

Notes:

  • ActiveInstall provides as many packaging options as possible but may not be able to meet highly specialized requirements such as spanning multiple disks, etc... In these cases, we recommend choosing an acceptable intermediate Build Configuration and extending ActiveInstall's capabilities through the use of Custom VBA code or an external packaging procedure.
See Also

Managing Build Configurations


%%ItemTitle%%

Build Configurations Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Build Configurations

The Build Configurations Manager allows you to view and configure Build Configurations for use in your installation package.

Adding Build Configurations

  1. In the Project Explorer, click Build Configuration Manager to display the Build Configuration Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Build Configuration Details Dialog.
  3. Enter details for this Build Configuration as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Build Configurations

Edit a Build Configuration by simply double-clicking on a row in the Build Configuration Manager or by clicking the Edit button on the options panel.

Deleting Build Configurations

  1. In the Build Configuration Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Build Configuration Field Reference

The table below details each field that makes up a Build Configuration record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Setup Type Y Specifies one of the following Setup Types:
  • Basic MSI - Produces an .msi file and any additional support files in a directory by themselves.
  • Setup.exe + MSI - Produces output described above with the addition of a spacially configured launcher application(Setup.exe).
  • Single File Setup.exe - Produces all files compressed into a single self-extracting Setup.exe file.
  • Web Setup - Produces a small Setup.exe file which when run, downloads the .msi file and .cab files on an as needed basis.
Compression Y Specifies one of the following Build Configuration types:
  • Uncompressed - No compression is used. Files are stored according to the layout specified in the installations source directory structure.
  • Internal - One CAB - All Files are compressed into a single internally-stored cab file.
  • Internal CAB per Component - All files are compressed into an internally-stored cab file for each component.
  • External - One CAB - All Files are compressed into a single externally-stored cab file.
  • External - CAB per Component - All files are compressed into an externally-stored cab file for each component.
Product Configuration | Y | Specifies an optional Product Configuration to apply during the build process.
Use Short Names | Y | Specifies that files should be stored in the source tree using (8.3) short filename format.
Skip Merge Modules | Y | Specifies that any Merge Modules marked for inclusion should be skipped. This setting is provided to allow for quick builds for debugging purposes only.
Skip Validation | Y | Specifies that no validation should be performed on the final output. This setting is provided for fast debugging purposes only. ALWAYS VALIDATE YOUR PACKAGE!!!.
Build Tables Only | Y | Specifies the build process should process any actual files for inclusion with the package. This setting is provided for fast debugging perposes only.
Web Setup Base URL | Y | Specifies the full URL to the directory which will contain the .msi file. Do not include the file name. For example, "http://www.activeinstall.com/activeinstall/msi/".
Base Installer Engine URL Y Specifies the full URL to the directory which will contain the installer engines. Do not include the file name. For example, "http://www.activeinstall.com/activeinstall/engines/".

NOTE: The installer engines must reside in the same directory and be named "InstMsiA.exe" and "InstMsiW.exe" respectively.
Private Key File | Y | Specifies the source path to a Private Key File (*.pvk) used to digitally sign the build output.
Credentials File | Y | Specifies the source path to a Credentials File (*.spc) used to digitally sign the build output.
Timestamp URL | Y | Specifies an optional url to provide a certified timestamp for the any digital signatures.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Digital Signatures are only applied if the Private Key File and Credential Files are present. The user will be prompted to authenticate themselves during the signing process, which could create problems during unattended build processes.
See Also

Build Configurations Overview


%%ItemTitle%%

Managing Product Configurations

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Product Configurations Overview

Product Configurations allow you to create special settings that 'override' the default settings of your project on a build-by-build basis. For example, if you had an 'Evaluation Version' of your product and a 'Full Version', you could separate features specific to the Full Version in separate Features. This would allow you to create a special Product Configuration that excludes the 'Full Version' features from the build output. Additional options are provided to allow the product name. version, and identifying codes to be changed for each Product Configuration.

Note:

  • Product Configurations are designed to be easy to use and meet the needs of the most common scenarios. If your requirements are more spophisticated, consider using Post-Build SQL statements which are more complex, but lack the inherent limitations of Product Configurations.
See Also

Managing Product Configurations


%%ItemTitle%%

Product Configurations Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Product Configurations

The Product Configurations Manager allows you to view and configure Product Configurations for use in your installation package.

Adding Product Configurations

  1. In the Project Explorer, click Product Configuration Manager to display the Product Configuration Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Product Configuration Details Dialog.
  3. Enter details for this Product Configuration as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Product Configurations

Edit a Product Configuration by simply double-clicking on a row in the Product Configuration Manager or by clicking the Edit button on the options panel.

Deleting Product Configurations

  1. In the Product Configuration Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Product Configuration Field Reference

The table below details each field that makes up a Product Configuration record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Product Name | N | Specifies an alternative Product Name used when this Product Configuration is applied.
Product Version | N | Specifies an alternative Product Version used when this Product Configuration is applied.
Product Code | N | Specifies an alternative Product Code used when this Product Configuration is applied.
Upgrade Code | N | Specifies an alternative Upgrade Code used when this Product Configuration is applied.
Excluded Features | N | Specifies a list of Features which should be excluded from this Product Configuration.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • When Features are excluded at build-time, anything that references an excluded Feature is omitted from the build output. In the case of Parent-Child Feature relationships, if the excluded Feature is a parent to another feature, then the child feature's parent is nullified, effectively making the child a root level Feature.
See Also

Product Configurations Overview


%%ItemTitle%%

Managing Localization

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Localization Overview

Localization is the process of configuring your installation to support more than one language. ActiveInstall addresses localization with a simple yet effective technique that allows your efforts to localize one installation to be reused over and over in subsequent projects.

ActiveInstall uses a global language database which stores literal string values in the default language and in one or more localized languages. The localization manager is used to identify strings which do not have a localized value for a given language. Once a localized value is entered, the value is added to the database and becomes available for use in all your projects.

Notes:

  • Formatted strings are treated the same as nay other string, though in most cases, they should not be localized. It is very important that the person or persons doing the localization be aware of some of the basic syntax used and what should be translated and what should be literally copied into the localized string.
  • ActiveInstall does not perform any validation of string length or size in user-interface elements. As a result, it is important that you design your user interface with localization in mind. As a general rule when laying out dialogs, allow enough room for strings to accomodate 150-200% of their normal size in your default language.
See Also

Managing Localization


%%ItemTitle%%

Localization Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Localization

The Localization Manager allows you to view and manage Localized Strings for use in your installation package.

Editing Localized Strings

  1. In the Project Explorer, click Localization Manager to display the Localization Manager view.
  2. Select a Language from the drop-down list. Localized strings that identically match the default language values from your project will be loaded and displayed.
  3. Select any row and type in a localized value. The new value is automatically saved.

Importing and Exporting Localized Strings

  1. In the Project Explorer, click Localization Manager to display the Localization Manager view.
  2. Select the desired language from the language list.
  3. Click the Import or Export button depending on which action you are performing. You will be propted to select a file for the import/export operation.
  4. Once a valid file has been selected, the import/export operation will be completed.

Notes:

  • Exported strings are stored in a tab-delimited text file with one record to a line. Each exported file contains the default language value and any existing localized value for the selected language only.
  • The Localization Manager dynamicaly gathers all localizeable strings from your project. As a result, this view always reflects the latest list of localizeable values. For example, let's say you have a string: "My Setup", which you have previously localized into 5 languages. Now, let's say you change the default language value to "My New Setup". Upon reloading the Localization Manager, the localized values for this string will all be blank. If you change the default value back to "My Setup", the previously localized values would once again be listed, since they are permanantly stored in the language database.
See Also

Localization Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing Features & Components

The Feature Manager view allows you to create and configure Features, Components and the mappings between Features and Components in your installation.

Features

Features are portions of an application's total functionality that represent specific features of your application that can be installed or uninstalled independently. For example, an application may have features like "Main Application", "Help Files", "Tutorials", "Sample Files", etc... Features can be created in a heirarchical manner though, in practice it is best to avoid complex relationships between parent and child features.

Learn More...

Components

Components are individual groups of data to be installed to the target system. A typical Component might contain a File, a Group of Files, a COM Server, one or more Registry Modifications, a Shortcut, or some other action to be performed on the target system.

Components are assigned to one or more Features in an Installation package. If any Feature which uses that Component is marked for installation, then one and only one instance of that Component is installed to the target system.

In contrast to Features which are visible and controlled by the user, Components are not visible to the user and are controlled entirely by the package author.

Learn More...


%%ItemTitle%%

Managing Features

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Features Overview

Features are portions of an application's total functionality that represent specific features of your application that can be installed or uninstalled independently. For example, an application may have features like "Main Application", "Help Files", "Tutorials", "Sample Files", etc... Features can be created in a heirarchical manner though, in practice it is best to avoid complex relationships between parent and child features.

Feature Features:

  • Allow users to install only the portions of an application they are interested in.
  • Can be arranged in a heirarchical relationship.
  • Can be Installed or Advertised.
  • Can be displayed in the Installation's user interface as either Expanded, Collapsed or Hidden.
  • Can be a required part of the installation.
  • Provide a robust mechanism for conditionally controlling their installation state.
  • Can be installed locally or run from the installation source.

Special Handling and Requirements:

  • Every installation package must have at least one Feature.
  • Each Feature must have at least one Component assigned to it, or be a parent of another Feature.
  • A child Feature's Advertsement setting must not conflict with that of it's parent.
  • The number of Components assigned to a Feature should not exceed 800 and must not exceed 1600.
See Also

Managing Features


%%ItemTitle%%

Features Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Features

The Feature Manager allows you to view and configure Features and Components for use in your installation package. This view also allows you to manage the mapping of Components to Features.

Adding a Feature

  1. In the Project Explorer, click Feature Manager.
  2. Select Add... from the main toolbar or use the keyboard short <Ins> while this view is active to display the Feature Details Dialog.
  3. Enter a unique name in the Reference Name field, or accept the default name provided for you.
  4. Select a Feature from the Parent Feature drop-down list to make this Feature a child of the selected item, or select "<None>" to make this Feature a root-level Feature.
  5. Enter a Title for this Feature. This is the name for this Feature displayed in the user interface.
  6. Select one of the following values from the Display Mode field:
    • Hidden - The Feature will not be displayed in the user interface.
    • Expanded - The Feature will be initially displayed in an expanded state.
    • Collapsed - The Feature will be initially displayed in the collapsed state.
  7. Enter a numeric Order for this Feature. This value controls the ordering of Features at the same level. For example, if a Feature has two children, the child Feature with the lower value in the Order field will be displayed first, followed by the second child Feature.

    Note: Odd numbers indicate an expanded state while even numbers indicate a collapsed state. A value of 0 indicates the Feature should be hidden.
  8. Enter a Description for this Feature.
  9. Select one of the following values from the Run From Location field:
    • Local System - The Feature will be installed to the target system.
    • Installation Source - The Feature will run from the installation source.
    • Follow Parent - The Feature will follow the setting of it's parent Feature, if any.
  10. Select a Directory for this Feature, or select "<Use Default>".

    Note: The usage of this field can be confusing. Simply put, selecting a directory here will allow the user to change the target location of that directory in the context of this Feature during the installation. It does not (necessarily) mean that the Feature will be installed to this location, but instead that anything being installed to the selected directory should be effected by the new path the user may select. Using the default value prevents the user from changing a directory's target location in the context of this Feature. It is important to remember that Features do do not get installed to a directory, Components do, but the Components assigned to a given Feature need not share the same directory.
  11. Select one of the following values from the Advertising Mode field:
    • Installed (Not Advertised) -
    • Advertised -
    • Advertised if Supported -
    • Installed (Advertising not Allowed) -
  12. Check or uncheck the "Allow Feature to be Set to Absent" field to indicate if the user can prevent the Feature from being installed.
  13. Select one of the following values from the Default Install Level field:
    • Always Install - The Feature will always be installed.
    • Never Install - The Feature will never be installed.
    • Custom Level - The Feature will be installed if the value of the INSTALLLEVEL Standard Property exceeds the value specified here.
  14. Enter Comments for this Feature as necessary. Comments are purely for the benefit of the package authors and are not included in the build output.
  15. Optionally specify Conditional Install Levels on the Advanced tab. For more information see Managing Feature Conditions.
  16. Click Save & Close on the dialog's toolbar.

Editing Features

Edit a Feature by simply double-clicking on an item in the Feature Manager.

Deleting Features

  1. In the Feature Manager, select the Feature you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the actions bar.

Notes:

  • Deleting a Feature does not delete it's child Features. Any child Features will become root-level Features after the parent feature is deleted.
  • Every installation must contain at least one Feature. As such, you should never attempt to delete all of the Features from your project.
See Also

Features Overview


%%ItemTitle%%

Managing Components

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Components Overview

Components are pieces of the application or product to be installed. The installer always installs or removes a component from a user's computer as a coherent piece. Components are usually hidden from the user. When a user selects a feature for installation, the installer determines which components must be installed to provide that feature.

See Also

Managing Components


%%ItemTitle%%

Components Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Components

The Feature Manager allows you to view and configure Components for use in your installation package.

Adding Components

  1. In the Project Explorer, click Feature Manager to display the Feature Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Component Details Dialog.
  3. Enter details for this Component as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Components

Edit a Component by simply double-clicking on a row in the Component Manager or by clicking the Edit button on the options panel.

Deleting Components

  1. In the Component Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Component Field Reference

The table below details each field that makes up a Component record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Directory | Y | Specifies the destination directory for this Component.
Run From Location Y Specifies the Component will run from one of the following locations:
  • Local System - Forces local installation of any Feature providing this Component.
  • Installation Source - Forces run from source installation of any Feature providing this Component.
  • Allow Either - Allow Feature settings to control where the Component is installed
Component ID | Y | Specifies a unique GUID for this component. A blank value means the Component will not be registered with Windows Installer and therefore never repaired or removed from the target system.
Permanent | Y | Specifies that the installer does not remove the component during an uninstall. The installer registers an extra system client for the component in the Windows Installer registry settings.
Shared | Y | Specifies that the installer should increment the reference count in the shared DLL registry of the component's key file. If this bit is not set, the installer increments the reference count only if the reference count already exists.
64-Bit | Y | Specifies he Component contains one or more 64-Bit elements.
Never Overwrite | Y | Specifies that the installer does not install or reinstall the component if a key path file or a key path registry entry for the component already exists. The application does register itself as a client of the component.
Key Member Type Y Specifies one of the following key Member types:
  • File
  • Directory
  • Registry Modification
  • ODBC Data Source
Key Member | Y | Specifies the actual Key Member based on the Key Member type setting.
Condition | Y | Specifies Conditional Statement which must be blank, or evaluate to TRUE for the Component to be installed.
Re-evaluate Condition | Y | Specifies that the installer should reevaluate the value of the statement in the Condition column upon a reinstall. If the value was previously False and has changed to True, the installer installs the component. If the value was previously True and has changed to False, the installer removes the component even if the component has other products as clients.
Reserved Space | Y | Specifies a collection of Reserve Space Actions.
Qualifiers | Y | Specifies a collection of Component Qualifiers.
Isolation | Y | Specifies a collection of Isolated Components.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Components Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing Action Items

The Action Items Manager allows you to view and configure a variety of common actions which are executed during the installation or configuration of your application on the target system.

The following Action Items are available:

Launch Condition Actions

Launch Condition Actions allow you to specify one or more conditions which must be met in order for the installation to be performed. A message is specified for each condition which is displayed to the user prior to the installation aborting when the specified condition is not met.

More Details

System Search Actions

System Search Actions are extremely powerful actions that allow you to search the target system for a specific file, directory or registry entry. The specified value, if located is then stored in a Property for use elsewhere in your project.

More Details

Upgrade Actions

Upgrade Actions are special actions performed in cases where a previous version of a related application may exist on the target system. Once identified, the installer can take no action (detect only), remove the entire application, or remove portions of the previous application. Optionally, Windows Installer can migrate the current state of Features from the existing application to that of the new application.

More Details

Custom Actions

Custom Actions are a powerful mechanism which allows you to extend the functionality of Windows Installer. Custom Actions invoke either some special action to be action by the installer, such as setting a specific property or directory, or displaying a specific error message. Alternatively, Custom Actions can tke the form of custom code written by the package author. Custom Actions can be written in C++, VBScript, JScript.

More Details

Move File Actions

Move File Actions allow you to move or copy files from one location on the target system to another. In many cases, this is useful for backing up existing files prior to installing new or update file that offer parallel functionality.

More Details

Remove File Actions

Remove File Actions allow you to specify one or more files or directories that should be removed either during initial installation, or removal of the product. In many cases, this feature is useful for applications which create files during it's execution. For example, log files, temp files, etc...

More Details

INI File Modification Actions

INI File Modification Actions allow you to create or modify entries in an INI File located anywhere on the target system.

More Details

Environment Variable Modification Actions

Environment Variable Modification Actions allow you to create of modify environment variables on the target system.

More Details


%%ItemTitle%%

Managing Launch Conditions | Launch Condition Samples

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Launch Conditions Overview

Launch Conditions are used to specify and enforce conditions which must be satisfied in order for the installation to execute. Launch Conditions are controlled by the use of a Conditional Statement which Windows Installer evaluates during the installation. Evaluation of Launch Conditions occurs when the LaunchConditions Standard Action is executed, which allows the package author flexibility to sequence this evaluation after other Standard or Custom Actions which may be used to inspect the user's system.

When the LaunchConditions Standard Action is executed, Windows Installer queries the LaunchCondition table and for each record found, takes the following actions:

  1. Evaluate the Conditional Statement determining it to be either "True" or "False".
  2. If the Statement evaluates to "False", display the message provided in the Description column, and exit the installation.
  3. If the Statement evaluates to "True", get the next record and return to step 1.

For examples of some common Launch Conditions, see the Tips & Tricks section.

See Also

Managing Launch Conditions | Launch Condition Samples


%%ItemTitle%%

Launch Conditions Overview | Launch Condition Samples

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Launch Conditions

The Action Items Manager allows you to view and configure Launch Conditions for use in your installation package.

Adding Launch Conditions

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then Launch Condition... to display the Launch Condition Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Launch Conditions

Edit a Launch Condition by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting Launch Conditions

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Launch Condition Field Reference

The table below details each field that makes up a Launch Condition record and provides a description of the usage of each field.

Field Name | Req'd | Description
Condition | Y | Specifies a unique Conditional Statement for this Launch Condition. The value you provide here must evaluate to TRUE for the installation to proceed. Must conform to the Windows Installer Condition Datatype. See the Samples topic for examples of typical Conditions.
Message | Y | Specifies the error message displayed to users when the Launch Condition is not met (fails).
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Launch Conditions Overview | Launch Condition Samples


%%ItemTitle%%

Managing System Searches

See Also ActiveInstall Online Documentation Send Feedback on this topic.

System Searches Overview

System Searches are actions used to locate resources on the target system during your installation.

System Searches are able to perform three basic types of searches:

  • Raw-Value - Locates a arbitrary value. Search logic continues as described below until a value is found. Obviously a recursive directory Search cannot locate a non-file system related value and as such does not apply in this case.
  • File Search - Attempts to locate a specific file based on specified criteria including file name, size, version, and modified dates. File must physically exist for a value to be returned.
  • Directory Search - Attempts to locate a specific directory. Directory must physically exist for a value to be returned.

System Searches are progressive in nature until a result has been achieved. For example, when searching for a file, you can specify that the file's path might be stored in a particular registry entry. If the file is not found based on the registry info, then the search should recursively look in all folders under the "Program Files" directory. The search will first retrieve the path from the registry, then use that folder to search for the file. If it is found, then the search ends and the path to the file is stored in the specified property. If it is not found, the search would go on to search the specified directory structure.

Search logic executes in the following order:

  1. Component - Retrieves the directory a Component is installed to or the full path to the Key Member of that Component. If the Search criteria is met, the search ends.
  2. Registry - Retrieves a value from the system registry. If this is a file or directory search, Windows Installer only returns the value if the specified path/file exists and matches the specified criteria. If the Search criteria is met, the search ends.
  3. INI File - Retrieves a value from an INI File located in the Windows directory. It is not possible to specify any other directory. If the Search criteria is met, the search ends.
  4. Directories - Searches a directory structure for a match. Can be limited in depth or unlimited. Can be based on the results of another System Search as well.

Notes:

  • Be sure to check our website for tips and examples on searching for common system components!
See Also

Managing System Searches


%%ItemTitle%%

System Searches Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing System Searches

The Action Items Manager allows you to view and configure System Search Actions for use in your installation package.

Adding System Search Actions

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then System Search Action... to display the System Search Action Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing System Search Actions

Edit a System Search Action by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting System Search Actions

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

System Search Action Field Reference

The table below details each field that makes up a System Search Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Results Property | Y | Specifies the name of a Property that will contain the results of the System Search Action. NOTE: This Property does NOT need to be initialized in the Property table or by any other means prior to the System Search Action. If it is however, the current value will remain unchanged if the Search fails.
Component Search Details | N | Component ID: Specifies a Component ID to be located on the target system. Key Member Type: Specifies if the Key Memeber of the Component being sought is a File or a Directory.
Registry Search Details | N | Search Action: Specifies whether to search for a raw value or a File/Directory. Registry Root: Specifies the section of the Registry the Key is stored in. Section: Specifies the section name in the Registry. Name: Specifies the name of the value key. Blank indicates the default key. Search 64-Bit Registry: Specifies whether the 64-Bit portions of the registry should be searched.
INI File Search Details | N | Search Action: Specifies whether to search for a raw value or a File/Directory. INI File Name: Specifies the file name of the INI File (in the System directory). Section: Specifies the section namein the INI File. Key: Specifies the name of the value key. Field: Specifies the numeric field number to search.
Directory Search Details | N | Specifies one or more Directory Searches: Parent Search: Specifies an optional reference to another System Search which should be used as the starting point for this search. Path: Specifies either a full path for the search or a path relative to the path specified by Parent Search. Depth: Specifies the depth to which the search should recurse. A value of 0 means the specified directory only, while a value of 1 means only immediate sub directories will be searched.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

System Searches Overview


%%ItemTitle%%

Managing Remove File Actions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Remove File Actions Overview

Remove File Actions are actions that allow you to have files on the target system moved or copied from one location to another. Through the use of wildcards, it is possible to move or copy multiple files and/or directories with a single Move File Action.

See Also

Managing Remove File Actions


%%ItemTitle%%

Remove File Actions Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Remove File Actions

The Action Items Manager allows you to view and configure Remove File Actions for use in your installation package.

Adding Remove File Actions

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then Remove File Action... to display the Remove File Action Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Remove File Actions

Edit a Remove File Action by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting Remove File Actions

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Remove File Action Field Reference

The table below details each field that makes up a Remove File Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Execution Y Specifies the action to be taken. Can be one of the following values:
  • Remove On Install - Specified files will be deleted during installs.
  • Remove On Uninstall - Specified files will be deleted during uninstalls.
  • Remove On Install and Uninstall - Specified files will be deleted during both installs and uninstalls.
Directory | N | Specifies the name of a Property whose value resolves to the source directory at runtime.
File | N | Specifies a filename indicating which file or files should be affected by this action. Wildcards are allowed in this field and long filename format must be used. A blank value instructs Windows Installer to delete the Directory if it is empty.
Component | N | Specifies a Component whose installation state controls the execution of this action.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Remove File Actions Overview


%%ItemTitle%%

Managing Move File Actions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Move File Actions Overview

Move File Actions are actions that allow you to have files on the target system moved or copied from one location to another. Through the use of wildcards, it is possible to move or copy multiple files and/or directories with a single Move File Action.

See Also

Managing Move File Actions


%%ItemTitle%%

Move File Actions Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Move File Actions

The Action Items Manager allows you to view and configure Move File Actions for use in your installation package.

Adding Move File Actions

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then Move File Action... to display the Move File Action Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Move File Actions

Edit a Move File Action by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting Move File Actions

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Move File Action Field Reference

The table below details each field that makes up a Move File Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Action Y Specifies the action to be taken. Can be one of the following values:
  • Copy File(s) - The specified files will be copied to the target location.
  • Move File(s) - The specified files will be moved to the target location.
Source Directory | N | Specifies the name of a Property whose value resolves to the source directory at runtime.
Source File | N | Specifies a filename indicating which file or files should be affected by this action. Wildcards are allowed in this field and long filename format must be used.
Target Directory | N | Specifies the name of a Property whose value resolves to the target directory at runtime.
Target File | N | Specifies the name the file will be given when copied or moved to the new location. Any value entered here will be ignored if wildcards were used in the Source File field.
Component | N | Specifies a Component whose installation state controls the execution of this action.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Move File Actions Overview


%%ItemTitle%%

Managing Custom Actions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Custom Actions Overview

Custom Actions are author-defined actions or author-provided custom code to be executed or performed during the execution of your installation.

The following types of Custom Actions are available:

Compiled DLL

DLL Custom Actions are written as functions in compiled Dynamic Link Libraries (.dll) files. Typically this type of Custom Action is written in C or C++, which provides the most greatest capability but also the most difficult authoring/debugging experience.

Compiled EXE

EXE Custom Actions are written as standard executable files (.exe). This type of Custom Action usually recieves input via command line arguments handed to it when it is launched.

Script

Script Custom Actions are written as text containing either Microsoft VBScript or JScript code. While this type of Custom Action provides the easiest model to work with, it may also expose some limitations based on Operating System and Browser versions.

Set Property/Directory

Set Property or Diectory Custom Actions don't involve Custom Code at all. Rather they are simple instructions to Windows Installer to set the value of a Property or the location of a Directory to some new value.

Nested Installation

Nested Install Custom Actions are instructions to run another Windows Installer installation. This nested install may be included with the package as a sub-storage, on the source media, or be a product which is already installed on the target system.

Error & Fail

Error & Fail Custom Actions are the simplest of all of the Custom Action types. These Custom Actions simply tell Windows Installer to display an error message and terminate the installation with a failure status.

See Also

Managing Custom Actions


%%ItemTitle%%

Custom Actions Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Custom Actions

The Action Items Manager allows you to view and configure Custom Actions for use in your installation package.

Adding Custom Actions

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then Custom Action... to display the Custom Action Details Dialog.
  3. When prompted, select a Custom Action type from the list of available choices and click OK.
  4. Provide the requested details as outlined in the Field Reference below.
  5. Click Save & Close on the dialog's toolbar.

Editing Custom Actions

Edit a Custom Action by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting Custom Actions

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

DLL/EXE/Script Custom Action Field Reference

The table below details each field that makes up a Custom Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Source Location | Y | Specifies the location at which the Custom Action code can be found.
Source File | N | Specifies the specific file or item based based on the value of the Source Location field.
Entry Point
- or -
Arguments 		N Specifies the function name in the case of a DLL or Script, and command-line arguments in the case of an EXE.
Execution & Scheduling N Specifies options controling the point and conditions under which the action will be executed. Options available depend on which of the following two modes of execution are used:

Immediate Execution - Specifies that the action will run at the point the Custom Action is encountered when Windows Installer is processing the Sequence table containg the Custom Action. Immediate Execution options include:
  • Always Execute - Always execute. Action may run twice if present in both sequence tables.
  • Execute Once - Execute once if present in both sequence tables. Skips action in execute sequence if UI sequence has run.
  • Execute Once Per Process - Execute once per process if in both sequence tables. Skips action in execute sequence if UI sequence has been run in same process, for example both run in the client process. Used to prevent actions that modify the session state, such as property and database data, from running twice.
  • Execute in Client-side Execute Phase Only - Execute only if running on client after UI sequence has run. The action runs only if the execute sequence is run on the client following UI sequence. May be used to provide either/or logic, or to suppress the UI related processing if already done for client session.

Deferred Execution - Specifies the the CustomAction should be queued for execution as part of the final script Windows Installer executes when the installation is committed. Deerred Execution options include:

  • Execute in Script - Queue for execution at scheduled point within script.
  • Execute on Rollback - Queue for execution at scheduled point within script. Execute only upon an installation rollback.
  • Execute on Commit - Queue for execution at scheduled point within script. Execute only upon install commit.
Return Processing N Specifies options related to the result of the Custom Action.

Synchronous - Windows Installer should wait for this action to complete before executing the next action.
  • Ignore Return Code - Installation continues even if the action eturns a failure code.
Asynchronous - Windows Installer should start this action and immediate move to the next action without waiting for this action to return.
  • Wait for Action - The installation will not terminate until the action has completed.
No User Impersonation | N | Specifies whether the action should execute with no user impersonation (run in system context).
Hide Target From Logs | N | Specifies if Windows Installer should be prevented from writing the value in the Target column of the CustomAction table to the installation log.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Set Property/Directory Custom Action Field Reference

The table below details each field that makes up a Custom Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name Y Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.

This field is for use in the development environment strictly as a convenience for the author and is not icluded in the roject's build output.
Action Y Specifies the action to be taken. Can be one of the following values:
  • Set a Property - Changes the value of a Property to the provided value.
  • Set a Directory - Changes the destination path of a Directory to the provided value.
Property/Directory Name | N | Specifies the Property or Directory whose value will be affected.
New Value | N | Specifies the new value to be set by this action.
Execution N Specifies options controling the point and conditions under which the action will be executed. Options include:
  • Always Execute - Always execute. Action may run twice if present in both sequence tables.
  • Execute Once - Execute once if present in both sequence tables. Skips action in execute sequence if UI sequence has run.
  • Execute Once Per Process - Execute once per process if in both sequence tables. Skips action in execute sequence if UI sequence has been run in same process, for example both run in the client process. Used to prevent actions that modify the session state, such as property and database data, from running twice.
  • Execute in Client-side Execute Phase Only - Execute only if running on client after UI sequence has run. The action runs only if the execute sequence is run on the client following UI sequence. May be used to provide either/or logic, or to suppress the UI related processing if already done for client session.
Hide Target From Logs | N | Specifies if Windows Installer should be prevented from writing the value in the Target column of the CustomAction table to the installation log.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Nested Install Custom Action Field Reference

The table below details each field that makes up a Custom Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Source Location | Y | Specifies the location at which the Custom Action code can be found.
Source File
- or -
Package Code 		N Specifies the specific file or item based based on the value of the Source Location field.
Property Settings | N | Specifies a string containing Property values to be initialized when running the install.
Execution N Specifies options controling the point and conditions under which the action will be executed. Options include:
  • Always Execute - Always execute. Action may run twice if present in both sequence tables.
  • Execute Once - Execute once if present in both sequence tables. Skips action in execute sequence if UI sequence has run.
  • Execute Once Per Process - Execute once per process if in both sequence tables. Skips action in execute sequence if UI sequence has been run in same process, for example both run in the client process. Used to prevent actions that modify the session state, such as property and database data, from running twice.
  • Execute in Client-side Execute Phase Only - Execute only if running on client after UI sequence has run. The action runs only if the execute sequence is run on the client following UI sequence. May be used to provide either/or logic, or to suppress the UI related processing if already done for client session.
Ignore Return Code | N | Specifies whether the installation should continue even if the nested install fails.
Hide Target From Logs | N | Specifies if Windows Installer should be prevented from writing the value in the Target column of the CustomAction table to the installation log.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Error & Fail Custom Action Field Reference

The table below details each field that makes up a Custom Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Message String# | Y | Specifies a numeric Message number. This value must refer to the Message# of a Message String in the Message Strings Manager.
Custom Message | N | Specifies a custom message displayed to the user just before the installation terminates.
Hide Message From Logs | N | Specifies if Windows Installer should be prevented from writing the value in the Target column of the CustomAction table to the installation log.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Custom Actions Overview


%%ItemTitle%%

Managing Upgrade Actions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Upgrade Actions Overview

Upgrade Actions allow the package author to identify previously installed packages for which some special actions should be taken prior to the current installation proceeding. Upgrade Actions are based primarily on the pre-defined UpgradeCode Windows Installer property. Use of this code is optional in installation packages, so it's not guaranteed that you will be able to use Upgrade Actions to detect a given package.

Upgrade Actions are stored in the Upgrade table in a Windows Installer database and are only available with Windows Installer 2.0 or greater.

Upgrade Action Features

  • Allows you to specify any number of products or product families to be detected.
  • Provides matching criteria that includes version and language in addition to the base Upgrade Code.
  • Allows for a "Detect Only" mode that identifies matching products, but does not perform any upgrade actions.
  • Allows a list of Features to be specified which should be removed prior to the current package being installed.
  • Allows Feature States (Installed, Advertised, Absent, etc...) to be migrated from the existing product to the new product.
  • Allows Upgrade Actions to be treated as non-critical, allowing the installation to continue if the Upgrade Action fails.

Special Handling and Requirements

  • Upgrade Actions require the author to specify a Property, which at runtime, will be populated with a semicolon delimited list of ProductCodes for all matching products found. This Property must be unique across all Upgrade Actions, must be Public in scope (all Uppercase), must NOT be listed in the Property table, and finally, must be present in the list of SecureCustomProperties.

Core Concepts

It is important to understand the two basic types of upgrades avaialble with Windows Installer. For a full discussion of all of the issues surrounding Upgrading Windows Installer Packages, please refer to the Windows Installer documentation.

Small/Minor Upgrades

A Small or Minor Upgrade is one in which minor updates have been made to the package. Typically updates to an existing version of the same application use Minor Upgrades since the layout and structure of the installation does not signifigantly change. For example, upgrading an application from version 1.0 to 1.1 where the changes include a new .exe file and perhaps a new .ini file.

You can use a Small/Minor Upgrade if ALL of the following are true:

  • Feature heirarchy has not changed.
  • No features or Components have been removed
  • No Component ID's have been changed

Major Upgrades

A Major Upgrade is best thought of as an "intelligent uninstall" of a previous version.

See Also

Managing Upgrade Actions


%%ItemTitle%%

Upgrade Actions Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Upgrade Actions

The Action Items Manager allows you to view and configure Upgrade Actions for use in your installation package.

Adding Upgrade Actions

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then Upgrade Action... to display the Upgrade Action Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Upgrade Actions

Edit a Upgrade Action by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting Upgrade Actions

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Upgrade Action Field Reference

The table below details each field that makes up a Upgrade Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own. This field is for use in the development environment strictly as a convenience for the author and is not icluded in the roject's build output.
Upgrade Code | Y | Specifies an Upgrade Code for this Upgrade Action by typing or pasting the code directly into the space provided. Optionally, you can browse to the .msi file with the desired Upgrade Code by clicking the ellipsis button to the right of the Upgrade Code field.
Min. Version | N | Specifies the lowest number used when searching for matching products.
Min. Inclusive | N | Specifies if the value of the Min. Version field is to be considered a match.
Max. Version | N | Specifies the highest number used when searching for matching products.
Max. Inclusive | N | Specifies if the value of the Max. Version field is to be considered a match.
Languages | N | Specifies a comma-delimited list of languages (LANGID's) that Windows Installer should consider when evaluating a possible match.
Languages Inclusive | N | Specifies if the Languages listed in the Languages field indicate an explicit match or an explicit exclusion.
Indicator Property | Y | Specifies a unique Property which Windows Installer will store the Product Code of any matching products found. If more than one is found, subsequent Product Codes will be apended to this property and delimited by semi-colons.
Features to Remove | N | Specifies a list of Features which should be removed from the found package prior to the current install proceeding. Optionally, browse to a .msi file by clicking the ellipsis button next to the Features to be Removed text box. Select a valid .msi file and a comma delimited list of all it's features will be populated in the Features to be Removed text box. You can then remove any you want to remain installed. Leave this field blank to instruct Windows Installer to Remove ALL features before proceeding.
Ignore Errors | N | Specifies whether Windows Installer should Ignore Errors encountered while removing features, or if the installation should fail.
Migrate Feature States | N | Specifies whether Windows Installer should attempt to Migrate Feature States (Installed, Advertised, Absent, etc...) from the found package to the current package.
Detect Only | N | Specifies that Windows Installer should attempt to locate the specified package(s) based on the provided criteria, but not perfrom any other Upgrade Actions for the package(s) if found.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • You MUST provide either a Minimum OR a Maximum version. Both fields can not be left blank.
  • Only the first three 'fields' of the provided version numbers are used during evaluation. If a fourth is provided, it will be ignored. For example, "5.000.000.001", is treated the same as "5.000.000" since Windows Installer ignores the fouth field ("001").
  • The Indicator Property must NOT be pre-declared in the Property Manager.
  • The Indicator Property must be unique among all Upgrade Actions in the package.
  • The Migrate Feature States option is very highly dependent upon the consistency of the 'Feature tree' between the found package and the current package. It is not recommended that you use this option if the structure or organization of features has changed signifigantly between the two packages.
  • Using Upgrade Actions with the Detect Only option is a clever way of detecting whether a dependent product is installed. In fact, you can even sequence LaunchConditions after FindRelatedProducts and use the Indicator Property in a Launch Condition!
See Also

Upgrade Actions Overview


%%ItemTitle%%

Managing Environment Variables

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Environment Variables Overview

Environment Variable Modifications are actions used to change enviroment variable setting on the target system. Values can be added, added only if absent, updated, appended, or removed. The action can apply to all users or only the current user.

Notes:

  • On Windows NT-based systems, this information is stored in the registry and a message notifies the system of changes when the installation completes. Any new processes, or existing processes that check for these messages, use the new or updated environment variables. On Windows 95, 98, and ME, this information is stored in the Autoexec.bat file, and do not affect the system until a system reboot.
See Also

Managing Environment Variables


%%ItemTitle%%

Environment Variables Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Environment Variables

The Action Items Manager allows you to view and configure Environment Variable Modifications for use in your installation package.

Adding Environment Variable Modifications

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then Environment Variable Modification... to display the Environment Variable Modification Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Environment Variable Modifications

Edit a Environment Variable Modification by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting Environment Variable Modifications

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Environment Variable Modification Field Reference

The table below details each field that makes up a Environment Variable Modification record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Action Y Specifies the action to be performed. Can be one of the following values:
  • Create or Update - The value should be created if it does not already exist and updated if it does exist.
  • Create Only if Missing - The value should only be created if it does not already exist on the target system.
  • Remove - The value will be removed if it exists on the target system.
Variable Name | Y | Specifies the name of the Environment Variable to be configured.
Value Placement Y Specifies how the new value should be placed relative to any existing value. Can be one of the following values:
  • Before - The new value will be inserted before any existing value.
  • After - The new value will be inserted after any existing value.
  • Replace - The new value will replace any existing value.
Delimiter | N | Specifies the delimiter used when adding a new value to existing values.
Value | N | Specifies the value to be set for the Environment Variable.
System-Wide | N | Specifies whether the change should affect all users of the system or only the current user.
Remove at Uninstall | N | Specifies whether the action should be reversed during an uninstall.
Component | Y | Specifies the Component whose installation state controls the execution of this action.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • On Windows NT-based systems, this information is stored in the registry and a message notifies the system of changes when the installation completes. Any new processes, or existing processes that check for these messages, use the new or updated environment variables. On Windows 95, 98, and ME, this information is stored in the Autoexec.bat file, and do not affect the system until a system reboot.
See Also

Environment Variables Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

INI File Modifications Overview

INI File Modifications are actions ued to make modifications to INI Files during the execution of your installation. Values can be added, added if not present, appended, or removed.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing INI File Modifications

The Action Items Manager allows you to view and configure INI File Modifications for use in your installation package.

Adding INI File Modifications

  1. In the Project Explorer, click Action Items Manager to display the Action Items Manager view.
  2. Select Add from the options panel, then INI File Modification... to display the INI File Modification Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing INI File Modifications

Edit a INI File Modification by simply double-clicking on a row in the Action Items Manager or clicking the Edit button on the options panel.

Deleting INI File Modifications

  1. In the Action Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

INI File Modification Field Reference

The table below details each field that makes up a INI File Modification record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Action Y Specifies the action to be performed. Can be one of the following values:
  • Create or Update - The item will be created if missing and updated if present.
  • Create if Absent - The item will be created ONLY if the item does not already exist.
  • Append Value - The value will be appended to any existing values.
  • Remove Line - The entire item will be removed.
  • Remove Value - The value will be removed from the item.
Directory | N | Specifies the name of a Property that will resolve to the path to the INI File at runtime. A blank value instructs Windows Installer to use the Windows Folder.
File Name | Y | Specifies the file name (no path) of the INI File.
Section | Y | Specifies Section Key for the modification.
Key | Y | Specifies the value key for the modification.
Value | N | Specifies the value to be inserted/updated/appended.
Component | Y | Specifies the Component whose installation state controls the execution of this action.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.


%%ItemTitle%%

Managing Resources

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Resources Overview

Resources are support files used during the execution of your installation. Typically resources are used to store images, scripts, or custom executables. Resources are not installed to the target system, but instead are permanently stored inside the installer database.

There are two types of resources used in an installation:

Binary Resources

Binary resources are files used at runtime during the execution of an installation. Binary Resources can be images, text files, scripts, or executables. With just one notable exception (see Stream Resources below), all resources required by an installation should be stored as Binary resources.

Stream Resources

Stream Resources are a special type of resource. Currently, the only supported use of Stream Resources is to store other installer packages for use by nested installations, (type 7 Custom Actions).

Notes:

  • Due to a limitation on OLE Streams, the name given to a resource must occupy no more than 62 bytes. In certain cases where DBCS characters are used, this can affect the maximum allowable length of the name. ActiveInstall does not test for this situation, so it is best to keep your names short or avoid DBCS characters.

Tips:

  • When adding image Resources to your project, pay close attention to file sizes. Images that are not optimized or compressed can add signifigant additional size to your installation package.
See Also

Managing Resources


%%ItemTitle%%

Resources Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Resources

The Resources Manager allows you to view and configure Resources for use in your installation package.

Adding Resources

  1. In the Project Explorer, click Resource Manager to display the Resource Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Resource Details Dialog.
  3. Enter details for this Resource as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Resources

Edit a Resource by simply double-clicking on a row in the Resource Manager or by clicking the Edit button on the options panel.

Deleting Resources

  1. In the Resource Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Resource Field Reference

The table below details each field that makes up a Resource record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Resource Type Y Specifies one of the following resource types:
  • Binary - A standard resource which will be stored in the Binary Table at build time.
  • Stream - A special resource type used with nested install Custom Actions.
Source Path | Y | Specifies the source path to the resource file on the development system.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Icons are a form of package resource as well, but unlike Binary and Stream Resources, are managed at the point in the project where they are used. This approach allows ActiveInstall to dynamically 'extract' icons from other files at build time, rather than including the entire file.
See Also

Resources Overview


%%ItemTitle%%

Managing Dialogs

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Dialogs Overview

Dialogs are what provides your installation with a user interface. At runtime, the Windows Installer engine dynamically creates a user interface for your installation based on instructions contained in the installation database. A Dialog in comprised of a window with one or more controls placed on it.

To allow you to control the logic used in the user interface, Windows Installer provides three mechanisms for interacting with the user through controls on your dialogs:

Control Conditions

Control Conditions are used to change the state of a control based on a predefined condition. For example, a Push Button can be enabled or disabled based on the value of a certain Property.

Control Events

Control Events are actions taken when the user interacts with a control. For example, when the user clicks a Push Button, a new dialog should be displayed. Control Events can be controlled through the use of a condition which must evaluate to TRUE in order for the Action to occur. Each control can have 0 or more Control Events defined for it. Each event has a priority, which controls the order in which the Actions are evaluated and executed.

Control Subscriptions

Control Subscriptions are notifications of signifigant events that Windows Installer send to controls under certain circumstances. For example, a Text control that subscribes to the TimeRemaining event will have it's value updated at various intervals by the Windows Installer engine.

See Also

Managing Dialogs


%%ItemTitle%%

Dialogs Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Dialogs

The Dialog Manager allows you to view and edit Dialogs for use in your installation package.

Adding Dialogs

  1. In the Project Explorer, click Dialog Manager to display the Dialog Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Dialog Details Dialog.
  3. Add controls and edit the behavior for this Dialog as outlined in the Platform SDK Documentation.
  4. Click Save & Close on the dialog's toolbar.

Editing Dialogs

Edit a Dialog by simply double-clicking on a row in the Dialog Manager or by clicking the Edit button on the options panel.

Deleting Dialogs

  1. In the Dialog Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Note:

  • Building and managing is a potentially complex topic which is covered in depth in the Windows Installer documentation. Rather than attempting to duplicate that information here, please refer to that documentation as your reference guide to specific controls, events, etc...
See Also

Dialogs Overview


%%ItemTitle%%

Managing Action Sequences

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Action Sequences Overview

Action Sequences are a group of actions performed during one of the two possible phases of an installation. All sequences are one of the following three types:

Standard Installation

A standard install sequence is used to install and configure a product in the traditional sense. The result of the standard install sequences is an application properly installed and configured on the target system.

  • UI Sequence - A sequence comprised of user interface elements displayed to provide feedback to the user and gather information to be used during the installation of the product.
  • Execute Sequence - A sequence of standard and custom actions which perform the actual work of installing and configuring the application on the target system.

Administrative Installation

An administrative install sequence is used to prepare a package for deployment to a group of computers in a networked environment. The result of a aministrative installation is an application properly prepared for mass deployment.

  • UI Sequence - A sequence comprised of user interface elements displayed to provide feedback to the user and gather information to be used during the preparation of the administrative install point.
  • Execute Sequence - A sequence of standard and custom actions which perform the actual work of preparing and copying the installation to the administrative install point.

Advertised Installation

An advertised installation is used to install an application in a fully advertised state. The result of a advertised installation is a series of advertisements on the target system, any of which when activated, will trigger the local installation of one or more Features of the product.

  • UI Sequence - Because of the nature of an advertised installation, it may not have a user interface sequence.
  • Execute Sequence - A sequence of standard and custom actions which perform the actual work of installing and configuring the advertisements on the target system.

About Actions

Each sequence is made up of a series of Actions. An Action can be a built-in Standard Action provided by Windows Installer, a Custom Action provided by the package author, or a Dialog defined by the package author. Each Action has a numeric Sequence Number that determines it's order of execution in the sequence, and a Condition, which can be used to control whether the action will execute or not.

Notes:

  • An Action can only appear once in each sequence. In certain situations, where it is desirable to run a Custom Action more than once, this limitation can be overcome by simply making a copy of the Custom Action with the same settings, but a different name.
  • Dialogs are expressly disallowed in all execute sequences.
See Also

Managing Action Sequences


%%ItemTitle%%

Action Sequences Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Action Sequences

The Action Sequences Manager allows you to view and configure Action Sequences for use in your installation package.

Adding Actions

  1. In the Project Explorer, click Action Sequences Manager to display the Action Sequences Manager view.
  2. Select the Sequence you would like to work with from the Sequences list.
  3. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Action Details Dialog.
  4. Enter details for this Action as outlined in the Field Reference below.
  5. Click Save & Close on the dialog's toolbar.

Editing Actions

Edit a Action by simply double-clicking on a row in the Action Sequences Manager or by clicking the Edit button on the options panel.

Deleting Actions

  1. In the Action Sequence Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Action Field Reference

The table below details each field that makes up an Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Action Name Y Specifies a reference to one of the following action types:
  • Standard Action - A built-in action provided by Windows Installer.
  • Custom Action - A Customn Action provided by the package author.
  • Dialog - A user interface element defined by the package author.

NOTE: Dialogs may only appear in UI Sequences.
Action Sequence Y Specifies one of the following Sequences:
  • Install UI Sequence
  • Install Execute Sequence
  • Admin. UI Sequence
  • Admin. Execute Sequence
  • Advt. Execute Sequence
Condition | N | Specifies an optional Condition which must evaluate to TRUE for the action to be executed. A blank value is considered to evaluate to TRUE.
Action Text Description N Specifies an optional description to be displayed in the user interface while this action is executing.

NOTE: Applies to Standard and Custom Actions only.
Action Text Template N Specifies an optional formatting template to be displayed in the user interface if this action sends any action data messages.

NOTE: Applies to Standard and Custom Actions only.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Action Text Description and Action Text Template are provided as an alternate method for editing Action String records. In other words, the values entered here also appear in the Action Strings Manager and vice versa. For more information, please see the Action Strings Overview.
See Also

Action Sequences Overview


%%ItemTitle%%

Managing Properties

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Properties Overview

Installer Properties are variables that the Windows Installer engine uses during an installation. Properties can be initialized through an entry in the Property table, predefined by the Windows Installer engine, or created dynamically at runtime during an installation. This is an important concept to understand since dynamically created properties are not listed in the Property table but may be referenced in many other places within the installation. Managing dynamic Properties carefully is a critical factor in building well-behaved installer packages.

There are three categories of properties used during an installation:

Private Properties

Private Properties are used internally by the Windows Installer engine. Private Properties can only be modified by a user through actions performed in the Installation's User Interface. Private Properties commonly describe the operating system environment. For example, the installer engine sets the WindowsFolder property to the configured value on the system on which the installation is running.

Public Properties

Public properties can be authored into the database and changed by a user or system administrator on the command line, by applying a transform, or by interacting with an authored user interface. Public properties are commonly set by users during the installation. For example, the public property INSTALLLEVEL property can be specified at the command line used to launch the installation or chosen by using an authored user interface.

All Public Properties can be overridden by any user if any of the following conditions are true:

  • The system is running either Windows 95 or Windows 98.
  • The user is a System Administrator.
  • The per-machine EnableUserControl policy is set to 1.
  • The EnableUserControl property is set to 1.
  • This is an Unmanaged Installation that is not being done with Elevated Privileges.

If none of the above conditions are true, the installer limits which Public Properties can be overridden by a user that is not a system administrator. See Secure Public Properties below for more information.

Secure Public Properties

Also referred to as Restricted Public Properties, Secure Public Properties allow the author of an installation package to restrict the Public Properties a user can change. Restrictions are commonly necessary in corporate deployments to maintain a secure environment when the installation requires the installer to use elevated privileges.

Note:

  • An application is a "Managed Application" if System Privileges (also known as Elevated Privileges) are used to install the application. An application is 'Managed" on a system if it is a per-machine installation on Windows NT 4.0, Windows 2000 or Windows XP, or if the application is assigned using Group Policies on Windows 2000 or Windows XP.

If all of the following conditions are met, a user that is not a System Administrator can only override an approved list of Secure Public Properties.

  • The system is Windows NT/Windows 2000/XP.
  • The user is not a System Administrator.
  • The application or product is being installed with Elevated Privileges.

Notes:

  • The author of an installation package can extend this default list to include additional Public Properties by using the SecureCustomProperties property.Setting the EnableUserControl Property or the EnableUserControl System Policy extends the list to all Public Properties. Any users can then change any public property.
  • The installer sets the RestrictedUserControl property whenever the list of Public Properties passed to the server by non-administrator users is restricted.

Required Properties

There are five properties that are required for every installation:

  1. ProductCode
  2. ProductLanguage
  3. Manufacturer
  4. ProductVersion
  5. ProductName

Note:

  • ActiveInstall manages all of these properties and several other significant properties for you. As a result, they are not allowed in the Property Manager view. Instead, they are managed primarily through the Project Properties Dialog.

Order of Property Precedence

The installer sets properties using the following order of precedence:

  1. Properties specified by the operating environment.
  2. Public properties set on the command line.
  3. Public properties listed by the AdminProperties property set during an administrative installation .
  4. Public or private properties set during the application of a transform.
  5. Public or private property that set by authoring the Property table of the .msi file.
See Also

Managing Properties


%%ItemTitle%%

Properties Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Properties

The Installer Properties Manager allows you to view and configure Windows Installer Properties for use in your installation package. Actions like setting Admin, Hidden and Secure Properties, and adding standard Windows Installer Properties are possible.

Adding Properties

  1. In the Project Explorer, click Installer Properties to display the Property Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Property Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Enter Comments for this Property as necessary. Comments are purely for the benefit of the package authors and are not included in the build output.
  5. Click Save & Close on the dialog's toolbar.

Editing Properties

Edit a Property by simply double-clicking on a row in the Property Manager or clicking the Edit button on the options panel.

Deleting Properties

  1. In the Property Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Property Field Reference

The table below details each field that makes up a Property record and provides a description of the usage of each field.

Field Name | Req'd | Description
Property Name Y Specifies a unique name for this Property. You can optionally select a standard Windows Installer Property from the drop-down list. The name you specify here must be unique and fit the criteria of the Windows Installer Identifier Datatype.

Be sure to use all capital letters to indicate this Property is Public, or mixed case to indicate it is Private.
Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype.

A unique Reference Name is automatically provided for you, but you are free to enter your own.
Default Value Y Specifies a Default Value for the Property. The value you provide here can be any length and has no formatting constraints, but may not be left blank.

Click the Localize button next to the Default Value text box to provide values for this field in languages other the default language of your project.
Options N Specifies additional Property settings:
  • Persist Property Value during Admin Installs - Indicates if this Property should be included in the AdminProperties Property. The AdminProperties Property is a semi-colon delimited list of Properties whose value is permanently written to the installation database during an Administrative Installation. During subsequent installation from the Admin Install point, the new Property Value is used in place of any value defined in the installation database.
  • Allow User Modifications even in Managed Installs - Indicates if this Property should be included in the SecureCustomProperties Property. The SecureCustomProperties Property is used to indicate which, if any, properties should be included with the default list of Secure Public Properties that the installer allows to be customized when doing a Managed Installation.
  • Hide Property Value from Logs - Indicate if this Property should be included in the MsiHiddenProperties Property. The MsiHiddenProperties Property is used to prevent the installer from displaying the value of certain properties (passwords or other confidential information) in the installation log file.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • The MsiHiddenProperty Property is only available with Windows Installer 2.0 or greater. Projects targeting earlier versions will not have the value of this property included in the build output.
  • Saving a Property with a blank Default Value results in ActiveInstall setting the Value to "0". Note that a value consisting of one or more spaces (" ") is acceptable.
  • The following Properties are managed by ActiveInstall and therefore cannot be added to your project:
    • ProductName
    • ProductVersion
    • ProductLanguage
    • Manufacturer
    • ProductCode
    • PackageCode
    • UpgradeCode
    • INSTALLDIR
    • ARPNOMODIFY
    • ARPNOREPAIR
    • ARPNOREMOVE
    • ARPCOMMENTS
    • ARPURLINFOABOUT
    • ARPPRODUCTICON
    • ARPREADME
    • ARPCONTACT
    • ARPHELPPHONE
    • ARPHELPLINK
    • ARPURLUPDATEINFO
See Also

Properties Overview


%%ItemTitle%%

Managing Merge Modules

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Merge Modules Overview

Merge Modules are a method of sharing a set of Components and application logic with multiple installation projects. Merge Modules cannot be installed by themselves. Rather, they are 'merged' into an existing Windows Installer package.

Merge Modules can specify other Merge Modules as dependencies which must be present in the installation database for them to ensure proper operation on the target system. Unfortunately, failing to provide a listed dependency results a validation error and not a warning. Often times the dependency is not required because the dependency is met by another system requirement. For example, if your installation requires Windows 2000 or higher, the Microsoft Visual Basic 6 runtime, Component Categories Manager, and OLE 2.40 are already present on the system, yet are listed as a Dependency of many Merge Modules.

Configurable Merge Modules

Configurable Merge Modules are specially authored Modules that contain one or more options that can be customized by the consumer of the Merge Module. For example, a Merge Module can allow the consumer to specify a registration code to enable functionality of licensed components in the Merge Module.

Notes:

  • ActiveInstall is able both create and consume Configurable Merge Modules, however this section is related to consuming them and not creating them.
See Also

Managing Merge Modules


%%ItemTitle%%

Merge Modules Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Merge Modules

The Merge Module Manager allows you to view and configure Windows Merge Module for use in your installation package. Actions like setting Admin, Hidden and Secure Merge Modules, and adding standard Windows Merge Module are possible.

Adding Merge Modules

  1. In the Project Explorer, click Merge Module Manager to display the Merge Module Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Merge Module Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Merge Modules

Edit a Merge Module by simply double-clicking on a row in the Merge Module Manager or clicking the Edit button on the options panel.

Deleting Merge Modules

  1. In the Merge Module Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Merge Module Field Reference

The table below details each field that makes up a Merge Module record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | N/A | Specifies the friendly name of the Merge Module based on the contents of the selected module. Read-Only.
Source Path | Y | Specifies the source location of the Merge Module on the development system.
Ignore Dependencies | N | Specifies that no attempt should be made to include dependent Merge Modules during the build process. NOTE: The default behavior is that during the build, if a dependent Merge Module can be located, it too, will be merged, referencing the same Features as the parent Module.
Features | N | Specifies a collection of Features to which the Merge Module will be associated with during the merge process.
Primary Feature | Y | Specifies the Feature which serves as the Primary Feature for the merge.
Options | N | Specifies a collection of values used to provide configuration data to Configurable merge Modules.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • .
See Also

Merge Modules Overview


%%ItemTitle%%

Project Summary | Package Settings | System Settings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Installer Settings

Action Strings

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Control Strings

Control Strings are small snippets of localized strings used by the Windows Installer Engine when rendering text in controls which is not specified elsewhere.

Manage Control Strings

Message Strings

Message Strings provide a special formatting template used by Windows Installer when processing errors or special messages.

Manage Message Strings

See Also

Project Summary | Package Settings | System Settings


%%ItemTitle%%

Managing Action Strings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Action Strings Overview

Action Strings are localizable snippets of text used to supply the Windows Installer engine with values you would like displayed while long running operations are executing. Action Strings are most commonly used in progress dialogs displayed to the end-user during the installation and are stored in the "ActionText" table in a Windows Installer database.

Aside from the Unique Identifier for the record, ActionText records have two values of significance:

  • Description - The Description column provides a description of the action being performed. It should be broad in scope and encompass the entire operation being executed as it is broadcast only once during the operation. For example, if the operation being performed was creating and populating several databases, an appropriate Description might be "Creating Databases..."
  • Template - The Template column optionally contains a more detailed description of the operation being executed. A standard Windows Installer Action or a Custom Action can send as many messages to the Windows Installer engine as it likes while executing. This means that if, for example, a Custom Action were creating and populating several databases, it could send numerous messages to Windows Installer as it begins each phase of the database creation operation. Along with the ActionData message, the Custom Action can send additional data about the operation being performed. For example, the name of the database being created. In this case, an appropriate Template might be "Creating Database: [1]". Since the name of the database is being passed as the first additional argument, the "[1]" would be replace by the name of the database prior to being displayed or logged.

Notes:

  • The Description field may be written to the installations's log file file depending on the logging options specified, however, the Template fields value is never written to the log.
  • There are three required entries in the ActionText table: Rollback, RollbackCleanup, and GenerateScript. These entries represent internal action taken by the Windows Installer engine at runtime. The Description field may be modified, but the template must always be "[1]".

Tips:

  • Use Action Strings prudently. While it is good to provide the user with plenty of feedback, too much information can be overwhelming, dizzying, and not very useful. For example, many authors create Action Strings which include the name of each file as it is being copied to the target system. This type of Action String provides little value to the user and tends to cause annoying flickering as the names of dozens or hundreds of files fly across the users screen. Avoid this behavior by providing a value in the Description field ("Copying Files..."), but leaving the Action Data Formatting Template field blank.
See Also

Managing Action Strings


%%ItemTitle%%

Action Strings Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Action Strings

The Action Strings Manager allows you to view and configure Action Strings for use in your installation package.

Adding Message Strings

  1. In the Project Explorer, click Installer Settings, then Action Strings to display the Action Strings Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Action String Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Action Strings

Edit an Action String by simply double-clicking on a row in the Action String Manager or clicking the Edit button on the options panel.

Deleting Action Strings

  1. In the Action String Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Action String Field Reference

The table below details each field that makes up a Action String record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Formatting Template | N | Specifies a Formatting Template for the Action String. The value you provide here can be no more than 255 characters in length and must fit the criteria of the Windows Installer Template Datatype. The provided template may include replacement parameters in the form "[n]" where n is a numeric value corresponding to an additional parameter passed to the Windows Installer engine at runtime. Click the Localize button next to the Action Data Formatting Template text box to provide values for this field in languages other the default language of your project.
Description | N | Specifies a description for the overall action being performed. Must be no more than 255 characters in length and has no formatting constraints.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • There are 3 special ActionStrings you should be aware of. They are Rollback, RollbackCleanup, and GenerateScript. These items are special values required by Windows Installer. As such, you may modify the value of the Description field, but they may not be otherwise modified or deleted.
See Also

Action Strings Overview


%%ItemTitle%%

Managing Message Strings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Message Strings Overview

Message Strings are localizable snippets of text used to supply the Windows Installer engine with values you would like displayed during the visible portion of your installation. Message Strings are commonly used for Error Messages displayed to the end-user during the installation and are stored in the "Error" table in a Windows Installer database, but in no way are simply Error Messages. There are x types of Message Strings:

  1. Fatal Error Messages - These types of Message Strings allow Windows Installer to display an author defined and localized message to the end-user at runtime when a fatal error occurs.
  2. Standard Error Messages - These types of Message Strings allow Windows Installer to display an author defined and localized message to the end-user at runtime when an error occurs. Typically this is an error that has been anticipated and therefore has a specific message number devoted to it.
  3. Status Messages - These types of Message Strings allow Windows Installer to display an author defined and localized message to the end-user at runtime during long running operations, or to provide feedback as to what is going on as a long running process executes.
  4. Information Messages - These types of Message Strings allow Windows Installer to display an author defined and localized message to the end-user at runtime. For example, a custom action that verifies a user's serial number might use this type of message to inform the user that validation of the serial number failed.
  5. User Request Messages - These types of Message Strings allow Windows Installer to display an author defined and localized message to the end-user at runtime when specific user action is required. For example, number 1803 is used when Windows Installer attempts to read from removable media that is not present. The user is prompted to either cancel or retry, therefore the normal Template used in this case is:
    "There is no disk in drive [2]. Please insert one and click Retry, or click Cancel to go back to the previously selected volume."

Tips:

  • Keep in mind that while Message Strings do map to the Error Table in a MSI database, many of the records found in this table are not errors at all, but instead are messages being communicated to and from the Windows Installer engine!
  • Text enclosed in double curly braces {{text}} is only visible in the log file. Use this to your advantage by providing extended error information available in the log only while keeping error messages visible to the user fairly friendly. ;-)
See Also

Managing Message Strings


%%ItemTitle%%

Control Strings Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Message Strings

The Message Strings Manager allows you to view and configure Message Strings for use in your installation package.

Adding Message Strings

  1. In the Project Explorer, click Installer Settings, then Message Strings to display the Message Strings Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Message String Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Message Strings

Edit a Message String by simply double-clicking on a row in the Message String Manager or by clicking the Edit button on the options panel.

Deleting Message Strings

  1. In the Message String Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Message String Field Reference

The table below details each field that makes up a Message String record and provides a description of the usage of each field.

Field Name | Req'd | Description
Message # | Y | Specifies a unique message number for this record. Must conform to the Windows Installer Integer Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Message Template | Y | Specifies a Message Template for the new Message String. The value you provide here can be no more than 255 characters in length and must fit the criteria of the Windows Installer Template Datatype. Click the Localize button next to the Message Template text box to provide values for this field in languages other the default language of your project.
Source Path | Y | Specifies the source path to the resource file on the development system.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • The range of Message#'s between 25000 to 30000 are reserved for use by your Custom Actions. It is highly recommended that you use only this range for custom messages, but is not enforced in any way.
See Also

Control Strings Overview


%%ItemTitle%%

Managing Control Strings | Control Strings Reference

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Control Strings Overview

Control Strings are localizable snippets of text used to supply the Windows Installer engine with values you would like displayed during the visible portion of your installation. Most, if not all of the Control Strings used are pre-defined values that Windows Installer explicitly looks for prior to displaying certain controls, or before firing certain Control Events. There are 51 pre-defined values used by the Windows Installer Engine. Please see the Reference page for the specific details of each standard Control String.

Control String Example:

To help illustrate what a Control String is and why we need them, let's consider an example:

The "SelParentCostPosPos" UIText record is used here to inform the user that, based on the current feature selection state, the "pcAnywhere" feature requires 11 MB of disk space. It also tells us that 1 of the 2 sub-features has been selected for installation, which adds an additional 1938 KB to the total disk space required to install the currently selected features.

So, what really happened here? Let's walk through it step by step:

  1. User clicks on "pcAnywhere"
  2. Windows Installer tallies the number of sub-features, their selection state and the amount of disk space required for each feature.
  3. Since it needs to display disk space expressed in megabytes and kilobytes, Windows Installer queries the UIText table for records with "MB" and "KB" in column one.
  4. Next, it queries the UIText table for an appropriate entry based in the criteria discovered in step 2. In this case, it's the "SelParentCostPosPos" record. Using the display value from column 2 of this record, and the disk size formatting instructions from step 3, Windows Installer builds the string seen in the picture above.
  5. Next, Windows Installer raises the "SelectionSize" Control Event to let any interested controls know that the updated info is available.
  6. Since the Text Control seen on the dialog above (inside the red rectangle) is subscribed to the "SelectionSize" event, it's value is automatically updated to reflect the new value that Windows Installer just generated.

Notes:

  • Hidden sub-features can create a confusing situation for the attentive user since the sub-feature count DOES NOT include hidden features and the disk space requirements displayed DOES include hidden Features. For example, if all sub-features in the Selection Tree in the dialog above are set to not install, the displayed text will still indicate that 0 of 2 sub-features are selected and yet the sub-features require 958 KB of disk space. Why? Because there are hidden sub-features not displayed in the Selection Tree.

  • When Windows Installer builds strings representing disk space, it strictly concatenates the values together. This means that if your "MB" entry has a value of "MB", the resulting value will be "11MB" (note that there is no space). To ensure your strings come out looking properly formatted, insert a space into the disk formatting entries. Entering " MB" (note the space in the string) for the Display Value will result in "11 MB".

See Also

Managing Control Strings | Control Strings Reference


%%ItemTitle%%

Control Strings Overview | Control Strings Reference

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Control Strings

The Control Strings Manager allows you to view and configure Control Strings for use in your installation package.

Adding Control Strings

  1. In the Project Explorer, click Installer Settings, then Control Strings to display the Control Strings Manager view.
  2. Select Add... from the options panel or use the keyboard shortcut <Insert> while this view is active to display the Control String Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Control Strings

Edit a Control String by simply double-clicking on a row in the Control String Manager or clicking the Edit button on the options panel.

Deleting Control Strings

  1. In the Control String Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Control String Field Reference

The table below details each field that makes up a Control String record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Display Value | Y | Specifies a Display Value for the new Control String. The value you provide here can be no more than 255 characters in length and has no formatting constraints. Click the Localize button next to the Display Value text box to provide values for this field in languages other the default language of your project.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • All 51 Pre-defined Control Strings cannot be deleted or have their Reference Name field modified, but they can have their Display Value field modified.

See Also

Control Strings Overview | Control Strings Reference


%%ItemTitle%%

Control Strings Overview | Managing Control Strings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Control Strings Reference

Control Strings are localizable snippets of text used to supply the Windows Installer engine with values you would like displayed during the visible portion of your installation. Most, if not all of the Control Strings used are pre-defined values that Windows Installer explicitly looks for prior to displaying certain controls, or before firing certain Control Events. The section below outlines all 51 pre-defined values used by the Windows Installer Engine.

Certain Control Strings include special parameters that are substituted for dynamic values at run time. Parameters are numeric values encased in square brackets. For example: "[1]". To use an available parameter, simply include it in the display value. For example, "This Feature Requires [1] disk space." The parameters available for each pre-defined Control String are included in the reference below.

SelectionTree Control Strings (Disk Related)

Reference Name | Description
AbsentPath
Published during a SelectionPath Control Event. Published to display a descriptive string in a Path control when the state of the selected Feature is set to "Not Installed".
SelChildCostPos Published during a SelectionSize Control Event. Published to display the disk space required for the selected Feature when that Feature is a child feature but NOT a parent to another Feature.

Parameters:

[1]: The amount of disk space required. For example: "54 MB"
SelChildCostNeg Published during a SelectionSize Control Event. Published to display the disk space to be reclaimed for the selected Feature when that Feature is a child feature but NOT a parent to another Feature.

Parameters:

[1]: The amount of disk space to be reclaimed. For example: "54 MB"
SelParentCostPosPos Published during a SelectionSize Control Event. Published to display the disk space required for the selected Feature when that Feature is a parent to another Feature and that Feature is being installed and one or more of the child features are being installed.

Parameters:

[1]: The amount of disk space required for the selected feature only. For example: "54 MB"
[2]: The number of sub-features selected for installation.
[3]: The total number of sub-features for the currently selected feature.
[4]: The amount of disk space required for all sub-features selected for installation. For example: "54 MB"
SelParentCostPosNeg Published during a SelectionSize Control Event. Published to display the disk space required for the selected Feature when that Feature is a parent to another Feature and that Feature is being installed and one or more of the child features are being removed.

Parameters:

[1]: The amount of disk space required for the selected feature only. For example: "54 MB"
[2]: The number of sub-features selected for removal.
[3]: The total number of sub-features for the currently selected feature.
[4]: The amount of disk space to be reclaimed for all sub-features selected for removal. For example: "54 MB"
SelParentCostNegPos Published during a SelectionSize Control Event. Published to display the disk space required for the selected Feature when that Feature is a parent to another Feature and that Feature is being removed and one or more of the child features are also being installed.

Parameters:

[1]: The amount of disk space to be reclaimed for the selected feature only. For example: "54 MB"
[2]: The number of sub-features selected for installation.
[3]: The total number of sub-features for the currently selected feature.
[4]: The amount of disk space required for all sub-features selected for installation. For example: "54 MB"
SelParentCostNegNeg Published during a SelectionSize Control Event. Published to display the disk space required for the selected Feature when that Feature is a parent to another Feature and that Feature is being removed and one or more of the child features are being removed.

Parameters:

[1]: The amount of disk space to be reclaimed for the selected feature only. For example: "54 MB"
[2]: The number of sub-features selected for removal.
[3]: The total number of sub-features for the currently selected feature.
[4]: The amount of disk space to be reclaimed for all sub-features selected for removal. For example: "54 MB"
SelCostPending | Published to display a message while disk space requirements are being calculated.

SelectionTree Control Strings (Feature State)

Reference Name | Description
SelAbsentAbsent | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is "Not Installed" and is not being changed.
SelAbsentAdvertise | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from "Not Installed" to "Install on first Use".
SelAbsentCD | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from "Not Installed" to Run from CD.
SelAbsentLocal | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from "Not Installed" to Run Locally.
SelAbsentNetwork | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from "Not Installed" to Run from Network.
SelAdvertiseAbsent | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Installed on First Use to "Not Installed".
SelAdvertiseAdvertise 'Added | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is Installed on First Use and is not being changed.
SelAdvertiseCD | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Installed on First Use to Run from CD.
SelAdvertiseLocal | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Installed on First Use to Run Locally.
SelAdvertiseNetwork | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Installed on First Use to Run from Network.
SelCDAbsent | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run from CD to "Not Installed".
SelCDAdvertise | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run from CD to Installed on First Use.
SelCDCD | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is Run from CD and is not being changed.
SelCDLocal | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run from CD to Run Locally.
SelLocalAbsent | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run Locally to "Not Installed".
SelLocalAdvertise | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run Locally to Installed on First Use.
SelLocalCD | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run Locally to Run from CD.
SelLocalLocal | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is Installed on First Use and is not being changed.
SelLocalNetwork | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run Locally to Run from Network.
SelNetworkAbsent | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run from Network to "Not Installed".
SelNetworkAdvertise | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run from Network to Installed on First Use.
SelNetworkLocal | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is changing from Run from Network to Run Locally.
SelNetworkNetwork | Published during a SelectionAction Control Event. Describes the action to be taken when the state of the feature is Run from Network and is not being changed.

SelectionTree Control Strings (Feature Menu)

Reference Name | Description
MenuAbsent | Used to control the text displayed in the Feature State menu for the Absent menu item.
MenuAdvertise | Used to control the text displayed in the Feature State menu for the Install on First Use menu item.
MenuLocal | Used to control the text displayed in the Feature State menu for the Install Locally menu item.
MenuCD | Used to control the text displayed in the Feature State menu for the Run from CD menu item.
MenuNetwork | Used to control the text displayed in the Feature State menu for the Run from Network menu item.
MenuAllLocal | Used to control the text displayed in the Feature State menu for the Install Entire Feature Locally menu item.
MenuAllCD | Used to control the text displayed in the Feature State menu for the Run Entire Feature from CD menu item.
MenuAllNetwork | Used to control the text displayed in the Feature State menu for the Run Entire Feature from Network menu item.

VolumeCostList Control Strings

Reference Name | Description
VolumeCostAvailable | Used to control the text displayed in the Column Header for the Available Space column.
VolumeCostDifference | Used to control the text displayed in the Column Header for the Difference column.
VolumeCostRequired | Used to control the text displayed in the Column Header for the Required Space column.
VolumeCostSize | Used to control the text displayed in the Column Header for the Volume Size column.
VolumeCostVolume | Used to control the text displayed in the Column Header for the Volume Name column.

Misc. Control Strings

Reference Name | Description
Bytes | Used in multiple place by the Windows Installer Engine. Indicates the text to be displayed when displaying disk storage units in Bytes.
KB | Used in multiple place by the Windows Installer Engine. Indicates the text to be displayed when displaying disk storage units in Kilobytes.
MB | Used in multiple place by the Windows Installer Engine. Indicates the text to be displayed when displaying disk storage units in Megabytes.
GB | Used in multiple place by the Windows Installer Engine. Indicates the text to be displayed when displaying disk storage units in Gigabytes.
ScriptInProgress | Published by the Windows Installer Engine to controls that Subscribe to the ScriptInProgress Control Event. Indicates the format of the Time Remaining text.
NewFolder | Used by the Windows Installer Engine when creating new folders. Indicates the default naming convention for new folders. Uses the SFN|LFN syntax.
TimeRemaining Published by the Windows Installer Engine to controls that Subscribe to the TimeRemaining Control Event. Indicates the format of the Time Remaining text.

Parameters:

[1]: The minutes portion of the estimated time remaining. For example: "2 Minutes"
[2]: The seconds portion of the estimated time remaining. For example: "22 Seconds"

See Also

Control Strings Overview | Managing Control Strings


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

File System Manager Overview

The File System Manager is used to create and configure Files and Folders used in your installation. The following items can be managed from this view:

Files

File records represent files that are to be installed and registered on the target system. Several file registration methods are available depending on the file type.

Read More...

Directories

Directory records represent directories being created by your installation or pre-defined system folders on the target system.

Read More...


%%ItemTitle%%

Managing Files

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Files Overview

Files are records that represent Files that are to be installed to the target system.

Windows Installer allows you to create instructions that effectively set permissions on a file based on a User Name and optional Domain.

Files can be broken down into the following types, each of which have special handling considerations:

Fonts

Font files *should* always be the Key Member of the responsible Component that controls their installation state. Installing a Font requires that special actions be taken by Windows Installer, so as a result, you need to ensure that Fonts use this registration option. TrueType fonts have the Font Name embedded in them so no further information is required. In the case of non-TrueType fonts, an option Font Name can be specified.

COM Servers

COM Servers MUST always be the Key Member of the responsible Component that controls their installation state. COM Servers require one of the following two registration options in order to operate properly:

  • Self-Registration - A technique which calls DLLRegisterServer when the component is installed and DLLUnregisterServer when the component is uninstalled. Use of this technique is not recomended.
  • COM Advertisement - A technique which allows a Feature providing the COM Server to be Advertised in much the same way a shortcut operates. This is seamless to the consumer of the server, since a minimal set of registry entries are created initially, which provides OLE with enough information to recognize the server as properly installed.

Assemblies

Assemblies MUST always be the Key Member of the responsible Component that controls their installation state. Win32 or .NET Assemblies require special registration actions to be taken to ensure they operate properly on the target system. Options include specifying a collection of configuration parameters and installing to the Global Assembly Cache.

Notes:

  • Files are one of more complex topics related to Windows Installer. For a complete understanding, please refer to the Platform SDK documentation.
See Also

Managing Files


%%ItemTitle%%

Files Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Files

The File System Manager allows you to view and configure Files for use in your installation package.

Adding Message Strings

  1. In the Project Explorer, click File System Manager to display the File System Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the File Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Files, Folders or entire structures of Files & Folders can be dragged & dropped to the target system in the File System Manager. In this situation, ActiveInstall makes some basic decisions for you based on best pactices that should meet most of your needs. Once the drag & drop operation is complete, you are free to make changes to the Feature/Component assignments as you see fit. The following is a summary of the basic rules used when adding multiple files or folders:

  • For each drag & drop operation, the user is prompted for a Feature to which the new components will be assigned. ALL new components are assigned to this single Feature.
  • Each .exe, .scr, .cpl, ocx, .dll file causes a new component to be created, with that file assigned as it's Key Member.
  • Each .fon, or .ttf file causes a new component to be created, with that file assigned as it's Key Member Additionally, each file will have it's Registration type set to "Font".
  • For each folder with files that do not meet the above criteria, a Component is created with the folder as it's Key Member. All other files are assigned to this Component.

Editing Files

Edit an File by simply double-clicking on a row in the File System Manager or clicking the Edit button on the options panel.

Deleting Files

  1. In the File System Manager, select the record you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

File Field Reference

The table below details each field that makes up a File record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
File Name N Specifies name assigned to the file on the target system.

To explicitly specify a short file name, use the format "SFN|LFN" where SFN is the short version and LFN is the long version. If no short version is provided and one is required, ActiveInstall will generate a name for you based on the long file name provided.

Click the Localize button next to the File Name text box to provide values for this field in languages other the default language of your project.
Size N Specifies the size of the file in bytes.

NOTE: While this field is not Read-Only, the value is currently overwritten with the current size during the build process.
Language N Specifies a list of decimal language IDs separated by commas.

NOTE: Font files should not be authored with a language ID, as fonts do not have an embedded language ID resource.
Compression N Specifies the Compression setting for this file. Can be one of the following values:
  • Default - The file is compressed or ncompressed basedf on the settings for the project.
  • Compressed - Overrides the Project Settings, forcing this File to be compressed.
  • Uncompressed - Overrides the Project Settings, forcing this File to be uncompressed.
Versioning N Specifies the type of versioning used for this file. Can be one of the following values:
  • Use Version - The specified version(if any) is used.
  • Use Companion File - The version of the specified file is used.

NOTE: Files that are the Key Member of a Component cannot be a Companion to another(versioned) file.

TIP: Windows Installer ALWAYS makes decisions about whether to install a file based on the version contained in this record and not on the actual file provided with the installation. This fact can be leveraged in some situations to 'force' a file's installation state one way or the other.
Source File Location | N | Specifies the path to the Source File on the development system.
Read-Only | N | Specifies whether the file should be marked as a "Read-Only File" when installed to the target system.
Hidden | N | Specifies whether the file should be marked as a "Hidden File" when installed to the target system.
System | N | Specifies whether the file should be marked as a "System File" when installed to the target system.
Vital | N | Specifies whether the installation should fail if the file is not sucessfully installed to the target system.
Component | N | Specifies the Component whose installation state controls whether this file is installed or removed.
Registration Type N Specifies the Registration Type for this file. Can be one of the following values:
  • Standard File - Indicates a standard file with no extended options.
  • Font - Indicates the file is a font. Enables options to set the Name of the font. Applies to non-TrueType fonts only.
  • COM Server - Indicates the file is a COM Server. Enables options to control how the file is registered on the target system.
  • Assembly - Indicates the file is a Win32 or .NET Assembly. Enables options to configure advanced settings.
Permissions | N | Specifies a collection of 0 or more Permissions to be set for the file. See the Permission Field Reference below for more information.
Duplication | N | Specifies a collection of 0 or more Duplicate File Actions to be performed for the file. See the Duplicate File Action Field Reference below for more information.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Duplicate Action Field Reference

The table below details each field that makes up a Duplicate File Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Component | Y | Specifies a Component whose installation state controls this duplication action. Can be any Component EXCEPT the Component to which this file is a member.
Destination Folder | N | Specifies the Folder the Duplicate File will be copied to. A blank value results in the file being copied to the same folder as the original.
Destination Name | N | Specifies the name given to the Duplicate File. A blank value results in the original name being used.

Note: The Destination Folder and Destination Name should never BOTH be blank. This would result oin the Duplicate File having the exact same Path and Name as the original file. In essence, no action would take place.

Permission Field Reference

The table below details each field that makes up a Registry Permission record and provides a description of the usage of each field.

Field Name | Req'd | Description
Domain | N | Specifies the domain of the user for which permissions are to be set. This is the name of a stand-alone machine or a domain name. The column data type is Formatted, so with Windows Installer 2.0 or later you can get the current domain by using the string %USERDOMAIN to get the value of the USERDOMAIN environment variable. Obtaining any other domain requires the use of a custom action.
User | Y | Specifies the name of the user for which permissions are to be set. This name must be located on the machine or domain. The installation fails if the machine or domain controller does not recognize the domain and user combination or if the user's security identifier (SID) cannot be retrieved. With Windows Installer 2.0 or later, the common user names "Everyone," and "Administrators" may be entered in English and are mapped to Well-Known SIDs. LocalSystem is given full control in all security descriptors created through the LockPermissions table. You may use the ComputerName property, LogonUser property, or the USERNAME property in this field to get the current user. A custom action is required to obtain the name of any other user or group.
Permissions | Y | Specifies the numeric permissions to be set.

See Also

Files Overview


%%ItemTitle%%

Managing Directories

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Directories Overview

Directories are records which define both the location of source files and the destination of files on the target sytem.

Understanding the behavior surrounding the Directory table can be a bit confusing for users new to Windows Installer, so we've compiled this list of Key Concepts to help clarify some common points of confusion:

Key Concepts:

  • A System Folder can be placed anywhere in your Directory heirarchy, but at runtime it ALWAYS resolves to the predefined location on the target system.
  • TARGETDIR is ALWAYS the destination folder for your installation. Using a user-defined property such as "INSTALLDIR" is ill-advised since TARGETDIR already exists for just this purpose.
  • If TARGETDIR is left undefined, it resolves to the value of ROOTDRIVE
  • If ROOTDRIVE is left undefined, it resolves to the root of the first physical drive with the most free space. For example, if you have two hardrives, C: with 1 GB of free space, and D: with 2GB of free space, then the value of ROOTDRIVE will be "D:\".
  • EVERY Folder defined in the Directory table can be easily re-targeted. The structure of the Directory table merely provides a default structure.
  • ALL Directory Names (Column 1 of the Directory table) are Properties. Uppercase directory names can have their location changed on the commandline since they are Public Properties, while mixed case names cannot, since they are private.
  • The TargetDir column(Column 3 of the Directory table) has no effect on the name of System Folders on the target system. For example, an entry with ProgramFilesFolder in col 1 can have "My Program Files" in col 3, but no change will be made to the system folder "C:\Program Files\" on the target system.

Setting the Installation Directory

There are generally two commonly used methods used to set the default installation directory:

  • Method 1: Explicit Parent Directories

In this method, user-defined directories are created which create the desired structure without the use of any other mechanism. The root installation directory is made Public (all caps) to allow it to be set from the command-line.

For example, a Directory named "My Company" is created under "ProgramFilesFolder", another Directory is created under "My Company" named "My Product". This directory is given the name "INSTALLDIR".

This works fairly well, even if INSTALLDIR is changed on the command line, since the parent directory won't be created since it is empty. The real problem with this method is that to change the install directory from the command-line, you have to have prior knowledge of the INSTALLDIR. Changing the value of TARGETDIR has no effect since it is not being used.

  • Method 2: Custom Action

In this method, a Custom Action is used to set the default location, but only if it has not already been set by some other method. This method sticks with the documented and expected TARGETDIR property and provides the greatest amount of flexibility for the author and consumer of the package.

NOTE: All ActiveInstall templates use this method.

See Also

Managing Directories


%%ItemTitle%%

Directories Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Directories

The File System Manager allows you to view and configure Directories for use in your installation package.

Adding Message Strings

  1. In the Project Explorer, click Installer Settings, then Directories to display the File System Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Directory Details Dialog.
  3. Provide the requested details as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Directories

Edit an Directory by simply double-clicking on a row in the File System Manager or clicking the Edit button on the options panel.

Deleting Directories

  1. In the File System Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Directory Field Reference

The table below details each field that makes up a Directory record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own. NOTE: This value becomes a property available for use in other areaas of your installation. To make the Property Public, ensure that it is enter in all uppercase characters. Mixed case names make the Property private.
Target Name | N | Specifies the name of the target (destination) directory using long file name format. NOTE: Short names for directories are created as needed during the build process.
Target Is Parent | N | Specifies that the location of the directory is actually in it's parent directory. See the notes below this reference for more information.
Source Name | N | Specifies the name of the source directory using long file name format. NOTE: Short names for directories are created as needed during the build process.
Source Is Parent | N | Specifies that the location of the directory is actually in it's parent directory. See the notes below this reference for more information.
Permissions | N | Specifies a collection of 0 or more Permissions to be set for the specified key or value. Does not apply to remove actions. See the Permission Field Reference below for more information.
Empty Folder Creation | N | Specifies a collection of Components, any of which, when installed will cause this directory to be created even if the directory will be empty.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Notes:

  • In certain situations you may have a need to install a platform specific version of a file with the same name. For example, one file named myfile.dll for Win9x machines and another file also named myfile.dll for WinNT machines. In this scenario, you can create the folder the files will be installed to, let's call it MyFolder, then create two subfolders, one called Win9x and the other called WinNT. By marking the two subfolders with the Target Is Parent and Source Is Parent flags, you are now able to include two files in the same folder with the same name. Of course you would conditionalize the components to ensure only one of the two files will be installed, but this should help to illustrate the use of the * Is Parent fields.
See Also

Directories Overview


%%ItemTitle%%

Managing Shortcuts

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Shortcuts Overview

Shortcuts are links to files or applications installed on the target system.

There are three types of shortcuts used in a Windows Installer package:

Windows Installer Shortcuts

A Windows Installer Shortcut is a special type of shortcut supported on all operating systems with Internet Explorer 4.01 or greater installed.

A Windows Installer Shortcut contains a pointer to three pieces of information; 1.) a product code 2.) a feature name 3.) a component name. When a Windows Installer Shortcut is activated, the Windows Installer engine uses information contained in the installation package(obtained by using #1) to verify that the Key Member of each Component in the requested Feature(obtained from #2) is properly installed. If any problem is detected, Windows Installer will automatically repair the entire Feature(#2), and finally activate the key member of the Component(obtained from #3) specified by the shortcut.

While Windows Installer Shortcuts are often referred to as "Advertised Shortcuts", we chose to refer to them as "Windows Installer Shortcuts". The reason is simple: There is no such thing as an Advertised Shortcut. Only Features can be advertised.

Standard Shortcuts

A Standard Shortcut is simply a pointer to an installed file. Standard shortcuts do not support the resiliency features mentioned above. The target of a Standard Shortcut is specified by the use of a Formatted Property. For example, setting the target to "[#ReadMe.txt]" indicates that Windows Installer should set the target of the shortcut to the installed location of the file whose unique name is "ReadMe.txt".

Command-line Shortcuts

A command-line shortcut is a shortcut whose target is defined as a command and optional argument which are executed when the shortcut is activated. The most important distinction between this and the other shortcut types, is that this shortcut is completely disconnected from anything being installed by the installation package. The author of the installation must ensure that the specified command will be valid on the target system.

For example, a command-line shortcut can be used to launch a read-me file with notepad. In this case, the command is "notepad.exe" and the argument is "[#ReadMe.txt]". Note that the argument is replaced at install time with the actual path that "ReadMe.txt" is installed to.

Notes:

  • Standard and Command-line Shortcuts seem very straightforward at a glance, but can quickly become quite complicated due to the nature of user profiles, per-machine/per-user installs, and the relationships between Features, Components and their key paths. As a result, you should avoid them and use Windows Installer shortcuts whenever possible.
See Also

Managing Shortcuts


%%ItemTitle%%

Shortcuts Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Shortcuts

The Shortcuts Manager allows you to view and configure Shortcuts for use in your installation package.

Adding Shortcuts

  1. In the Project Explorer, click Shortcut Manager to display the Shortcut Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Shortcut Details Dialog.
  3. Enter details for this Shortcut as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Shortcuts

Edit a Shortcut by simply double-clicking on a row in the Shortcut Manager or by clicking the Edit button on the options panel.

Deleting Shortcuts

  1. In the Shortcut Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Shortcut Field Reference

The table below details each field that makes up a Shortcut record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Shortcut Type Y Specifies one of the following Shortcut types:
  • Windows Installer - A special shortcut which supports resiliency and install-on-demand for advertised Features.
  • Standard - A shortcut that launches a file installed by the current installation.
  • Command Line - A shortcut that executes a command-line.
Display Name | Y | Specifies the name of the shortcut displayed to the user.
Directory | Y | Specifies the directory on the target system that the shortcut will be installed to.
Target | Y | Specifies the target of the shortcut. The value of this setting is dependent on the Shortcut Type field.
Description | N | Specifies the descriptive text for the shortcut, usually displayed as a tool-tip in the user's start menu.
Icon | Y | Specifies the icon to be displayed for Windows Installer Shortcuts. Required for Windows Installer Shortcuts. Not available to all other types.
Working Directory | N | Specifies the current directory to start in when the shortcut is activated.
Argument | N | Specifies the argument passed to the target when the shortcut is activated. Not available to Windows Installer Shortcuts.
Window Style | Y | Specifies the initial window state to be set when the shortcut is activated.
HotKey N Specifies the system-wide hotkey for this shortcut.

Use of this option is not recommend because this can add duplicate hotkeys to a users desktop. In addition, the practice of assigning hotkeys to shortcuts can be problematic for users using hotkeys for accessibility.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Icons are extracted as necessary at build-time. As a result, it is acceptable to select an executable file when choosing the shortcut's icon, since only the chosen icon is included in the built package.
See Also

Shortcuts Overview


%%ItemTitle%%

Managing Associations

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Associations Overview

Associations are used to connect applications with file types that they are able to utilize. The connection between the specific file type and the application is typically made when a user double-clicks a file in Windows Explorer, opens an e-mail attachment or downloads a file from the internet. A Windows Installer Association is a special type of Association supported on all operating systems with Internet Explorer 4.01 or greater installed.

Much like shortcuts, a Windows Installer Association contains a pointer to three pieces of information; 1.) a product code 2.) a feature name 3.) a component name. When a Windows Installer Association is activated, the Windows Installer engine uses information contained in the installation package(obtained by using #1) to verify that the Key Member of each Component in the requested Feature(obtained from #2) is properly installed. If any problem is detected, Windows Installer will automatically repair the entire Feature(#2), and finally activate the key member of the Component(obtained from #3) specified by the Association.

Verbs

For each association created, one or more Verbs can also be created. A Verb is a command made available for a given File Type through the Windows Shell. The most common example is when a user right-clicks on a file. A menu appears, offering the user a number of options for what he might like to do with the file. For example, Edit, Print, etc...

MIME Types

For each association created, one or more MIME Types can also be created. Creating a MIME Type instructs Windows Installer to have the target system treat the MIME Type just the same as files with the extension specified in the Association.

See Also

Managing Associations


%%ItemTitle%%

Associations Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Associations

The Associations Manager allows you to view and configure Associations for use in your installation package.

Adding Associations

  1. In the Project Explorer, click Association Manager to display the Association Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Association Details Dialog.
  3. When prompted, enter the extension for this Association without the leading period. For example, "aix".
  4. Enter details for this Association as outlined in the Field Reference below.
  5. Click Save & Close on the dialog's toolbar.

Editing Associations

Edit a Association by simply double-clicking on a row in the Association Manager or by clicking the Edit button on the options panel.

Deleting Associations

  1. In the Association Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Association Field Reference

The table below details each field that makes up a Association record and provides a description of the usage of each field.

Field Name | Req'd | Description
File Extension | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own. Do not include a leading period.
Associated Application | Y | Specifies the Application (Component) which will open this file type and the Feature which will provide the application. NOTE: Since more than one Feature can provide a given Component, what you are selecting here is the Feature that Windows Installer should install or repair (if needed when activating this Association.
Prog ID | N | Specifies the name of a Prog ID to be used with this Association. NOTE: The selected Prog ID provides the file types icon and description displayed by the Windows shell.
Default MIME Type | N | Specifies a primary MIME Type for this Association.
Verbs | N | Specifies 0 or more Verbs that are to be made available for this Association. See the Verb Field Reference below for more information.
MIME Types | N | Specifies 0 or more MIME Types that are to be made available for this Association. See the MIME TYpe Field Reference below for more information.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Verb Field Reference

The table below details each field that makes up a Verb record and provides a description of the usage of each field.

Field Name | Req'd | Description
Verb | Y | Specifies a unique name for this record.
Sequence | N | Specifies the ordering of Verbs in a context menu. Verbs with values provided are sorted in that order, with the lowest number becoming the default verb. If no value is provided, the menu items are unordered.
Command | N | Specifies the name of the command displayed to the user. May include a pneumonic, (for example, "&Print...") but you should use caution to ensure you don't create a conflict with another command which may already exist for this file type.
Argument | N | Specifies arguments passed to the associated application when this Verb is executed.

MIME Type Field Reference

The table below details each field that makes up a MIME Type record and provides a description of the usage of each field.

Field Name | Req'd | Description
Content Type | Y | Specifies a unique name for this record. Also specifies the Content Type. For example, "text/html".
CLSID | N | Specifies an optional CLSID to associate with this MIME Type. This can be a CLSID being installed, or a CLSID which already exists on the target system.

Note:

  • Icons are extracted as necessary at build-time. As a result, it is acceptable to select an executable file when choosing the Association's icon, since only the chosen icon is included in the built package.
See Also

Associations Overview


%%ItemTitle%%

Managing Registry Modifications

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Registry Modifications Overview

Registry Modifications are actions used to perform changes to the system registry on the target system.

Windows Installer allows you to create instructions that effectively set permissions on a Registry key or value based on a User Name, and an optional Domain.

See Also

Managing Registry Modifications


%%ItemTitle%%

Registry Modifications Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Registry Modifications

The Registry Manager allows you to view and configure Registry Modifications for use in your installation package.

Adding Registry Modifications

  1. In the Project Explorer, click Registry Manager to display the Registry Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Registry Modification Details Dialog.
  3. Enter details for this Registry Modification as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Registry Modifications

Edit a Registry Modification by simply double-clicking on a row in the Registry Manager or by clicking the Edit button on the options panel.

Deleting Registry Modifications

  1. In the Registry Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Registry Field Reference

The table below details each field that makes up a Registry Modification record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. Must conform to the Windows Installer Identifier Datatype. A unique Reference Name is automatically provided for you, but you are free to enter your own. Do not include a leading period.
Action Y Specifies the action to be taken. Can be one of the following values:
  • Create/Update Item - The key is to be created if absent, or updated if present, when the component is installed.
  • Create Key on Install - The key is to be created, if absent, when the component is installed.
  • Remove Key on Uninstall - The key is to be deleted, if present, with all of its values and subkeys, when the component is uninstalled.
  • Create Key on Install/Remove on Uninstall - The key is to be created, if absent, when the component is installed. Additionally, the key is to be deleted, if present, with all of its values and subkeys, when the component is uninstalled.
  • Remove Item - The item is to be deleted, if present, when the component is installed
  • Remove Key - The key is to be deleted, if present, with all of its values and subkeys, when the component is installed
Registry Root Y Specifies the predefined root key for the registry value. Can be one of the following values:
  • HKEY_RUNTIME - Indicates either HKEY_LOCAL_MACHINE or HKEY_CURRENT_USER depending on whether the install is being perfromed for all users or the current user only.
  • HKEY_CLASSES_ROOT
  • HKEY_CURRENT_USER
  • HKEY_LOCAL_MACHINE
  • HKEY_USERS
Section Key | Y | Specifies the registry path to be used with this Registry Modification.
Name | N | Specifies the name of the registry item used with this Registry Modification.
Value | N | Specifies the value used with this registry Modification.
Value Type N Specifies the type of Value. Can be one of the following values:
  • REG_SZ
  • REG_BINARY
  • REG_EXPAND_SZ
  • REG_DWORD
Component | Y | Specifies the Component whose installation state controls controls whether this Registry Modification will be performed on the target system.
Permissions | N/A | Specifies a collection of 0 or more Permissions to be set for the specified key or value. Does not apply to remove actions. See the Permission Field Reference below for more information.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Permission Field Reference

The table below details each field that makes up a Registry Permission record and provides a description of the usage of each field.

Field Name | Req'd | Description
Domain | N | Specifies the domain of the user for which permissions are to be set. This is the name of a stand-alone machine or a domain name. The column data type is Formatted, so with Windows Installer 2.0 or later you can get the current domain by using the string %USERDOMAIN to get the value of the USERDOMAIN environment variable. Obtaining any other domain requires the use of a custom action.
User | Y | Specifies the name of the user for which permissions are to be set. This name must be located on the machine or domain. The installation fails if the machine or domain controller does not recognize the domain and user combination or if the user's security identifier (SID) cannot be retrieved. With Windows Installer 2.0 or later, the common user names "Everyone," and "Administrators" may be entered in English and are mapped to Well-Known SIDs. LocalSystem is given full control in all security descriptors created through the LockPermissions table. You may use the ComputerName property, LogonUser property, or the USERNAME property in this field to get the current user. A custom action is required to obtain the name of any other user or group.
Permissions | Y | Specifies the numeric permissions to be set.

See Also

Registry Modifications Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

COM Resources Overview

The COM Resources Manager is used to create and configure COM-related resources for your installation. The following types of resources can be configured:

COM Classes

COM Classes are used as an alternative method for installing COM Components to the target system.

Read More...

Type Libraries

Type Libraries are used to install and configure Type Libraries on the target system.

Read More...

Prog IDs

Prog IDs are used to install and configure Prog IDs on the target system.

Read More...


%%ItemTitle%%

Managing COM Classes

See Also ActiveInstall Online Documentation Send Feedback on this topic.

COM Classes Overview

COM Classes are actions used to set-up and configure support for advertisement of COM Resources on the target system.

Windows Installer supports two mechanisms for installing COM Servers and ActiveX components:

Self-Registration

Self-Registration is the process of calling the DLLRegisterServer and DLLUnregisterServer functions in a COM component. Calling these functions instructs the component to create the registry entries necassary for the component to operate properly. Windows Installer supports self-registration of components, but it is strongly discouraged since it defeats many of the advantages and features of the Windows Installer technology.

COM Advertisement

COM Advertisement is one of the advertising-related Features provided by Windows Installer.

The best way to think of COM Advertisement is to liken it to a Windows Installer shortcut. In fact, the truth is that COM Advertisement works exactly like a Windows Installer Shortcut. To help illustrate this, consider the following scenario:

  1. An installation is run that installs a COM Component that installs a .dll (using the COM Advertisement mechanism).
  2. The user deletes the .dll file.
  3. The user executes a script that contains the following line:
    oObj = CreateObject("MyServer.MyLib")
  4. The Windows Installer service 'intertcepts' the request for an instance of the object, and based on settings contained in the installation, verifies that all Key Members of Components provided by the Feature listed in the COM tables are properly installed. Since the file is not found, the Windows Installer service reinstalls the appropriate Feature, then allows the instance of the server to be created and handed back to the calling script.

For more details on COM Advertisement, please refer to the Platform SDK docs.

See Also

Managing COM Classes


%%ItemTitle%%

COM Classes Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing COM Classes

The COM Resources Manager allows you to view and configure COM Classes for use in your installation package.

Adding COM Classes

  1. In the Project Explorer, click COM Resources Manager to display the COM Resources Manager view.
  2. Select COM Classes from the Resource Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the COM Class Details Dialog.
  3. Enter details for this COM Class as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing COM Classes

Edit a COM Class by simply double-clicking on a row in the COM Resources Manager or by clicking the Edit button on the options panel.

Deleting COM Classes

  1. In the COM Resources Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

COM Class Field Reference

The table below details each field that makes up a COM Class record and provides a description of the usage of each field.

Field Name | Req'd | Description
CLSID | Y | Specifies a unique Class identifier for the COM server.
Associated Server | Y | Specifies the Feature/Component combination that provides the COM Server.
Server Context Y Specifies The server context for this server. Can be one of the following values:
  • LocalServer
  • LocalServer32
  • InprocServer
  • InprocServer32
Default Prog ID | N | Specifies the default Program ID associated with this Class. This field is a reference to a Prog ID record.
Default InProc Handler N Specifies a default inproc handler.

This field only applies to Classes where the Server Context field is LocalServer or LocalServer32.

A non-numeric value is treated as a system file that serves as the 32-bit InprocHandler (appearing as the InprocHandler32 value).
Arguments N Specifies the argument used by OLE while creating the OLE server.

This field only applies to Classes where the Server Context field is LocalServer or LocalServer32.
Description | N | Specifies the description associated with the Class ID and Prog ID.
File Type Mask N Specifies a File Type Mask for this server.

If multiple patterns exist, they must be delimited by a semicolon.

For more information about this functionality, refer to the documentation for the GetClassFile function.
Icon | N | Specifies the icon associated with this Class.
Use Relative Path | N | Specifies whether the bare file name can be used for COM servers. If enabled, the installer registers the file name only instead of the complete path. This enables the server in the current directory to take precedence and allows multiple copies of the same component.
AppID | N | Specifies the DCOM AppID. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
Remote Server Name | N | Specifies the DCOM Remote Server Name. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
Local Service | N | Specifies the DCOM Local Service Name. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
Service Parameters | N | Specifies the DCOM Service Parameters. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
DLL Surrogate | N | Specifies theDCOM DLL Surrogate. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
Activate at Storage | N | Specifies theDCOM Activate At Storage setting. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
Run As Interactive User | N | Specifies the DCOM Run As Interactive User setting. For more information on DCOM configuration, refer to the DCOM documentation in the Platform SDK.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

COM Classes Overview


%%ItemTitle%%

Managing Type Libraries

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Type Libraries Overview

Type Libraries are actions used to set-up and configure Type Libraries in support if COM Advertisement on the target system.

For more information on COM Advertisement, refer to the COM Classes topic or the Platform SDK docs.

See Also

Managing Type Libraries


%%ItemTitle%%

Type Libraries Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Type Libraries

The COM Resources Manager allows you to view and configure Type Libraries for use in your installation package.

Adding Type Libraries

  1. In the Project Explorer, click COM Resources Manager to display the COM Resources Manager view.
  2. Select Type Libraries from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the Type Library Details Dialog.
  3. Enter details for this Type Library as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Type Libraries

Edit a Type Library by simply double-clicking on a row in the COM Resources Manager or by clicking the Edit button on the options panel.

Deleting Type Libraries

  1. In the COM Resources Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Type Library Field Reference

The table below details each field that makes up a Type Library record and provides a description of the usage of each field.

Field Name | Req'd | Description
Type Library ID | Y | Specifies a unique GUID that identifies the library.
Associated Server | Y | Specifies the Feature/Component combination that provides the Type Library.
Language | Y | Specifies the language of the type library.
Version | N | Specifies the version of the library.
Registration Cost | N | Specifies an additional cost incurred by the installation as result of registering this Type Library.
Description | N | Specifies a description of the Type Library.
Help Directory | N | Specifies the Help path for the type library.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Type Libraries Overview


%%ItemTitle%%

Managing Prog IDs

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Prog IDs Overview

Prog IDs are actions used to set-up and configure Program IDs on the target system.

Windows Installer allows you to configure 0 or more Version Independent Prog IDs for each Prog ID created.

Prog IDs are used for a number of purposes, so for more information, please refer to the Platform SDK documentation.

See Also

Managing Prog IDs


%%ItemTitle%%

Prog IDs Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Prog IDs

The COM Resources Manager allows you to view and configure Prog IDs for use in your installation package.

Adding Prog IDs

  1. In the Project Explorer, click COM Resources Manager to display the COM Resources Manager view.
  2. Select Prog IDs from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the Prog ID Details Dialog.
  3. Enter details for this Prog ID as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Prog IDs

Edit a Prog ID by simply double-clicking on a row in the COM Resources Manager or by clicking the Edit button on the options panel.

Deleting Prog IDs

  1. In the COM Resources Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Prog ID Field Reference

The table below details each field that makes up a Prog ID record and provides a description of the usage of each field.

Field Name | Req'd | Description
Prog ID | Y | Specifies a unique Program ID for this record.
Icon | N | Specifies the Icon for this Prog ID.
Class | N | Specifies the COM Class associated with this Prog ID.
Description | N | Specifies the the Description for this Prog ID.
Version Independent Prog IDs | N | Specifies a collection of Version Independent Prog IDs.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

Prog IDs Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

ODBC Resources Overview

The ODBC Resources Manager is used to mange the following types of ODBC related data:

ODBC Data Sources

ODBC Data Sources are used to define and configure ODBC Data Sources to be installed and configured on the target system.

Read More...

ODBC Drivers

ODBC Drivers are used to define and configure ODBC Drivers to be installed and configured on the target system.

Read More...

ODBC Translators

ODBC Translators are used to define and configure ODBC Translators to be installed and configured on the target system.

Read More...


%%ItemTitle%%

Managing ODBC Data Sources

See Also ActiveInstall Online Documentation Send Feedback on this topic.

ODBC Data Sources Overview

ODBC Data Sources are actions used to set-up and configure ODBC Data Sources on the target system. The installation and removal of ODBC Resources is controlled by the state of the Component to which the resource is assigned.

Data Sources can be installed for all system users or for the current user only.

Data Sources also allow you to create a collection of ODBC Attributes which contain additional configuration parameters for the specific provider (driver) being used. Attributes are defined as simple name/value pairs. Specific configurable options depend on the driver being used, so refer the documentation for your driver for more information.

See Also

Managing ODBC Data Sources


%%ItemTitle%%

ODBC Data Sources Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing ODBC Data Sources

The ODBC Resources Manager allows you to view and configure ODBC Data Sources for use in your installation package.

Adding ODBC Data Sources

  1. In the Project Explorer, click ODBC Resources Manager to display the ODBC Resources Manager view.
  2. Select ODBC Data Sources from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the ODBC Data Source Details Dialog.
  3. Enter details for this ODBC Data Source as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing ODBC Data Sources

Edit a ODBC Data Source by simply double-clicking on a row in the ODBC Resources Manager or by clicking the Edit button on the options panel.

Deleting ODBC Data Sources

  1. In the ODBC Resources Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

ODBC Data Source Field Reference

The table below details each field that makes up a ODBC Data Source record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Registration Y Specifies how the Data Source will be registered. Can be one of the following values:
  • System - The Data Source is available to all users of the system.
  • User - The Data Source is only available to the current user.
Data Source Name | Y | Specifies the name that will given to the Data Source on the target system.
Driver | Y | Specifies the name of the Driver used by this Data Source. This value can be a Driver which already exists on the target system, or a Driver being installed.
ODBC Attributes | N | Specifies a collection of name/value pairs used to provide additional configuration parameters for this Data Source. Specific values depend on the driver being used, so refer to your driver's documentation for more information.
Component | Y | Specifies the Component whose installation state controls controls whether this Data Source will be installed or removed from the target system.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

ODBC Data Sources Overview


%%ItemTitle%%

Managing ODBC Drivers

See Also ActiveInstall Online Documentation Send Feedback on this topic.

ODBC Drivers Overview

ODBC Drivers are actions used to set-up and configure ODBC Drivers on the target system. The installation and removal of ODBC Resources is controlled by the state of the Component to which the resource is assigned.

Drivers allow you to create a collection of ODBC Attributes which contain additional configuration parameters for the specific provider (driver) being used. Attributes are defined as simple name/value pairs. Specific configurable options depend on the driver being used, so refer the documentation for your driver for more information.

See Also

Managing ODBC Drivers


%%ItemTitle%%

ODBC Drivers Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing ODBC Drivers

The ODBC Resources Manager allows you to view and configure ODBC Drivers for use in your installation package.

Adding ODBC Drivers

  1. In the Project Explorer, click ODBC Resources Manager to display the ODBC Resources Manager view.
  2. Select ODBC Drivers from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the ODBC Driver Details Dialog.
  3. Enter details for this ODBC Driver as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing ODBC Drivers

Edit a ODBC Driver by simply double-clicking on a row in the ODBC Resources Manager or by clicking the Edit button on the options panel.

Deleting ODBC Drivers

  1. In the ODBC Resources Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

ODBC Driver Field Reference

The table below details each field that makes up a ODBC Driver record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Driver Name | Y | Specifies the name that will given to the Driver on the target system.
Driver File | Y | Specifies the File being installed which provides the Driver.
Setup File | N | Specifies the File being installed which provides the setup functions for the driver. If no File is selected, the Driver File is assumed to provide setup functions.
ODBC Attributes | N | Specifies a collection of name/value pairs used to provide additional configuration parameters for this Driver. Specific values depend on the driver being used, so refer to your driver's documentation for more information.
Component | Y | Specifies the Component whose installation state controls controls whether this Driver will be installed or removed from the target system.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

ODBC Drivers Overview


%%ItemTitle%%

Managing ODBC Translators

See Also ActiveInstall Online Documentation Send Feedback on this topic.

ODBC Translators Overview

ODBC Translators are actions used to set-up and configure ODBC Translators on the target system. The installation and removal of ODBC Resources is controlled by the state of the Component to which the resource is assigned.

See Also

Managing ODBC Translators


%%ItemTitle%%

ODBC Translators Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing ODBC Translators

The ODBC Resources Manager allows you to view and configure ODBC Translators for use in your installation package.

Adding ODBC Translators

  1. In the Project Explorer, click ODBC Resources Manager to display the ODBC Resources Manager view.
  2. Select ODBC Translators from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the ODBC Translator Details Dialog.
  3. Enter details for this ODBC Translator as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing ODBC Translators

Edit a ODBC Translator by simply double-clicking on a row in the ODBC Resources Manager or by clicking the Edit button on the options panel.

Deleting ODBC Translators

  1. In the ODBC Resources Manager, select the row you would like to delete.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

ODBC Translator Field Reference

The table below details each field that makes up a ODBC Translator record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Translator Name | Y | Specifies the name that will given to the Translator on the target system.
Translator File | Y | Specifies the File being installed which provides the Translator.
Setup File | N | Specifies the File being installed which provides the setup functions for the Translator. If no File is selected, the Translator File is assumed to provide setup functions.
Component | Y | Specifies the Component whose installation state controls controls whether this Translator will be installed or removed from the target system.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

See Also

ODBC Translators Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

System Services Manager

The System Services Manager is used to mange two types of actions related to Sytem Services:

Service Install Actions

Service Install Actions are used to install system services to NT-based systems.

Read More...

Service Control Actions

Service Control Actions are used to Start, Stop, or Delete services on NT-based systems.

Read More...


%%ItemTitle%%

Managing Service Install Actions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Service Install Actions Overview

Service Install Actions are used to install and configure System Services on NT-based systems.

Note:

  • Kernel-Mode and File System Drivers are not supported by Microsoft
  • A Description field was added in Windows Installer 2.0.
  • Starting with Windows Installer 2.0, passwords specified in the ServiceInstall table are not written to the installation log.
See Also

Managing Service Install Actions


%%ItemTitle%%

Service Install Actions Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Service Install Actions

The System Services Manager allows you to view and configure Service Install Actions for use in your installation package.

Adding Service Install Actions

  1. In the Project Explorer, click System Services Manager to display the System Services Manager view.
  2. Select Service Install Actions from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the Service Install Action Details Dialog.
  3. Enter details for this Service Install Action as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Service Install Actions

Edit a Service Install Action by simply double-clicking on a row in the System Services Manager or by clicking the Edit button on the options panel.

Deleting Service Install Actions

  1. In the System Services Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Service Install Action Field Reference

The table below details each field that makes up a Service Install Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Service File | Y | Indicates the File record who will provide the Service. This field is for display purposes only and is driven by the Key Member of the currently selected Component. Read-Only.
Service Type Y Specifies the type of Service being configured. Can be one of the following values:
  • Standard - Isolated Process - A Microsoft Win32 service that runs its own process.
  • Standard - Shared Process - A Win32 service that shares a process.
  • Kernel-Mode Driver - A Driver Service.
  • File System Driver - A File System Driver Service..
Service Name | Y | Specifies the name used to control and manage this service on the target system.
Startup Mode Y Specifies the mode used to start this serrvice on the target system. Can be one of the following values:
  • Sytem Boot - A device driver started by the operating system loader. Valid for drivers only.
  • System Start - A device driver started by calling the IoInitSystem function. Valid for Drivers only.
  • Automatic - A service start during startup of the system.
  • Manual - A service start when the service control manager calls the Win32 StartService function.
  • Disabled - Specifies a service that can no longer be started.
Display Name | N | Specifies the Display Name visible to users in any user interface displayed for for this service. For example, the Service Control Manager.
Error Control Y Specifies the action taken by the startup program if the service fails to start during startup.
  • Log and Continue - Logs the error and continues with the startup operation.
  • Log, Display and Continue - Logs the error, displays a message box and continues the startup operation.
  • Log (if possible) and Reboot - Logs the error if it is possible and the system is restarted with the last configuration known to be good. If the last-known-good configuration is being started, the startup operation fails.
Description | N | Specifies a description for the service being configured. If this field is left blank any existing description will remain unchanged. To erase an existing description enter "[~]" in this field. This field only applies to Windows Installer 2.0 or greater.
Interactive | N | Specifies whether the service is able to interact with the desktop.
Component | Y | Specifies the Component whose Key Member is an executable File providing the Service.
Dependencies | N | Specifies a list of names of services or load ordering groups that the system must start before starting this service. Separate names in the list by Null markers("[~]"). Dependency on a group means that this service can run if at least one member of the group is running after an attempt to start all members of the group.
Load Order Group | N | Specifies the load ordering group of which this Service is a member.
Arguments | N | Specifies any command line arguments required to run the Service.
Run As | N | Specifies the account the service is logged on as. If the Service Type is Standard - Isolated Process use an account name in the form: DomainName\UserName. If the account belongs to the built-in domain it is permitted to specify .\UserName. The LocalSystem account must be used if the Service Type is Standard - Shared Process. The Win32 CreateService function uses the LocalSystem account if the Run As field is left blank, so therefore, most services can leave this column blank.
Password N Specifies the password to the account name in the Run As field.

With Windows Installer 2.0 and later versions, the installer never writes the value entered into the Password field into the log file.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Deleting a Service Install Action does NOT delete the file providing the Service from your installation.

  • The value entered in the Password field is NOT written to the log file for installations using Windows Installer 2.0 or greater.

  • The Description field was added in Windows Installer 2.0. The value you provide here is simply ignored in projects using an earlier version.

  • Kernel-mode and File System Drivers are not supported by Microsoft.

  • After deleting a service that was installed with a user name and password, the installer cannot rollback the service without first using a custom action to get the password. The installer can acquire all the necessary information about the service except the password, which is stored in a protected part of the system. The custom action acquires the password by prompting the user, reading a property from the database, or reading a file. The custom action must then call the Win32 ChangeServiceConfig function, to supply the password, before reinstalling the service.

See Also

Service Install Actions Overview


%%ItemTitle%%

Managing Service Control Actions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Service Control Actions Overview

Service Control Actions are used to control services on NT-based systems during your installation. Services that already exist on the target system can be controlled in addition to services being installed by your installation. In all cases, services can be started, stoped or deleted in an combination during install and/or uninstall.

See Also

Managing Service Control Actions


%%ItemTitle%%

Service Control Actions Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Service Control Actions

The System Services Manager allows you to view and configure Service Control Actions for use in your installation package.

Adding Service Control Actions

  1. In the Project Explorer, click System Services Manager to display the System Services Manager view.
  2. Select Service Control Actions from the Action Type list. Select Add... from the options panel or use the keyboard short <Insert> to display the Service Control Action Details Dialog.
  3. Enter details for this Service Control Action as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Service Control Actions

Edit a Service Control Action by simply double-clicking on a row in the System Services Manager or by clicking the Edit button on the options panel.

Deleting Service Control Actions

  1. In the System Services Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Service Control Action Field Reference

The table below details each field that makes up a Service Control Action record and provides a description of the usage of each field.

Field Name | Req'd | Description
Reference Name | Y | Specifies a unique name for this record. A unique Reference Name is automatically provided for you, but you are free to enter your own.
Service Name | Y | Specifies the name of the service to be controlled. This name can be the name of a Service being installed, or the name of a service already present on the target system.
Arguments | N | Specifies a list of arguments for starting this service. Multiple arguments are separated by Null markers("[~]"). For example, the list of arguments One, Two, and Three are listed as: One[~]Two[~]Three.
Install Actions N Specifies the action(s) to be taken during installation of the Component listed in the Component field. Can be any compination of the following values:
  • Start - Starts the service during the StartServices action.
  • Stop - Stops the service during the StopServices action.
  • Delete - Deletes the service during the DeleteServices action.
Uninstall Actions N Specifies the action(s) to be taken during removal of the Component listed in the Component field. Can be any compination of the following values:
  • Start - Starts the service during the StartServices action.
  • Stop - Stops the service during the StopServices action.
  • Delete - Deletes the service during the DeleteServices action.
Critical | N | Specifies whether the installation should wait for the servicew to fully complete the requested action, or just long enough to confirn that the Service Control Manager has acknowledged the request.
Component | Y | Specifies the Component whose Key Member is an executable File providing the Service.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Service Control Actions are processed by three separate Standard Actions, so it is possible that you may have other Actions running in between the point where a service is Started, Stopped, or Deleted.

See Also

Service Control Actions Overview


%%ItemTitle%%

Managing Post-Build SQL

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Post-Build SQL Overview

Post-Build SQL Statements are used to perform modifications to the .msi or .msm file generated by ActiveInstall at the end of the build process. There are two primary situations where this feature may prove useful:

Customizing Build Output

In the unlikely situation that ActiveInstall is not producing the exact output desired, Post-Build SQL can be used to 'tweak' the final installation database. For example, if you wanted to set an unsupported bit in the Attributes colum of the Feature table, you would created your Feature normally, but also created a Post-Build SQL statement to modify the field after the database is built.

Product Configurations

Since Post-Build SQL statements can be toggled on or off for each Build Configuration, you can easily leverage this feature to control different Product Configurations. For example, if you have a product with a "Light Version" and a "Professional Version", you can build the project to the requirements of the Professional version, then use Post-Build SQL statements to remove features not available in the light version, change the product name, etc...

Note:

  • Post-Build SQL statements are executed after the database is built, but prior to validation being performed. This ensures that the final validation done against the build output reflects changes made by your Post-Build SQL statements.
See Also

Managing Post-Build SQL


%%ItemTitle%%

Post-Build SQL Overview

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Managing Post-Build SQL

The Post-Build SQL Manager allows you to view and configure Post-Build SQL statements for use in your installation package.

Adding Post-Build SQLs

  1. In the Project Explorer, click Post-Build SQL Manager to display the Post-Build SQL Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Post-Build SQL Details Dialog.
  3. Enter details for this Post-Build SQL as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Post-Build SQLs

Edit a Post-Build SQL by simply double-clicking on a row in the Post-Build SQL Manager or by clicking the Edit button on the options panel.

Deleting Post-Build SQLs

  1. In the Post-Build SQL Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Post-Build SQL Field Reference

The table below details each field that makes up a Post-Build SQL record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies a unique name for this record. A unique Name is automatically provided for you, but you are free to enter your own.
SQL Statement | Y | Specifies the SQL Statement to be executed. NOTE: The "Verify" option validates that the statement executes properly against an empty database with the same schema that will be used to build the project based on the current settings. Errors can still occur during the actual execution of the statement at build time, so be sure to monitor that portion of the build process very closely.
Build Configurations | N | Specifies each Build Configuration that the Post-Build SQL should be executed for. A check mark next a Build Configuration means the Post-Build SQL WILL be executed for that configuration.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Post-Build SQL statements are executed after the database is built, but prior to validation being performed. This ensures that the final validation done against the build output reflects changes made by your Post-Build SQL statements.

See Also

Post-Build SQL Overview


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing Custom Tables

The Custom Table Manager allows you to view, configure and manage data for Custom Tables used in your installation package.

Adding Custom Tables

  1. In the Project Explorer, click Custom Table Manager to display the Custom Table Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Custom Table Details Dialog.
  3. Enter details for this Custom Table as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Custom Tables

Edit a Custom Table by simply double-clicking on a row in the Custom Table Manager or by clicking the Edit button on the options panel.

Deleting Custom Tables

  1. In the Custom Table Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Custom Table Field Reference

The table below details each field that makes up a Custom Table record and provides a description of the usage of each field.

Field Name | Req'd | Description
Table Name | Y | Specifies a unique name for this record. A unique Name is automatically provided for you, but you are free to enter your own.
Column Definitions | Y | Specifies one or more columns for this Custom Table. Each Custom Table must have at least one Column. Form ore information, see the Column Definition Field Reference below.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Column Definition Field Reference

The table below details each field that makes up a Custom Table record and provides a description of the usage of each field.

Field Name | Req'd | Description
Column Name | Y | Specifies a unique name for this column.
Data Type | Y | Specifies the basic data type for this column.
Max Length | N | Specifies the maximum size allowed for string values. Valid values are in the range of 0-255. A value of 0 indicates that no max length should be enforced.
Required Field | N | Specifies whether a NULL (blank) value is allowed.
Primary Key | N | Specifies whether the column should be treated as a primary key for the table. NOTE: The first column of all tables must be a Primary Key column. Multiple Primary Key columns can be designated, but they must follow in immediate succession. For example, if you have three Primary key columns, they must be columns 1, 2 and 3.
Extended Data Type | N | Specifies an extended datatype used for this column. Use of this field is strongly advised wherever appropriate in that it will alert you to potentail errors in your data during the build process.
Min | N | Specifies the minimum acceptable numeric value. Applies to numeric datatypes only. All others are ignored.
Max | N | Specifies the maximum acceptable numeric value. Applies to numeric datatypes only. All others are ignored.
Foreign Key Tables(s) | N | Specifies an option table name to which this column is a Foreign key to. The Foreign Key Col# (below) indicates the specific column for the relationship. Multiple tables may be delimited using semi-colons(";").
Foreign Key Col# | N | Specifies the numeric column number of the Foreign Key relationship. This field is only valid if one or more tables where specified in the Foreign Key Table(s) field. Valid values are in the range of 1-32. If multiple tables are listed in Foreign Key Table(s) field, they must all share the same column#.
Description | N | Specifies a contextual description of the data stored in this column.

Note:

  • You can create a maximum of 20 columns in each Custom Table.

  • Data for the Custom Table is not validated according to the Column Definition as it is entered. All values are treated as simple strings. It is the authors responsibility to ensure data entered meets the requirements of the chosen data type.

  • Entering data that does not conform to the Column Definition will result in build and/or validation errors.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Merge Module Configurable Items Overview

Merge Module Configurable Items are attributes that are configurable by the consumer of the merge module. This enables the merge module to be configured at the time the installation package and module are merged and installed by the end user. Configurable merge modules require version 2.0 of Mergemod.dll but can run on any version of the Windows Installer.

Configurable merge modules are fully compatible with tools earlier than Mergemod.dll version 2.0. In these cases, the tool uses the default values in the module.

Note:

  • Configurable Items work hand-in-hand with Merge Module Substitutions. A Merge Module Substitution item that refers to a non-existant Confiurable Item will cause the Merge to fail.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Merge Module Configurable Items

The Merge Module Configurable Items Manager allows you to view and configure Merge Module Configurable Items for use in your Merge Module projects.

Adding Merge Module Configurable Items

  1. In the Project Explorer, click Merge Module Configurable Items Manager to display the Merge Module Configurable Items Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Merge Module Configurable Item Details Dialog.
  3. Enter details for this Merge Module Configurable Item as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Merge Module Configurable Items

Edit a Merge Module Configurable Item by simply double-clicking on a row in the Merge Module Configurable Items Manager or by clicking the Edit button on the options panel.

Deleting Merge Module Configurable Items

  1. In the Merge Module Configurable Items Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Merge Module Configurable Item Field Reference

The table below details each field that makes up a Merge Module Configurable Item record and provides a description of the usage of each field.

Field Name | Req'd | Description
Name | Y | Specifies the name of the Configurable Item. This name is referenced in the formatting template in the Value column of Merge Module Substitution items.
Display Name | N | Specifies a short description of this item that the authoring tool may use in the user interface.
Data Type Y Specifies the Data Type of the Default Value and of any value provided by the authoring tool at merge time. Can be one of the following values:
  • Arbitrary Text
  • List Value
  • Windows Installer Formatted Text
  • Windows Installer Identifier
  • Rich Text Format
  • Integer
  • Foreign Key
  • Bitfield
Default Value | N | Specifies a default value to be used if the merge tool declines to provide a value. This value must conform to the specification of the selected Data Type. If this is a "Foreign Key", the Foreign Key must be a valid key into the tables of the module.
Bit Mask
- or -
Table 		N Specifies a numeric Bit Mask used to ensure only allowable bits are set in the provided value.

If the data type is a Foreign Key, then this field specifies a table reference. Can be one of the following values:
  • Binary (Bitmap)
  • Binary (EXE)
  • Binary (EXE 64)
  • Binary (Icon)
  • Dialog (Next)
  • Dialog (Previous)
  • Directory (Component)
  • Directory (Shortcut)
  • File
  • Icon
  • Property
  • Property (Private Only)
  • Property (Public Only)
Description | N | Specifies a description of this item that the authoring tool may use in UI elements.
Help Location | N | Specifies either the name of a help file (without the .chm extension) or a semicolon delimited list of help namespaces. This column can be blank if no help is available.
Help Keyword | N | Specifies a keyword into the help file or namespace from the Help Location field. The interpretation of this keyword depends on the Help Location field.
Allow Null Values | N | Specifies whether NULL is an allowable value. Does not apply to Integer or BitField data types.
Skip Unreferenced Rows N Applies to Foreign Key data types only. Specifies that the merge tool should not merge the row referenced by the Default Value field into the target database if the following conditions are satisfied after processing all configuration options:
  • Every Configurable Item with the same Default Value has the Skip Unreferenced Rows property set.
  • No rows are using the Default Value as a result of the authoring tool not providing a value.
List Values | N | Specifies the Primary Key which uniquely identifies the row used in this Configurable Item. Multi-column keys are specified by delimiting the keys with semicolons (";"). Literal semicolons can be escaped with backslashes ("\") .
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Refer to the Windows Installer doumentation of Configurable Merge Modules for much more valuable information.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Merge Module Relationships Overview

Merge Module Relationships are used in Merge Module Projects to define and store the following types of relationships between the Merge Module being created and other well-known Merge Modules:

Dependencies

Merge Modules can define one or more other Merge Modules with which it is dependect upon in order to function properly when installed on the target system. Dependency relationships are specified by the Dependency Module's ModuleID, Language and an optional Version. If a version is not specified then it is assumed that ANY version of the specified Module meets the dependency requirement.

Exclusions

Merge Modules can also define one or more other Merge Modules with which a known conflict exists. In other words, if both Merge Modules were installed as part of the installation, a known problem would exist. Exclusions are defined by the excluded Module's ModuleID, Language, and an optional Minimum and Maximum Version. The Language specified can be expressed as a negative number, which indicates that all languages except the one provided should be excluded. See the Managing Module Relationships topic for more information.

Note:

  • Relationships are evaluated collectively and not based on a single item. For example, an Exclusion may exist which says that says all languages except French should be excluded. Another Exclusion may exist that says all languages except Spanish should be excluded. In the case of a Spanish module, the French exclusion will be ignored, since the Spanish item expressly allows the Spanish module.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing Merge Module Relationships

The Merge Module Relationships Manager allows you to view and configure Merge Module Relationships for use in your Merge Module projects.

Adding Merge Module Relationships

  1. In the Project Explorer, click Merge Module Relationships Manager to display the Merge Module Relationships Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Merge Module Relationship Details Dialog.
  3. Enter details for this Merge Module Relationship as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Merge Module Relationships

Edit a Merge Module Relationship by simply double-clicking on a row in the Merge Module Relationships Manager or by clicking the Edit button on the options panel.

Deleting Merge Module Relationships

  1. In the Merge Module Relationships Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Merge Module Relationship Field Reference

The table below details each field that makes up a Merge Module Relationship record and provides a description of the usage of each field.

Field Name | Req'd | Description
Relationship Type | Y | Specifies a unique name for this record. A unique Name is automatically provided for you, but you are free to enter your own.
Module ID | Y | Specifies the ModuleID of the Merge Module identified by this relationship.
Language | N | Specifies a numeric Language ID (LANGID) for the Relationship. A value of "0" indicates that language should no be consider when evaluationg the relationship. For exclusions only, a negative value can be used to indicate that all languages except the one provided are to be excluded. A positive value means the specified language is to be excluded. "0" indicates that no exclusion is made based on language.
Min. Version | N | Specifies the Minimum version in the range. If no value is provided, then ALL versions less than Max. Version are excluded.
Max. Version | N | Specifies the Maximum version in the range. If no value is provided, then ALL versions greater than Min. Version are excluded.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Merge Module Relationships are evaluated collectively and not based on a single item. For example, an Exclusion may exist which says that says all languages except French should be excluded. Another Exclusion may exist that says all languages except Spanish should be excluded. In the case of a Spanish module, the French exclusion will be ignored, since the Spanish item expressly allows the Spanish module.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

ActiveInstall IDE Reference

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Condition Builder Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

GUID Generator Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

New Item Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

New Project Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Open Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Options Dialog

The Options Dialog is used to set a variety or options affecting the behavior of ActiveInstall. This topic describes each of the settings available on each tab of the Options Dialog.

General

Dialog Editor Options

  • Display Layout Grid - Specifies whether a grid of small dots is displayed in the background of Dialogs while they are being edited.
  • Grid Size - Specifies the number of pixels separating each dot.
  • Align Controls to Grid - Specifies whether controls should 'snap' to the nearest grid point when being sized or dragged.

Internet Options

  • Use My Default Settings - Indicates that ActiveInstall should not use any special settings when connecting to the internet.
  • Use these Custom Settings: - Indicates that ActiveInstall should use the custom settings provided.
  • Use this Proxy Server - Indicates that ActiveInstall should use the provided proxy server and port.
  • Proxy Server - Specifies the host name or IP Address of a proxy server to use for connectiong to the internet.
  • Proxy Port - Specifies the port to use with the specified Proxy Server when connectiong to the internet.

Debug Mode

  • Normal - Specifies that only errors in critical sections should be displayed for reporting and diagnosis.
  • Strict - Specifies that ALL errors should be displayed for reporting and diagnosis.

Folders

Default Project Folder

Specifies the default path used for creating new projects.

Templates Folder

Specifies the path used for Project Templates.

Search Paths

Specifies a collection of folders used when searching for dependencies of Merge Modules.

SourceSafe

SourceSafe Authentication

  • Use Windows Logon Credentials - Specifies that ActiveInstall should use the current user's Windows Logon credentials when connecting to SourceSafe
  • Use Custom Credentials - Specifies that an alternate name and password should be used when connecting to SourceSafe.
  • User Name - Specifies a custom user name for SourceSafe authentication.
  • Password - Specifies a custom password used for SourceSafe authentication.
    NOTE: Passwords are encrypted before being stored with the user's settings.

SourceSafe Options

  • Database - Specifies an alternate database to use. If no value is provided, ActiveInstall uses the most recently used database by the SourceSafe client application.

Visual Basic for Applications

Visual Basic® for Applications

  • Enable VBA Integration - Specifies whether VBA should be integrated with ActiveInstall. (Requires application restart).
  • Manage Security - Allows management of security settings used when working with ActiveInstall projects containing VBA code.
  • Manage Add Ins - Allows management of COM Add Ins.

Misc. Options

  • Reserved for future use.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Action Chooser Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Column Definition Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Text Styles Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

COM Settings Dialog

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Assembly Settings

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Feature Details Dialog

The Feature Details Dialog allows you to maintain the properties and settings of an individual Feature in your installation.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Wizards

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Component Export Wizard

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

Visual Basic for Applications | COM Add-Ins | Automation Interface

See Also ActiveInstall Online Documentation Send Feedback on this topic.

ActiveInstall Extensibility Overview

ActiveInstall provides three primary mechanisms through which it can be customized or extended. Different types of solutions can use any of the following approaches or a combination of all of them!

Visual Basic for Applications - Provides the quickest and easiest way to extend ActiveInstall

COM Add-Ins - Provides the most power, speed and durability but is a slightly more complex programming model.

Automation Interface - Perfect for creating quick scripts, automated builds, etc...

See Also

Visual Basic for Applications | COM Add-Ins | Automation Interface


%%ItemTitle%%

COM Add-Ins | Automation Interface

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Visual Basic for Applications

ActiveInstall is pleased to provide complete integration of the award winning Microsoft Visual Basic for Applications development environment. This integration allows users to quickly and easily hook into the default behavior and extend or modify the behavior of ActiveInstall to meet their specific needs.

VBA Concepts

Before you get started writing VBA code, there are a couple of concepts that are important to understand. ActiveInstall's VBA integration provides two types of VBA projects for you to work with:

Understanding the Global Project

The Global VBA project is created or loaded immediately as soon as ActiveInstall is loaded. This special Project runs outside the context of any particular Installation Project. In other words, it is fully functional regardless of whether a project is currently active or not.

Global projects allow you to store and maintain code that is shared across all of your installation projects. For example, an FTP Upload utility would best be placed in the global project so it can be shared across all projects and operate without a project being open.

Understanding the Project Project

No, I didn't stutter. A project project is a vba project at the installation project level. Am I projecting the meaning of this properly? Seriously, this type of project contains code that is specific to the parent installation project. Examples would be code that modifies the behavior of the project to meet specific requirements for the output of that particular project. Code contained in this type of project is not shared across projects.

See Also

COM Add-Ins | Automation Interface


%%ItemTitle%%

Visual Basic for Applications | Automation Interface

See Also ActiveInstall Online Documentation Send Feedback on this topic.

COM Add-Ins

ActiveInstall provides rich support for COM Add-Ins. A COM Add-In is a special COM Server which implements the IDTExtensibility2 interface. ActiveInstall interacts with this interface through a collection of Add-Ins which are loaded and unloaded at start-up and shutdown, or on demand through the Add-In Manager Dialog.

The subject of creating a COM Server is beyond the scope of this documentation, however, a sample Add-In written in VB6 is included with the ActiveInstall installation. The sample source code demonstrates the basic steps required to create a function Add-In.

Registering Add-Ins

In order for ActiveInstall to recognize your Add-In, it must be properly registered in the system registry. The listing below describes each registry setting and it's purpose.

HKCU\Software\ActiveInstall Corp.\ActiveInstall Professional\VBA\AddIns\<ProgID>
FriendlyName: Specifies a short descriptive name for the Add-In
Description: Provides a descriptive paragraph of the Add-Ins functionality
LoadBehavior: Specifies the conditions under which the Add-In should be loaded. Can be one of the following values:
  • 0 - Disabled
  • 2 - Load at startup. COM add-in is to be loaded and connected when ActiveInstall starts.
  • 8 - Load on demand. COM add-in is to be loaded and connected only when the user requests it, such as by using the COM Add-Ins dialog box.
  • 16 - Connect first time. COM add-in is loaded and connected the first time the user runs ActiveInstall after the COM add-in has been registered. The next time ActiveInstall is run, the COM add-in is loaded when the user requests it. Use this value if your COM add-in modifies the user interface to allow the user to request the COM add-in be connected on demand (by clicking a button, for example).

About IDTExtensibility2

The IDTExtensibility2 interface has 5 metods which must be implemented in your COM Server:

Option Explicit
Implements IDTExtensibility2

Private Sub IDTExtensibility2_OnAddInsUpdate(custom() As Variant)
    'Occurs when any add-in is connected or disconnected in the COM Add-Ins collection
End Sub

Private Sub IDTExtensibility2_OnBeginShutdown(custom() As Variant)
    'Occurs when ActiveInstall begins its shutdown routines, if the add-in is connected
End Sub

Private Sub IDTExtensibility2_OnConnection(ByVal Application As Object, ByVal ConnectMode As AddInDesignerObjects.ext_ConnectMode, ByVal AddInInst As Object, custom() As Variant)
    'Occurs when the add-in is connected to ActiveInstall
End Sub

Private Sub IDTExtensibility2_OnDisconnection(ByVal RemoveMode As AddInDesignerObjects.ext_DisconnectMode, custom() As Variant)
    'Occurs when the add-in is disconnected from ActiveInstall
End Sub

Private Sub IDTExtensibility2_OnStartupComplete(custom() As Variant)
    'Occurs when ActiveInstall completes its startup routines
End Sub

For more information on creating COM Add-Ins, consult the MSDN Documentation.

See Also

Visual Basic for Applications | Automation Interface


%%ItemTitle%%

Visual Basic for Applications | COM Add-Ins

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Automation Interface

ActiveInstall exposes one createable "Application" class which you can use to control ActiveInstall programatically from any COM-enabled programming language.

Dim oApp As ActiveInstall.Application
Set oApp = New ActiveInstall.Application
MsgBox "ActiveInstall Version: " & oApp.Version, vbInformation

Once you have created an instance of ActiveInstall.Application, you can use it's properties and methods to access over 1400 properties and methods in the ActiveInstall object model! Have fun!

See Also

Visual Basic for Applications | COM Add-Ins


%%phrase%%

ActiveInstall Professional Send Feedback on this topic.

Project Overview

Description

ActiveInstall Professional

Object Model

Classes

Class Module | Description
Action |
ActionItems |
Actions |
ActionString |
ActionStrings |
Alert |
Alerts |
Application |
ArchivedBuild |
ArchivedBuilds |
AssemblyParam |
AssemblyParams |
Association |
Associations |
BuildConfig |
BuildConfigRefs |
BuildConfigs |
Class |
Classes |
ColumnDef |
ColumnDefs |
Component |
ComponentMembers |
ComponentQualifier |
ComponentQualifiers |
ComponentRefs |
Components |
ControlString |
ControlStrings |
CopyFile |
CopyFiles |
CtlCondition |
CtlConditions |
CtlEvent |
CtlEvents |
CtlListValue |
CtlListValues |
CtlListViewValue |
CtlListViewValues |
CtlRBValue |
CtlRBValues |
CtlSubscription |
CtlSubscriptions |
CTRecord |
CTRecords |
CustomAction |
CustomActions |
CustomTable |
CustomTables |
Dialog |
Dialogs |
Directories |
Directory |
DirectorySearch |
DirectorySearches |
DlgControl |
DlgControls |
EnvironmentVar |
EnvironmentVars |
Feature |
FeatureLevel |
FeatureLevels |
FeatureRefs |
Features |
File |
Files |
Global |
IActionItem |
IComponentMember |
INIFileMod |
INIFileMods |
IPLClient |
Language |
Languages |
LaunchCondition |
LaunchConditions |
MergeMod |
MergeModOption |
MergeModOptions |
MergeMods |
MIMEType |
MIMETypes |
MMOption |
MMOptions |
MMRelationship |
MMRelationships |
MMSubstitution |
MMSubstitutions |
MoveFile |
MoveFiles |
MsgString |
MsgStrings |
ODBCAttribute |
ODBCAttributes |
ODBCDataSource |
ODBCDataSources |
ODBCDriver |
ODBCDrivers |
ODBCTranslator |
ODBCTranslators |
PathVar |
PathVars |
Permission |
Permissions |
PostBuildSQL |
PostBuildSQLs |
ProductConfig |
ProductConfigs |
ProgID |
ProgIDs |
Project |
Properties |
Property |
RegistryMod |
RegistryMods |
RemoveFile |
RemoveFiles |
ReservedSpace |
ReservedSpaces |
Resource |
Resources |
Sequence |
Service |
ServiceAction |
ServiceActions |
Services |
Shortcut |
Shortcuts |
StandardAction |
StandardActions |
SystemSearch |
SystemSearches |
Task |
Tasks |
TextStyle |
TextStyles |
TypeLib |
TypeLibs |
UpgradeAction |
UpgradeActions |
Verb |
Verbs |
VIProgID |
VIProgIDs |

Public Enumerations

Enumeration | Description
aiAlertType |
aiArchiveMode |
aiAssemblyType |
aiClassContext |
aiComponentKeyPathType |
aiComponentRunFrom |
aiCompression |
aiControlAction |
aiControlEvent |
aiCustomActionDLLSourceLocation |
aiCustomActionEXESourceLocation |
aiCustomActionNISourceLocation |
aiCustomActionPropDirAction |
aiCustomActionPropDirExecution |
aiCustomActionReturnProcessing |
aiCustomActionScheduling |
aiCustomActionScriptSourceLocation |
aiCustomActionScriptType |
aiCustomActionSourceLocation |
aiCustomActionType |
aiDataSourceScope |
aiDialogStyle |
aiEnvVarAppendStyle |
aiEnvVarInstallAction |
aiEnvVarScope |
aiFeatureAdvertise |
aiFeatureRunFrom |
aiFeatureState |
aiFileCompression |
aiFileRegistrationType |
aiINIFileModAction |
aiLanguage |
aiLeftRight |
aiMMRelationshipType |
aiMoveFileAction |
aiPlatform |
aiProjectType |
aiPushButtonIconSize |
aiPushButtonStyle |
aiRegistryModAction |
aiRegistryModRoot |
aiRegistryModValueType |
aiReleaseType |
aiRemoveFileMode |
aiResourceType |
aiscShowCmd |
aiSequence |
aiSequenceActionType |
aiServiceErrorControl |
aiServiceStartType |
aiServiceType |
aiSetupExeType |
aiStandardActionSection |
aiStandardActionSeqFlags |
aiToolWindowPos |
aiValidState |
aiWindowState |
ColType |
ColTypeEx |


%%PageItemTitle%%

Action Members

See Also ActiveInstall Professional Send Feedback on this topic.

Action Object

For a list of all members defined in this module, see Action members.

Object Model

See Also

Action Members


%%PageItemTitle%% $$Members$$

Action Members

Action Object Members

Public Methods

Public Method Index |
Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property ActionID |
Public Property ActionRefName |
Public Property ActionType |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Condition |
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Order |
Public Property Parent | Returns the parent of this object.
Public Property Sequence |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Action Overview


%%PageItemTitle%%

Action Object

Index Method

Syntax

Public Function Index() As Long

See Also

Action Object


%%PageItemTitle%%

Action Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Action Object


%%PageItemTitle%%

Action Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Action Object


%%PageItemTitle%%

Action Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Action Object


%%PageItemTitle%%

Action Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Action Object


%%PageItemTitle%%

Action Object

ActionID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ActionID() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

ActionRefName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionRefName() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

ActionType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ActionType() As aiSequenceActionType

See Also

Action Object


%%PageItemTitle%%

Action Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Action Object


%%PageItemTitle%%

Action Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

Condition Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Action Object


%%PageItemTitle%%

Action Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

Order Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Order() As Integer

See Also

Action Object


%%PageItemTitle%%

Action Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Actions

See Also

Action Object


%%PageItemTitle%%

Action Object

Sequence Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Sequence() As aiSequence

See Also

Action Object


%%PageItemTitle%%

Action Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Action Object


%%PageItemTitle%%

Action Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Action Object


%%PageItemTitle%%

ActionItems Members

ActionItems Collection

For a list of all members defined in this module, see ActionItems members.

Object Model

See Also

ActionItems Members


%%PageItemTitle%% $$Members$$

ActionItems Members

ActionItems Collection Members

Public Methods

Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ActionItems Overview


%%PageItemTitle%%

ActionItems Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ActionItems Collection


%%PageItemTitle%%

ActionItems Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As IActionItem

Parameters

Key

See Also

ActionItems Collection


%%PageItemTitle%%

ActionItems Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Variant

Parameters

Key

See Also

ActionItems Collection


%%PageItemTitle%%

ActionItems Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ActionItems Collection


%%PageItemTitle%%

ActionItems Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef oItem As Object _
)

Parameters

oItem

See Also

ActionItems Collection


%%PageItemTitle%%

ActionItems Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef oItem As Object _
)

Parameters

oItem

See Also

ActionItems Collection


%%PageItemTitle%%

ActionItems Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef oItem As Object _
)

Parameters

oItem

See Also

ActionItems Collection


%%PageItemTitle%%

Actions Members

Actions Collection

For a list of all members defined in this module, see Actions members.

Object Model

See Also

Actions Members


%%PageItemTitle%% $$Members$$

Actions Members

Actions Collection Members

Public Methods

Public Method AddCustomAction |
Public Method AddDialog |
Public Method AddStandardAction |
Public Method Index |
Public Method Item |
Public Method MoveAction |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Save | Commits any changes in the data and cause re-valiation to occur.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property Parent | Returns the parent of this object.
Public Property SeqType |

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Actions Overview


%%PageItemTitle%%

Actions Collection

CA
See Also ActiveInstall Professional Send Feedback on this topic.

AddCustomAction Method

Syntax

Public Function AddCustomAction( _
   ByRef CA As CustomAction _
) As Action

Parameters

CA

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Dlg
See Also ActiveInstall Professional Send Feedback on this topic.

AddDialog Method

Syntax

Public Function AddDialog( _
   ByRef Dlg As Dialog _
) As Action

Parameters

Dlg

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

sA
See Also ActiveInstall Professional Send Feedback on this topic.

AddStandardAction Method

Syntax

Public Function AddStandardAction( _
   ByRef sA As StandardAction _
) As Action

Parameters

sA

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Index Method

Syntax

Public Function Index( _
   ByRef Key As Variant _
) As Long

Parameters

Key

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As Action

Parameters

Key

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Action
Before
After
See Also ActiveInstall Professional Send Feedback on this topic.

MoveAction Method

Syntax

Public Function MoveAction( _
   ByRef Action As Action, _
   Optional ByRef Before As Action, _
   Optional ByRef After As Action _
) As Variant

Parameters

Action
Before
After

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As String _
) As Boolean

Parameters

Key

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Variant

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Object

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

SeqType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property SeqType() As aiSequence

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef oItem As Object _
)

Parameters

oItem

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef oItem As Object _
)

Parameters

oItem

See Also

Actions Collection


%%PageItemTitle%%

Actions Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef oItem As Object _
)

Parameters

oItem

See Also

Actions Collection


%%PageItemTitle%%

ActionString Members

ActionString Object

For a list of all members defined in this module, see ActionString members.

Object Model

See Also

ActionString Members


%%PageItemTitle%% $$Members$$

ActionString Members

ActionString Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Description |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Template |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

ActionString Overview


%%PageItemTitle%%

ActionString Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ActionStrings

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

Template Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Template() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionString Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ActionString Object


%%PageItemTitle%%

ActionStrings Members

ActionStrings Collection

For a list of all members defined in this module, see ActionStrings members.

Object Model

See Also

ActionStrings Members


%%PageItemTitle%% $$Members$$

ActionStrings Members

ActionStrings Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ActionStrings Overview


%%PageItemTitle%%

ActionStrings Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ActionString

Parameters

Name

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ActionString

Parameters

key

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ActionString _
)

Parameters

Item

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ActionString _
)

Parameters

Item

See Also

ActionStrings Collection


%%PageItemTitle%%

ActionStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ActionString _
)

Parameters

Item

See Also

ActionStrings Collection


%%PageItemTitle%%

Alert Members

Alert Object

For a list of all members defined in this module, see Alert members.

See Also

Alert Members


%%PageItemTitle%% $$Members$$

Alert Members

Alert Object Members

Public Properties

Public Property AlertType
Public Property Description
Public Property ItemClass
Public Property ItemPtr
Public Property Name

See Also

Alert Overview


%%PageItemTitle%%

Alert Object

AlertType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property AlertType() As aiAlertType

See Also

Alert Object


%%PageItemTitle%%

Alert Object

Description Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Alert Object


%%PageItemTitle%%

Alert Object

ItemClass Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemClass() As String

See Also

Alert Object


%%PageItemTitle%%

Alert Object

ItemPtr Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ItemPtr() As Long

See Also

Alert Object


%%PageItemTitle%%

Alert Object

Name Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Alert Object


%%PageItemTitle%%

Alerts Members

Alerts Collection

For a list of all members defined in this module, see Alerts members.

Object Model

See Also

Alerts Members


%%PageItemTitle%% $$Members$$

Alerts Members

Alerts Collection Members

Public Methods

Public Method AlertStatus
Public Method Item

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

See Also

Alerts Overview


%%PageItemTitle%%

Alerts Collection

AlertStatus Method

Syntax

Public Function AlertStatus() As aiAlertType

See Also

Alerts Collection


%%PageItemTitle%%

Alerts Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Alert

Parameters

key

See Also

Alerts Collection


%%PageItemTitle%%

Alerts Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Alerts Collection


%%PageItemTitle%%

Application Members

Application Object

For a list of all members defined in this module, see Application members.

Object Model

See Also

Application Members


%%PageItemTitle%% $$Members$$

Application Members

Application Object Members

Public Methods

Public Method Activate
Public Method AddCommand
Public Method CloseProject
Public Method Help
Public Method OpenProject
Public Method Quit
Public Method RemoveCommand

Public Properties

Public Property CommandChecked
Public Property CommandEnabled
Public Property CommandVisible
Public Property Height
Public Property hWnd
Public Property Left
Public Property Project
Public Property ProjectFolder
Public Property TemplateFolder
Public Property Top
Public Property UserName
Public Property Version
Public Property Visible
Public Property Width
Public Property WindowState

Events

Public Event BeforeViewSwitch
Public Event CommandClick
Public Event ProjectClose
Public Event ProjectOpen
Public Event ProjectSave
Public Event ViewSwitch

See Also

Application Overview


%%PageItemTitle%%

Application Object

Activate Method

Syntax

Public Sub Activate()

See Also

Application Object


%%PageItemTitle%%

Application Object

Name
Caption
Image
CommandBar
See Also ActiveInstall Professional Send Feedback on this topic.

AddCommand Method

Syntax

Public Function AddCommand( _
   ByRef Name As String, _
   ByRef Caption As String, _
   Optional ByRef Image As IPictureDisp = Nothing, _
   Optional ByRef CommandBar As String = "" _
) As Boolean

Parameters

Name
Caption
Image
CommandBar

See Also

Application Object


%%PageItemTitle%%

Application Object

CloseProject Method

Syntax

Public Sub CloseProject()

See Also

Application Object


%%PageItemTitle%%

Application Object

HelpFile
HelpContextID
See Also ActiveInstall Professional Send Feedback on this topic.

Help Method

Syntax

Public Sub Help( _
   Optional ByRef HelpFile As String, _
   Optional ByRef HelpContextID As Long _
)

Parameters

HelpFile
HelpContextID

See Also

Application Object


%%PageItemTitle%%

Application Object

FilePath
See Also ActiveInstall Professional Send Feedback on this topic.

OpenProject Method

Syntax

Public Function OpenProject( _
   ByRef FilePath As String _
) As Project

Parameters

FilePath

See Also

Application Object


%%PageItemTitle%%

Application Object

Quit Method

Syntax

Public Sub Quit()

See Also

Application Object


%%PageItemTitle%%

Application Object

Name
See Also ActiveInstall Professional Send Feedback on this topic.

RemoveCommand Method

Syntax

Public Function RemoveCommand( _
   ByRef Name As String _
) As Boolean

Parameters

Name

See Also

Application Object


%%PageItemTitle%%

Application Object

Name
See Also ActiveInstall Professional Send Feedback on this topic.

CommandChecked Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CommandChecked( _
   ByRef Name As String _
) As Boolean

Parameters

Name

See Also

Application Object


%%PageItemTitle%%

Application Object

Name
See Also ActiveInstall Professional Send Feedback on this topic.

CommandEnabled Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CommandEnabled( _
   ByRef Name As String _
) As Boolean

Parameters

Name

See Also

Application Object


%%PageItemTitle%%

Application Object

Name
See Also ActiveInstall Professional Send Feedback on this topic.

CommandVisible Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CommandVisible( _
   ByRef Name As String _
) As Boolean

Parameters

Name

See Also

Application Object


%%PageItemTitle%%

Application Object

Height Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Height() As Long

See Also

Application Object


%%PageItemTitle%%

Application Object

hWnd Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property hWnd() As Long

See Also

Application Object


%%PageItemTitle%%

Application Object

Left Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Left() As Long

See Also

Application Object


%%PageItemTitle%%

Application Object

Project Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Project() As Project

See Also

Application Object


%%PageItemTitle%%

Application Object

ProjectFolder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProjectFolder() As String

See Also

Application Object


%%PageItemTitle%%

Application Object

TemplateFolder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateFolder() As String

See Also

Application Object


%%PageItemTitle%%

Application Object

Top Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Top() As Long

See Also

Application Object


%%PageItemTitle%%

Application Object

UserName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserName() As String

See Also

Application Object


%%PageItemTitle%%

Application Object

Version Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Version() As String

See Also

Application Object


%%PageItemTitle%%

Application Object

Visible Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible() As Boolean

See Also

Application Object


%%PageItemTitle%%

Application Object

Width Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Width() As Long

See Also

Application Object


%%PageItemTitle%%

Application Object

WindowState Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WindowState() As aiWindowState

See Also

Application Object


%%PageItemTitle%%

Application Object

BeforeViewSwitch Event

Syntax

Public Event BeforeViewSwitch()

See Also

Application Object


%%PageItemTitle%%

Application Object

Name
See Also ActiveInstall Professional Send Feedback on this topic.

CommandClick Event

Syntax

Public Event CommandClick( _
   ByRef Name As String _
)

Parameters

Name

See Also

Application Object


%%PageItemTitle%%

Application Object

Project
See Also ActiveInstall Professional Send Feedback on this topic.

ProjectClose Event

Syntax

Public Event ProjectClose( _
   ByRef Project As Project _
)

Parameters

Project

See Also

Application Object


%%PageItemTitle%%

Application Object

Project
See Also ActiveInstall Professional Send Feedback on this topic.

ProjectOpen Event

Syntax

Public Event ProjectOpen( _
   ByRef Project As Project _
)

Parameters

Project

See Also

Application Object


%%PageItemTitle%%

Application Object

Project
See Also ActiveInstall Professional Send Feedback on this topic.

ProjectSave Event

Syntax

Public Event ProjectSave( _
   ByRef Project As Project _
)

Parameters

Project

See Also

Application Object


%%PageItemTitle%%

Application Object

ViewSwitch Event

Syntax

Public Event ViewSwitch()

See Also

Application Object


%%PageItemTitle%%

ArchivedBuild Members

ArchivedBuild Object

For a list of all members defined in this module, see ArchivedBuild members.

Object Model

See Also

ArchivedBuild Members


%%PageItemTitle%% $$Members$$

ArchivedBuild Members

ArchivedBuild Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Errors |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property TimeStamp |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Warnings |
Public Property XML | Returns the XML for this record.

See Also

ArchivedBuild Overview


%%PageItemTitle%%

ArchivedBuild Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Errors Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Errors() As Integer

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ArchivedBuilds

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

TimeStamp Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TimeStamp() As Date

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

Warnings Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Warnings() As Integer

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuild Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ArchivedBuild Object


%%PageItemTitle%%

ArchivedBuilds Members

ArchivedBuilds Collection

For a list of all members defined in this module, see ArchivedBuilds members.

Object Model

See Also

ArchivedBuilds Members


%%PageItemTitle%% $$Members$$

ArchivedBuilds Members

ArchivedBuilds Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ArchivedBuilds Overview


%%PageItemTitle%%

ArchivedBuilds Collection

TimeStamp
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef TimeStamp As Date _
) As ArchivedBuild

Parameters

TimeStamp

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As ArchivedBuild

Parameters

Key

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ArchivedBuild _
)

Parameters

Item

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ArchivedBuild _
)

Parameters

Item

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

ArchivedBuilds Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ArchivedBuild _
)

Parameters

Item

See Also

ArchivedBuilds Collection


%%PageItemTitle%%

AssemblyParam Members

AssemblyParam Object

For a list of all members defined in this module, see AssemblyParam members.

Object Model

See Also

AssemblyParam Members


%%PageItemTitle%% $$Members$$

AssemblyParam Members

AssemblyParam Object Members

Public Properties

Public Property ID |
Public Property ParamName |
Public Property ParamValue |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

AssemblyParam Overview


%%PageItemTitle%%

AssemblyParam Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

AssemblyParam Object


%%PageItemTitle%%

AssemblyParam Object

ParamName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamName() As String

See Also

AssemblyParam Object


%%PageItemTitle%%

AssemblyParam Object

ParamValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParamValue() As String

See Also

AssemblyParam Object


%%PageItemTitle%%

AssemblyParam Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As AssemblyParams

See Also

AssemblyParam Object


%%PageItemTitle%%

AssemblyParam Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

AssemblyParam Object


%%PageItemTitle%%

AssemblyParams Members

AssemblyParams Collection

For a list of all members defined in this module, see AssemblyParams members.

Object Model

See Also

AssemblyParams Members


%%PageItemTitle%% $$Members$$

AssemblyParams Members

AssemblyParams Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

AssemblyParams Overview


%%PageItemTitle%%

AssemblyParams Collection

ParamName
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef ParamName As String _
) As AssemblyParam

Parameters

ParamName

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As AssemblyParam

Parameters

key

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As AssemblyParam _
)

Parameters

Item

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As AssemblyParam _
)

Parameters

Item

See Also

AssemblyParams Collection


%%PageItemTitle%%

AssemblyParams Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As AssemblyParam _
)

Parameters

Item

See Also

AssemblyParams Collection


%%PageItemTitle%%

Association Members

Association Object

For a list of all members defined in this module, see Association members.

Object Model

See Also

Association Members


%%PageItemTitle%% $$Members$$

Association Members

Association Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Extension |
Public Property Feature |
Public Property Id |
Public Property MIMEType |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property ProgId |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Association Overview


%%PageItemTitle%%

Association Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Association Object


%%PageItemTitle%%

Association Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Association Object


%%PageItemTitle%%

Association Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Association Object


%%PageItemTitle%%

Association Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Association Object


%%PageItemTitle%%

Association Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Association Object


%%PageItemTitle%%

Association Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

Association Object


%%PageItemTitle%%

Association Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Association Object


%%PageItemTitle%%

Association Object

Extension Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Extension() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

Feature Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Feature() As Feature

See Also

Association Object


%%PageItemTitle%%

Association Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

MIMEType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property MIMEType() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Associations

See Also

Association Object


%%PageItemTitle%%

Association Object

ProgId Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProgId() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Association Object


%%PageItemTitle%%

Association Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Association Object


%%PageItemTitle%%

Associations Members

Associations Collection

For a list of all members defined in this module, see Associations members.

Object Model

See Also

Associations Members


%%PageItemTitle%% $$Members$$

Associations Members

Associations Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Associations Overview


%%PageItemTitle%%

Associations Collection

Extension
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Extension As String _
) As Association

Parameters

Extension

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Association

Parameters

key

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Association _
)

Parameters

Item

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Association _
)

Parameters

Item

See Also

Associations Collection


%%PageItemTitle%%

Associations Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Association _
)

Parameters

Item

See Also

Associations Collection


%%PageItemTitle%%

BuildConfig Members

BuildConfig Object

For a list of all members defined in this module, see BuildConfig members.

Object Model

See Also

BuildConfig Members


%%PageItemTitle%% $$Members$$

BuildConfig Members

BuildConfig Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property BasePackageURL |
Public Property BuildTablesOnly |
Public Property CABSize |
Public Property ClusterSize |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Compression |
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property ExeCopyright |
Public Property ExeType |
Public Property ExeVersion |
Public Property GenAutorun |
Public Property GenPDF |
Public Property Id |
Public Property InternalStorage |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property ProductConfig |
Public Property ShortFileNames |
Public Property SignPVKPath |
Public Property SignSPCPath |
Public Property SignTimeStampURL |
Public Property SkipMerge |
Public Property SkipValidation |
Public Property SupressReboot |
Public Property SupressVersionWarning |
Public Property System |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property WebBaseEngineURL |
Public Property WebProductDisplayName |
Public Property WebPropertyValuePairs |
Public Property WebRelativeEnginePath9X |
Public Property WebRelativeEnginePathNT |
Public Property WebRelativePackagePath |
Public Property XML | Returns the XML for this record.

See Also

BuildConfig Overview


%%PageItemTitle%%

BuildConfig Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

BasePackageURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BasePackageURL() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

BuildTablesOnly Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BuildTablesOnly() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

CABSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CABSize() As Long

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

ClusterSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ClusterSize() As Long

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Compression Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Compression() As aiCompression

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

ExeCopyright Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ExeCopyright() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

ExeType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ExeType() As aiSetupExeType

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

ExeVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ExeVersion() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

GenAutorun Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property GenAutorun() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

GenPDF Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property GenPDF() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

InternalStorage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InternalStorage() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As BuildConfigs

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

ProductConfig Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductConfig() As ProductConfig

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

ShortFileNames Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ShortFileNames() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SignPVKPath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SignPVKPath() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SignSPCPath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SignSPCPath() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SignTimeStampURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SignTimeStampURL() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SkipMerge Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SkipMerge() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SkipValidation Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SkipValidation() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SupressReboot Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SupressReboot() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

SupressVersionWarning Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SupressVersionWarning() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

System Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property System() As Boolean

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

WebBaseEngineURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WebBaseEngineURL() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

WebProductDisplayName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WebProductDisplayName() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

WebPropertyValuePairs Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WebPropertyValuePairs() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

WebRelativeEnginePath9X Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WebRelativeEnginePath9X() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

WebRelativeEnginePathNT Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WebRelativeEnginePathNT() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

WebRelativePackagePath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WebRelativePackagePath() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfig Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

BuildConfig Object


%%PageItemTitle%%

BuildConfigRefs Members

BuildConfigRefs Collection

For a list of all members defined in this module, see BuildConfigRefs members.

Object Model

See Also

BuildConfigRefs Members


%%PageItemTitle%% $$Members$$

BuildConfigRefs Members

BuildConfigRefs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

See Also

BuildConfigRefs Overview


%%PageItemTitle%%

BuildConfigRefs Collection

oBC
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   ByRef oBC As BuildConfig _
) As Variant

Parameters

oBC

See Also

BuildConfigRefs Collection


%%PageItemTitle%%

BuildConfigRefs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

BuildConfigRefs Collection


%%PageItemTitle%%

BuildConfigRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

BuildConfigRefs Collection


%%PageItemTitle%%

BuildConfigRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As BuildConfig

Parameters

Key

See Also

BuildConfigRefs Collection


%%PageItemTitle%%

BuildConfigRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Variant

Parameters

Key

See Also

BuildConfigRefs Collection


%%PageItemTitle%%

BuildConfigRefs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

BuildConfigRefs Collection


%%PageItemTitle%%

BuildConfigs Members

BuildConfigs Collection

For a list of all members defined in this module, see BuildConfigs members.

Object Model

See Also

BuildConfigs Members


%%PageItemTitle%% $$Members$$

BuildConfigs Members

BuildConfigs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

BuildConfigs Overview


%%PageItemTitle%%

BuildConfigs Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As BuildConfig

Parameters

Name

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As BuildConfig

Parameters

key

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As BuildConfig _
)

Parameters

Item

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As BuildConfig _
)

Parameters

Item

See Also

BuildConfigs Collection


%%PageItemTitle%%

BuildConfigs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As BuildConfig _
)

Parameters

Item

See Also

BuildConfigs Collection


%%PageItemTitle%%

Class Members

Class Object

For a list of all members defined in this module, see Class members.

Object Model

See Also

Class Members


%%PageItemTitle%% $$Members$$

Class Members

Class Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Argument |
Public Property Attributes |
Public Property Author | Gets the name of the last author to modify this record.
Public Property CLSID |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Context |
Public Property Created | Returns the date/time when the record was created.
Public Property DCOM_ActivateAtStorage |
Public Property DCOM_AppID |
Public Property DCOM_DllSurrogate |
Public Property DCOM_LocalService |
Public Property DCOM_RemoteServerName |
Public Property DCOM_RunAsInteractiveUser |
Public Property DCOM_ServiceParameters |
Public Property DefInprocHandler |
Public Property Description |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Feature |
Public Property FileTypeMask |
Public Property IconFile |
Public Property IconIndex |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property ProgId_Default |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Class Overview


%%PageItemTitle%%

Class Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Class Object


%%PageItemTitle%%

Class Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Class Object


%%PageItemTitle%%

Class Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Class Object


%%PageItemTitle%%

Class Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Class Object


%%PageItemTitle%%

Class Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Class Object


%%PageItemTitle%%

Class Object

Argument Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Argument() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Attributes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Attributes() As Long

See Also

Class Object


%%PageItemTitle%%

Class Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

CLSID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CLSID() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

Class Object


%%PageItemTitle%%

Class Object

Context Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Context() As aiClassContext

See Also

Class Object


%%PageItemTitle%%

Class Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_ActivateAtStorage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_ActivateAtStorage() As Boolean

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_AppID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_AppID() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_DllSurrogate Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_DllSurrogate() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_LocalService Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_LocalService() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_RemoteServerName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_RemoteServerName() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_RunAsInteractiveUser Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_RunAsInteractiveUser() As Boolean

See Also

Class Object


%%PageItemTitle%%

Class Object

DCOM_ServiceParameters Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DCOM_ServiceParameters() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

DefInprocHandler Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefInprocHandler() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Class Object


%%PageItemTitle%%

Class Object

Feature Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Feature() As Feature

See Also

Class Object


%%PageItemTitle%%

Class Object

FileTypeMask Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileTypeMask() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

IconFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconFile() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

IconIndex Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconIndex() As Integer

See Also

Class Object


%%PageItemTitle%%

Class Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Classes

See Also

Class Object


%%PageItemTitle%%

Class Object

ProgId_Default Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProgId_Default() As ProgId

See Also

Class Object


%%PageItemTitle%%

Class Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Class Object


%%PageItemTitle%%

Class Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Class Object


%%PageItemTitle%%

Classes Members

Classes Collection

For a list of all members defined in this module, see Classes members.

Object Model

See Also

Classes Members


%%PageItemTitle%% $$Members$$

Classes Members

Classes Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Classes Overview


%%PageItemTitle%%

Classes Collection

CLSID
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef CLSID As String _
) As Class

Parameters

CLSID

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Class

Parameters

key

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Class _
)

Parameters

Item

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Class _
)

Parameters

Item

See Also

Classes Collection


%%PageItemTitle%%

Classes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Class _
)

Parameters

Item

See Also

Classes Collection


%%PageItemTitle%%

ColumnDef Members

ColumnDef Object

For a list of all members defined in this module, see ColumnDef members.

Object Model

See Also

ColumnDef Members


%%PageItemTitle%% $$Members$$

ColumnDef Members

ColumnDef Object Members

Public Properties

Public Property Category |
Public Property ColSize |
Public Property ColType |
Public Property Column |
Public Property Description |
Public Property ID |
Public Property KeyColumn |
Public Property KeyTable |
Public Property Max |
Public Property Min |
Public Property Nullable |
Public Property Parent | Returns the parent of this object.
Public Property PrimaryKey |
Public Property ValueSet |
Public Property XML | Returns the XML for this record.

See Also

ColumnDef Overview


%%PageItemTitle%%

ColumnDef Object

Category Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Category() As ColTypeEx

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

ColSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ColSize() As Integer

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

ColType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ColType() As ColType

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

Column Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Column() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

KeyColumn Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeyColumn() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

KeyTable Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeyTable() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

Max Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Max() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

Min Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Min() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

Nullable Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Nullable() As Boolean

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ColumnDefs

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

PrimaryKey Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrimaryKey() As Boolean

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

ValueSet Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ValueSet() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDef Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ColumnDef Object


%%PageItemTitle%%

ColumnDefs Members

ColumnDefs Collection

For a list of all members defined in this module, see ColumnDefs members.

Object Model

See Also

ColumnDefs Members


%%PageItemTitle%% $$Members$$

ColumnDefs Members

ColumnDefs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ColumnDefs Overview


%%PageItemTitle%%

ColumnDefs Collection

Column
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Column As String _
) As ColumnDef

Parameters

Column

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ColumnDef

Parameters

key

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ColumnDef _
)

Parameters

Item

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ColumnDef _
)

Parameters

Item

See Also

ColumnDefs Collection


%%PageItemTitle%%

ColumnDefs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ColumnDef _
)

Parameters

Item

See Also

ColumnDefs Collection


%%PageItemTitle%%

Component Members

Component Object

For a list of all members defined in this module, see Component members.

Object Model

See Also

Component Members


%%PageItemTitle%% $$Members$$

Component Members

Component Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property ComponentID |
Public Property Condition |
Public Property Created | Returns the date/time when the record was created.
Public Property Directory |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DynamicFilesDirectory |
Public Property DynamicFilesMask |
Public Property Id |
Public Property Is64Bit |
Public Property IsolatedComponents |
Public Property KeyPath |
Public Property KeyPathType |
Public Property Members |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property NeverOverWrite |
Public Property Parent | Returns the parent of this object.
Public Property Permanent |
Public Property Qualifiers |
Public Property RegFile |
Public Property ReservedSpaces |
Public Property RunFrom |
Public Property SharedDLLRefCount |
Public Property Transitive |
Public Property UserData | Gets/Sets a string of user-defined data for this record.

See Also

Component Overview


%%PageItemTitle%%

Component Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Component Object


%%PageItemTitle%%

Component Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Component Object


%%PageItemTitle%%

Component Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

ComponentID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ComponentID() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Condition Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Directory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Directory() As Directory

See Also

Component Object


%%PageItemTitle%%

Component Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

DynamicFilesDirectory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DynamicFilesDirectory() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

DynamicFilesMask Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DynamicFilesMask() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Is64Bit Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Is64Bit() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

IsolatedComponents Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property IsolatedComponents() As ComponentRefs

See Also

Component Object


%%PageItemTitle%%

Component Object

KeyPath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeyPath() As Object

See Also

Component Object


%%PageItemTitle%%

Component Object

KeyPathType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property KeyPathType() As aiComponentKeyPathType

See Also

Component Object


%%PageItemTitle%%

Component Object

Members Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Members() As ComponentMembers

See Also

Component Object


%%PageItemTitle%%

Component Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

NeverOverWrite Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property NeverOverWrite() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Components

See Also

Component Object


%%PageItemTitle%%

Component Object

Permanent Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Permanent() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Qualifiers Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Qualifiers() As ComponentQualifiers

See Also

Component Object


%%PageItemTitle%%

Component Object

RegFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RegFile() As String

See Also

Component Object


%%PageItemTitle%%

Component Object

ReservedSpaces Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReservedSpaces() As ReservedSpaces

See Also

Component Object


%%PageItemTitle%%

Component Object

RunFrom Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RunFrom() As aiComponentRunFrom

See Also

Component Object


%%PageItemTitle%%

Component Object

SharedDLLRefCount Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SharedDLLRefCount() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

Transitive Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Transitive() As Boolean

See Also

Component Object


%%PageItemTitle%%

Component Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Component Object


%%PageItemTitle%%

ComponentMembers Members

ComponentMembers Collection

For a list of all members defined in this module, see ComponentMembers members.

Object Model

See Also

ComponentMembers Members


%%PageItemTitle%% $$Members$$

ComponentMembers Members

ComponentMembers Collection Members

Public Methods

Public Method Exists
Public Method Item

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ComponentMembers Overview


%%PageItemTitle%%

ComponentMembers Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ComponentMembers Collection


%%PageItemTitle%%

ComponentMembers Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As IComponentMember

Parameters

Key

See Also

ComponentMembers Collection


%%PageItemTitle%%

ComponentMembers Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ComponentMembers Collection


%%PageItemTitle%%

ComponentMembers Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef oItem As IComponentMember _
)

Parameters

oItem

See Also

ComponentMembers Collection


%%PageItemTitle%%

ComponentMembers Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef oItem As IComponentMember _
)

Parameters

oItem

See Also

ComponentMembers Collection


%%PageItemTitle%%

ComponentMembers Collection

oItem
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef oItem As IComponentMember _
)

Parameters

oItem

See Also

ComponentMembers Collection


%%PageItemTitle%%

ComponentQualifier Members

ComponentQualifier Object

For a list of all members defined in this module, see ComponentQualifier members.

Object Model

See Also

ComponentQualifier Members


%%PageItemTitle%% $$Members$$

ComponentQualifier Members

ComponentQualifier Object Members

Public Properties

Public Property AppData |
Public Property CategoryID |
Public Property Feature |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property Qualifier |
Public Property XML | Returns the XML for this record.

See Also

ComponentQualifier Overview


%%PageItemTitle%%

ComponentQualifier Object

AppData Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AppData() As String

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifier Object

CategoryID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CategoryID() As String

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifier Object

Feature Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Feature() As Feature

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifier Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifier Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ComponentQualifiers

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifier Object

Qualifier Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Qualifier() As String

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifier Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ComponentQualifier Object


%%PageItemTitle%%

ComponentQualifiers Members

ComponentQualifiers Collection

For a list of all members defined in this module, see ComponentQualifiers members.

Object Model

See Also

ComponentQualifiers Members


%%PageItemTitle%% $$Members$$

ComponentQualifiers Members

ComponentQualifiers Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ComponentQualifiers Overview


%%PageItemTitle%%

ComponentQualifiers Collection

CategoryID
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef CategoryID As String _
) As ComponentQualifier

Parameters

CategoryID

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ComponentQualifier

Parameters

key

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ComponentQualifier _
)

Parameters

Item

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ComponentQualifier _
)

Parameters

Item

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentQualifiers Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ComponentQualifier _
)

Parameters

Item

See Also

ComponentQualifiers Collection


%%PageItemTitle%%

ComponentRefs Members

ComponentRefs Collection

For a list of all members defined in this module, see ComponentRefs members.

Object Model

See Also

ComponentRefs Members


%%PageItemTitle%% $$Members$$

ComponentRefs Members

ComponentRefs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method fr_Revert |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

See Also

ComponentRefs Overview


%%PageItemTitle%%

ComponentRefs Collection

oC
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   ByRef oC As Component _
) As Variant

Parameters

oC

See Also

ComponentRefs Collection


%%PageItemTitle%%

ComponentRefs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ComponentRefs Collection


%%PageItemTitle%%

ComponentRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ComponentRefs Collection


%%PageItemTitle%%

ComponentRefs Collection

fr_Revert Method

Syntax

Public Function fr_Revert() As Boolean

See Also

ComponentRefs Collection


%%PageItemTitle%%

ComponentRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As Component

Parameters

Key

See Also

ComponentRefs Collection


%%PageItemTitle%%

ComponentRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Variant

Parameters

Key

See Also

ComponentRefs Collection


%%PageItemTitle%%

ComponentRefs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ComponentRefs Collection


%%PageItemTitle%%

Components Members

Components Collection

For a list of all members defined in this module, see Components members.

Object Model

See Also

Components Members


%%PageItemTitle%% $$Members$$

Components Members

Components Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Components Overview


%%PageItemTitle%%

Components Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Component

Parameters

Name

See Also

Components Collection


%%PageItemTitle%%

Components Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Components Collection


%%PageItemTitle%%

Components Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Component

Parameters

key

See Also

Components Collection


%%PageItemTitle%%

Components Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Components Collection


%%PageItemTitle%%

Components Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Components Collection


%%PageItemTitle%%

Components Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Components Collection


%%PageItemTitle%%

Components Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Component _
)

Parameters

Item

See Also

Components Collection


%%PageItemTitle%%

Components Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Component _
)

Parameters

Item

See Also

Components Collection


%%PageItemTitle%%

Components Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Component _
)

Parameters

Item

See Also

Components Collection


%%PageItemTitle%%

ControlString Members

ControlString Object

For a list of all members defined in this module, see ControlString members.

Object Model

See Also

ControlString Members


%%PageItemTitle%% $$Members$$

ControlString Members

ControlString Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Text |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

ControlString Overview


%%PageItemTitle%%

ControlString Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ControlStrings

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

Text Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlString Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ControlString Object


%%PageItemTitle%%

ControlStrings Members

ControlStrings Collection

For a list of all members defined in this module, see ControlStrings members.

Object Model

See Also

ControlStrings Members


%%PageItemTitle%% $$Members$$

ControlStrings Members

ControlStrings Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ControlStrings Overview


%%PageItemTitle%%

ControlStrings Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ControlString

Parameters

Name

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ControlString

Parameters

key

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ControlString _
)

Parameters

Item

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ControlString _
)

Parameters

Item

See Also

ControlStrings Collection


%%PageItemTitle%%

ControlStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ControlString _
)

Parameters

Item

See Also

ControlStrings Collection


%%PageItemTitle%%

CopyFile Members

CopyFile Object

For a list of all members defined in this module, see CopyFile members.

Object Model

See Also

CopyFile Members


%%PageItemTitle%% $$Members$$

CopyFile Members

CopyFile Object Members

Public Properties

Public Property DestFolder |
Public Property DestName |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

CopyFile Overview


%%PageItemTitle%%

CopyFile Object

DestFolder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DestFolder() As String

See Also

CopyFile Object


%%PageItemTitle%%

CopyFile Object

DestName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DestName() As String

See Also

CopyFile Object


%%PageItemTitle%%

CopyFile Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CopyFile Object


%%PageItemTitle%%

CopyFile Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CopyFiles

See Also

CopyFile Object


%%PageItemTitle%%

CopyFile Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CopyFile Object


%%PageItemTitle%%

CopyFiles Members

CopyFiles Collection

For a list of all members defined in this module, see CopyFiles members.

Object Model

See Also

CopyFiles Members


%%PageItemTitle%% $$Members$$

CopyFiles Members

CopyFiles Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CopyFiles Overview


%%PageItemTitle%%

CopyFiles Collection

DestName
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef DestName As String _
) As CopyFile

Parameters

DestName

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CopyFile

Parameters

key

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As CopyFile _
)

Parameters

Item

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As CopyFile _
)

Parameters

Item

See Also

CopyFiles Collection


%%PageItemTitle%%

CopyFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As CopyFile _
)

Parameters

Item

See Also

CopyFiles Collection


%%PageItemTitle%%

CtlCondition Members

CtlCondition Object

For a list of all members defined in this module, see CtlCondition members.

Object Model

See Also

CtlCondition Members


%%PageItemTitle%% $$Members$$

CtlCondition Members

CtlCondition Object Members

Public Properties

Public Property Action |
Public Property Condition |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

CtlCondition Overview


%%PageItemTitle%%

CtlCondition Object

Action Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Action() As String

See Also

CtlCondition Object


%%PageItemTitle%%

CtlCondition Object

Condition Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition() As String

See Also

CtlCondition Object


%%PageItemTitle%%

CtlCondition Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CtlCondition Object


%%PageItemTitle%%

CtlCondition Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CtlConditions

See Also

CtlCondition Object


%%PageItemTitle%%

CtlCondition Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlCondition Object


%%PageItemTitle%%

CtlConditions Members

CtlConditions Collection

For a list of all members defined in this module, see CtlConditions members.

Object Model

See Also

CtlConditions Members


%%PageItemTitle%% $$Members$$

CtlConditions Members

CtlConditions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CtlConditions Overview


%%PageItemTitle%%

CtlConditions Collection

Action
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Action As String _
) As CtlCondition

Parameters

Action

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CtlCondition

Parameters

key

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlConditions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlConditions Collection


%%PageItemTitle%%

CtlEvent Members

CtlEvent Object

For a list of all members defined in this module, see CtlEvent members.

Object Model

See Also

CtlEvent Members


%%PageItemTitle%% $$Members$$

CtlEvent Members

CtlEvent Object Members

Public Properties

Public Property Argument |
Public Property Condition |
Public Property CtlEvent |
Public Property ID |
Public Property Ordering |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

CtlEvent Overview


%%PageItemTitle%%

CtlEvent Object

Argument Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Argument() As String

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvent Object

Condition Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition() As String

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvent Object

CtlEvent Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CtlEvent() As String

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvent Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvent Object

Ordering Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Ordering() As Integer

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvent Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CtlEvents

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvent Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlEvent Object


%%PageItemTitle%%

CtlEvents Members

CtlEvents Collection

For a list of all members defined in this module, see CtlEvents members.

Object Model

See Also

CtlEvents Members


%%PageItemTitle%% $$Members$$

CtlEvents Members

CtlEvents Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CtlEvents Overview


%%PageItemTitle%%

CtlEvents Collection

CtlEvent
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef CtlEvent As String _
) As CtlEvent

Parameters

CtlEvent

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CtlEvent

Parameters

key

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlEvents Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlEvents Collection


%%PageItemTitle%%

CtlListValue Members

CtlListValue Object

For a list of all members defined in this module, see CtlListValue members.

Object Model

See Also

CtlListValue Members


%%PageItemTitle%% $$Members$$

CtlListValue Members

CtlListValue Object Members

Public Properties

Public Property ID |
Public Property Order |
Public Property Parent | Returns the parent of this object.
Public Property Text |
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

CtlListValue Overview


%%PageItemTitle%%

CtlListValue Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CtlListValue Object


%%PageItemTitle%%

CtlListValue Object

Order Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

CtlListValue Object


%%PageItemTitle%%

CtlListValue Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CtlListValues

See Also

CtlListValue Object


%%PageItemTitle%%

CtlListValue Object

Text Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

CtlListValue Object


%%PageItemTitle%%

CtlListValue Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

CtlListValue Object


%%PageItemTitle%%

CtlListValue Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlListValue Object


%%PageItemTitle%%

CtlListValues Members

CtlListValues Collection

For a list of all members defined in this module, see CtlListValues members.

Object Model

See Also

CtlListValues Members


%%PageItemTitle%% $$Members$$

CtlListValues Members

CtlListValues Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CtlListValues Overview


%%PageItemTitle%%

CtlListValues Collection

Text
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Text As String _
) As CtlListValue

Parameters

Text

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CtlListValue

Parameters

key

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlListValues Collection


%%PageItemTitle%%

CtlListViewValue Members

CtlListViewValue Object

For a list of all members defined in this module, see CtlListViewValue members.

Object Model

See Also

CtlListViewValue Members


%%PageItemTitle%% $$Members$$

CtlListViewValue Members

CtlListViewValue Object Members

Public Properties

Public Property Binary_ |
Public Property ID |
Public Property Order |
Public Property Parent | Returns the parent of this object.
Public Property Text |
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

CtlListViewValue Overview


%%PageItemTitle%%

CtlListViewValue Object

Binary_ Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Binary_() As String

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValue Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValue Object

Order Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValue Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CtlListViewValues

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValue Object

Text Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValue Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValue Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlListViewValue Object


%%PageItemTitle%%

CtlListViewValues Members

CtlListViewValues Collection

For a list of all members defined in this module, see CtlListViewValues members.

Object Model

See Also

CtlListViewValues Members


%%PageItemTitle%% $$Members$$

CtlListViewValues Members

CtlListViewValues Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CtlListViewValues Overview


%%PageItemTitle%%

CtlListViewValues Collection

Text
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Text As String _
) As CtlListViewValue

Parameters

Text

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CtlListViewValue

Parameters

key

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlListViewValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlListViewValues Collection


%%PageItemTitle%%

CtlRBValue Members

CtlRBValue Object

For a list of all members defined in this module, see CtlRBValue members.

Object Model

See Also

CtlRBValue Members


%%PageItemTitle%% $$Members$$

CtlRBValue Members

CtlRBValue Object Members

Public Properties

Public Property Height |
Public Property ID |
Public Property Left |
Public Property Order |
Public Property Parent | Returns the parent of this object.
Public Property Text |
Public Property ToolTip |
Public Property Top |
Public Property Value |
Public Property Width |
Public Property XML | Returns the XML for this record.

See Also

CtlRBValue Overview


%%PageItemTitle%%

CtlRBValue Object

Height Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Height() As Long

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Left Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Left() As Long

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Order Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CtlRBValues

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Text Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

ToolTip Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ToolTip() As String

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Top Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Top() As Long

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

Width Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Width() As Long

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValue Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlRBValue Object


%%PageItemTitle%%

CtlRBValues Members

CtlRBValues Collection

For a list of all members defined in this module, see CtlRBValues members.

Object Model

See Also

CtlRBValues Members


%%PageItemTitle%% $$Members$$

CtlRBValues Members

CtlRBValues Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CtlRBValues Overview


%%PageItemTitle%%

CtlRBValues Collection

Text
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Text As String _
) As CtlRBValue

Parameters

Text

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CtlRBValue

Parameters

key

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlRBValues Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlRBValues Collection


%%PageItemTitle%%

CtlSubscription Members

CtlSubscription Object

For a list of all members defined in this module, see CtlSubscription members.

Object Model

See Also

CtlSubscription Members


%%PageItemTitle%% $$Members$$

CtlSubscription Members

CtlSubscription Object Members

Public Properties

Public Property CtlAttribute |
Public Property CtlEvent |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

CtlSubscription Overview


%%PageItemTitle%%

CtlSubscription Object

CtlAttribute Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CtlAttribute() As String

See Also

CtlSubscription Object


%%PageItemTitle%%

CtlSubscription Object

CtlEvent Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CtlEvent() As String

See Also

CtlSubscription Object


%%PageItemTitle%%

CtlSubscription Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CtlSubscription Object


%%PageItemTitle%%

CtlSubscription Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CtlSubscriptions

See Also

CtlSubscription Object


%%PageItemTitle%%

CtlSubscription Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlSubscription Object


%%PageItemTitle%%

CtlSubscriptions Members

CtlSubscriptions Collection

For a list of all members defined in this module, see CtlSubscriptions members.

Object Model

See Also

CtlSubscriptions Members


%%PageItemTitle%% $$Members$$

CtlSubscriptions Members

CtlSubscriptions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CtlSubscriptions Overview


%%PageItemTitle%%

CtlSubscriptions Collection

CtlEvent
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef CtlEvent As String _
) As CtlSubscription

Parameters

CtlEvent

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CtlSubscription

Parameters

key

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CtlSubscriptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CtlSubscriptions Collection


%%PageItemTitle%%

CTRecord Members

CTRecord Object

For a list of all members defined in this module, see CTRecord members.

Object Model

See Also

CTRecord Members


%%PageItemTitle%% $$Members$$

CTRecord Members

CTRecord Object Members

Public Properties

Public Property F1 |
Public Property F10 |
Public Property F11 |
Public Property F12 |
Public Property F13 |
Public Property F14 |
Public Property F15 |
Public Property F16 |
Public Property F17 |
Public Property F18 |
Public Property F19 |
Public Property F2 |
Public Property F20 |
Public Property F3 |
Public Property F4 |
Public Property F5 |
Public Property F6 |
Public Property F7 |
Public Property F8 |
Public Property F9 |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

CTRecord Overview


%%PageItemTitle%%

CTRecord Object

F1 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F1() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F10 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F10() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F11 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F11() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F12 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F12() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F13 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F13() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F14 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F14() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F15 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F15() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F16 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F16() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F17 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F17() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F18 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F18() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F19 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F19() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F2 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F2() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F20 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F20() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F3 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F3() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F4 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F4() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F5 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F5() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F6 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F6() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F7 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F7() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F8 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F8() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

F9 Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property F9() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CTRecords

See Also

CTRecord Object


%%PageItemTitle%%

CTRecord Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CTRecord Object


%%PageItemTitle%%

CTRecords Members

CTRecords Collection

For a list of all members defined in this module, see CTRecords members.

Object Model

See Also

CTRecords Members


%%PageItemTitle%% $$Members$$

CTRecords Members

CTRecords Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CTRecords Overview


%%PageItemTitle%%

CTRecords Collection

F1
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef F1 As String _
) As CTRecord

Parameters

F1

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CTRecord

Parameters

key

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As CTRecord _
)

Parameters

Item

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As CTRecord _
)

Parameters

Item

See Also

CTRecords Collection


%%PageItemTitle%%

CTRecords Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As CTRecord _
)

Parameters

Item

See Also

CTRecords Collection


%%PageItemTitle%%

CustomAction Members

CustomAction Object

For a list of all members defined in this module, see CustomAction members.

Object Model

See Also

CustomAction Members


%%PageItemTitle%% $$Members$$

CustomAction Members

CustomAction Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property ActionType |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property HideTarget |
Public Property Id |
Public Property Is64Bit |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property PropDirAction |
Public Property RefName |
Public Property ReturnProcessing |
Public Property Scheduling |
Public Property ScriptType |
Public Property Source |
Public Property SourceLocation |
Public Property SystemContext |
Public Property Target |
Public Property UserData | Gets/Sets a string of user-defined data for this record.

See Also

CustomAction Overview


%%PageItemTitle%%

CustomAction Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

ActionType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionType() As aiCustomActionType

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

HideTarget Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HideTarget() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Id Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Id() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Is64Bit Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Is64Bit() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CustomActions

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

PropDirAction Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property PropDirAction() As aiCustomActionPropDirAction

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

RefName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RefName() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

ReturnProcessing Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ReturnProcessing() As aiCustomActionReturnProcessing

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Scheduling Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Scheduling() As aiCustomActionScheduling

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

ScriptType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ScriptType() As aiCustomActionScriptType

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Source Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Source() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

SourceLocation Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceLocation() As aiCustomActionSourceLocation

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

SystemContext Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SystemContext() As Boolean

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

Target Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Target() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomAction Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

CustomAction Object


%%PageItemTitle%%

CustomActions Members

CustomActions Collection

For a list of all members defined in this module, see CustomActions members.

Object Model

See Also

CustomActions Members


%%PageItemTitle%% $$Members$$

CustomActions Members

CustomActions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CustomActions Overview


%%PageItemTitle%%

CustomActions Collection

CAType
Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   ByRef CAType As aiCustomActionType, _
   Optional ByRef Name As String _
) As CustomAction

Parameters

CAType
Value Description
aiCADLL
aiCAEXE
aicaScript
aicaSetPropOrDir
aicaErrorFail
aicaNestedInstall
Name

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CustomAction

Parameters

key

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CustomActions Collection


%%PageItemTitle%%

CustomActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

CustomActions Collection


%%PageItemTitle%%

CustomTable Members

CustomTable Object

For a list of all members defined in this module, see CustomTable members.

Object Model

See Also

CustomTable Members


%%PageItemTitle%% $$Members$$

CustomTable Members

CustomTable Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property ColumnDefs |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Records |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

CustomTable Overview


%%PageItemTitle%%

CustomTable Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

ColumnDefs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ColumnDefs() As ColumnDefs

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As CustomTables

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

Records Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Records() As CTRecords

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTable Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CustomTable Object


%%PageItemTitle%%

CustomTables Members

CustomTables Collection

For a list of all members defined in this module, see CustomTables members.

Object Model

See Also

CustomTables Members


%%PageItemTitle%% $$Members$$

CustomTables Members

CustomTables Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

CustomTables Overview


%%PageItemTitle%%

CustomTables Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As CustomTable

Parameters

Name

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As CustomTable

Parameters

key

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As CustomTable _
)

Parameters

Item

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As CustomTable _
)

Parameters

Item

See Also

CustomTables Collection


%%PageItemTitle%%

CustomTables Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As CustomTable _
)

Parameters

Item

See Also

CustomTables Collection


%%PageItemTitle%%

Dialog Members

Dialog Object

For a list of all members defined in this module, see Dialog members.

Object Model

See Also

Dialog Members


%%PageItemTitle%% $$Members$$

Dialog Members

Dialog Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Attributes |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Control_Cancel |
Public Property Control_Default |
Public Property Controls |
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property ErrorDialog |
Public Property HCentering |
Public Property Height |
Public Property Id |
Public Property KeepModeless |
Public Property LeftScroll |
Public Property Minimized |
Public Property Modal |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property RightAligned |
Public Property RightToLeft |
Public Property SysModal |
Public Property Title |
Public Property TrackDiskSpace |
Public Property UseCustomPalette |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property VCentering |
Public Property Visible |
Public Property Width |
Public Property XML | Returns the XML for this record.

See Also

Dialog Overview


%%PageItemTitle%%

Dialog Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Attributes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Attributes() As Long

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Control_Cancel Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Control_Cancel() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Control_Default Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Control_Default() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Controls Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Controls() As DlgControls

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

ErrorDialog Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ErrorDialog() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

HCentering Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HCentering() As Integer

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Height Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Height() As Integer

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

KeepModeless Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeepModeless() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

LeftScroll Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LeftScroll() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Minimized Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Minimized() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Modal Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modal() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Dialogs

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

RightAligned Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RightAligned() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

RightToLeft Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RightToLeft() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

SysModal Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SysModal() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Title Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Title() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

TrackDiskSpace Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TrackDiskSpace() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

UseCustomPalette Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseCustomPalette() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

VCentering Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property VCentering() As Integer

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Visible Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible() As Boolean

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

Width Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Width() As Integer

See Also

Dialog Object


%%PageItemTitle%%

Dialog Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Dialog Object


%%PageItemTitle%%

Dialogs Members

Dialogs Collection

For a list of all members defined in this module, see Dialogs members.

Object Model

See Also

Dialogs Members


%%PageItemTitle%% $$Members$$

Dialogs Members

Dialogs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Dialogs Overview


%%PageItemTitle%%

Dialogs Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Dialog

Parameters

Name

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Dialog

Parameters

key

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

Dialogs Collection


%%PageItemTitle%%

Dialogs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

Dialogs Collection


%%PageItemTitle%%

Directories Members

Directories Collection

For a list of all members defined in this module, see Directories members.

Object Model

See Also

Directories Members


%%PageItemTitle%% $$Members$$

Directories Members

Directories Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Directories Overview


%%PageItemTitle%%

Directories Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Directory

Parameters

Name

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As Directory

Parameters

Key

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Directory _
)

Parameters

Item

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Directory _
)

Parameters

Item

See Also

Directories Collection


%%PageItemTitle%%

Directories Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Directory _
)

Parameters

Item

See Also

Directories Collection


%%PageItemTitle%%

Directory Members

Directory Object

For a list of all members defined in this module, see Directory members.

Object Model

See Also

Directory Members


%%PageItemTitle%% $$Members$$

Directory Members

Directory Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property CreateFolderComponents |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property ParentDirectory |
Public Property Permissions |
Public Property Source |
Public Property SourceIsParent |
Public Property Target |
Public Property TargetIsParent |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Directory Overview


%%PageItemTitle%%

Directory Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

CreateFolderComponents Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CreateFolderComponents() As ComponentRefs

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Directories

See Also

Directory Object


%%PageItemTitle%%

Directory Object

ParentDirectory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParentDirectory() As Directory

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Permissions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Permissions

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Source Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Source() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

SourceIsParent Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceIsParent() As Boolean

See Also

Directory Object


%%PageItemTitle%%

Directory Object

Target Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Target() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

TargetIsParent Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TargetIsParent() As Boolean

See Also

Directory Object


%%PageItemTitle%%

Directory Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Directory Object


%%PageItemTitle%%

Directory Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Directory Object


%%PageItemTitle%%

DirectorySearch Members

DirectorySearch Object

For a list of all members defined in this module, see DirectorySearch members.

Object Model

See Also

DirectorySearch Members


%%PageItemTitle%% $$Members$$

DirectorySearch Members

DirectorySearch Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Depth |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property ID |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property ParentSearch |
Public Property Path |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

DirectorySearch Overview


%%PageItemTitle%%

DirectorySearch Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Depth Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Depth() As Integer

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As DirectorySearches

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

ParentSearch Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParentSearch() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

Path Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Path() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearch Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

DirectorySearch Object


%%PageItemTitle%%

DirectorySearches Members

DirectorySearches Collection

For a list of all members defined in this module, see DirectorySearches members.

Object Model

See Also

DirectorySearches Members


%%PageItemTitle%% $$Members$$

DirectorySearches Members

DirectorySearches Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

DirectorySearches Overview


%%PageItemTitle%%

DirectorySearches Collection

Path
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Path As String _
) As DirectorySearch

Parameters

Path

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As DirectorySearch

Parameters

key

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As DirectorySearch _
)

Parameters

Item

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As DirectorySearch _
)

Parameters

Item

See Also

DirectorySearches Collection


%%PageItemTitle%%

DirectorySearches Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As DirectorySearch _
)

Parameters

Item

See Also

DirectorySearches Collection


%%PageItemTitle%%

DlgControl Members

DlgControl Object

For a list of all members defined in this module, see DlgControl members.

Object Model

See Also

DlgControl Members


%%PageItemTitle%% $$Members$$

DlgControl Members

DlgControl Object Members

Public Properties

Public Property Bitmap |
Public Property ButtonStyle |
Public Property CDROMVolume |
Public Property CheckBoxValue |
Public Property ComboList |
Public Property CtlConditions |
Public Property CtlEvents |
Public Property CtlListValues |
Public Property CtlListViewValues |
Public Property CtlRBValues |
Public Property CtlSubscriptions |
Public Property CtlType |
Public Property Enabled |
Public Property FixedVolume |
Public Property Flags |
Public Property FloppyVolume |
Public Property FormatSize |
Public Property HasBorder |
Public Property Height |
Public Property Icon |
Public Property IconSize |
Public Property ID |
Public Property ImageResource |
Public Property Indirect |
Public Property IsInteger |
Public Property LeftScroll |
Public Property Multiline |
Public Property Name |
Public Property NoPrefix |
Public Property NoWrap |
Public Property Parent | Returns the parent of this object.
Public Property Password |
Public Property Property |
Public Property PushButtonStyle |
Public Property RAMDiskVolume |
Public Property RemoteVolume |
Public Property RemovableVolume |
Public Property RightAligned |
Public Property RightToLeft |
Public Property ShowRollbackCost |
Public Property Smooth |
Public Property Sorted |
Public Property Stretch |
Public Property Sunken |
Public Property TabIndex |
Public Property TabStop |
Public Property Text |
Public Property TextStyle |
Public Property ToolTipText |
Public Property TRANSPARENT |
Public Property UseImageHandle |
Public Property UsersLanguage |
Public Property Visible |
Public Property Width |
Public Property X |
Public Property XML | Returns the XML for this record.
Public Property Y |

See Also

DlgControl Overview


%%PageItemTitle%%

DlgControl Object

Bitmap Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Bitmap() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

ButtonStyle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ButtonStyle() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CDROMVolume Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CDROMVolume() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CheckBoxValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CheckBoxValue() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

ComboList Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ComboList() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlConditions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CtlConditions() As CtlConditions

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlEvents Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CtlEvents() As CtlEvents

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlListValues Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CtlListValues() As CtlListValues

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlListViewValues Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CtlListViewValues() As CtlListViewValues

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlRBValues Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CtlRBValues() As CtlRBValues

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlSubscriptions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CtlSubscriptions() As CtlSubscriptions

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

CtlType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CtlType() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Enabled Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Enabled() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

FixedVolume Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FixedVolume() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Flags Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Flags() As Long

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

FloppyVolume Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FloppyVolume() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

FormatSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FormatSize() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

HasBorder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HasBorder() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Height Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Height() As Long

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Icon Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Icon() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

IconSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconSize() As aiPushButtonIconSize

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

ImageResource Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ImageResource() As Resource

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Indirect Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Indirect() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

IsInteger Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IsInteger() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

LeftScroll Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LeftScroll() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Multiline Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Multiline() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

NoPrefix Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property NoPrefix() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

NoWrap Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property NoWrap() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As DlgControls

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Password Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Password() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Property Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

PushButtonStyle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property PushButtonStyle() As aiPushButtonStyle

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

RAMDiskVolume Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RAMDiskVolume() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

RemoteVolume Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RemoteVolume() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

RemovableVolume Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RemovableVolume() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

RightAligned Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RightAligned() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

RightToLeft Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RightToLeft() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

ShowRollbackCost Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ShowRollbackCost() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Smooth Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Smooth() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Sorted Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Sorted() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Stretch Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Stretch() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Sunken Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Sunken() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

TabIndex Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TabIndex() As Integer

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

TabStop Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TabStop() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Text Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Text() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

TextStyle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TextStyle() As TextStyle

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

ToolTipText Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ToolTipText() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

TRANSPARENT Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TRANSPARENT() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

UseImageHandle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseImageHandle() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

UsersLanguage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UsersLanguage() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Visible Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible() As Boolean

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Width Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Width() As Long

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

X Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property X() As Long

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

DlgControl Object


%%PageItemTitle%%

DlgControl Object

Y Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Y() As Long

See Also

DlgControl Object


%%PageItemTitle%%

DlgControls Members

DlgControls Collection

For a list of all members defined in this module, see DlgControls members.

Object Model

See Also

DlgControls Members


%%PageItemTitle%% $$Members$$

DlgControls Members

DlgControls Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

DlgControls Overview


%%PageItemTitle%%

DlgControls Collection

CtlType
Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   ByRef CtlType As String, _
   ByRef Name As String _
) As DlgControl

Parameters

CtlType
Name

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As DlgControl

Parameters

Key

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Object _
)

Parameters

Item

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Object _
)

Parameters

Item

See Also

DlgControls Collection


%%PageItemTitle%%

DlgControls Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Object _
)

Parameters

Item

See Also

DlgControls Collection


%%PageItemTitle%%

EnvironmentVar Members

EnvironmentVar Object

For a list of all members defined in this module, see EnvironmentVar members.

Object Model

See Also

EnvironmentVar Members


%%PageItemTitle%% $$Members$$

EnvironmentVar Members

EnvironmentVar Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property AppendStyle |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Delimiter |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property InstallAction |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Scope |
Public Property Uninstall |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property VarName |
Public Property VarValue |
Public Property XML | Returns the XML for this record.

See Also

EnvironmentVar Overview


%%PageItemTitle%%

EnvironmentVar Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

AppendStyle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AppendStyle() As aiEnvVarAppendStyle

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Delimiter Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Delimiter() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

InstallAction Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InstallAction() As aiEnvVarInstallAction

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As EnvironmentVars

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Scope Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Scope() As aiEnvVarScope

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

Uninstall Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Uninstall() As Boolean

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

VarName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property VarName() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

VarValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property VarValue() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVar Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

EnvironmentVar Object


%%PageItemTitle%%

EnvironmentVars Members

EnvironmentVars Collection

For a list of all members defined in this module, see EnvironmentVars members.

Object Model

See Also

EnvironmentVars Members


%%PageItemTitle%% $$Members$$

EnvironmentVars Members

EnvironmentVars Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

EnvironmentVars Overview


%%PageItemTitle%%

EnvironmentVars Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As EnvironmentVar

Parameters

Name

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As EnvironmentVar

Parameters

key

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As EnvironmentVar _
)

Parameters

Item

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As EnvironmentVar _
)

Parameters

Item

See Also

EnvironmentVars Collection


%%PageItemTitle%%

EnvironmentVars Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As EnvironmentVar _
)

Parameters

Item

See Also

EnvironmentVars Collection


%%PageItemTitle%%

Feature Members

Feature Object

For a list of all members defined in this module, see Feature members.

Object Model

See Also

Feature Members


%%PageItemTitle%% $$Members$$

Feature Members

Feature Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property AdvertiseMode |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Components |
Public Property Created | Returns the date/time when the record was created.
Public Property DefaultLevel |
Public Property Description |
Public Property Directory |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DisableUnsupportedAdvertising |
Public Property Display |
Public Property Id |
Public Property Levels |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Order |
Public Property Parent | Returns the parent of this object.
Public Property ParentFeature |
Public Property Required |
Public Property RunFromMode |
Public Property State |
Public Property Title |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Feature Overview


%%PageItemTitle%%

Feature Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Feature Object


%%PageItemTitle%%

Feature Object

AdvertiseMode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AdvertiseMode() As aiFeatureAdvertise

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Components Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Components() As ComponentRefs

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

DefaultLevel Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultLevel() As Integer

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Directory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Directory() As Directory

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Feature Object


%%PageItemTitle%%

Feature Object

DisableUnsupportedAdvertising Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisableUnsupportedAdvertising() As Boolean

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Display Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Display() As Integer

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Levels Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Levels() As FeatureLevels

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Order Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Features

See Also

Feature Object


%%PageItemTitle%%

Feature Object

ParentFeature Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ParentFeature() As Feature

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Required Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Required() As Boolean

See Also

Feature Object


%%PageItemTitle%%

Feature Object

RunFromMode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RunFromMode() As aiFeatureRunFrom

See Also

Feature Object


%%PageItemTitle%%

Feature Object

State Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property State() As aiFeatureState

See Also

Feature Object


%%PageItemTitle%%

Feature Object

Title Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Title() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Feature Object


%%PageItemTitle%%

Feature Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Feature Object


%%PageItemTitle%%

FeatureLevel Members

FeatureLevel Object

For a list of all members defined in this module, see FeatureLevel members.

Object Model

See Also

FeatureLevel Members


%%PageItemTitle%% $$Members$$

FeatureLevel Members

FeatureLevel Object Members

Public Properties

Public Property Condition |
Public Property ID |
Public Property Level |
Public Property Parent | Returns the parent of this object.
Public Property XML | Returns the XML for this record.

See Also

FeatureLevel Overview


%%PageItemTitle%%

FeatureLevel Object

Condition Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition() As String

See Also

FeatureLevel Object


%%PageItemTitle%%

FeatureLevel Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

FeatureLevel Object


%%PageItemTitle%%

FeatureLevel Object

Level Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Level() As Integer

See Also

FeatureLevel Object


%%PageItemTitle%%

FeatureLevel Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As FeatureLevels

See Also

FeatureLevel Object


%%PageItemTitle%%

FeatureLevel Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

FeatureLevel Object


%%PageItemTitle%%

FeatureLevels Members

FeatureLevels Collection

For a list of all members defined in this module, see FeatureLevels members.

Object Model

See Also

FeatureLevels Members


%%PageItemTitle%% $$Members$$

FeatureLevels Members

FeatureLevels Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

FeatureLevels Overview


%%PageItemTitle%%

FeatureLevels Collection

Level
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Level As Integer _
) As FeatureLevel

Parameters

Level

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As FeatureLevel

Parameters

key

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As FeatureLevel _
)

Parameters

Item

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As FeatureLevel _
)

Parameters

Item

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureLevels Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As FeatureLevel _
)

Parameters

Item

See Also

FeatureLevels Collection


%%PageItemTitle%%

FeatureRefs Members

FeatureRefs Collection

For a list of all members defined in this module, see FeatureRefs members.

Object Model

See Also

FeatureRefs Members


%%PageItemTitle%% $$Members$$

FeatureRefs Members

FeatureRefs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

See Also

FeatureRefs Overview


%%PageItemTitle%%

FeatureRefs Collection

oF
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   ByRef oF As Feature _
) As Variant

Parameters

oF

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As Feature

Parameters

Key

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Variant

Parameters

Key

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Sub Save()

See Also

FeatureRefs Collection


%%PageItemTitle%%

FeatureRefs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

FeatureRefs Collection


%%PageItemTitle%%

Features Members

Features Collection

For a list of all members defined in this module, see Features members.

Object Model

See Also

Features Members


%%PageItemTitle%% $$Members$$

Features Members

Features Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Features Overview


%%PageItemTitle%%

Features Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Feature

Parameters

Name

See Also

Features Collection


%%PageItemTitle%%

Features Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Features Collection


%%PageItemTitle%%

Features Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Features Collection


%%PageItemTitle%%

Features Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Feature

Parameters

key

See Also

Features Collection


%%PageItemTitle%%

Features Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Features Collection


%%PageItemTitle%%

Features Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Features Collection


%%PageItemTitle%%

Features Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Features Collection


%%PageItemTitle%%

Features Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Features Collection


%%PageItemTitle%%

Features Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Feature _
)

Parameters

Item

See Also

Features Collection


%%PageItemTitle%%

Features Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Feature _
)

Parameters

Item

See Also

Features Collection


%%PageItemTitle%%

Features Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Feature _
)

Parameters

Item

See Also

Features Collection


%%PageItemTitle%%

File Members

File Object

For a list of all members defined in this module, see File members.

Object Model

See Also

File Members


%%PageItemTitle%% $$Members$$

File Members

File Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Assembly_ApplicationID |
Public Property Assembly_AssemblyType |
Public Property Assembly_FeatureID |
Public Property Assembly_ManifestID |
Public Property Assembly_Params |
Public Property Attributes |
Public Property Author | Gets the name of the last author to modify this record.
Public Property BindImage |
Public Property BindImagePaths |
Public Property COM_Cost |
Public Property COM_ExtractAtBuild |
Public Property COM_UseRelativePaths |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Compression |
Public Property CopyFiles |
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property FileName |
Public Property FileSize |
Public Property Font_Title |
Public Property Hidden |
Public Property Id |
Public Property Language |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Permissions |
Public Property ReadOnly |
Public Property Registration |
Public Property Sequence |
Public Property SourcePath |
Public Property System |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Version |
Public Property Vital |
Public Property XML | Returns the XML for this record.

See Also

File Overview


%%PageItemTitle%%

File Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

File Object


%%PageItemTitle%%

File Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

File Object


%%PageItemTitle%%

File Object

Assembly_ApplicationID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Assembly_ApplicationID() As String

See Also

File Object


%%PageItemTitle%%

File Object

Assembly_AssemblyType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Assembly_AssemblyType() As aiAssemblyType

See Also

File Object


%%PageItemTitle%%

File Object

Assembly_FeatureID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Assembly_FeatureID() As String

See Also

File Object


%%PageItemTitle%%

File Object

Assembly_ManifestID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Assembly_ManifestID() As String

See Also

File Object


%%PageItemTitle%%

File Object

Assembly_Params Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Assembly_Params() As AssemblyParams

See Also

File Object


%%PageItemTitle%%

File Object

Attributes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Attributes() As Integer

See Also

File Object


%%PageItemTitle%%

File Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

File Object


%%PageItemTitle%%

File Object

BindImage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BindImage() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

BindImagePaths Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BindImagePaths() As String

See Also

File Object


%%PageItemTitle%%

File Object

COM_Cost Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property COM_Cost() As Long

See Also

File Object


%%PageItemTitle%%

File Object

COM_ExtractAtBuild Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property COM_ExtractAtBuild() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

COM_UseRelativePaths Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property COM_UseRelativePaths() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

File Object


%%PageItemTitle%%

File Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

File Object


%%PageItemTitle%%

File Object

Compression Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Compression() As aiFileCompression

See Also

File Object


%%PageItemTitle%%

File Object

CopyFiles Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CopyFiles() As CopyFiles

See Also

File Object


%%PageItemTitle%%

File Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

File Object


%%PageItemTitle%%

File Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

FileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

File Object


%%PageItemTitle%%

File Object

FileSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileSize() As Long

See Also

File Object


%%PageItemTitle%%

File Object

Font_Title Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Font_Title() As String

See Also

File Object


%%PageItemTitle%%

File Object

Hidden Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Hidden() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

File Object


%%PageItemTitle%%

File Object

Language Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Language() As String

See Also

File Object


%%PageItemTitle%%

File Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

File Object


%%PageItemTitle%%

File Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

File Object


%%PageItemTitle%%

File Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Files

See Also

File Object


%%PageItemTitle%%

File Object

Permissions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Permissions

See Also

File Object


%%PageItemTitle%%

File Object

ReadOnly Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ReadOnly() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

Registration Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Registration() As aiFileRegistrationType

See Also

File Object


%%PageItemTitle%%

File Object

Sequence Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Sequence() As Integer

See Also

File Object


%%PageItemTitle%%

File Object

SourcePath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourcePath() As String

See Also

File Object


%%PageItemTitle%%

File Object

System Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property System() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

File Object


%%PageItemTitle%%

File Object

Version Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Version() As String

See Also

File Object


%%PageItemTitle%%

File Object

Vital Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Vital() As Boolean

See Also

File Object


%%PageItemTitle%%

File Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

File Object


%%PageItemTitle%%

Files Members

Files Collection

For a list of all members defined in this module, see Files members.

Object Model

See Also

Files Members


%%PageItemTitle%% $$Members$$

Files Members

Files Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Files Overview


%%PageItemTitle%%

Files Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As File

Parameters

Name

See Also

Files Collection


%%PageItemTitle%%

Files Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Files Collection


%%PageItemTitle%%

Files Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Files Collection


%%PageItemTitle%%

Files Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As File

Parameters

key

See Also

Files Collection


%%PageItemTitle%%

Files Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Files Collection


%%PageItemTitle%%

Files Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Files Collection


%%PageItemTitle%%

Files Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Files Collection


%%PageItemTitle%%

Files Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Files Collection


%%PageItemTitle%%

Files Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As File _
)

Parameters

Item

See Also

Files Collection


%%PageItemTitle%%

Files Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As File _
)

Parameters

Item

See Also

Files Collection


%%PageItemTitle%%

Files Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As File _
)

Parameters

Item

See Also

Files Collection


%%PageItemTitle%%

Global Members

Global Object

For a list of all members defined in this module, see Global members.

Object Model

See Also

Global Members


%%PageItemTitle%% $$Members$$

Global Members

Global Object Members

Public Methods

Public Method FromPathVar
Public Method GetPathVarsForFolder
Public Method ImportMSI
Public Method OpenProjectFile
Public Method ToPathVar

See Also

Global Overview


%%PageItemTitle%%

Global Object

PathVar
See Also ActiveInstall Professional Send Feedback on this topic.

FromPathVar Method

Syntax

Public Function FromPathVar( _
   ByRef PathVar As String _
) As String

Parameters

PathVar

See Also

Global Object


%%PageItemTitle%%

Global Object

Folder
See Also ActiveInstall Professional Send Feedback on this topic.

GetPathVarsForFolder Method

Syntax

Public Function GetPathVarsForFolder( _
   ByRef Folder As String _
) As CCollectionString

Parameters

Folder

See Also

Global Object


%%PageItemTitle%%

Global Object

MSIPath
NewProjectPath
See Also ActiveInstall Professional Send Feedback on this topic.

ImportMSI Method

Syntax

Public Function ImportMSI( _
   ByRef MSIPath As String, _
   ByRef NewProjectPath As String _
) As Boolean

Parameters

MSIPath
NewProjectPath

See Also

Global Object


%%PageItemTitle%%

Global Object

FilePath
See Also ActiveInstall Professional Send Feedback on this topic.

OpenProjectFile Method

Syntax

Public Function OpenProjectFile( _
   ByRef FilePath As String _
) As Project

Parameters

FilePath

See Also

Global Object


%%PageItemTitle%%

Global Object

Path
See Also ActiveInstall Professional Send Feedback on this topic.

ToPathVar Method

Syntax

Public Function ToPathVar( _
   ByRef Path As String _
) As String

Parameters

Path

See Also

Global Object


%%PageItemTitle%%

IActionItem Members

IActionItem Object

For a list of all members defined in this module, see IActionItem members.

See Also

IActionItem Members


%%PageItemTitle%% $$Members$$

IActionItem Members

IActionItem Object Members

Public Methods

Public Method Delete |
Public Method DisplayName |
Public Method HTMLDesc |
Public Method ID |
Public Method ItemType |
Public Method Object |
Public Method Show | Displays an edit dialog for this element.

See Also

IActionItem Overview


%%PageItemTitle%%

IActionItem Object

Delete Method

Syntax

Public Function Delete() As Boolean

See Also

IActionItem Object


%%PageItemTitle%%

IActionItem Object

DisplayName Method

Syntax

Public Function DisplayName() As String

See Also

IActionItem Object


%%PageItemTitle%%

IActionItem Object

HTMLDesc Method

Syntax

Public Function HTMLDesc() As String

See Also

IActionItem Object


%%PageItemTitle%%

IActionItem Object

ID Method

Syntax

Public Function ID() As String

See Also

IActionItem Object


%%PageItemTitle%%

IActionItem Object

ItemType Method

Syntax

Public Function ItemType() As String

See Also

IActionItem Object


%%PageItemTitle%%

IActionItem Object

Object Method

Syntax

Public Function Object() As Object

See Also

IActionItem Object


%%PageItemTitle%%

IActionItem Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

IActionItem Object


%%PageItemTitle%%

IComponentMember Members

IComponentMember Object

For a list of all members defined in this module, see IComponentMember members.

See Also

IComponentMember Members


%%PageItemTitle%% $$Members$$

IComponentMember Members

IComponentMember Object Members

Public Methods

Public Method Delete |
Public Method DisplayName |
Public Method ID |
Public Method ItemType |
Public Method Show | Displays an edit dialog for this element.

See Also

IComponentMember Overview


%%PageItemTitle%%

IComponentMember Object

Delete Method

Syntax

Public Function Delete() As Boolean

See Also

IComponentMember Object


%%PageItemTitle%%

IComponentMember Object

DisplayName Method

Syntax

Public Function DisplayName() As String

See Also

IComponentMember Object


%%PageItemTitle%%

IComponentMember Object

ID Method

Syntax

Public Function ID() As String

See Also

IComponentMember Object


%%PageItemTitle%%

IComponentMember Object

ItemType Method

Syntax

Public Function ItemType() As String

See Also

IComponentMember Object


%%PageItemTitle%%

IComponentMember Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

IComponentMember Object


%%PageItemTitle%%

INIFileMod Members

INIFileMod Object

For a list of all members defined in this module, see INIFileMod members.

Object Model

See Also

INIFileMod Members


%%PageItemTitle%% $$Members$$

INIFileMod Members

INIFileMod Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Action |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property DirProperty |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property FileName |
Public Property Id |
Public Property KeyName |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Section |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

INIFileMod Overview


%%PageItemTitle%%

INIFileMod Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Action Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Action() As aiINIFileModAction

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

DirProperty Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DirProperty() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

FileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

KeyName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeyName() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As INIFileMods

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Section Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Section() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMod Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

INIFileMod Object


%%PageItemTitle%%

INIFileMods Members

INIFileMods Collection

For a list of all members defined in this module, see INIFileMods members.

Object Model

See Also

INIFileMods Members


%%PageItemTitle%% $$Members$$

INIFileMods Members

INIFileMods Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

INIFileMods Overview


%%PageItemTitle%%

INIFileMods Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As INIFileMod

Parameters

Name

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As INIFileMod

Parameters

key

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As INIFileMod _
)

Parameters

Item

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As INIFileMod _
)

Parameters

Item

See Also

INIFileMods Collection


%%PageItemTitle%%

INIFileMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As INIFileMod _
)

Parameters

Item

See Also

INIFileMods Collection


%%PageItemTitle%%

IPLClient Members

IPLClient Object

For a list of all members defined in this module, see IPLClient members.

See Also

IPLClient Members


%%PageItemTitle%% $$Members$$

IPLClient Members

IPLClient Object Members

Public Methods

Public Method CustomEdit
Public Method InitProperties
Public Method RefreshData
Public Method ShutDown
Public Method ValueChanged

Public Properties

Public Property DisplayName
Public Property ID
Public Property TypeName

See Also

IPLClient Overview


%%PageItemTitle%%

IPLClient Object

Key
See Also ActiveInstall Professional Send Feedback on this topic.

CustomEdit Method

Syntax

Public Sub CustomEdit( _
   ByRef Key As String _
)

Parameters

Key

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

InitProperties Method

Syntax

Public Sub InitProperties()

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

RefreshData Method

Syntax

Public Sub RefreshData()

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

ShutDown Method

Syntax

Public Sub ShutDown()

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

Key
Value
Cancel
See Also ActiveInstall Professional Send Feedback on this topic.

ValueChanged Method

Syntax

Public Sub ValueChanged( _
   ByRef Key As String, _
   ByRef Value As Variant, _
   ByRef Cancel As Boolean _
)

Parameters

Key
Value
Cancel

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

DisplayName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property DisplayName() As String

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

ID Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ID() As String

See Also

IPLClient Object


%%PageItemTitle%%

IPLClient Object

TypeName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property TypeName() As String

See Also

IPLClient Object


%%PageItemTitle%%

Language Members

Language Object

For a list of all members defined in this module, see Language members.

Object Model

See Also

Language Members


%%PageItemTitle%% $$Members$$

Language Members

Language Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property BuildFileName |
Public Property CodePage |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property LanguageCodes |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Language Overview


%%PageItemTitle%%

Language Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Language Object


%%PageItemTitle%%

Language Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Language Object


%%PageItemTitle%%

Language Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Language Object


%%PageItemTitle%%

Language Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Language Object


%%PageItemTitle%%

Language Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Language Object


%%PageItemTitle%%

Language Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

BuildFileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BuildFileName() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

CodePage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CodePage() As Integer

See Also

Language Object


%%PageItemTitle%%

Language Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Language Object


%%PageItemTitle%%

Language Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

LanguageCodes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LanguageCodes() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Languages

See Also

Language Object


%%PageItemTitle%%

Language Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Language Object


%%PageItemTitle%%

Language Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Language Object


%%PageItemTitle%%

Languages Members

Languages Collection

For a list of all members defined in this module, see Languages members.

Object Model

See Also

Languages Members


%%PageItemTitle%% $$Members$$

Languages Members

Languages Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Languages Overview


%%PageItemTitle%%

Languages Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Language

Parameters

Name

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Language

Parameters

key

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Language _
)

Parameters

Item

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Language _
)

Parameters

Item

See Also

Languages Collection


%%PageItemTitle%%

Languages Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Language _
)

Parameters

Item

See Also

Languages Collection


%%PageItemTitle%%

LaunchCondition Members

LaunchCondition Object

For a list of all members defined in this module, see LaunchCondition members.

Object Model

See Also

LaunchCondition Members


%%PageItemTitle%% $$Members$$

LaunchCondition Members

LaunchCondition Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Condition |
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Message |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

LaunchCondition Overview


%%PageItemTitle%%

LaunchCondition Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Condition Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Condition() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Message Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Message() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As LaunchConditions

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchCondition Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

LaunchCondition Object


%%PageItemTitle%%

LaunchConditions Members

LaunchConditions Collection

For a list of all members defined in this module, see LaunchConditions members.

Object Model

See Also

LaunchConditions Members


%%PageItemTitle%% $$Members$$

LaunchConditions Members

LaunchConditions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

LaunchConditions Overview


%%PageItemTitle%%

LaunchConditions Collection

Condition
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Condition As String _
) As LaunchCondition

Parameters

Condition

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As LaunchCondition

Parameters

key

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As LaunchCondition _
)

Parameters

Item

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As LaunchCondition _
)

Parameters

Item

See Also

LaunchConditions Collection


%%PageItemTitle%%

LaunchConditions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As LaunchCondition _
)

Parameters

Item

See Also

LaunchConditions Collection


%%PageItemTitle%%

MergeMod Members

MergeMod Object

For a list of all members defined in this module, see MergeMod members.

Object Model

See Also

MergeMod Members


%%PageItemTitle%% $$Members$$

MergeMod Members

MergeMod Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property DefaultFeature |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Features |
Public Property Id |
Public Property IgnoreRelationships |
Public Property Language |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property ModuleID |
Public Property Name |
Public Property Options |
Public Property Parent | Returns the parent of this object.
Public Property RootDirectory |
Public Property SourcePath |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Version |
Public Property XML | Returns the XML for this record.

See Also

MergeMod Overview


%%PageItemTitle%%

MergeMod Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

DefaultFeature Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultFeature() As Feature

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Features Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Features() As FeatureRefs

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

IgnoreRelationships Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IgnoreRelationships() As Boolean

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Language Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Language() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

ModuleID Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ModuleID() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Name Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Options Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Options() As MergeModOptions

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MergeMods

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

RootDirectory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RootDirectory() As Directory

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

SourcePath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourcePath() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

Version Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Version() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeMod Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MergeMod Object


%%PageItemTitle%%

MergeModOption Members

MergeModOption Object

For a list of all members defined in this module, see MergeModOption members.

Object Model

See Also

MergeModOption Members


%%PageItemTitle%% $$Members$$

MergeModOption Members

MergeModOption Object Members

Public Properties

Public Property ID |
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

MergeModOption Overview


%%PageItemTitle%%

MergeModOption Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

MergeModOption Object


%%PageItemTitle%%

MergeModOption Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MergeModOption Object


%%PageItemTitle%%

MergeModOption Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MergeModOptions

See Also

MergeModOption Object


%%PageItemTitle%%

MergeModOption Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

MergeModOption Object


%%PageItemTitle%%

MergeModOption Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MergeModOption Object


%%PageItemTitle%%

MergeModOptions Members

MergeModOptions Collection

For a list of all members defined in this module, see MergeModOptions members.

Object Model

See Also

MergeModOptions Members


%%PageItemTitle%% $$Members$$

MergeModOptions Members

MergeModOptions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MergeModOptions Overview


%%PageItemTitle%%

MergeModOptions Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As MergeModOption

Parameters

Name

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MergeModOption

Parameters

key

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MergeModOption _
)

Parameters

Item

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MergeModOption _
)

Parameters

Item

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeModOptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MergeModOption _
)

Parameters

Item

See Also

MergeModOptions Collection


%%PageItemTitle%%

MergeMods Members

MergeMods Collection

For a list of all members defined in this module, see MergeMods members.

Object Model

See Also

MergeMods Members


%%PageItemTitle%% $$Members$$

MergeMods Members

MergeMods Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MergeMods Overview


%%PageItemTitle%%

MergeMods Collection

SourcePath
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   ByRef SourcePath As String _
) As MergeMod

Parameters

SourcePath

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MergeMod

Parameters

key

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MergeMod _
)

Parameters

Item

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MergeMod _
)

Parameters

Item

See Also

MergeMods Collection


%%PageItemTitle%%

MergeMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MergeMod _
)

Parameters

Item

See Also

MergeMods Collection


%%PageItemTitle%%

MIMEType Members

MIMEType Object

For a list of all members defined in this module, see MIMEType members.

Object Model

See Also

MIMEType Members


%%PageItemTitle%% $$Members$$

MIMEType Members

MIMEType Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property CLSID |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Extension |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

MIMEType Overview


%%PageItemTitle%%

MIMEType Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

CLSID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CLSID() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Extension Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Extension() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MIMETypes

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMEType Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MIMEType Object


%%PageItemTitle%%

MIMETypes Members

MIMETypes Collection

For a list of all members defined in this module, see MIMETypes members.

Object Model

See Also

MIMETypes Members


%%PageItemTitle%% $$Members$$

MIMETypes Members

MIMETypes Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MIMETypes Overview


%%PageItemTitle%%

MIMETypes Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As MIMEType

Parameters

Name

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MIMEType

Parameters

key

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MIMEType _
)

Parameters

Item

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MIMEType _
)

Parameters

Item

See Also

MIMETypes Collection


%%PageItemTitle%%

MIMETypes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MIMEType _
)

Parameters

Item

See Also

MIMETypes Collection


%%PageItemTitle%%

MMOption Members

MMOption Object

For a list of all members defined in this module, see MMOption members.

Object Model

See Also

MMOption Members


%%PageItemTitle%% $$Members$$

MMOption Members

MMOption Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Attributes |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property ContextData |
Public Property Created | Returns the date/time when the record was created.
Public Property DefaultValue |
Public Property Description |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DisplayName |
Public Property Format |
Public Property HelpKeyword |
Public Property HelpLocation |
Public Property Id |
Public Property ItemType |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

MMOption Overview


%%PageItemTitle%%

MMOption Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Attributes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Attributes() As Long

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

ContextData Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ContextData() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

DefaultValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultValue() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

DisplayName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayName() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Format Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Format() As Long

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

HelpKeyword Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HelpKeyword() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

HelpLocation Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HelpLocation() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

ItemType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ItemType() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MMOptions

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOption Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MMOption Object


%%PageItemTitle%%

MMOptions Members

MMOptions Collection

For a list of all members defined in this module, see MMOptions members.

Object Model

See Also

MMOptions Members


%%PageItemTitle%% $$Members$$

MMOptions Members

MMOptions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MMOptions Overview


%%PageItemTitle%%

MMOptions Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As MMOption

Parameters

Name

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MMOption

Parameters

key

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MMOption _
)

Parameters

Item

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MMOption _
)

Parameters

Item

See Also

MMOptions Collection


%%PageItemTitle%%

MMOptions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MMOption _
)

Parameters

Item

See Also

MMOptions Collection


%%PageItemTitle%%

MMRelationship Members

MMRelationship Object

For a list of all members defined in this module, see MMRelationship members.

Object Model

See Also

MMRelationship Members


%%PageItemTitle%% $$Members$$

MMRelationship Members

MMRelationship Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Language |
Public Property MaxVersion |
Public Property MinVersion |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property ModuleID |
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property RelationshipType |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

MMRelationship Overview


%%PageItemTitle%%

MMRelationship Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Language Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Language() As Long

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

MaxVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property MaxVersion() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

MinVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property MinVersion() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

ModuleID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ModuleID() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MMRelationships

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

RelationshipType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RelationshipType() As aiMMRelationshipType

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationship Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MMRelationship Object


%%PageItemTitle%%

MMRelationships Members

MMRelationships Collection

For a list of all members defined in this module, see MMRelationships members.

Object Model

See Also

MMRelationships Members


%%PageItemTitle%% $$Members$$

MMRelationships Members

MMRelationships Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MMRelationships Overview


%%PageItemTitle%%

MMRelationships Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As MMRelationship

Parameters

Name

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MMRelationship

Parameters

key

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MMRelationship _
)

Parameters

Item

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MMRelationship _
)

Parameters

Item

See Also

MMRelationships Collection


%%PageItemTitle%%

MMRelationships Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MMRelationship _
)

Parameters

Item

See Also

MMRelationships Collection


%%PageItemTitle%%

MMSubstitution Members

MMSubstitution Object

For a list of all members defined in this module, see MMSubstitution members.

Object Model

See Also

MMSubstitution Members


%%PageItemTitle%% $$Members$$

MMSubstitution Members

MMSubstitution Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Column |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Row |
Public Property Table |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

MMSubstitution Overview


%%PageItemTitle%%

MMSubstitution Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Column Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Column() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MMSubstitutions

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Row Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Row() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Table Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Table() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitution Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MMSubstitution Object


%%PageItemTitle%%

MMSubstitutions Members

MMSubstitutions Collection

For a list of all members defined in this module, see MMSubstitutions members.

Object Model

See Also

MMSubstitutions Members


%%PageItemTitle%% $$Members$$

MMSubstitutions Members

MMSubstitutions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MMSubstitutions Overview


%%PageItemTitle%%

MMSubstitutions Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As MMSubstitution

Parameters

Name

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MMSubstitution

Parameters

key

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MMSubstitution _
)

Parameters

Item

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MMSubstitution _
)

Parameters

Item

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MMSubstitutions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MMSubstitution _
)

Parameters

Item

See Also

MMSubstitutions Collection


%%PageItemTitle%%

MoveFile Members

MoveFile Object

For a list of all members defined in this module, see MoveFile members.

Object Model

See Also

MoveFile Members


%%PageItemTitle%% $$Members$$

MoveFile Members

MoveFile Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Action |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property DestFolder |
Public Property DestName |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property SourceFolder |
Public Property SourceName |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

MoveFile Overview


%%PageItemTitle%%

MoveFile Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Action Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Action() As aiMoveFileAction

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

DestFolder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DestFolder() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

DestName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DestName() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MoveFiles

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

SourceFolder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceFolder() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

SourceName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceName() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFile Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MoveFile Object


%%PageItemTitle%%

MoveFiles Members

MoveFiles Collection

For a list of all members defined in this module, see MoveFiles members.

Object Model

See Also

MoveFiles Members


%%PageItemTitle%% $$Members$$

MoveFiles Members

MoveFiles Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MoveFiles Overview


%%PageItemTitle%%

MoveFiles Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As MoveFile

Parameters

Name

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MoveFile

Parameters

key

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MoveFile _
)

Parameters

Item

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MoveFile _
)

Parameters

Item

See Also

MoveFiles Collection


%%PageItemTitle%%

MoveFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MoveFile _
)

Parameters

Item

See Also

MoveFiles Collection


%%PageItemTitle%%

MsgString Members

MsgString Object

For a list of all members defined in this module, see MsgString members.

Object Model

See Also

MsgString Members


%%PageItemTitle%% $$Members$$

MsgString Members

MsgString Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property MsgNumber |
Public Property Parent | Returns the parent of this object.
Public Property Template |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

MsgString Overview


%%PageItemTitle%%

MsgString Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

MsgNumber Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property MsgNumber() As Integer

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As MsgStrings

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

Template Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Template() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgString Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MsgString Object


%%PageItemTitle%%

MsgStrings Members

MsgStrings Collection

For a list of all members defined in this module, see MsgStrings members.

Object Model

See Also

MsgStrings Members


%%PageItemTitle%% $$Members$$

MsgStrings Members

MsgStrings Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

MsgStrings Overview


%%PageItemTitle%%

MsgStrings Collection

MsgNumber
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef MsgNumber As Integer _
) As MsgString

Parameters

MsgNumber

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As MsgString

Parameters

key

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As MsgString _
)

Parameters

Item

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As MsgString _
)

Parameters

Item

See Also

MsgStrings Collection


%%PageItemTitle%%

MsgStrings Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As MsgString _
)

Parameters

Item

See Also

MsgStrings Collection


%%PageItemTitle%%

ODBCAttribute Members

ODBCAttribute Object

For a list of all members defined in this module, see ODBCAttribute members.

Object Model

See Also

ODBCAttribute Members


%%PageItemTitle%% $$Members$$

ODBCAttribute Members

ODBCAttribute Object Members

Public Properties

Public Property ID |
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

ODBCAttribute Overview


%%PageItemTitle%%

ODBCAttribute Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

ODBCAttribute Object


%%PageItemTitle%%

ODBCAttribute Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ODBCAttribute Object


%%PageItemTitle%%

ODBCAttribute Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ODBCAttributes

See Also

ODBCAttribute Object


%%PageItemTitle%%

ODBCAttribute Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

ODBCAttribute Object


%%PageItemTitle%%

ODBCAttribute Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCAttribute Object


%%PageItemTitle%%

ODBCAttributes Members

ODBCAttributes Collection

For a list of all members defined in this module, see ODBCAttributes members.

Object Model

See Also

ODBCAttributes Members


%%PageItemTitle%% $$Members$$

ODBCAttributes Members

ODBCAttributes Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ODBCAttributes Overview


%%PageItemTitle%%

ODBCAttributes Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ODBCAttribute

Parameters

Name

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ODBCAttribute

Parameters

key

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ODBCAttribute _
)

Parameters

Item

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ODBCAttribute _
)

Parameters

Item

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCAttributes Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ODBCAttribute _
)

Parameters

Item

See Also

ODBCAttributes Collection


%%PageItemTitle%%

ODBCDataSource Members

ODBCDataSource Object

For a list of all members defined in this module, see ODBCDataSource members.

Object Model

See Also

ODBCDataSource Members


%%PageItemTitle%% $$Members$$

ODBCDataSource Members

ODBCDataSource Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Attributes |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property DataSourceName |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Driver |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Registration |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

ODBCDataSource Overview


%%PageItemTitle%%

ODBCDataSource Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Attributes Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attributes() As ODBCAttributes

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

DataSourceName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DataSourceName() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Driver Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Driver() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ODBCDataSources

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

Registration Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Registration() As aiDataSourceScope

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSource Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCDataSource Object


%%PageItemTitle%%

ODBCDataSources Members

ODBCDataSources Collection

For a list of all members defined in this module, see ODBCDataSources members.

Object Model

See Also

ODBCDataSources Members


%%PageItemTitle%% $$Members$$

ODBCDataSources Members

ODBCDataSources Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ODBCDataSources Overview


%%PageItemTitle%%

ODBCDataSources Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ODBCDataSource

Parameters

Name

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ODBCDataSource

Parameters

key

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ODBCDataSource _
)

Parameters

Item

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ODBCDataSource _
)

Parameters

Item

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDataSources Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ODBCDataSource _
)

Parameters

Item

See Also

ODBCDataSources Collection


%%PageItemTitle%%

ODBCDriver Members

ODBCDriver Object

For a list of all members defined in this module, see ODBCDriver members.

Object Model

See Also

ODBCDriver Members


%%PageItemTitle%% $$Members$$

ODBCDriver Members

ODBCDriver Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Attributes |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DriverFile |
Public Property DriverName |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property SetupFile |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

ODBCDriver Overview


%%PageItemTitle%%

ODBCDriver Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Attributes Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Attributes() As ODBCAttributes

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

DriverFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DriverFile() As File

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

DriverName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DriverName() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ODBCDrivers

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

SetupFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SetupFile() As File

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDriver Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCDriver Object


%%PageItemTitle%%

ODBCDrivers Members

ODBCDrivers Collection

For a list of all members defined in this module, see ODBCDrivers members.

Object Model

See Also

ODBCDrivers Members


%%PageItemTitle%% $$Members$$

ODBCDrivers Members

ODBCDrivers Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ODBCDrivers Overview


%%PageItemTitle%%

ODBCDrivers Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ODBCDriver

Parameters

Name

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ODBCDriver

Parameters

key

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ODBCDriver _
)

Parameters

Item

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ODBCDriver _
)

Parameters

Item

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCDrivers Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ODBCDriver _
)

Parameters

Item

See Also

ODBCDrivers Collection


%%PageItemTitle%%

ODBCTranslator Members

ODBCTranslator Object

For a list of all members defined in this module, see ODBCTranslator members.

Object Model

See Also

ODBCTranslator Members


%%PageItemTitle%% $$Members$$

ODBCTranslator Members

ODBCTranslator Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property SetupFile |
Public Property TranslatorFile |
Public Property TranslatorName |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

ODBCTranslator Overview


%%PageItemTitle%%

ODBCTranslator Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ODBCTranslators

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

SetupFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SetupFile() As File

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

TranslatorFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TranslatorFile() As File

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

TranslatorName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TranslatorName() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslator Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCTranslator Object


%%PageItemTitle%%

ODBCTranslators Members

ODBCTranslators Collection

For a list of all members defined in this module, see ODBCTranslators members.

Object Model

See Also

ODBCTranslators Members


%%PageItemTitle%% $$Members$$

ODBCTranslators Members

ODBCTranslators Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ODBCTranslators Overview


%%PageItemTitle%%

ODBCTranslators Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ODBCTranslator

Parameters

Name

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ODBCTranslator

Parameters

key

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ODBCTranslator _
)

Parameters

Item

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ODBCTranslator _
)

Parameters

Item

See Also

ODBCTranslators Collection


%%PageItemTitle%%

ODBCTranslators Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ODBCTranslator _
)

Parameters

Item

See Also

ODBCTranslators Collection


%%PageItemTitle%%

PathVar Members

PathVar Object

For a list of all members defined in this module, see PathVar members.

Object Model

See Also

PathVar Members


%%PageItemTitle%% $$Members$$

PathVar Members

PathVar Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property System |
Public Property TestValue |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

PathVar Overview


%%PageItemTitle%%

PathVar Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As PathVars

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

System Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property System() As Boolean

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

TestValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TestValue() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVar Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

PathVar Object


%%PageItemTitle%%

PathVars Members

PathVars Collection

For a list of all members defined in this module, see PathVars members.

Object Model

See Also

PathVars Members


%%PageItemTitle%% $$Members$$

PathVars Members

PathVars Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

PathVars Overview


%%PageItemTitle%%

PathVars Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As PathVar

Parameters

Name

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As PathVar

Parameters

key

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As PathVar _
)

Parameters

Item

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As PathVar _
)

Parameters

Item

See Also

PathVars Collection


%%PageItemTitle%%

PathVars Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As PathVar _
)

Parameters

Item

See Also

PathVars Collection


%%PageItemTitle%%

Permission Members

Permission Object

For a list of all members defined in this module, see Permission members.

Object Model

See Also

Permission Members


%%PageItemTitle%% $$Members$$

Permission Members

Permission Object Members

Public Properties

Public Property Domain |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property Permissions |
Public Property User |
Public Property XML | Returns the XML for this record.

See Also

Permission Overview


%%PageItemTitle%%

Permission Object

Domain Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Domain() As String

See Also

Permission Object


%%PageItemTitle%%

Permission Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

Permission Object


%%PageItemTitle%%

Permission Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Permissions

See Also

Permission Object


%%PageItemTitle%%

Permission Object

Permissions Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Permissions() As Long

See Also

Permission Object


%%PageItemTitle%%

Permission Object

User Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property User() As String

See Also

Permission Object


%%PageItemTitle%%

Permission Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Permission Object


%%PageItemTitle%%

Permissions Members

Permissions Collection

For a list of all members defined in this module, see Permissions members.

Object Model

See Also

Permissions Members


%%PageItemTitle%% $$Members$$

Permissions Members

Permissions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Permissions Overview


%%PageItemTitle%%

Permissions Collection

User
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef User As String _
) As Permission

Parameters

User

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Permission

Parameters

key

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Permission _
)

Parameters

Item

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Permission _
)

Parameters

Item

See Also

Permissions Collection


%%PageItemTitle%%

Permissions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Permission _
)

Parameters

Item

See Also

Permissions Collection


%%PageItemTitle%%

PostBuildSQL Members

PostBuildSQL Object

For a list of all members defined in this module, see PostBuildSQL members.

Object Model

See Also

PostBuildSQL Members


%%PageItemTitle%% $$Members$$

PostBuildSQL Members

PostBuildSQL Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property BuildConfigs |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property SQL |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

PostBuildSQL Overview


%%PageItemTitle%%

PostBuildSQL Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

BuildConfigs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property BuildConfigs() As BuildConfigRefs

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As PostBuildSQLs

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

SQL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SQL() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQL Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

PostBuildSQL Object


%%PageItemTitle%%

PostBuildSQLs Members

PostBuildSQLs Collection

For a list of all members defined in this module, see PostBuildSQLs members.

Object Model

See Also

PostBuildSQLs Members


%%PageItemTitle%% $$Members$$

PostBuildSQLs Members

PostBuildSQLs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

PostBuildSQLs Overview


%%PageItemTitle%%

PostBuildSQLs Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As PostBuildSQL

Parameters

Name

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As PostBuildSQL

Parameters

key

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As PostBuildSQL _
)

Parameters

Item

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As PostBuildSQL _
)

Parameters

Item

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

PostBuildSQLs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As PostBuildSQL _
)

Parameters

Item

See Also

PostBuildSQLs Collection


%%PageItemTitle%%

ProductConfig Members

ProductConfig Object

For a list of all members defined in this module, see ProductConfig members.

Object Model

See Also

ProductConfig Members


%%PageItemTitle%% $$Members$$

ProductConfig Members

ProductConfig Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property FeatureExclusions |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property ProductCode |
Public Property ProductName |
Public Property ProductVersion |
Public Property UpgradeCode |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

ProductConfig Overview


%%PageItemTitle%%

ProductConfig Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

FeatureExclusions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FeatureExclusions() As FeatureRefs

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ProductConfigs

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

ProductCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductCode() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

ProductName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductName() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

ProductVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductVersion() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

UpgradeCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UpgradeCode() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfig Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ProductConfig Object


%%PageItemTitle%%

ProductConfigs Members

ProductConfigs Collection

For a list of all members defined in this module, see ProductConfigs members.

Object Model

See Also

ProductConfigs Members


%%PageItemTitle%% $$Members$$

ProductConfigs Members

ProductConfigs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ProductConfigs Overview


%%PageItemTitle%%

ProductConfigs Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ProductConfig

Parameters

Name

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As ProductConfig

Parameters

Key

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ProductConfig _
)

Parameters

Item

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ProductConfig _
)

Parameters

Item

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProductConfigs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ProductConfig _
)

Parameters

Item

See Also

ProductConfigs Collection


%%PageItemTitle%%

ProgID Members

ProgID Object

For a list of all members defined in this module, see ProgID members.

Object Model

See Also

ProgID Members


%%PageItemTitle%% $$Members$$

ProgID Members

ProgID Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Class |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Description |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property IconFile |
Public Property IconIndex |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property ProgId |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property VIProgIDs |
Public Property XML | Returns the XML for this record.

See Also

ProgID Overview


%%PageItemTitle%%

ProgID Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Class Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Class() As Class

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

IconFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconFile() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

IconIndex Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconIndex() As Integer

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ProgIDs

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

ProgId Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProgId() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

VIProgIDs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property VIProgIDs() As VIProgIDs

See Also

ProgID Object


%%PageItemTitle%%

ProgID Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ProgID Object


%%PageItemTitle%%

ProgIDs Members

ProgIDs Collection

For a list of all members defined in this module, see ProgIDs members.

Object Model

See Also

ProgIDs Members


%%PageItemTitle%% $$Members$$

ProgIDs Members

ProgIDs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ProgIDs Overview


%%PageItemTitle%%

ProgIDs Collection

ProgID
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef ProgID As String _
) As ProgId

Parameters

ProgID

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ProgId

Parameters

key

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ProgId _
)

Parameters

Item

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ProgId _
)

Parameters

Item

See Also

ProgIDs Collection


%%PageItemTitle%%

ProgIDs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ProgId _
)

Parameters

Item

See Also

ProgIDs Collection


%%PageItemTitle%%

Project Members

Project Object

For a list of all members defined in this module, see Project members.

Object Model

See Also

Project Members


%%PageItemTitle%% $$Members$$

Project Members

Project Object Members

Public Methods

Public Method Build |
Public Method CancelBuild |
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method SaveAs |
Public Method SaveSettings |
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.
Public Method ValidateSettings |

Public Properties

Public Property ActionItems |
Public Property ActionStrings |
Public Property AdminExSequence |
Public Property AdminUISequence |
Public Property AdvtExSequence |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property ArchivedBuilds |
Public Property Associations |
Public Property Author | Gets the name of the last author to modify this record.
Public Property BuildConfigs |
Public Property Classes |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Components |
Public Property ControlStrings |
Public Property Created | Returns the date/time when the record was created.
Public Property CustomActions |
Public Property CustomTables |
Public Property DefaultUIFont |
Public Property Dialogs |
Public Property Directories |
Public Property DirectorySearches |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DisableChangeButton |
Public Property DisableRemoveButton |
Public Property EnvironmentVars |
Public Property ErrorDialog |
Public Property Features |
Public Property Files |
Public Property HideRepairButton |
Public Property INIFileMods |
Public Property InstallExSequence |
Public Property InstallUISequence |
Public Property Language |
Public Property Languages |
Public Property LastBuildDate |
Public Property LastBuildPath |
Public Property LaunchConditions |
Public Property Manufacturer |
Public Property MergeMods |
Public Property MIMETypes |
Public Property MMOptions |
Public Property MMRelationships |
Public Property MMSubstitutions |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property MoveFiles |
Public Property MsgStrings |
Public Property ODBCDataSources |
Public Property ODBCDrivers |
Public Property ODBCTranslators |
Public Property PackageCode |
Public Property PathVars |
Public Property Platform |
Public Property PostBuildSQLs |
Public Property ProductCode |
Public Property ProductConfigs |
Public Property ProductIcon |
Public Property ProductIconIndex |
Public Property ProductName |
Public Property ProductURL |
Public Property ProductVersion |
Public Property ProgIDs |
Public Property ProjectFile |
Public Property ProjectFolder |
Public Property ProjectType |
Public Property Properties |
Public Property ReadMeURL |
Public Property RegistryMods |
Public Property RemoveFiles |
Public Property Resources |
Public Property ServiceActions |
Public Property Services |
Public Property SettingsAlerts |
Public Property Shortcuts |
Public Property SkipPropertiesInMM |
Public Property SkipUIInMM |
Public Property SSEnabled |
Public Property SSProject |
Public Property StandardActions |
Public Property SupportComments |
Public Property SupportContact |
Public Property SupportPhone |
Public Property SupportURL |
Public Property SystemSearches |
Public Property Tasks |
Public Property TextStyles |
Public Property TypeLibs |
Public Property UpdateURL |
Public Property UpgradeActions |
Public Property UpgradeCode |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Verbs |
Public Property WIVersion |

Events

Public Event OnAddAlert |
Public Event OnBeginBuild |
Public Event OnBuildComplete |
Public Event OnBuildCompression |
Public Event OnBuildFinal |
Public Event OnBuildOutput |
Public Event OnBuildPhase |
Public Event OnBuildPhaseProgress |
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemoveAlert |
Public Event OnSave |

See Also

Project Overview


%%PageItemTitle%%

Project Object

ConfigName
See Also ActiveInstall Professional Send Feedback on this topic.

Build Method

Syntax

Public Function Build( _
   Optional ByRef ConfigName As String = "Default" _
) As Boolean

Parameters

ConfigName

See Also

Project Object


%%PageItemTitle%%

Project Object

CancelBuild Method

Syntax

Public Sub CancelBuild()

See Also

Project Object


%%PageItemTitle%%

Project Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

FilePath
See Also ActiveInstall Professional Send Feedback on this topic.

SaveAs Method

Syntax

Public Function SaveAs( _
   ByRef FilePath As String _
) As Boolean

Parameters

FilePath

See Also

Project Object


%%PageItemTitle%%

Project Object

SaveSettings Method

Syntax

Public Function SaveSettings() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

ValidateSettings Method

Syntax

Public Function ValidateSettings() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

ActionItems Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionItems() As ActionItems

See Also

Project Object


%%PageItemTitle%%

Project Object

ActionStrings Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ActionStrings() As ActionStrings

See Also

Project Object


%%PageItemTitle%%

Project Object

AdminExSequence Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property AdminExSequence() As Sequence

See Also

Project Object


%%PageItemTitle%%

Project Object

AdminUISequence Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property AdminUISequence() As Sequence

See Also

Project Object


%%PageItemTitle%%

Project Object

AdvtExSequence Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property AdvtExSequence() As Sequence

See Also

Project Object


%%PageItemTitle%%

Project Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As CCollectionString

See Also

Project Object


%%PageItemTitle%%

Project Object

ArchivedBuilds Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ArchivedBuilds() As ArchivedBuilds

See Also

Project Object


%%PageItemTitle%%

Project Object

Associations Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Associations() As Associations

See Also

Project Object


%%PageItemTitle%%

Project Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

BuildConfigs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property BuildConfigs() As BuildConfigs

See Also

Project Object


%%PageItemTitle%%

Project Object

Classes Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Classes() As Classes

See Also

Project Object


%%PageItemTitle%%

Project Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

Components Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Components() As Components

See Also

Project Object


%%PageItemTitle%%

Project Object

ControlStrings Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ControlStrings() As ControlStrings

See Also

Project Object


%%PageItemTitle%%

Project Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

CustomActions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CustomActions() As CustomActions

See Also

Project Object


%%PageItemTitle%%

Project Object

CustomTables Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CustomTables() As CustomTables

See Also

Project Object


%%PageItemTitle%%

Project Object

DefaultUIFont Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultUIFont() As TextStyle

See Also

Project Object


%%PageItemTitle%%

Project Object

Dialogs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dialogs() As Dialogs

See Also

Project Object


%%PageItemTitle%%

Project Object

Directories Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Directories() As Directories

See Also

Project Object


%%PageItemTitle%%

Project Object

DirectorySearches Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property DirectorySearches() As DirectorySearches

See Also

Project Object


%%PageItemTitle%%

Project Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

DisableChangeButton Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisableChangeButton() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

DisableRemoveButton Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisableRemoveButton() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

EnvironmentVars Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property EnvironmentVars() As EnvironmentVars

See Also

Project Object


%%PageItemTitle%%

Project Object

ErrorDialog Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ErrorDialog() As Dialog

See Also

Project Object


%%PageItemTitle%%

Project Object

Features Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Features() As Features

See Also

Project Object


%%PageItemTitle%%

Project Object

Files Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Files() As Files

See Also

Project Object


%%PageItemTitle%%

Project Object

HideRepairButton Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HideRepairButton() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

INIFileMods Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property INIFileMods() As INIFileMods

See Also

Project Object


%%PageItemTitle%%

Project Object

InstallExSequence Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property InstallExSequence() As Sequence

See Also

Project Object


%%PageItemTitle%%

Project Object

InstallUISequence Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property InstallUISequence() As Sequence

See Also

Project Object


%%PageItemTitle%%

Project Object

Language Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Language() As aiLanguage

See Also

Project Object


%%PageItemTitle%%

Project Object

Languages Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Languages() As Languages

See Also

Project Object


%%PageItemTitle%%

Project Object

LastBuildDate Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LastBuildDate() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

LastBuildPath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LastBuildPath() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

LaunchConditions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property LaunchConditions() As LaunchConditions

See Also

Project Object


%%PageItemTitle%%

Project Object

Manufacturer Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Manufacturer() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

MergeMods Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MergeMods() As MergeMods

See Also

Project Object


%%PageItemTitle%%

Project Object

MIMETypes Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MIMETypes() As MIMETypes

See Also

Project Object


%%PageItemTitle%%

Project Object

MMOptions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MMOptions() As MMOptions

See Also

Project Object


%%PageItemTitle%%

Project Object

MMRelationships Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MMRelationships() As MMRelationships

See Also

Project Object


%%PageItemTitle%%

Project Object

MMSubstitutions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MMSubstitutions() As MMSubstitutions

See Also

Project Object


%%PageItemTitle%%

Project Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

MoveFiles Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MoveFiles() As MoveFiles

See Also

Project Object


%%PageItemTitle%%

Project Object

MsgStrings Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MsgStrings() As MsgStrings

See Also

Project Object


%%PageItemTitle%%

Project Object

ODBCDataSources Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ODBCDataSources() As ODBCDataSources

See Also

Project Object


%%PageItemTitle%%

Project Object

ODBCDrivers Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ODBCDrivers() As ODBCDrivers

See Also

Project Object


%%PageItemTitle%%

Project Object

ODBCTranslators Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ODBCTranslators() As ODBCTranslators

See Also

Project Object


%%PageItemTitle%%

Project Object

PackageCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property PackageCode() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

PathVars Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property PathVars() As PathVars

See Also

Project Object


%%PageItemTitle%%

Project Object

Platform Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Platform() As aiPlatform

See Also

Project Object


%%PageItemTitle%%

Project Object

PostBuildSQLs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property PostBuildSQLs() As PostBuildSQLs

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductCode() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductConfigs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProductConfigs() As ProductConfigs

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductIcon Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductIcon() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductIconIndex Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductIconIndex() As Long

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductName() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductURL() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProductVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProductVersion() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProgIDs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProgIDs() As ProgIDs

See Also

Project Object


%%PageItemTitle%%

Project Object

ProjectFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProjectFile() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProjectFolder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProjectFolder() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

ProjectType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProjectType() As Integer

See Also

Project Object


%%PageItemTitle%%

Project Object

Properties Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Properties() As Properties

See Also

Project Object


%%PageItemTitle%%

Project Object

ReadMeURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ReadMeURL() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

RegistryMods Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property RegistryMods() As RegistryMods

See Also

Project Object


%%PageItemTitle%%

Project Object

RemoveFiles Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property RemoveFiles() As RemoveFiles

See Also

Project Object


%%PageItemTitle%%

Project Object

Resources Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Resources() As Resources

See Also

Project Object


%%PageItemTitle%%

Project Object

ServiceActions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ServiceActions() As ServiceActions

See Also

Project Object


%%PageItemTitle%%

Project Object

Services Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Services() As Services

See Also

Project Object


%%PageItemTitle%%

Project Object

SettingsAlerts Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property SettingsAlerts() As Alerts

See Also

Project Object


%%PageItemTitle%%

Project Object

Shortcuts Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Shortcuts() As Shortcuts

See Also

Project Object


%%PageItemTitle%%

Project Object

SkipPropertiesInMM Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SkipPropertiesInMM() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

SkipUIInMM Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SkipUIInMM() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

SSEnabled Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SSEnabled() As Boolean

See Also

Project Object


%%PageItemTitle%%

Project Object

SSProject Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SSProject() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

StandardActions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property StandardActions() As StandardActions

See Also

Project Object


%%PageItemTitle%%

Project Object

SupportComments Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SupportComments() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

SupportContact Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SupportContact() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

SupportPhone Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SupportPhone() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

SupportURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SupportURL() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

SystemSearches Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property SystemSearches() As SystemSearches

See Also

Project Object


%%PageItemTitle%%

Project Object

Tasks Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Tasks() As Tasks

See Also

Project Object


%%PageItemTitle%%

Project Object

TextStyles Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property TextStyles() As TextStyles

See Also

Project Object


%%PageItemTitle%%

Project Object

TypeLibs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property TypeLibs() As TypeLibs

See Also

Project Object


%%PageItemTitle%%

Project Object

UpdateURL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UpdateURL() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

UpgradeActions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property UpgradeActions() As UpgradeActions

See Also

Project Object


%%PageItemTitle%%

Project Object

UpgradeCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UpgradeCode() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Project Object


%%PageItemTitle%%

Project Object

Verbs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Verbs() As Verbs

See Also

Project Object


%%PageItemTitle%%

Project Object

WIVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WIVersion() As Long

See Also

Project Object


%%PageItemTitle%%

Project Object

OnAddAlert Event

Syntax

Public Event OnAddAlert()

See Also

Project Object


%%PageItemTitle%%

Project Object

BuildConfig
PhaseCount
See Also ActiveInstall Professional Send Feedback on this topic.

OnBeginBuild Event

Syntax

Public Event OnBeginBuild( _
   ByRef BuildConfig As Object, _
   ByRef PhaseCount As Long _
)

Parameters

BuildConfig
PhaseCount

See Also

Project Object


%%PageItemTitle%%

Project Object

Success
ErrorCount
WarningCount
MSIFileName
See Also ActiveInstall Professional Send Feedback on this topic.

OnBuildComplete Event

Syntax

Public Event OnBuildComplete( _
   ByRef Success As Boolean, _
   ByRef ErrorCount As Long, _
   ByRef WarningCount As Long, _
   ByRef MSIFileName As String _
)

Parameters

Success
ErrorCount
WarningCount
MSIFileName

See Also

Project Object


%%PageItemTitle%%

Project Object

Current
Max
See Also ActiveInstall Professional Send Feedback on this topic.

OnBuildCompression Event

Syntax

Public Event OnBuildCompression( _
   ByRef Current As Long, _
   ByRef Max As Long _
)

Parameters

Current
Max

See Also

Project Object


%%PageItemTitle%%

Project Object

WI
DB
See Also ActiveInstall Professional Send Feedback on this topic.

OnBuildFinal Event

Syntax

Public Event OnBuildFinal( _
   ByRef WI As Installer, _
   ByRef DB As Database _
)

Parameters

WI
DB

See Also

Project Object


%%PageItemTitle%%

Project Object

OutputType
Description
See Also ActiveInstall Professional Send Feedback on this topic.

OnBuildOutput Event

Syntax

Public Event OnBuildOutput( _
   ByRef OutputType As aiAlertType, _
   ByRef Description As String _
)

Parameters

OutputType
Value Description
aiatInfo
aiatWarning
aiatError
Description

See Also

Project Object


%%PageItemTitle%%

Project Object

Phase
StepCount
See Also ActiveInstall Professional Send Feedback on this topic.

OnBuildPhase Event

Syntax

Public Event OnBuildPhase( _
   ByRef Phase As String, _
   ByRef StepCount As Long _
)

Parameters

Phase
StepCount

See Also

Project Object


%%PageItemTitle%%

Project Object

ActionData
See Also ActiveInstall Professional Send Feedback on this topic.

OnBuildPhaseProgress Event

Syntax

Public Event OnBuildPhaseProgress( _
   ByRef ActionData As String _
)

Parameters

ActionData

See Also

Project Object


%%PageItemTitle%%

Project Object

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange()

See Also

Project Object


%%PageItemTitle%%

Project Object

OnRemoveAlert Event

Syntax

Public Event OnRemoveAlert()

See Also

Project Object


%%PageItemTitle%%

Project Object

OnSave Event

Syntax

Public Event OnSave()

See Also

Project Object


%%PageItemTitle%%

Properties Members

Properties Collection

For a list of all members defined in this module, see Properties members.

Object Model

See Also

Properties Members


%%PageItemTitle%% $$Members$$

Properties Members

Properties Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Properties Overview


%%PageItemTitle%%

Properties Collection

Property
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Property As String _
) As Property

Parameters

Property

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Property

Parameters

key

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Property _
)

Parameters

Item

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Property _
)

Parameters

Item

See Also

Properties Collection


%%PageItemTitle%%

Properties Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Property _
)

Parameters

Item

See Also

Properties Collection


%%PageItemTitle%%

Property Members

Property Object

For a list of all members defined in this module, see Property members.

Object Model

See Also

Property Members


%%PageItemTitle%% $$Members$$

Property Members

Property Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Admin |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Hidden |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property Property |
Public Property Secure |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Value |
Public Property XML | Returns the XML for this record.

See Also

Property Overview


%%PageItemTitle%%

Property Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Property Object


%%PageItemTitle%%

Property Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

Admin Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Admin() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Property Object


%%PageItemTitle%%

Property Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

Hidden Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Hidden() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Properties

See Also

Property Object


%%PageItemTitle%%

Property Object

Property Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Secure Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Secure() As Boolean

See Also

Property Object


%%PageItemTitle%%

Property Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

Property Object


%%PageItemTitle%%

Property Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Property Object


%%PageItemTitle%%

RegistryMod Members

RegistryMod Object

For a list of all members defined in this module, see RegistryMod members.

Object Model

See Also

RegistryMod Members


%%PageItemTitle%% $$Members$$

RegistryMod Members

RegistryMod Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Action |
Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property EntryName |
Public Property Id |
Public Property Key |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Permissions |
Public Property Root |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Value |
Public Property ValueType |
Public Property XML | Returns the XML for this record.

See Also

RegistryMod Overview


%%PageItemTitle%%

RegistryMod Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Action Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Action() As aiRegistryModAction

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

EntryName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property EntryName() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Key Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Key() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As RegistryMods

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Permissions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Permissions() As Permissions

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Root Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Root() As aiRegistryModRoot

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

ValueType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ValueType() As aiRegistryModValueType

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMod Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

RegistryMod Object


%%PageItemTitle%%

RegistryMods Members

RegistryMods Collection

For a list of all members defined in this module, see RegistryMods members.

Object Model

See Also

RegistryMods Members


%%PageItemTitle%% $$Members$$

RegistryMods Members

RegistryMods Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

RegistryMods Overview


%%PageItemTitle%%

RegistryMods Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As RegistryMod

Parameters

Name

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As RegistryMod

Parameters

key

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As RegistryMod _
)

Parameters

Item

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As RegistryMod _
)

Parameters

Item

See Also

RegistryMods Collection


%%PageItemTitle%%

RegistryMods Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As RegistryMod _
)

Parameters

Item

See Also

RegistryMods Collection


%%PageItemTitle%%

RemoveFile Members

RemoveFile Object

For a list of all members defined in this module, see RemoveFile members.

Object Model

See Also

RemoveFile Members


%%PageItemTitle%% $$Members$$

RemoveFile Members

RemoveFile Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property DirProperty |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property FileName |
Public Property Id |
Public Property InstallMode |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

RemoveFile Overview


%%PageItemTitle%%

RemoveFile Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

DirProperty Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DirProperty() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

FileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

InstallMode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InstallMode() As aiRemoveFileMode

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As RemoveFiles

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFile Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

RemoveFile Object


%%PageItemTitle%%

RemoveFiles Members

RemoveFiles Collection

For a list of all members defined in this module, see RemoveFiles members.

Object Model

See Also

RemoveFiles Members


%%PageItemTitle%% $$Members$$

RemoveFiles Members

RemoveFiles Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

RemoveFiles Overview


%%PageItemTitle%%

RemoveFiles Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As RemoveFile

Parameters

Name

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As RemoveFile

Parameters

key

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As RemoveFile _
)

Parameters

Item

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As RemoveFile _
)

Parameters

Item

See Also

RemoveFiles Collection


%%PageItemTitle%%

RemoveFiles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As RemoveFile _
)

Parameters

Item

See Also

RemoveFiles Collection


%%PageItemTitle%%

ReservedSpace Members

ReservedSpace Object

For a list of all members defined in this module, see ReservedSpace members.

Object Model

See Also

ReservedSpace Members


%%PageItemTitle%% $$Members$$

ReservedSpace Members

ReservedSpace Object Members

Public Properties

Public Property Folder |
Public Property ID |
Public Property LocalSpace |
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property SourceSpace |
Public Property XML | Returns the XML for this record.

See Also

ReservedSpace Overview


%%PageItemTitle%%

ReservedSpace Object

Folder Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Folder() As String

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpace Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpace Object

LocalSpace Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LocalSpace() As Long

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpace Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpace Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ReservedSpaces

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpace Object

SourceSpace Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourceSpace() As Long

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpace Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ReservedSpace Object


%%PageItemTitle%%

ReservedSpaces Members

ReservedSpaces Collection

For a list of all members defined in this module, see ReservedSpaces members.

Object Model

See Also

ReservedSpaces Members


%%PageItemTitle%% $$Members$$

ReservedSpaces Members

ReservedSpaces Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ReservedSpaces Overview


%%PageItemTitle%%

ReservedSpaces Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ReservedSpace

Parameters

Name

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ReservedSpace

Parameters

key

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ReservedSpace _
)

Parameters

Item

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ReservedSpace _
)

Parameters

Item

See Also

ReservedSpaces Collection


%%PageItemTitle%%

ReservedSpaces Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ReservedSpace _
)

Parameters

Item

See Also

ReservedSpaces Collection


%%PageItemTitle%%

Resource Members

Resource Object

For a list of all members defined in this module, see Resource members.

Object Model

See Also

Resource Members


%%PageItemTitle%% $$Members$$

Resource Members

Resource Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property ResType |
Public Property SourcePath |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Resource Overview


%%PageItemTitle%%

Resource Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Resources

See Also

Resource Object


%%PageItemTitle%%

Resource Object

ResType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ResType() As aiResourceType

See Also

Resource Object


%%PageItemTitle%%

Resource Object

SourcePath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SourcePath() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Resource Object


%%PageItemTitle%%

Resource Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Resource Object


%%PageItemTitle%%

Resources Members

Resources Collection

For a list of all members defined in this module, see Resources members.

Object Model

See Also

Resources Members


%%PageItemTitle%% $$Members$$

Resources Members

Resources Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Resources Overview


%%PageItemTitle%%

Resources Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Resource

Parameters

Name

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Resource

Parameters

key

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Resource _
)

Parameters

Item

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Resource _
)

Parameters

Item

See Also

Resources Collection


%%PageItemTitle%%

Resources Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Resource _
)

Parameters

Item

See Also

Resources Collection


%%PageItemTitle%%

Sequence Members

Sequence Object

For a list of all members defined in this module, see Sequence members.

Object Model

See Also

Sequence Members


%%PageItemTitle%% $$Members$$

Sequence Members

Sequence Object Members

Public Properties

Public Property Actions
Public Property SeqType

See Also

Sequence Overview


%%PageItemTitle%%

Sequence Object

Actions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Actions() As Actions

See Also

Sequence Object


%%PageItemTitle%%

Sequence Object

SeqType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property SeqType() As aiSequence

See Also

Sequence Object


%%PageItemTitle%%

Service Members

Service Object

For a list of all members defined in this module, see Service members.

Object Model

See Also

Service Members


%%PageItemTitle%% $$Members$$

Service Members

Service Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Arguments |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Dependencies |
Public Property Description |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DisplayName |
Public Property ErrorControl |
Public Property Id |
Public Property Interactive |
Public Property LoadOrderGroup |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Password |
Public Property ServiceName |
Public Property ServiceType |
Public Property StartName |
Public Property StartType |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Service Overview


%%PageItemTitle%%

Service Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Service Object


%%PageItemTitle%%

Service Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Service Object


%%PageItemTitle%%

Service Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Service Object


%%PageItemTitle%%

Service Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Service Object


%%PageItemTitle%%

Service Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Service Object


%%PageItemTitle%%

Service Object

Arguments Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Arguments() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

Service Object


%%PageItemTitle%%

Service Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Dependencies Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Dependencies() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Service Object


%%PageItemTitle%%

Service Object

DisplayName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayName() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

ErrorControl Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ErrorControl() As aiServiceErrorControl

See Also

Service Object


%%PageItemTitle%%

Service Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Interactive Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Interactive() As Boolean

See Also

Service Object


%%PageItemTitle%%

Service Object

LoadOrderGroup Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LoadOrderGroup() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Services

See Also

Service Object


%%PageItemTitle%%

Service Object

Password Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Password() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

ServiceName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServiceName() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

ServiceType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServiceType() As aiServiceType

See Also

Service Object


%%PageItemTitle%%

Service Object

StartName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartName() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

StartType Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartType() As aiServiceStartType

See Also

Service Object


%%PageItemTitle%%

Service Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Service Object


%%PageItemTitle%%

Service Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Service Object


%%PageItemTitle%%

ServiceAction Members

ServiceAction Object

For a list of all members defined in this module, see ServiceAction members.

Object Model

See Also

ServiceAction Members


%%PageItemTitle%% $$Members$$

ServiceAction Members

ServiceAction Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Arguments |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Id |
Public Property InstallDelete |
Public Property InstallStart |
Public Property InstallStop |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property ServiceName |
Public Property UninstallDelete |
Public Property UninstallStart |
Public Property UninstallStop |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Wait |
Public Property XML | Returns the XML for this record.

See Also

ServiceAction Overview


%%PageItemTitle%%

ServiceAction Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Arguments Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Arguments() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

InstallDelete Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InstallDelete() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

InstallStart Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InstallStart() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

InstallStop Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InstallStop() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As ServiceActions

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

ServiceName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ServiceName() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

UninstallDelete Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UninstallDelete() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

UninstallStart Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UninstallStart() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

UninstallStop Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UninstallStop() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

Wait Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Wait() As Boolean

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceAction Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ServiceAction Object


%%PageItemTitle%%

ServiceActions Members

ServiceActions Collection

For a list of all members defined in this module, see ServiceActions members.

Object Model

See Also

ServiceActions Members


%%PageItemTitle%% $$Members$$

ServiceActions Members

ServiceActions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

ServiceActions Overview


%%PageItemTitle%%

ServiceActions Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As ServiceAction

Parameters

Name

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As ServiceAction

Parameters

key

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As ServiceAction _
)

Parameters

Item

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As ServiceAction _
)

Parameters

Item

See Also

ServiceActions Collection


%%PageItemTitle%%

ServiceActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As ServiceAction _
)

Parameters

Item

See Also

ServiceActions Collection


%%PageItemTitle%%

Services Members

Services Collection

For a list of all members defined in this module, see Services members.

Object Model

See Also

Services Members


%%PageItemTitle%% $$Members$$

Services Members

Services Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Services Overview


%%PageItemTitle%%

Services Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Service

Parameters

Name

See Also

Services Collection


%%PageItemTitle%%

Services Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Services Collection


%%PageItemTitle%%

Services Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Services Collection


%%PageItemTitle%%

Services Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Service

Parameters

key

See Also

Services Collection


%%PageItemTitle%%

Services Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Services Collection


%%PageItemTitle%%

Services Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Services Collection


%%PageItemTitle%%

Services Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Services Collection


%%PageItemTitle%%

Services Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Services Collection


%%PageItemTitle%%

Services Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Service _
)

Parameters

Item

See Also

Services Collection


%%PageItemTitle%%

Services Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Service _
)

Parameters

Item

See Also

Services Collection


%%PageItemTitle%%

Services Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Service _
)

Parameters

Item

See Also

Services Collection


%%PageItemTitle%%

Shortcut Members

Shortcut Object

For a list of all members defined in this module, see Shortcut members.

Object Model

See Also

Shortcut Members


%%PageItemTitle%% $$Members$$

Shortcut Members

Shortcut Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Arguments |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Created | Returns the date/time when the record was created.
Public Property Description |
Public Property Directory |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DisplayName |
Public Property Hotkey |
Public Property IconFile |
Public Property IconIndex |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property showCmd |
Public Property Target |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property WkDir |
Public Property XML | Returns the XML for this record.

See Also

Shortcut Overview


%%PageItemTitle%%

Shortcut Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Arguments Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Arguments() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Directory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Directory() As Directory

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

DisplayName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DisplayName() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Hotkey Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Hotkey() As Long

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

IconFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconFile() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

IconIndex Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property IconIndex() As Integer

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Shortcuts

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

showCmd Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property showCmd() As Integer

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

Target Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Target() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

WkDir Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property WkDir() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcut Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Shortcut Object


%%PageItemTitle%%

Shortcuts Members

Shortcuts Collection

For a list of all members defined in this module, see Shortcuts members.

Object Model

See Also

Shortcuts Members


%%PageItemTitle%% $$Members$$

Shortcuts Members

Shortcuts Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Shortcuts Overview


%%PageItemTitle%%

Shortcuts Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Shortcut

Parameters

Name

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Shortcut

Parameters

key

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Shortcut _
)

Parameters

Item

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Shortcut _
)

Parameters

Item

See Also

Shortcuts Collection


%%PageItemTitle%%

Shortcuts Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Shortcut _
)

Parameters

Item

See Also

Shortcuts Collection


%%PageItemTitle%%

StandardAction Members

StandardAction Object

For a list of all members defined in this module, see StandardAction members.

Object Model

See Also

StandardAction Members


%%PageItemTitle%% $$Members$$

StandardAction Members

StandardAction Object Members

Public Properties

Public Property Action |
Public Property DependencyOf |
Public Property DependsOn |
Public Property MustComeAfter |
Public Property MustComeBefore |
Public Property Order |
Public Property Parent | Returns the parent of this object.
Public Property Prohibited |
Public Property Required |
Public Property Section |

See Also

StandardAction Overview


%%PageItemTitle%%

StandardAction Object

Action Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Action() As String

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

DependencyOf Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property DependencyOf() As String

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

DependsOn Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property DependsOn() As String

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

MustComeAfter Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MustComeAfter() As String

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

MustComeBefore Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MustComeBefore() As String

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

Order Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Order() As Long

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As StandardActions

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

Prohibited Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Prohibited() As aiSequence

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

Required Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Required() As aiSequence

See Also

StandardAction Object


%%PageItemTitle%%

StandardAction Object

Section Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Section() As aiStandardActionSection

See Also

StandardAction Object


%%PageItemTitle%%

StandardActions Members

StandardActions Collection

For a list of all members defined in this module, see StandardActions members.

Object Model

See Also

StandardActions Members


%%PageItemTitle%% $$Members$$

StandardActions Members

StandardActions Collection Members

Public Methods

Public Method Exists
Public Method Item

Public Properties

Public Property Count Returns the number of items in the collection.
Returns a count of the number of collection members

See Also

StandardActions Overview


%%PageItemTitle%%

StandardActions Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef Key As Variant _
) As Boolean

Parameters

Key

See Also

StandardActions Collection


%%PageItemTitle%%

StandardActions Collection

Key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef Key As Variant _
) As StandardAction

Parameters

Key

See Also

StandardActions Collection


%%PageItemTitle%%

StandardActions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

StandardActions Collection


%%PageItemTitle%%

SystemSearch Members

SystemSearch Object

For a list of all members defined in this module, see SystemSearch members.

Object Model

See Also

SystemSearch Members


%%PageItemTitle%% $$Members$$

SystemSearch Members

SystemSearch Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property ComplianceCheck |
Public Property ComponentFileKeyPath |
Public Property ComponentID |
Public Property Created | Returns the date/time when the record was created.
Public Property DirectorySearches |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property FileFileName |
Public Property FileLanguages |
Public Property FileMaxDate |
Public Property FileMaxSize |
Public Property FileMaxVersion |
Public Property FileMinDate |
Public Property FileMinSize |
Public Property FileMinVersion |
Public Property Id |
Public Property INIField |
Public Property INIFileName |
Public Property INIKey |
Public Property INIRawValue |
Public Property INISection |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Property |
Public Property RegKey |
Public Property RegName |
Public Property RegRawValue |
Public Property RegRoot |
Public Property RegSearch64Bit |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

SystemSearch Overview


%%PageItemTitle%%

SystemSearch Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

ComplianceCheck Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ComplianceCheck() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

ComponentFileKeyPath Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ComponentFileKeyPath() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

ComponentID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ComponentID() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

DirectorySearches Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property DirectorySearches() As DirectorySearches

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileFileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileFileName() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileLanguages Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileLanguages() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileMaxDate Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileMaxDate() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileMaxSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileMaxSize() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileMaxVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileMaxVersion() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileMinDate Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileMinDate() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileMinSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileMinSize() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

FileMinVersion Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileMinVersion() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

INIField Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property INIField() As Integer

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

INIFileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property INIFileName() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

INIKey Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property INIKey() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

INIRawValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property INIRawValue() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

INISection Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property INISection() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As SystemSearches

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

Property Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Property() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

RegKey Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RegKey() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

RegName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RegName() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

RegRawValue Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RegRawValue() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

RegRoot Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RegRoot() As aiRegistryModRoot

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

RegSearch64Bit Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RegSearch64Bit() As Boolean

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearch Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

SystemSearch Object


%%PageItemTitle%%

SystemSearches Members

SystemSearches Collection

For a list of all members defined in this module, see SystemSearches members.

Object Model

See Also

SystemSearches Members


%%PageItemTitle%% $$Members$$

SystemSearches Members

SystemSearches Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

SystemSearches Overview


%%PageItemTitle%%

SystemSearches Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As SystemSearch

Parameters

Name

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As SystemSearch

Parameters

key

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As SystemSearch _
)

Parameters

Item

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As SystemSearch _
)

Parameters

Item

See Also

SystemSearches Collection


%%PageItemTitle%%

SystemSearches Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As SystemSearch _
)

Parameters

Item

See Also

SystemSearches Collection


%%PageItemTitle%%

Task Members

Task Object

For a list of all members defined in this module, see Task members.

Object Model

See Also

Task Members


%%PageItemTitle%% $$Members$$

Task Members

Task Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property AssignedTo |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property DueDate |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Priority |
Public Property RTFDescription |
Public Property StartDate |
Public Property Status |
Public Property Subject |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

Task Overview


%%PageItemTitle%%

Task Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Task Object


%%PageItemTitle%%

Task Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Task Object


%%PageItemTitle%%

Task Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Task Object


%%PageItemTitle%%

Task Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Task Object


%%PageItemTitle%%

Task Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Task Object


%%PageItemTitle%%

Task Object

AssignedTo Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AssignedTo() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Task Object


%%PageItemTitle%%

Task Object

DueDate Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DueDate() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Tasks

See Also

Task Object


%%PageItemTitle%%

Task Object

Priority Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Priority() As Integer

See Also

Task Object


%%PageItemTitle%%

Task Object

RTFDescription Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RTFDescription() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

StartDate Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property StartDate() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

Status Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Status() As Integer

See Also

Task Object


%%PageItemTitle%%

Task Object

Subject Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Subject() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Task Object


%%PageItemTitle%%

Task Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Task Object


%%PageItemTitle%%

Tasks Members

Tasks Collection

For a list of all members defined in this module, see Tasks members.

Object Model

See Also

Tasks Members


%%PageItemTitle%% $$Members$$

Tasks Members

Tasks Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Tasks Overview


%%PageItemTitle%%

Tasks Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As Task

Parameters

Name

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Task

Parameters

key

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Task _
)

Parameters

Item

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Task _
)

Parameters

Item

See Also

Tasks Collection


%%PageItemTitle%%

Tasks Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Task _
)

Parameters

Item

See Also

Tasks Collection


%%PageItemTitle%%

TextStyle Members

TextStyle Object

For a list of all members defined in this module, see TextStyle members.

Object Model

See Also

TextStyle Members


%%PageItemTitle%% $$Members$$

TextStyle Members

TextStyle Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Bold |
Public Property Color |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property FontName |
Public Property ID |
Public Property Italic |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property Size |
Public Property Strikethrough |
Public Property Underline |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property XML | Returns the XML for this record.

See Also

TextStyle Overview


%%PageItemTitle%%

TextStyle Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Bold Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Bold() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Color Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Color() As Long

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

FontName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontName() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Italic Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Italic() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As TextStyles

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Size Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Size() As Integer

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Strikethrough Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Strikethrough() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

Underline Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Underline() As Boolean

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyle Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

TextStyle Object


%%PageItemTitle%%

TextStyles Members

TextStyles Collection

For a list of all members defined in this module, see TextStyles members.

Object Model

See Also

TextStyles Members


%%PageItemTitle%% $$Members$$

TextStyles Members

TextStyles Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

TextStyles Overview


%%PageItemTitle%%

TextStyles Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As TextStyle

Parameters

Name

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As TextStyle

Parameters

key

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As TextStyle _
)

Parameters

Item

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As TextStyle _
)

Parameters

Item

See Also

TextStyles Collection


%%PageItemTitle%%

TextStyles Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As TextStyle _
)

Parameters

Item

See Also

TextStyles Collection


%%PageItemTitle%%

TypeLib Members

TypeLib Object

For a list of all members defined in this module, see TypeLib members.

Object Model

See Also

TypeLib Members


%%PageItemTitle%% $$Members$$

TypeLib Members

TypeLib Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Component | Gets/Sets a reference to a component which controls the behavior of this element.
Public Property Cost |
Public Property Created | Returns the date/time when the record was created.
Public Property Description |
Public Property Directory |
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Feature |
Public Property Id |
Public Property Language |
Public Property LibID |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Version |
Public Property XML | Returns the XML for this record.

See Also

TypeLib Overview


%%PageItemTitle%%

TypeLib Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Component Property

Description

Gets/Sets a reference to a component which controls the behavior of this element.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Component() As Component

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Cost Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Cost() As Long

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Directory Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Directory() As Directory

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Feature Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Feature() As Feature

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Language Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Language() As Integer

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

LibID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LibID() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As TypeLibs

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

Version Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Version() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLib Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

TypeLib Object


%%PageItemTitle%%

TypeLibs Members

TypeLibs Collection

For a list of all members defined in this module, see TypeLibs members.

Object Model

See Also

TypeLibs Members


%%PageItemTitle%% $$Members$$

TypeLibs Members

TypeLibs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

TypeLibs Overview


%%PageItemTitle%%

TypeLibs Collection

LibID
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef LibID As String _
) As TypeLib

Parameters

LibID

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As TypeLib

Parameters

key

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As TypeLib _
)

Parameters

Item

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As TypeLib _
)

Parameters

Item

See Also

TypeLibs Collection


%%PageItemTitle%%

TypeLibs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As TypeLib _
)

Parameters

Item

See Also

TypeLibs Collection


%%PageItemTitle%%

UpgradeAction Members

UpgradeAction Object

For a list of all members defined in this module, see UpgradeAction members.

Object Model

See Also

UpgradeAction Members


%%PageItemTitle%% $$Members$$

UpgradeAction Members

UpgradeAction Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Author | Gets the name of the last author to modify this record.
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Flags |
Public Property Id |
Public Property LanguageList |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Name |
Public Property Parent | Returns the parent of this object.
Public Property RemoveFeatureList |
Public Property ResultsProperty |
Public Property UpgradeCode |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property VersionMax |
Public Property VersionMin |
Public Property XML | Returns the XML for this record.

See Also

UpgradeAction Overview


%%PageItemTitle%%

UpgradeAction Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Flags Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Flags() As Long

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

LanguageList Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LanguageList() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Name Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Name() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As UpgradeActions

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

RemoveFeatureList Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RemoveFeatureList() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

ResultsProperty Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ResultsProperty() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

UpgradeCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UpgradeCode() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

VersionMax Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property VersionMax() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

VersionMin Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property VersionMin() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeAction Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

UpgradeAction Object


%%PageItemTitle%%

UpgradeActions Members

UpgradeActions Collection

For a list of all members defined in this module, see UpgradeActions members.

Object Model

See Also

UpgradeActions Members


%%PageItemTitle%% $$Members$$

UpgradeActions Members

UpgradeActions Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

UpgradeActions Overview


%%PageItemTitle%%

UpgradeActions Collection

Name
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Name As String _
) As UpgradeAction

Parameters

Name

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As UpgradeAction

Parameters

key

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As UpgradeAction _
)

Parameters

Item

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As UpgradeAction _
)

Parameters

Item

See Also

UpgradeActions Collection


%%PageItemTitle%%

UpgradeActions Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As UpgradeAction _
)

Parameters

Item

See Also

UpgradeActions Collection


%%PageItemTitle%%

Verb Members

Verb Object

For a list of all members defined in this module, see Verb members.

Object Model

See Also

Verb Members


%%PageItemTitle%% $$Members$$

Verb Members

Verb Object Members

Public Methods

Public Method Revert | Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.
Public Method Save | Commits any changes in the data and cause re-valiation to occur.
Public Method Show | Displays an edit dialog for this element.
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Alerts | Returns a collection of Alert objects for this element.
Public Property Argument |
Public Property Author | Gets the name of the last author to modify this record.
Public Property Command |
Public Property Comments | Gets/Sets user-defined comments for this record. Not included in build output.
Public Property Created | Returns the date/time when the record was created.
Public Property Dirty | Returns a boolean value indicating if this element has been changed.
Public Property Extension |
Public Property Id |
Public Property Modified | Returns the date/time of the last modification to this record.
Public Property Parent | Returns the parent of this object.
Public Property Sequence |
Public Property UserData | Gets/Sets a string of user-defined data for this record.
Public Property Verb |
Public Property XML | Returns the XML for this record.

See Also

Verb Overview


%%PageItemTitle%%

Verb Object

Revert Method

Description

Cancels any changes made to the data, reverting back to the previously loaded values and causes re-validation to occur.

Syntax

Public Function Revert() As Boolean

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Save Method

Description

Commits any changes in the data and cause re-valiation to occur.

Syntax

Public Function Save() As Boolean

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Show Method

Description

Displays an edit dialog for this element.

Syntax

Public Sub Show()

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Alerts Property

Description

Returns a collection of Alert objects for this element.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Alerts() As Alerts

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Argument Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Argument() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Author Property

Description

Gets the name of the last author to modify this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Author() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Command Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Command() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Comments Property

Description

Gets/Sets user-defined comments for this record. Not included in build output.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Created Property

Description

Returns the date/time when the record was created.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Created() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Dirty Property

Description

Returns a boolean value indicating if this element has been changed.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Dirty() As Boolean

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Extension Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Extension() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Id Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Id() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Modified Property

Description

Returns the date/time of the last modification to this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property Modified() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As Verbs

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Sequence Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Sequence() As Long

See Also

Verb Object


%%PageItemTitle%%

Verb Object

UserData Property

Description

Gets/Sets a string of user-defined data for this record.

Property type

Read-write property

Syntax (Visual Basic)

Public Property UserData() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

Verb Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Verb() As String

See Also

Verb Object


%%PageItemTitle%%

Verb Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Verb Object


%%PageItemTitle%%

Verbs Members

Verbs Collection

For a list of all members defined in this module, see Verbs members.

Object Model

See Also

Verbs Members


%%PageItemTitle%% $$Members$$

Verbs Members

Verbs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection
Public Method Validate | Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

Verbs Overview


%%PageItemTitle%%

Verbs Collection

Extension
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef Extension As String _
) As Verb

Parameters

Extension

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As Verb

Parameters

key

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

Validate Method

Description

Cause validation to performed for this element. Any previous alerts are cleared before validation is performed.

Syntax

Public Function Validate() As Boolean

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As Verb _
)

Parameters

Item

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As Verb _
)

Parameters

Item

See Also

Verbs Collection


%%PageItemTitle%%

Verbs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As Verb _
)

Parameters

Item

See Also

Verbs Collection


%%PageItemTitle%%

VIProgID Members

VIProgID Object

For a list of all members defined in this module, see VIProgID members.

Object Model

See Also

VIProgID Members


%%PageItemTitle%% $$Members$$

VIProgID Members

VIProgID Object Members

Public Properties

Public Property Description |
Public Property ID |
Public Property Parent | Returns the parent of this object.
Public Property ProgId |
Public Property XML | Returns the XML for this record.

See Also

VIProgID Overview


%%PageItemTitle%%

VIProgID Object

Description Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Description() As String

See Also

VIProgID Object


%%PageItemTitle%%

VIProgID Object

ID Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ID() As String

See Also

VIProgID Object


%%PageItemTitle%%

VIProgID Object

Parent Property

Description

Returns the parent of this object.

Property type

Read-only property

Syntax (Visual Basic)

Public Property Parent() As VIProgIDs

See Also

VIProgID Object


%%PageItemTitle%%

VIProgID Object

ProgId Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProgId() As String

See Also

VIProgID Object


%%PageItemTitle%%

VIProgID Object

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

VIProgID Object


%%PageItemTitle%%

VIProgIDs Members

VIProgIDs Collection

For a list of all members defined in this module, see VIProgIDs members.

Object Model

See Also

VIProgIDs Members


%%PageItemTitle%% $$Members$$

VIProgIDs Members

VIProgIDs Collection Members

Public Methods

Public Method Add | Adds a new item to this collection. Add an item to the collection
Public Method Clear | Clears the collection, removing/deleting any items it may contain.
Public Method Exists |
Public Method Item |
Public Method Remove | Removes an item from this collection. Remove an item from the collection

Public Properties

Public Property Count | Returns the number of items in the collection. Returns a count of the number of collection members
Public Property XML | Returns the XML for this record.

Events

Public Event OnAdd | Occurs when a new item is added to this collection.
Public Event OnChange | Occurs when an item belonging to this collection is changed.
Public Event OnRemove | Occurs when an item belonging to this collection is removed.

See Also

VIProgIDs Overview


%%PageItemTitle%%

VIProgIDs Collection

ProgId
See Also ActiveInstall Professional Send Feedback on this topic.

Add Method

Description

Adds a new item to this collection.
Add an item to the collection

Syntax

Public Function Add( _
   Optional ByRef ProgId As String _
) As VIProgID

Parameters

ProgId

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

Clear Method

Description

Clears the collection, removing/deleting any items it may contain.

Syntax

Public Sub Clear()

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Exists Method

Syntax

Public Function Exists( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Item Method

Syntax

Public Function Item( _
   ByRef key As Variant _
) As VIProgID

Parameters

key

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

key
See Also ActiveInstall Professional Send Feedback on this topic.

Remove Method

Description

Removes an item from this collection.
Remove an item from the collection

Syntax

Public Function Remove( _
   ByRef key As Variant _
) As Boolean

Parameters

key

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

Count Property

Description

Returns the number of items in the collection.
Returns a count of the number of collection members

Property type

Read-only property

Syntax (Visual Basic)

Public Property Count() As Long

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

XML Property

Description

Returns the XML for this record.

Property type

Read-only property

Syntax (Visual Basic)

Public Property XML() As String

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnAdd Event

Description

Occurs when a new item is added to this collection.

Syntax

Public Event OnAdd( _
   ByRef Item As VIProgID _
)

Parameters

Item

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnChange Event

Description

Occurs when an item belonging to this collection is changed.

Syntax

Public Event OnChange( _
   ByRef Item As VIProgID _
)

Parameters

Item

See Also

VIProgIDs Collection


%%PageItemTitle%%

VIProgIDs Collection

Item
See Also ActiveInstall Professional Send Feedback on this topic.

OnRemove Event

Description

Occurs when an item belonging to this collection is removed.

Syntax

Public Event OnRemove( _
   ByRef Item As VIProgID _
)

Parameters

Item

See Also

VIProgIDs Collection


%%PageItemTitle%%

Global Object

aiAlertType Enumeration

Members

Member | Description
aiatInfo |
aiatWarning |
aiatError |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiArchiveMode Enumeration

Members

Member | Description
aiamNever |
aiamAlways |
aiamOnZeroErrors |
aiamPrompt |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiAssemblyType Enumeration

Members

Member | Description
aiatDOTNET |
aiatWin32 |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiClassContext Enumeration

Members

Member | Description
aiccLocalServer |
aiccLocalServer32 |
aiccInProcServer |
aiccInProcServer32 |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiComponentKeyPathType Enumeration

Members

Member | Description
aickfile |
aickRegistry |
aickODBC |
aickDirectory |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiComponentRunFrom Enumeration

Members

Member | Description
aicrLocal |
aicrSource |
aicrOptional |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCompression Enumeration

Members

Member | Description
aicompUncompressed |
aicompOneCAB |
aicompOneCABPerComponent |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiControlAction Enumeration

Members

Member | Description
aicaDefault |
aicaDisable |
aicaEnable |
aicaHide |
aicaShow |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiControlEvent Enumeration

Members

Member | Description
aiceActionData |
aiceActionString |
aiceAddLocal |
aiceAddSource |
aiceCheckExistingTargetPath |
aiceCheckTargetPath |
aiceDirectoryListNew |
aiceDirectoryListOpen |
aiceDirectoryListUp |
aiceDoAction |
aiceEnableRollback |
aiceEndDialog |
aiceIgnoreChange |
aiceNewDialog |
aiceReinstall |
aiceReinstallMode |
aiceRemove |
aiceReset |
aiceScriptInProgress |
aiceSelectionAction |
aiceSelectionBrowse |
aiceSelectionDescription |
aiceSelectionIcon |
aiceSelectionNoItems |
aiceSelectionPath |
aiceSelectionPathOn |
aiceSelectionSize |
aiceSetInstallLevel |
aiceSetProgress |
aiceSetProperty |
aiceSetTargetPath |
aiceSpawnDialog |
aiceSpawnWaitDialog |
aiceTimeRemaining |
aiceValidateProductID |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionDLLSourceLocation Enumeration

Members

Member | Description
aicaslDLLBinaryTable |
aicaslDLLSourceFile |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionEXESourceLocation Enumeration

Members

Member | Description
aicaslEXEBinaryTable |
aicaslEXESourceFile |
aicaslEXEProperty |
aicaslEXEDirectory |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionNISourceLocation Enumeration

Members

Member | Description
aicaslniSubStorage |
aicaslniRelativePath |
aicanislProductCode |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionPropDirAction Enumeration

Members

Member | Description
aicpdaSetProperty |
aicpdaSetDirectory |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionPropDirExecution Enumeration

Members

Member | Description
aicapdeAlways |
aicapdeOncePerInstall |
aicapdeOncePerProcess |
aicapdeClientExecuteOnly |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionReturnProcessing Enumeration

Members

Member | Description
aicsSynchronousWait |
aicsSynchronousContinue |
aicsAsynchronousWait |
aicsAsynchronousContinue |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionScheduling Enumeration

Members

Member | Description
aicscAlways |
aicscOncePerInstall |
aicscOncePerProcess |
aicscClientExecuteOnly |
aicscInScript |
aicscInScriptCommit |
aicscInScriptRollback |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionScriptSourceLocation Enumeration

Members

Member | Description
aicaslSCRIPTBinaryTable |
aicaslSCRIPTSourceFile |
aicaslSCRIPTProperty |
aicaslScriptInline |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionScriptType Enumeration

Members

Member | Description
aicastVBScript |
aicastJScript |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionSourceLocation Enumeration

Members

Member | Description
aicaslBinaryTable |
aicaslSourceFile |
aicaslProperty |
aicaslDirectory |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiCustomActionType Enumeration

Members

Member | Description
aiCADLL |
aiCAEXE |
aicaScript |
aicaSetPropOrDir |
aicaErrorFail |
aicaNestedInstall |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiDataSourceScope Enumeration

Members

Member | Description
aidsSystem |
aidsUser |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiDialogStyle Enumeration

Members

Member | Description
aidsModeless |
aidsModal |
aidsSysModal |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiEnvVarAppendStyle Enumeration

Members

Member | Description
aievAppendBefore |
aievAppendAfter |
aievAppendReplace |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiEnvVarInstallAction Enumeration

Members

Member | Description
aievInstallActionInstall |
aievInstallActionInstallIfAbsent |
aievInstallActionRemove |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiEnvVarScope Enumeration

Members

Member | Description
aievScopeSystem |
aievScopeUser |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiFeatureAdvertise Enumeration

Members

Member | Description
aifaInstalled |
aifaAdvertised |
aifaAdvertisedIfSupported |
aifaDisallow |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiFeatureRunFrom Enumeration

Members

Member | Description
aifrLocal |
aifrSource |
aifrFollowParent |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiFeatureState Enumeration

Members

Member | Description
aifsHidden |
aifsExpanded |
aifsCollapsed |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiFileCompression Enumeration

Members

Member | Description
aifcDefault |
aifcUncompressed |
aifcCompressed |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiFileRegistrationType Enumeration

Members

Member | Description
aifrtStandard |
aifrtFont |
aifrtCOM |
aifrtAssembly |
aifrtService |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiINIFileModAction Enumeration

Members

Member | Description
aiifCreate |
aiifCreateIfAbsent |
aiifRemoveLine |
aiifAppend |
aiifRemoveTag |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiLanguage Enumeration

Members

Member | Description
aiLang1025Arabic |
aiLang1027Catalan |
aiLang1028Chinese |
aiLang2052Chinese |
aiLang1029Czech |
aiLang1030Danish |
aiLang1031German |
aiLang1032Greek |
aiLang1033English |
aiLang3082Spanish |
aiLang1061Estonian |
aiLang1035Finnish |
aiLang1036French |
aiLang1037Hebrew |
aiLang1038Hungarian |
aiLang1040Italian |
aiLang1041Japanese |
aiLang1042Korean |
aiLang1063Lithuanian |
aiLang1062Latvian |
aiLang1043Dutch |
aiLang1044Norwegian |
aiLang1045Polish |
aiLang1046Portuguese |
aiLang2070Portuguese |
aiLang1048Romanian |
aiLang1049Russian |
aiLang1050Croatian |
aiLang1051Slovak |
aiLang1053Swedish |
aiLang1054Thai |
aiLang1055Turkish |
aiLang1060Slovenian |
aiLang1066Vietnamese |
aiLang1069Basque |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiLeftRight Enumeration

Members

Member | Description
ailrLeft |
ailrRight |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiMMRelationshipType Enumeration

Members

Member | Description
aimmrDependency |
aimmrExclusion |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiMoveFileAction Enumeration

Members

Member | Description
aimfCopyFile |
aimfMoveFile |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiPlatform Enumeration

Members

Member | Description
aipfIndependent |
aipfIntel |
aipfIntel64 |
aipfAlpha |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiProjectType Enumeration

Members

Member | Description
aiInstaller |
aiMergeModule |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiPushButtonIconSize Enumeration

Members

Member | Description
aipbisDefault |
aipbis16x16 |
aipbis32x32 |
aipbis48x48 |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiPushButtonStyle Enumeration

Members

Member | Description
aipbsNormal |
aipbsIcon |
aipbsBitmap |
aipbsHandle |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiRegistryModAction Enumeration

Members

Member | Description
airaCreateUpdate |
airaRemoveItem |
airaRemoveKey |
airaCreateKeyInstall |
airaCreateKeyUninstall |
airaCreateKeyBoth |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiRegistryModRoot Enumeration

Members

Member | Description
airrHK_RUNTIME |
airrHKEY_CLASSES_ROOT |
airrHKEY_CURRENT_USER |
airrHKEY_LOCAL_MACHINE |
airrHKEY_USERS |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiRegistryModValueType Enumeration

Members

Member | Description
airvtREG_SZ |
airvtREG_BINARY |
airvtREG_EXPAND_SZ |
airvtREG_DWORD |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiReleaseType Enumeration

Members

Member | Description
airtInstaller |
airtPatch |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiRemoveFileMode Enumeration

Members

Member | Description
airfInstall |
airfUninstall |
airfBoth |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiResourceType Enumeration

Members

Member | Description
airtBinary |
airtStream |
airtStorage |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiscShowCmd Enumeration

Members

Member | Description
aiwsNormal |
aiwsMinimized |
aiwsMaximized |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiSequence Enumeration

Members

Member | Description
aiseqAdminUI |
aiseqAdminEx |
aiseqAdvtUI |
aiseqAdvtEx |
aiseqInstallUI |
aiseqInstallEx |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiSequenceActionType Enumeration

Members

Member | Description
aisatStandardAction |
aisatCustomAction |
aisatDialog |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiServiceErrorControl Enumeration

Members

Member | Description
aiseIgnore |
aiseNormal |
aiseCritical |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiServiceStartType Enumeration

Members

Member | Description
aissBootStart |
aissSystemStart |
aissAutomatic |
aissManual |
aissDisabled |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiServiceType Enumeration

Members

Member | Description
aistOwnProcess |
aistSharedProcess |
aistKernelDriver |
aistFileSystemDriver |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiSetupExeType Enumeration

Members

Member | Description
aisetNone |
aisetStandard |
aisetSFX |
aisetWeb |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiStandardActionSection Enumeration

Members

Member | Description
aisasSearch |
aisasCost |
aisasSelection |
aisasExecution |
aisasPostExecution |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiStandardActionSeqFlags Enumeration

Members

Member | Description
aisafOptional |
aisafProhibited |
aisafRequired |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiToolWindowPos Enumeration

Members

Member | Description
aitwposTop |
aitwposLeft |
aitwposRight |
aitwposBottom |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiValidState Enumeration

Members

Member | Description
aivsValid |
aivsWarnings |
aivsErrors |

See Also

Global Object


%%PageItemTitle%%

Global Object

aiWindowState Enumeration

Members

Member | Description
aiwsNormal |
aiwsMinimized |
aiwsMaximized |

See Also

Global Object


%%PageItemTitle%%

Global Object

ColType Enumeration

Members

Member | Description
ctString |
ctLocalizeableString |
ctInteger |
ctBinary |

See Also

Global Object


%%PageItemTitle%%

Global Object

ColTypeEx Enumeration

Members

Member | Description
dtexNone |
dtexText |
dtexUpperCase |
dtexLowerCase |
dtexInteger |
dtexDoubleInteger |
dtexTimeDate |
dtexIdentifier |
dtexProperty |
dtexFileName |
dtexWildCardFilename |
dtexPath |
dtexPaths |
dtexAnyPath |
dtexDefaultDir |
dtexRegPath |
dtexFormatted |
dtexTemplate |
dtexCondition |
dtexGUID |
dtexVersion |
dtexLanguage |
dtexBinary |
dtexCustomSource |
dtexCabinet |
dtexShortcut |

See Also

Global Object


%%ItemTitle%%

Walkthrough - Creating a Basic Installation | Walkthrough - Qualified Components | Walkthrough - Upgrading | Walkthrough - Patching

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Tutorials Overview

Learning by example is one of the most-powerful techniques available to help get you up and running with a new technology. In this series of small walk-throughs, we'll progressively build on each step as we explore the capabilities of ActiveInstall and Windows Installer.

Phase 1: Basic Install

In this phase, we start by developing a simple installation for our fictious application, "WidgetPad". WidgetPad is a document viewer that allows the staff at "WidgetWare" to view "Widget Document Files". Widget Docs are text files stored with a ".wdoc" file extension. Our basic installation will perform the following operations:

  • Install Document Reader Application
  • Install (3) Widget Document Files
  • Create a Start-Menu Shortcut
  • Create an Association between our application and ".wdoc" files.
  • Configure a ProgId to display an icon and description for our document files in Windows Explorer.

Begin Phase 1

Phase 2: Qualified Components

In Phase 2, we will build on our installation from Phase 1. In this phase, we're going to get a bit fancy and use of the more powerful features of Windows Installer called "Qualifed Components". Qualified Components allow you to register a group of items with similar functionality with Windows Installer. Once installed, you can request the path to a qualified component, by using the unique Component ID and a qualifer string, or you can enumerate all of the available qualifiers for a component. If you don't understand, don't worry! Just follow along and the concept will become clearer as we go.

Begin Phase 2

Phase 3: Upgrading

Ok, Phase 2 was short, but we dealt with a fairly complex topic. Now, in Phase 3, we need to configure our installation so that we can automatically upgrade installations for users who have previously installed our application. We want any old version to be removed and have the new version installed in it's place. Additionally, we want to ensure that users don't accidentally install an old version over a more current version.

Begin Phase 3

Phase 4: Patching

Well, Phase 3 was enlightening, but in the real world, there is one more issue to contend with. It is not always convenient or desirable to have to send out an entire new version of our installation when only a few files have been changed. In this phase, we will create a small patch which contains only the binary changes to our WidgetPad application and the installation package.

Begin Phase 4

See Also

Walkthrough - Creating a Basic Installation | Walkthrough - Qualified Components | Walkthrough - Upgrading | Walkthrough - Patching


%%ItemTitle%%

Walkthrough - Qualified Components

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Walkthrough - Creating a Basic Installation

In this walkthrough, you will create a basic, yet complete and fully functional installation. You will begin by creating a new ActiveInstall Project based on a template project provided with ActiveInstall. You'll go on to add files, create shortcuts and file associations, and finally compile your package to a fully functional msi file.

Creating a New Project

In this step, you will create a new ActiveInstall project file which will be used to hold all of your project's data and settings.

Creating a New Project File

  1. Launch ActiveInstall by selecting "ActiveInstall Professional" from your Start Menu.
  2. Once ActiveInstall has started, you will be greeted by the New/Open Project Dialog.
  3. Select Standard Installer and then click the Open button.
  4. At this point, the New Project Settings dialog will display, allowing us to quickly set some basic properties for your new project.
  5. Enter "WidgetPad" in the Name field.
  6. Enter "Widgets, Inc." in the Manufacturer field.
  7. Select "Intel" from the Platform list.
  8. Leave the remaining fields unchanged.
  9. Click OK.
  10. At this point, the project will be opened, and the Project Explorer will populate with a list of all the available views you will use in working with your project.

Add Files to the Project

In this section, we will work with the File System View to add three files to our project:

  • WT1.exe - A Widget Document viewer/editor.
  • WidgetList.wdoc - A Widget Document File listing widget products.
  • WidgetStores.wdoc - A Widget Document File listing retail locations

Adding Files

  1. From the Project Explorer, select "File System Manager".
  2. In the Local System Folders list, browse to "<ActiveInstall Installation Path>\Walkthroughs\Phase 1". (Replace "<ActiveInstall Installation Path>" with the path you installed ActiveInstall to.)
  3. Select WPad.exe, WidgetList.wdoc, and WidgetStores.wdoc (CTRL+Click) and drag and drop them on the "Application Root" folder in the Target System Folders list. When prompted for a Feature, select "Default Feature" and click OK.
  4. When prompted for a Path Variable, select the create option and enter "WidgetRoot" as the name. Click OK.
  5. Click the Save button on the main toolbar to save your project to disk.

Creating a Start Menu Shortcut

In this section, you will create a Shortcut to WPad.exe that will allow users to launch the WidgetPad application.

Creating a Shortcut

  1. From the Project Explorer, select "Shortcut Manager".
  2. Click the "Add..." button.
  3. At this point the Shortcut Details Dialog will be displayed.
  4. Enter "WidgetPad" in the Display Name field.
  5. Click the Target Selector button next to the Target field to display the Target Selector Dialog.
  6. Since the correct entry is already selected, click OK to return to the Shortcut Details Dialog.
  7. Click the Select... button in the Icon Settings group box to display the Icon Selector Dialog.
  8. Click the Browse button next to the File Name field and browse to the "WT1.exe" file, then select the icon numbered "0" in the list.
  9. Click OK.
  10. When prompted for a Path Variable, accept the default entry of "WidgetRoot", and click OK.
  11. Click the Save & Close button on the dialog's toolbar.
  12. Click the Save button on the main toolbar to save your project to disk.

Creating a File Association

In this section, you will create an association for files with the .wdoc extension. You will associate them with WT1.exe so that when a user of the application double-clicks a .wdoc file, it will be opened with our application. You will also create a ProgID for this file type which will provide an icon and a description for the new file type.

Add an Association

  1. From the Project Explorer, select "Association Manager".
  2. Click the "Add..." button.
  3. At this point, you will prompted to enter the new extension. Enter "wdoc" and click OK.
  4. At this point the Association Details Dialog will be displayed.
  5. Click the Select... button in the Associated Application group box to display the Target Selector Dialog.
  6. Since the correct entries are already selected, click OK to return to the Association Details Dialog.
  7. Click the Add... button next to the ProgID field to display the ProgID Details Dialog.
  8. Enter "WidgetPad.DocumentFile" in the Prog ID field.
  9. Enter "Widget Document File" in the Description field.
  10. Click the Select... button in the Icon Settings group box to display the Icon Selector Dialog.
  11. Click the Browse button next to the File Name field and browse to the "WidgetDoc.ico" file, then select the icon numbered "0" in the list.
  12. Click OK.
  13. When prompted for a Path Variable, accept the default entry of "WidgetRoot", and click OK.
  14. Click the Save & Close button on the dialog's toolbar.
  15. Back in the Association Details Dialog, select "WidgetPad.DocumentFile" from the Prog ID field.
  16. Switch to the "Advanced" tab.
  17. In the Verbs section, click Add... to display the Verb Details Dialog.
  18. Enter "open" in the Verb field
  19. Enter "0" in the Sequence field.
  20. Enter "&Open" in the Command field.
  21. Enter ""%1"" in the Argument field.
  22. Click OK to return to the Association Properties Dialog.
  23. Click the Save & Close button on the dialog's toolbar.
  24. Click the Save button on the main toolbar to save your project to disk.

Compiling and Testing the Project

In this step, you will compile the project into a fully operational and completely error-free .msi file. The build output will include a Setup.exe file to launch your .msi along with the Windows Installer engine installers.

Building the Project

  1. On the main toolbar, locate and click the Build! button.
  2. The Build Progress Dialog will be displayed while the project is compiled into a msi file. Additionally, the Output Window will display details of the build process and any errors it encounters during the process.
  3. Upon completion of the build process, verify that the build completed without any errors, by reading the last line of the build output in the Output Window.
  4. Display the Launch Options Dialog for your newly compiled msi file by clicking the Run! button on the main toolbar.
  5. Uncheck the "DO NOT ALLOW..." box to allow the application to install to your system.
  6. Click Run!
  7. Follow the steps in the Installation Wizard.
  8. On completion of the installation, a log of the installation will be displayed.

Verifying installation results

In this step you will briefly inspect your system to confirm the expected changes were made.

Inspecting the Results

  1. From the Start Menu, choose Programs then Widget Tools and confirm that the a shortcut was created and works properly. Close the instance of NotePad that was started.
  2. Open Windows Explorer and navigate to the location you installed Widget Tools to.
  3. Verify that Windows Explorer displays the correct icon, and file type description for this file as pictured below.
  4. Delete WT1.exe.
  5. From the Start Menu, choose Programs, then Widget Tools.
  6. Verify that Windows Installer repairs the 'broken' installation and starts the application.
  7. Optionally validate the .msi file using tools from the Windows Installer SDK to verify that it is free of errors and would meet the requirements of Windows Logo Certification.

Summary

In this walkthrough, you have taken all the basic steps required to create a fully functional and error-free Windows Installer package. Admittedly, this is an introductory presentation that bypasses many advanced features, but we hope it has given you a good basis for moving on to more complex tasks.

See Also

Walkthrough - Qualified Components


%%ItemTitle%%

Walkthrough - Creating a Basic Installation | Walkthrough - Upgrading

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Walkthrough - Qualified Components

In the first Walkthrough, we created a fully functional installation with features that are pretty common to most installations. In this walkthrough, we are going to get a bit fancy and demonstrate the power of Qualified Components.

To use this walkthrough, you need to have performed all the steps in the first walkthrough since this one picks up where the previous one left off.

Updating the WidgetPad Application

The first thing we need to do is change our installation to point to an updated version of WT1.exe which has been modified to take advantage of Qualified Components.

To change the Source Path:

  1. From the Project Explorer, select "File System Manager".
  2. In the Target System Files list, double-click the "WT1.exe" file to open the File Details Dialog.
  3. Click the ellipsis button next to the Source Path field and browse to "<ActiveInstall Installation Path>\Walkthroughs\Phase 2\WT1.exe". (Replace "<ActiveInstall Installation Path>" with the path you installed ActiveInstall to.)
  4. When prompted for a Path Variable, select the create option and enter "Phase2" as the name. Click OK.
  5. Click the Save button on the main toolbar to save your project to disk.

Adding New Components

In this step, we will create two new components to hold the two special directory files we will be installing.

To Add our New Components:

  1. From the Project Explorer, select Feature Manager.
  2. From the drop-down portion of the Add... button, select Add Component...
  3. Enter "EastCoastDir" as the name of the component.
  4. On the Super Advanced tab, click the Add... button next to the Qualified Components list.
  5. In the Component Qualifier Details Dialog, enter:
    • Category ID: "{81EBBF4C-1CDA-4F96-B060-6430D99C6300}"
    • Qualifier: "EastCoastDir"
    • App Data: "East Coast Company Directory"
    • Feature: "Default_Feature"
  6. Click OK to save and return to the Component Details Dialog.
  7. Click Save & Close.
  8. Repeat steps 1 - 7 to add another new component named WestCoastDir with the following data entered as a Qualifier.
    • Category ID: "{81EBBF4C-1CDA-4F96-B060-6430D99C6300}"
    • Qualifier: "WestCoastDir"
    • App Data: "West Coast Company Directory"
    • Feature: "Default_Feature"
  9. Click the Save button on the main toolbar to save your project to disk.

Adding the Company Directory Files

In this step, we will add the two directory files and assign them as the Key Members of their respective Components.

To Add the Files:

  1. From the Project Explorer, select File System Manager.
  2. From the Drop-Down portion of the Add... button, select Add File...
  3. Enter the following information on the General tab:
    • Name: "EastCoast.txt"
    • File Name: "EastCoast.txt"
  4. Click the ellipsis button next to the Source Path field and browse to "<ActiveInstall Installation Path>\Walkthroughs\Phase 2\EastCoast.txt". (Replace "<ActiveInstall Installation Path>" with the path you installed ActiveInstall to.)
  5. When prompted for a Path Variable, select "Phase2" entry and click OK.
  6. On the Advanced tab, select "EastCoastDir" as the Component for this file.
  7. Click Save & Close.
  8. Repeat steps 1 - 7 using WestCoast.txt as the file and "WestCoastDir" as the Component.
  9. Click Save on the the main toolbar to save your project to disk.

Setting the Key Members

Now that we have created our components and added the files, the only thing left to do is to set the new files as the key members of their respective Components.

To Set the Key Members:

  1. From the Project Explorer, select Feature Manager.
  2. In the list of Components, double-click the "EastCoastDir" entry.
  3. On the Advanced tab of the Component Details Dialog, select "File" as the Key Member type, then select "EastCoast.txt" from the Key Member drop-down list.
  4. Click Save & Close.
  5. Repeat steps 1 - 4 for the WestCoastDir Component, setting "WestCoast.txt" as it's Key Member.
  6. Click Save on the the main toolbar to save your project to disk.

Check it Out!

Well, we're done with the hard part! All that's left for us to do is inspect the results of our work!

  1. If you haven't already done so, uninstall the previous version from the first walkthrough.
  2. Compile the project, ensuring that no errors occur during the build or validation phases.
  3. Install the newly compiled version.
  4. Run the application.
  5. Notice that the list of Directories is populated based on the Qualified Components we created in this walkthrough.
  6. Select each item in the list observing that the respective directory is loaded into the viewer.
See Also

Walkthrough - Creating a Basic Installation | Walkthrough - Upgrading


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Walkthrough - Upgrading

In the first two Walkthroughs, we created a fairly standard installation then enhanced it with some cool features of Windows Installer. That worked out well enough, but what if we hav already distributed some copies of the first version to some of our customers? Would they have to completely uninstall the first version then install the second version as we did?

Well fortunately, there is a better way! It's called upgrading and that's what we are going to cover in this walkthrough. we're going to use the first walkthrough as the baseline install that already exists on the user's computer, and walkthrough two as the update install we now want to deploy.

Before we begin, make sure you have the first version of WidgetPad that we created in the first walkthrough installed on your computer.

Incrementing the Installations Version

In this step, we need to change the Version number of our installation so that Windows Installer will know that this is a newer version.

To Change the Installation Version:

  1. Open the Project Properties Dialog by selecting Project Properties... from the Project Menu.
  2. Change the Version for "1.0.0" to "1.0.1".
  3. Click Save & Close.

Detecting Older Versions

In this step, we are going to provide Windows Installer with some information to use in detecting if an older version of this product is installed, and what to do if it is. We do this by adding one or more Upgrade Actions to our project.

To Add the Upgrade Action:

  1. From the main toolbar, select "Add Item...".
  2. In the Add Item Dialog, select Upgrade Action and click OK.
  3. In the Upgrade Action Details Dialog, note that the current project's Upgrade Code has been added by default. Since this is the one we want to use, there is no need to change it.
  4. In the Max. Version field, enter "1.0.1". This tells Windows Installer to locate any products with the specified Upgrade Code and a version less than "1.0.1", which of course the current version being installed.
  5. In the Indicator Property field, enter "OLDER_VERSIONS_FOUND". At runtime, a property by this name will be available which will contain a list of any matching Product Codes.
  6. Click Save & Close.

Detecting Newer Versions

With mutliple versions of our installation in circulation, it is likely that at some point, someone may try to install an older version over a newer version. To prevent this, we will also detect newer versions of the installation and use a Error & Fail Custom Action to abort the installation.

To Add the Upgrade Action:

  1. From the main toolbar, select "Add Item...".
  2. In the Add Item Dialog, select Upgrade Action and click OK.
  3. In the Upgrade Action Details Dialog, note that the current project's Upgrade Code has been added by default. Since this is the one we want to use, there is no need to change it.
  4. In the Min. Version field, enter "1.0.1". This tells Windows Installer to locate any products with the specified Upgrade Code and a version greater than "1.0.1", which of course, is the current version being installed.
  5. In the Indicator Property field, enter "NEWER_VERSIONS_FOUND". At runtime, a property by this name will be available which will contain a list of any matching Product Codes.
  6. Check the Detect Only field to ensure Windows Installer doesn't actually attempt an upgrade.
  7. Click Save & Close.

To Add the Custom Action:

  1. From the main toolbar, select "Add Item...".
  2. In the Add Item Dialog, select Custom Action and click OK.
  3. In the Custom Action Type Dialog, select Error & Fail and click OK.
  4. In the Custom Action Details Dialog, enter NewVersionEF in the Name field.
  5. Select the "Use this Message" option and enter "Newer version detected. Installation cannot continue." in the Message field.
  6. On the Sequencing tab, check the box next to the Install UI Sequence, then select "DetectExitingProducts".
  7. In the Condition field, enter "NEWER_VERSION_FOUND".
  8. Click Save & Close.
  9. Click Save on the main toolbar to save your project to disk.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Walkthrough - Patching

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

Obtaining Technical Support | Contacting Sales | How to Purchase

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Contact Information

This topic provides reference information about the following items:

Obtaining Technical Support

Contacting the Sales Team

How to Purchase ActiveInstall

See Also

Obtaining Technical Support | Contacting Sales | How to Purchase


%%ItemTitle%%

Contacting Sales | How to Purchase

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Obtaining Technical Support

Technical Support is available at no cost to all users. Naturally priority is given to Licensed users, how ever we do make every effort to respond to everyone in an equally expeditious manner.

Please e-mail support requests to support@activeinstall.com of visit our website at http://www.activeinstall.com where you will find a wealth of information and resources to assist in your development efforts.

See Also

Contacting Sales | How to Purchase


%%ItemTitle%%

Obtaining Technical Support | How to Purchase

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Contacting Sales

If you have any pre-sales related questions or any issues you would like to discuss with our sales team, you can contact them by sending e-mail to sales@activeinstall.com.
See Also

Obtaining Technical Support | How to Purchase


%%ItemTitle%%

Obtaining Technical Support | Contacting Sales

See Also ActiveInstall Online Documentation Send Feedback on this topic.

How to Purchase

ActiveInstall Professional is available for purchase on our website located at http://www.activeinstall.com or through our reseller partners.

Volume licensing is available for quantities of 5 or more. Site Licenses are available based on a single geographic location.

If you have any question regarding licensing, please contact our sales staff by send e-mail to sales@activeinstall.com.

See Also

Obtaining Technical Support | Contacting Sales


Glossary

A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

P

Property
A variable either defined by the package author or the Windows Installer engine which contains variable data used during the execution of the installation.

R

Row Selector
The area to the immediate left of the first column in a grid. Clicking the row selector causes the entire row to be selected.


%%phrase%%

ActiveInstall Online Documentation Send Feedback on this topic.

Documentation Overview

Description

ActiveInstall Professional

Projects

Project | Description
ActiveInstall | ActiveInstall Professional


%%PageItemTitle%%

C_Application Members

C_Application Object

For a list of all members defined in this module, see C_Application members.

See Also

C_Application Members


%%PageItemTitle%% $$Members$$

C_Application Members

C_Application Object Members

Public Methods

Public Method CallStackClear
Public Method CallStackPop
Public Method CallStackPush
Public Method CloseLog
Public Method HandleError
Public Method Output
Public Method StartLog

Public Properties

Public Property AppSettings
Public Property DebuggerEventTypes
Public Property Help
Public Property LogEventTypes
Public Property MMCatalog
Public Property MMSearchPaths
Public Property MRUList
Public Property Registry
Public Property Shell
Public Property UserOptions
Public Property UserSettings

See Also

C_Application Overview


%%PageItemTitle%%

C_Application Object

AppSettings Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property AppSettings() As C_Settings

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

CallStackClear Method

Syntax

Public Sub CallStackClear()

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

CallStackPop Method

Syntax

Public Sub CallStackPop()

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

Procedure
Data
See Also ActiveInstall Professional Send Feedback on this topic.

CallStackPush Method

Syntax

Public Sub CallStackPush( _
   ByRef Procedure As String, _
   Optional ByRef Data As String = "" _
)

Parameters

Procedure
Data

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

CloseLog Method

Syntax

Public Sub CloseLog()

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

DebuggerEventTypes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DebuggerEventTypes() As OutputEventTypes

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

Procedure
bDisplay
See Also ActiveInstall Professional Send Feedback on this topic.

HandleError Method

Syntax

Public Sub HandleError( _
   Optional ByRef Procedure As String = "", _
   Optional ByRef bDisplay As Boolean = False _
)

Parameters

Procedure
bDisplay

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

Help Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Help() As HTMLHelp

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

LogEventTypes Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LogEventTypes() As OutputEventTypes

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

MMCatalog Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MMCatalog() As C_MMCatItems

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

MMSearchPaths Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MMSearchPaths() As C_MMSearchPaths

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

MRUList Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property MRUList() As MRUList

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

DebugText
EventType
ForceOutput
See Also ActiveInstall Professional Send Feedback on this topic.

Output Method

Syntax

Public Sub Output( _
   ByRef DebugText As String, _
   Optional ByRef EventType As OutputEventTypes = opLogCheckPoint, _
   Optional ByVal ForceOutput As Boolean _
)

Parameters

DebugText
EventType
Value Description
opLogNone
opLogError
opLogWarning
opLogInformational
opWindowProc
opResources
opEnvironment
opLogCheckPoint
opNoCheckpoints
opAll
ForceOutput

See Also

C_Application Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

OutputEventTypes Enumeration

Members

Member | Description
opLogNone |
opLogError |
opLogWarning |
opLogInformational |
opWindowProc |
opResources |
opEnvironment |
opLogCheckPoint |
opNoCheckpoints |
opAll |


%%PageItemTitle%%

C_Application Object

Registry Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Registry() As Registry

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

Shell Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Shell() As Shell

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

LogPath
Truncate
LogEventTypes
DebuggerEventTypes
See Also ActiveInstall Professional Send Feedback on this topic.

StartLog Method

Syntax

Public Sub StartLog( _
   ByVal LogPath As String, _
   Optional ByVal Truncate As Boolean, _
   Optional ByVal LogEventTypes As OutputEventTypes = -1, _
   Optional ByVal DebuggerEventTypes As OutputEventTypes = -1 _
)

Parameters

LogPath
Truncate
LogEventTypes
Value Description
opLogNone
opLogError
opLogWarning
opLogInformational
opWindowProc
opResources
opEnvironment
opLogCheckPoint
opNoCheckpoints
opAll
DebuggerEventTypes
Value Description
opLogNone
opLogError
opLogWarning
opLogInformational
opWindowProc
opResources
opEnvironment
opLogCheckPoint
opNoCheckpoints
opAll

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

UserOptions Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserOptions() As C_UserOptions

See Also

C_Application Object


%%PageItemTitle%%

C_Application Object

UserSettings Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property UserSettings() As C_Settings

See Also

C_Application Object


%%PageItemTitle%%

C_CABExtractor Members

C_CABExtractor Object

For a list of all members defined in this module, see C_CABExtractor members.

See Also

C_CABExtractor Members


%%PageItemTitle%% $$Members$$

C_CABExtractor Members

C_CABExtractor Object Members

Public Methods

Public Method Extract
Public Method GetInfo
Public Method GetXML

Public Properties

Public Property CabName
Public Property FileCount

Events

Public Event AfterExtract
Public Event BeforeExtract
Public Event FileFound

See Also

C_CABExtractor Overview


%%PageItemTitle%%

C_CABExtractor Object

FileName
See Also ActiveInstall Professional Send Feedback on this topic.

AfterExtract Event

Syntax

Public Event AfterExtract( _
   ByVal FileName As String _
)

Parameters

FileName

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CABExtractor Object

FileName
Cancel
See Also ActiveInstall Professional Send Feedback on this topic.

BeforeExtract Event

Syntax

Public Event BeforeExtract( _
   ByVal FileName As String, _
   ByRef Cancel As Boolean _
)

Parameters

FileName
Cancel

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CABExtractor Object

CabName Property

Property type

Read-write property

Syntax (Visual Basic)

Public CabName As String

See Also

C_CABExtractor Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

Errors Enumeration

Members

Member | Description
errNoCabFile |


%%PageItemTitle%%

C_CABExtractor Object

FileToExtract
OutputPath
OutputFile
See Also ActiveInstall Professional Send Feedback on this topic.

Extract Method

Syntax

Public Function Extract( _
   Optional ByRef FileToExtract As String = vbNullString, _
   Optional ByRef OutputPath As String = vbNullString, _
   Optional ByRef OutputFile As String = vbNullString _
) As Boolean

Parameters

FileToExtract
OutputPath
OutputFile

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CABExtractor Object

FileCount Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileCount() As Long

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CABExtractor Object

FileName
DateTime
Size
Path
See Also ActiveInstall Professional Send Feedback on this topic.

FileFound Event

Syntax

Public Event FileFound( _
   ByVal FileName As String, _
   ByVal DateTime As Date, _
   ByVal Size As Variant, _
   ByVal Path As String _
)

Parameters

FileName
DateTime
Size
Path

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CABExtractor Object

FileToInvestigate
See Also ActiveInstall Professional Send Feedback on this topic.

GetInfo Method

Syntax

Public Function GetInfo( _
   Optional ByRef FileToInvestigate As String = vbNullString _
) As Boolean

Parameters

FileToInvestigate

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CABExtractor Object

FileToInvestigate
See Also ActiveInstall Professional Send Feedback on this topic.

GetXML Method

Syntax

Public Function GetXML( _
   Optional ByRef FileToInvestigate As String = vbNullString _
) As String

Parameters

FileToInvestigate

See Also

C_CABExtractor Object


%%PageItemTitle%%

C_CommonDialog Members

C_CommonDialog Object

For a list of all members defined in this module, see C_CommonDialog members.

See Also

C_CommonDialog Members


%%PageItemTitle%% $$Members$$

C_CommonDialog Members

C_CommonDialog Object Members

Public Methods

Public Method cdFreeLibrary
Public Method cdLoadLibrary
Public Method CentreDialog
Public Method ConfirmOK
Public Method DialogClose
Public Method FileChange
Public Method FolderChange
Public Method GetDialogSize
Public Method InitDialog
Public Method ParseMultiFileName
Public Method SetHelpPosition
Public Method ShowColor
Public Method ShowFont
Public Method ShowHelp
Public Method ShowOpen
Public Method ShowPrinter
Public Method ShowSave
Public Method TypeChange
Public Method WMCommand

Public Properties

Public Property CancelError
Public Property Color
Public Property Copies
Public Property CustomColor
Public Property DefaultExt
Public Property DialogTitle
Public Property FileName
Public Property FileTitle
Public Property Filter
Public Property FilterIndex
Public Property Flags
Public Property Font
Public Property FontBold
Public Property FontColor
Public Property FontItalic
Public Property FontName
Public Property FontSize
Public Property FontStrikethru
Public Property FontUnderline
Public Property FromPage
Public Property HelpCommand
Public Property HelpContext
Public Property HelpFile
Public Property HelpKey
Public Property hInstance
Public Property HookDialog
Public Property hwnd
Public Property InitDir
Public Property Max
Public Property MaxFileSize
Public Property Min
Public Property Object
Public Property PrinterDefault
Public Property TemplateName
Public Property ToPage

Events

Public Event DialogClose
Public Event DialogOK
Public Event FileChange
Public Event FolderChange
Public Event InitDialog
Public Event TypeChange
Public Event WMCommand

See Also

C_CommonDialog Overview


%%PageItemTitle%%

C_CommonDialog Object

CancelError Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CancelError() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

cdFreeLibrary Method

Syntax

Public Sub cdFreeLibrary()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

DllName
See Also ActiveInstall Professional Send Feedback on this topic.

cdLoadLibrary Method

Syntax

Public Sub cdLoadLibrary( _
   ByRef DllName As String _
)

Parameters

DllName

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
oCentreTo
See Also ActiveInstall Professional Send Feedback on this topic.

CentreDialog Method

Syntax

Public Sub CentreDialog( _
   ByVal hDlg As Long, _
   ByRef oCentreTo As Object _
)

Parameters

hDlg
oCentreTo

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Color Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Color() As OLE_COLOR

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ConfirmOK Method

Syntax

Public Function ConfirmOK() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Copies Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Copies() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

i
See Also ActiveInstall Professional Send Feedback on this topic.

CustomColor Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomColor( _
   ByVal i As Integer _
) As OLE_COLOR

Parameters

i

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

DefaultExt Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DefaultExt() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

DialogClose Method

Syntax

Public Sub DialogClose()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

DialogClose Event

Syntax

Public Event DialogClose()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

bCancel
See Also ActiveInstall Professional Send Feedback on this topic.

DialogOK Event

Syntax

Public Event DialogOK( _
   ByRef bCancel As Boolean _
)

Parameters

bCancel

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

DialogTitle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property DialogTitle() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EShowHelpCommands Enumeration

Members

Member | Description
HELP_COMMAND |
HELP_CONTENTS |
HELP_CONTEXT |
HELP_CONTEXTPOPUP |
HELP_FORCEFILE |
HELP_HELPONHELP |
HELP_INDEX |
HELP_KEY |
HELP_MULTIKEY |
HELP_PARTIALKEY |
HELP_QUIT |
HELP_SETCONTENTS |
HELP_SETINDEX |
HELP_SETWINPOS |
HELP_FINDER |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EShowHelpWindowPos Enumeration

Members

Member | Description
eSW_HIDE |
eSW_MAXIMIZE |
eSW_MINIMIZE |
eSW_SHOW |
eSW_SHOWMAXIMIZED |
eSW_SHOWMINIMIZED |
eSW_SHOWMINNOACTIVE |
eSW_SHOWNA |
eSW_SHOWNOACTIVATE |
eSW_SHOWNORMAL |


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

FileChange Method

Syntax

Public Function FileChange( _
   ByVal hDlg As Long _
) As Long

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

FileChange Event

Syntax

Public Event FileChange( _
   ByVal hDlg As Long _
)

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FileTitle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileTitle() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Filter Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Filter() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FilterIndex Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FilterIndex() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Flags Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Flags() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

FolderChange Method

Syntax

Public Function FolderChange( _
   ByVal hDlg As Long _
) As Long

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

FolderChange Event

Syntax

Public Event FolderChange( _
   ByVal hDlg As Long _
)

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Font Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Font() As StdFont

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontBold Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontBold() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontColor Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontColor() As OLE_COLOR

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontItalic Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontItalic() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontName() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontSize() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontStrikethru Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontStrikethru() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FontUnderline Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FontUnderline() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

FromPage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FromPage() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
lL
lT
lW
lH
See Also ActiveInstall Professional Send Feedback on this topic.

GetDialogSize Method

Syntax

Public Sub GetDialogSize( _
   ByVal hDlg As Long, _
   ByRef lL As Long, _
   ByRef lT As Long, _
   ByRef lW As Long, _
   ByRef lH As Long _
)

Parameters

hDlg
lL
lT
lW
lH

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

HelpCommand Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HelpCommand() As EShowHelpCommands

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

HelpContext Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HelpContext() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

HelpFile Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HelpFile() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

HelpKey Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HelpKey() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hInstance Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property hInstance() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

HookDialog Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property HookDialog() As Boolean

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hwnd Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property hwnd() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

InitDialog Method

Syntax

Public Function InitDialog( _
   ByVal hDlg As Long _
) As Long

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

InitDialog Event

Syntax

Public Event InitDialog( _
   ByVal hDlg As Long _
)

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

InitDir Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property InitDir() As String

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Max Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Max() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

MaxFileSize Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property MaxFileSize() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Min Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Min() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

Object Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Object() As Object

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

sDir
sFiles
iFileCount
See Also ActiveInstall Professional Send Feedback on this topic.

ParseMultiFileName Method

Syntax

Public Sub ParseMultiFileName( _
   ByRef sDir As String, _
   ByRef sFiles() As String, _
   ByRef iFileCount As Long _
)

Parameters

sDir
sFiles
iFileCount

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

PrinterDefault Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property PrinterDefault() As Integer

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

x
y
dx
dy
eWindowType
See Also ActiveInstall Professional Send Feedback on this topic.

SetHelpPosition Method

Syntax

Public Sub SetHelpPosition( _
   ByRef x As Long, _
   ByRef y As Long, _
   ByRef dx As Long, _
   ByRef dy As Long, _
   ByRef eWindowType As EShowHelpWindowPos _
)

Parameters

x
y
dx
dy
eWindowType
Value Description
eSW_HIDE
eSW_MAXIMIZE
eSW_MINIMIZE
eSW_SHOW
eSW_SHOWMAXIMIZED
eSW_SHOWMINIMIZED
eSW_SHOWMINNOACTIVE
eSW_SHOWNA
eSW_SHOWNOACTIVATE
eSW_SHOWNORMAL

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ShowColor Method

Syntax

Public Sub ShowColor()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ShowFont Method

Syntax

Public Sub ShowFont()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ShowHelp Method

Syntax

Public Sub ShowHelp()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ShowOpen Method

Syntax

Public Sub ShowOpen()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ShowPrinter Method

Syntax

Public Sub ShowPrinter()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ShowSave Method

Syntax

Public Sub ShowSave()

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

TemplateName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TemplateName() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

ToPage Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ToPage() As Long

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

TypeChange Method

Syntax

Public Function TypeChange( _
   ByVal hDlg As Long _
) As Long

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
See Also ActiveInstall Professional Send Feedback on this topic.

TypeChange Event

Syntax

Public Event TypeChange( _
   ByVal hDlg As Long _
)

Parameters

hDlg

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
wParam
lParam
See Also ActiveInstall Professional Send Feedback on this topic.

WMCommand Method

Syntax

Public Sub WMCommand( _
   ByVal hDlg As Long, _
   ByRef wParam As Long, _
   ByRef lParam As Long _
)

Parameters

hDlg
wParam
lParam

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_CommonDialog Object

hDlg
wParam
lParam
See Also ActiveInstall Professional Send Feedback on this topic.

WMCommand Event

Syntax

Public Event WMCommand( _
   ByVal hDlg As Long, _
   ByRef wParam As Long, _
   ByRef lParam As Long _
)

Parameters

hDlg
wParam
lParam

See Also

C_CommonDialog Object


%%PageItemTitle%%

C_Error Members

C_Error Object

For a list of all members defined in this module, see C_Error members.

See Also

C_Error Members


%%PageItemTitle%% $$Members$$

C_Error Members

C_Error Object Members

Public Methods

Public Method BreakInCode
Public Method CacheError
Public Method ErrClear
Public Method ErrContinue
Public Method ErrInIDE
Public Method ERROR
Public Method ExtractFromReport
Public Method InException
Public Method InPropagation
Public Method IsException
Public Method RestoreError
Public Method SaveToFile
Public Method Validate

Public Properties

Public Property AccumBuffer
Public Property Arguments
Public Property Context
Public Property ErrDescription
Public Property ErrHelpContext
Public Property ErrHelpFile
Public Property ErrNumber
Public Property ErrOriginalDescription
Public Property ErrOriginalSource
Public Property ErrSource
Public Property ErrStopFlag
Public Property LineNumber
Public Property Module
Public Property Procedure
Public Property Report
Public Property ReportHTML

See Also

C_Error Overview


%%PageItemTitle%%

C_ErrorHandler Members

C_ErrorHandler Object

For a list of all members defined in this module, see C_ErrorHandler members.

See Also

C_ErrorHandler Members


%%PageItemTitle%% $$Members$$

C_ErrorHandler Members

C_ErrorHandler Object Members

Public Methods

Public Method Init
Public Method Report

Public Properties

Public Property Comments
Public Property ForceAction
Public Property KBURL
Public Property Notify
Public Property Signature
Public Property Status
Public Property StatusDate

See Also

C_ErrorHandler Overview


%%PageItemTitle%%

C_ErrorHandler Object

Comments Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Comments() As String

See Also

C_ErrorHandler Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

eErrorStatus Enumeration

Members

Member | Description
esNew |
esExisting |


%%PageItemTitle%%

C_ErrorHandler Object

ForceAction Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ForceAction() As Long

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

Init Method

Syntax

Public Sub Init()

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

KBURL Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property KBURL() As String

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

Notify Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Notify() As Boolean

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

Report Method

Syntax

Public Function Report() As Boolean

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

Signature Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Signature() As String

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

Status Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Status() As Long

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_ErrorHandler Object

StatusDate Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property StatusDate() As Date

See Also

C_ErrorHandler Object


%%PageItemTitle%%

C_Error Object

AccumBuffer Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AccumBuffer() As String

See Also

C_Error Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

AIERR Enumeration

Members

Member | Description
ERR_ACCUMULATE |
AIERR_FIRST |
AIERR_RESERVED_FIRST |
ERR_SYSEXCEPTION |
AIERR_RESERVED_LAST |
AIERR_EXC_FIRST |
EXC_GENERAL |
EXC_VALIDATION |
EXC_MULTIPLE |
EXC_CANCELLED |
AIERR_EXC_LAST |
AIERR_APP_FIRST |
ERR_GENERAL |
ERR_BC_INVALIDBUILDCONFIG |


%%PageItemTitle%%

C_Error Object

Arguments Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Arguments() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

BreakInCode Method

Syntax

Public Function BreakInCode() As Boolean

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

CacheError Method

Syntax

Public Sub CacheError()

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

Context Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Context() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrClear Method

Syntax

Public Sub ErrClear()

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrNum
ErrReport
See Also ActiveInstall Professional Send Feedback on this topic.

ErrContinue Method

Syntax

Public Sub ErrContinue( _
   ByVal ErrNum As Long, _
   ByVal ErrReport As Variant _
)

Parameters

ErrNum
ErrReport

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrDescription Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrDescription() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrHelpContext Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrHelpContext() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrHelpFile Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrHelpFile() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrInIDE Method

Syntax

Public Function ErrInIDE() As Boolean

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrNumber Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrNumber() As Long

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

Module
Procedure
Action
arrArgNames
arrArgValues
arrEnvNames
arrEnvValues
See Also ActiveInstall Professional Send Feedback on this topic.

ERROR Method

Syntax

Public Function ERROR( _
   ByVal Module As String, _
   ByVal Procedure As String, _
   Optional ByVal Action As ERROR_ACTION = EA_DEFAULT, _
   Optional ByVal arrArgNames As Variant, _
   Optional ByVal arrArgValues As Variant, _
   Optional ByVal arrEnvNames As Variant, _
   Optional ByVal arrEnvValues As Variant _
) As String

Parameters

Module
Procedure
Action
Value Description
EA_RERAISE
EA_REPORT
EA_DEFAULT
EA_NORERAISE
arrArgNames
arrArgValues
arrEnvNames
arrEnvValues

See Also

C_Error Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ERROR_ACTION Enumeration

Members

Member | Description
EA_RERAISE |
EA_REPORT |
EA_DEFAULT |
EA_NORERAISE |


%%PageItemTitle%%

C_Error Object

ErrOriginalDescription Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrOriginalDescription() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrOriginalSource Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrOriginalSource() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrSource Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrSource() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrStopFlag Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ErrStopFlag() As Boolean

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

FromStr
TillStr
See Also ActiveInstall Professional Send Feedback on this topic.

ExtractFromReport Method

Syntax

Public Function ExtractFromReport( _
   ByVal FromStr As String, _
   ByVal TillStr As String _
) As Variant

Parameters

FromStr
TillStr

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

InException Method

Syntax

Public Function InException() As Boolean

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

InPropagation Method

Syntax

Public Function InPropagation() As Boolean

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

lErrNumber
See Also ActiveInstall Professional Send Feedback on this topic.

IsException Method

Syntax

Public Function IsException( _
   ByVal lErrNumber As Long _
) As Boolean

Parameters

lErrNumber

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

LineNumber Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property LineNumber() As Long

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

Module Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Module() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

Procedure Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Procedure() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

Report Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Report() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ReportHTML Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ReportHTML() As String

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

RestoreError Method

Syntax

Public Sub RestoreError()

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

ErrFileName
See Also ActiveInstall Professional Send Feedback on this topic.

SaveToFile Method

Syntax

Public Function SaveToFile( _
   Optional ByVal ErrFileName As String = "Errors.txt" _
) As Boolean

Parameters

ErrFileName

See Also

C_Error Object


%%PageItemTitle%%

C_Error Object

Condition
ErrNumber
ErrDescr
Values
HelpFile
HelpContext
See Also ActiveInstall Professional Send Feedback on this topic.

Validate Method

Syntax

Public Sub Validate( _
   ByVal Condition As Boolean, _
   ByVal ErrNumber As AIERR, _
   ByVal ErrDescr As String, _
   Optional ByVal Values As Variant, _
   Optional ByVal HelpFile As Variant, _
   Optional ByVal HelpContext As Variant _
)

Parameters

Condition
ErrNumber
Value Description
ERR_ACCUMULATE
AIERR_FIRST
AIERR_RESERVED_FIRST
ERR_SYSEXCEPTION
AIERR_RESERVED_LAST
AIERR_EXC_FIRST
EXC_GENERAL
EXC_VALIDATION
EXC_MULTIPLE
EXC_CANCELLED
AIERR_EXC_LAST
AIERR_APP_FIRST
ERR_GENERAL
ERR_BC_INVALIDBUILDCONFIG
ErrDescr
Values
HelpFile
HelpContext

See Also

C_Error Object


%%PageItemTitle%%

C_FileIcon Members

C_FileIcon Object

For a list of all members defined in this module, see C_FileIcon members.

See Also

C_FileIcon Members


%%PageItemTitle%% $$Members$$

C_FileIcon Members

C_FileIcon Object Members

Public Methods

Public Method AddImage
Public Method CloneTo
Public Method DrawIconImage
Public Method LoadIcon
Public Method LoadIconFromEXE
Public Method RemoveImage
Public Method SaveIcon

Public Properties

Public Property FileName
Public Property IconHandle
Public Property IconPicture
Public Property ImageColorCount
Public Property ImageCount
Public Property ImageHeight
Public Property ImageSize
Public Property ImageWidth
Public Property ResourceID

See Also

C_FileIcon Overview


%%PageItemTitle%%

C_FileIcon Object

nWidth
nHeight
nColorCount
See Also ActiveInstall Professional Send Feedback on this topic.

AddImage Method

Syntax

Public Function AddImage( _
   ByVal nWidth As Long, _
   ByVal nHeight As Long, _
   ByVal nColorCount As Long _
) As Long

Parameters

nWidth
nHeight
nColorCount

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

cThis
See Also ActiveInstall Professional Send Feedback on this topic.

CloneTo Method

Syntax

Public Sub CloneTo( _
   ByRef cThis As C_FileIcon _
)

Parameters

cThis

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

lHDC
nIndex
eType
x
y
lWidth
lHeight
eRasterOp
See Also ActiveInstall Professional Send Feedback on this topic.

DrawIconImage Method

Syntax

Public Sub DrawIconImage( _
   ByVal lHDC As Long, _
   ByVal nIndex As Long, _
   Optional ByVal eType As ECFIImageConstants = ecfiImage, _
   Optional ByVal x As Long = 0, _
   Optional ByVal y As Long = 0, _
   Optional ByVal lWidth As Long = 0, _
   Optional ByVal lHeight As Long = 0, _
   Optional ByVal eRasterOp As RasterOpConstants = vbSrcCopy _
)

Parameters

lHDC
nIndex
eType
Value Description
ecfiImage
ecfiMask
x
y
lWidth
lHeight
eRasterOp

See Also

C_FileIcon Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ECFIImageConstants Enumeration

Members

Member | Description
ecfiImage |
ecfiMask |


%%PageItemTitle%%

C_FileIcon Object

FileName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

lHDC
nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

IconHandle Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property IconHandle( _
   ByVal lHDC As Long, _
   ByVal nIndex As Long _
) As Long

Parameters

lHDC
nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

lHDC
nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

IconPicture Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property IconPicture( _
   ByVal lHDC As Long, _
   ByVal nIndex As Long _
) As StdPicture

Parameters

lHDC
nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ImageColorCount Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageColorCount( _
   ByVal nIndex As Long _
) As Long

Parameters

nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

ImageCount Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageCount() As Long

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ImageHeight Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageHeight( _
   ByVal nIndex As Long _
) As Long

Parameters

nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ImageSize Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageSize( _
   ByVal nIndex As Long _
) As Long

Parameters

nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ImageWidth Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ImageWidth( _
   ByVal nIndex As Long _
) As Long

Parameters

nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

sFile
See Also ActiveInstall Professional Send Feedback on this topic.

LoadIcon Method

Syntax

Public Function LoadIcon( _
   ByVal sFile As String _
) As Boolean

Parameters

sFile

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

sFile
lpID
lpName
See Also ActiveInstall Professional Send Feedback on this topic.

LoadIconFromEXE Method

Syntax

Public Function LoadIconFromEXE( _
   ByVal sFile As String, _
   Optional ByVal lpID As Long = 0, _
   Optional ByVal lpName As String = "" _
) As Boolean

Parameters

sFile
lpID
lpName

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

nIndex
See Also ActiveInstall Professional Send Feedback on this topic.

RemoveImage Method

Syntax

Public Function RemoveImage( _
   ByVal nIndex As Long _
) As Long

Parameters

nIndex

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

ResourceID Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResourceID() As Variant

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileIcon Object

sFileName
See Also ActiveInstall Professional Send Feedback on this topic.

SaveIcon Method

Syntax

Public Function SaveIcon( _
   Optional ByVal sFileName As String = "" _
) As Boolean

Parameters

sFileName

See Also

C_FileIcon Object


%%PageItemTitle%%

C_FileVersion Members

C_FileVersion Object

For a list of all members defined in this module, see C_FileVersion members.

See Also

C_FileVersion Members


%%PageItemTitle%% $$Members$$

C_FileVersion Members

C_FileVersion Object Members

Public Methods

Public Method Compare
Public Method Init

Public Properties

Public Property DriverKind
Public Property FileFlags
Public Property FileKind
Public Property FileName
Public Property FileVersion
Public Property FontKind
Public Property ProductVersion
Public Property TargetOs

See Also

C_FileVersion Overview


%%PageItemTitle%%

C_FileVersion Object

BaseVersionAsText
CompareType
See Also ActiveInstall Professional Send Feedback on this topic.

Compare Method

Syntax

Public Function Compare( _
   ByRef BaseVersionAsText As String, _
   Optional ByRef CompareType As ECompareType = eCompareType_FileVer _
) As ECompareResult

Parameters

BaseVersionAsText
CompareType
Value Description
eCompareType_FileVer
eCompareType_ProdVer

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

DriverKind Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property DriverKind() As EDriverKind

See Also

C_FileVersion Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ECompareResult Enumeration

Members

Member | Description
eCompareResult_BaseIsOlder |
eCompareResult_BaseIsNewer |
eCompareResult_Equal |
eCompareResult_Unknown |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ECompareType Enumeration

Members

Member | Description
eCompareType_FileVer |
eCompareType_ProdVer |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EDriverKind Enumeration

Members

Member | Description
eDriverKind_Printer |
eDriverKind_Keyboard |
eDriverKind_Language |
eDriverKind_Display |
eDriverKind_Mouse |
eDriverKind_Network |
eDriverKind_System |
eDriverKind_Installable |
eDriverKind_Sound |
eDriverKind_Comm |
eDriverKind_Unknown |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EErrFileVersion Enumeration

Members

Member | Description
eErrFileVersion_NotInitialized |
eErrFileVersion_FileNotFound |
eErrFileVersion_VersionInfoNotFound |
eErrFileVersion_InvalidCompareType |
eErrFileVersion_ComponentFailure |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFileFlags Enumeration

Members

Member | Description
eFileFlag_Debug |
eFileFlag_PreRel |
eFileFlag_Patched |
eFileFlag_Private |
eFileFlag_Info |
eFileFlag_Special |
eFileFlag_Unknown |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFileKind Enumeration

Members

Member | Description
eFileKind_Application |
eFileKind_DLL |
eFileKind_Driver |
eFileKind_Font |
eFileKind_VxD |
eFileKind_StaticLib |
eFileKind_Unknown |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFontKind Enumeration

Members

Member | Description
eFontKind_Raster |
eFontKind_Vector |
eFontKind_TrueType |
eFontKind_Unknown |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ETargetOs Enumeration

Members

Member | Description
eTargetOs_DosWin16 |
eTargetOs_DosWin32 |
eTargetOs_Os216 |
eTargetOs_Os232 |
eTargetOs_NtWin32 |
eTargetOs_Unknown |


%%PageItemTitle%%

C_FileVersion Object

FileFlags Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileFlags() As EFileFlags

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

FileKind Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileKind() As EFileKind

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

FileName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property FileName() As String

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

FileVersion Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FileVersion() As String

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

FontKind Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property FontKind() As EFontKind

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

FileName
See Also ActiveInstall Professional Send Feedback on this topic.

Init Method

Syntax

Public Sub Init( _
   ByRef FileName As String _
)

Parameters

FileName

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

ProductVersion Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ProductVersion() As String

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FileVersion Object

TargetOs Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property TargetOs() As ETargetOs

See Also

C_FileVersion Object


%%PageItemTitle%%

C_FormPos Members

C_FormPos Object

For a list of all members defined in this module, see C_FormPos members.

See Also

C_FormPos Members


%%PageItemTitle%% $$Members$$

C_FormPos Members

C_FormPos Object Members

Public Methods

Public Method GetPosition
Public Method Init
Public Method SavePosition

Public Properties

Public Property AppSettings
Public Property CenteredByDefault
Public Property KeyName
Public Property NeverStartMinimized

See Also

C_FormPos Overview


%%PageItemTitle%%

C_FormPos Object

AppSettings Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AppSettings() As C_Settings

See Also

C_FormPos Object


%%PageItemTitle%%

C_FormPos Object

CenteredByDefault Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CenteredByDefault() As Boolean

See Also

C_FormPos Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EErrFormRestore Enumeration

Members

Member | Description
eErrFormRestore_NotInitialized |
eErrFormRestore_InvalidAppSettingsObject |
eErrFormRestore_InvalidKeyName |
eErrFormRestore_ComponentFailure |


%%PageItemTitle%%

C_FormPos Object

FormObject
See Also ActiveInstall Professional Send Feedback on this topic.

GetPosition Method

Syntax

Public Sub GetPosition( _
   ByRef FormObject As Form _
)

Parameters

FormObject

See Also

C_FormPos Object


%%PageItemTitle%%

C_FormPos Object

AppSettings
CenteredByDefault
See Also ActiveInstall Professional Send Feedback on this topic.

Init Method

Syntax

Public Sub Init( _
   ByRef AppSettings As C_Settings, _
   Optional ByRef CenteredByDefault As Boolean = True _
)

Parameters

AppSettings
CenteredByDefault

See Also

C_FormPos Object


%%PageItemTitle%%

C_FormPos Object

KeyName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property KeyName() As String

See Also

C_FormPos Object


%%PageItemTitle%%

C_FormPos Object

NeverStartMinimized Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property NeverStartMinimized() As Boolean

See Also

C_FormPos Object


%%PageItemTitle%%

C_FormPos Object

FormObject
See Also ActiveInstall Professional Send Feedback on this topic.

SavePosition Method

Syntax

Public Sub SavePosition( _
   ByRef FormObject As Form _
)

Parameters

FormObject

See Also

C_FormPos Object


%%PageItemTitle%%

C_GCommonDialog Members

C_GCommonDialog Object

For a list of all members defined in this module, see C_GCommonDialog members.

See Also

C_GCommonDialog Members


%%PageItemTitle%% $$Members$$

C_GCommonDialog Members

C_GCommonDialog Object Members

Public Methods

Public Method DialogHook
Public Method VBChooseColor
Public Method VBChooseFont
Public Method VBGetFileTitle
Public Method VBGetOpenFileName
Public Method VBGetOpenFileName2
Public Method VBGetSaveFileName
Public Method VBGetSaveFileName2
Public Method VBPageSetupDlg
Public Method VBPageSetupDlg2
Public Method VBPrintDlg

Public Properties

Public Property APIReturn
Public Property CustomColor
Public Property ExtendedError

See Also

C_GCommonDialog Overview


%%PageItemTitle%%

C_GCommonDialog Object

APIReturn Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property APIReturn() As Long

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

i
See Also ActiveInstall Professional Send Feedback on this topic.

CustomColor Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomColor( _
   ByRef i As Integer _
) As Long

Parameters

i

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

hDlg
msg
wParam
lParam
See Also ActiveInstall Professional Send Feedback on this topic.

DialogHook Method

Syntax

Public Function DialogHook( _
   ByVal hDlg As Long, _
   ByVal msg As Long, _
   ByVal wParam As Long, _
   ByVal lParam As Long _
) As Variant

Parameters

hDlg
msg
wParam
lParam

See Also

C_GCommonDialog Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EChooseColor Enumeration

Members

Member | Description
CC_RGBINIT |
CC_FULLOPEN |
CC_PREVENTFULLOPEN |
CC_ColorShowHelp |
CC_SOLIDCOLOR |
CC_ANYCOLOR |
CC_ENABLEHOOK |
CC_ENABLETEMPLATE |
CC_ENABLETEMPLATEHANDLE |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EChooseFont Enumeration

Members

Member | Description
CF_SCREENFONTS |
CF_PRINTERFONTS |
CF_BOTH |
CF_FONTSHOWHELP |
CF_USESTYLE |
CF_EFFECTS |
CF_ANSIONLY |
CF_NOVECTORFONTS |
CF_NOOEMFONTS |
CF_NOSIMULATIONS |
CF_LIMITSIZE |
CF_FIXEDPITCHONLY |
CF_WYSIWYG |
CF_FORCEFONTEXIST |
CF_SCALABLEONLY |
CF_TTONLY |
CF_NOFACESEL |
CF_NOSTYLESEL |
CF_NOSIZESEL |
CF_SELECTSCRIPT |
CF_NOSCRIPTSEL |
CF_NOVERTFONTS |
CF_INITTOLOGFONTSTRUCT |
CF_APPLY |
CF_ENABLEHOOK |
CF_ENABLETEMPLATE |
CF_ENABLETEMPLATEHANDLE |
CF_FontNotSupported |
CF_WYSIWYG_C |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EDialogError Enumeration

Members

Member | Description
CDERR_DIALOGFAILURE |
CDERR_GENERALCODES |
CDERR_STRUCTSIZE |
CDERR_INITIALIZATION |
CDERR_NOTEMPLATE |
CDERR_NOHINSTANCE |
CDERR_LOADSTRFAILURE |
CDERR_FINDRESFAILURE |
CDERR_LOADRESFAILURE |
CDERR_LOCKRESFAILURE |
CDERR_MEMALLOCFAILURE |
CDERR_MEMLOCKFAILURE |
CDERR_NOHOOK |
CDERR_REGISTERMSGFAIL |
PDERR_PRINTERCODES |
PDERR_SETUPFAILURE |
PDERR_PARSEFAILURE |
PDERR_RETDEFFAILURE |
PDERR_LOADDRVFAILURE |
PDERR_GETDEVMODEFAIL |
PDERR_INITFAILURE |
PDERR_NODEVICES |
PDERR_NODEFAULTPRN |
PDERR_DNDMMISMATCH |
PDERR_CREATEICFAILURE |
PDERR_PRINTERNOTFOUND |
PDERR_DEFAULTDIFFERENT |
CFERR_CHOOSEFONTCODES |
CFERR_NOFONTS |
CFERR_MAXLESSTHANMIN |
FNERR_FILENAMECODES |
FNERR_SUBCLASSFAILURE |
FNERR_INVALIDFILENAME |
FNERR_BUFFERTOOSMALL |
CCERR_CHOOSECOLORCODES |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EErrorCommonDialog Enumeration

Members

Member | Description
eeBaseCommonDialog |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFontType Enumeration

Members

Member | Description
SIMULATED_FONTTYPE |
PRINTER_FONTTYPE |
SCREEN_FONTTYPE |
BOLD_FONTTYPE |
ITALIC_FONTTYPE |
REGULAR_FONTTYPE |
Simulated_FontType_C |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EOpenFile Enumeration

Members

Member | Description
OFN_READONLY |
OFN_OVERWRITEPROMPT |
OFN_HIDEREADONLY |
OFN_NOCHANGEDIR |
OFN_SHOWHELP |
OFN_ENABLEHOOK |
OFN_ENABLETEMPLATE |
OFN_ENABLETEMPLATEHANDLE |
OFN_NOVALIDATE |
OFN_ALLOWMULTISELECT |
OFN_EXTENSIONDIFFERENT |
OFN_PATHMUSTEXIST |
OFN_FILEMUSTEXIST |
OFN_CREATEPROMPT |
OFN_SHAREAWARE |
OFN_NOREADONLYRETURN |
OFN_NOTESTFILECREATE |
OFN_NONETWORKBUTTON |
OFN_NOLONGNAMES |
OFN_EXPLORER |
OFN_NODEREFERENCELINKS |
OFN_LONGNAMES |
OFN_ENABLEINCLUDENOTIFY |
OFN_ENABLESIZING |
OFN_NOREADONLYRETURN_C |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

eOrientation Enumeration

Members

Member | Description
eoPortrait |
eoLandscape |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EPageSetup Enumeration

Members

Member | Description
PSD_DEFAULTMINMARGINS |
PSD_INWININIINTLMEASURE |
PSD_MINMARGINS |
PSD_MARGINS |
PSD_INTHOUSANDTHSOFINCHES |
PSD_INHUNDREDTHSOFMILLIMETERS |
PSD_DISABLEMARGINS |
PSD_DISABLEPRINTER |
PSD_NOWARNING |
PSD_DISABLEORIENTATION |
PSD_RETURNDEFAULT |
PSD_DISABLEPAPER |
PSD_SHOWHELP |
PSD_ENABLEPAGESETUPHOOK |
PSD_ENABLEPAGESETUPTEMPLATE |
PSD_ENABLEPAGESETUPTEMPLATEHANDLE |
PSD_ENABLEPAGEPAINTHOOK |
PSD_DISABLEPAGEPAINTING |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EPageSetupUnits Enumeration

Members

Member | Description
epsuInches |
epsuMillimeters |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EPaperSize Enumeration

Members

Member | Description
epsLetter |
epsLetterSmall |
epsTabloid |
epsLedger |
epsLegal |
epsStatement |
epsExecutive |
epsA3 |
epsA4 |
epsA4Small |
epsA5 |
epsB4 |
epsB5 |
epsFolio |
epsQuarto |
eps10x14 |
eps11x17 |
epsNote |
epsEnv9 |
epsEnv10 |
epsEnv11 |
epsEnv12 |
epsEnv14 |
epsCSheet |
epsDSheet |
epsESheet |
epsEnvDL |
epsEnvC3 |
epsEnvC4 |
epsEnvC5 |
epsEnvC6 |
epsEnvC65 |
epsEnvB4 |
epsEnvB5 |
epsEnvB6 |
epsEnvItaly |
epsenvmonarch |
epsEnvPersonal |
epsFanfoldUS |
epsFanfoldStdGerman |
epsFanfoldLglGerman |
epsUser |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EPrintDialog Enumeration

Members

Member | Description
PD_ALLPAGES |
PD_SELECTION |
PD_PAGENUMS |
PD_NOSELECTION |
PD_NOPAGENUMS |
PD_COLLATE |
PD_PRINTTOFILE |
PD_PRINTSETUP |
PD_NOWARNING |
PD_RETURNDC |
PD_RETURNIC |
PD_RETURNDEFAULT |
PD_SHOWHELP |
PD_ENABLEPRINTHOOK |
PD_ENABLESETUPHOOK |
PD_ENABLEPRINTTEMPLATE |
PD_ENABLESETUPTEMPLATE |
PD_ENABLEPRINTTEMPLATEHANDLE |
PD_ENABLESETUPTEMPLATEHANDLE |
PD_USEDEVMODECOPIES |
PD_USEDEVMODECOPIESANDCOLLATE |
PD_DISABLEPRINTTOFILE |
PD_HIDEPRINTTOFILE |
PD_NONETWORKBUTTON |
PD_ENABLESETUPTEMPLATE_C |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EPrintQuality Enumeration

Members

Member | Description
epqDraft |
epqLow |
epqMedium |
epqHigh |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EPrintRange Enumeration

Members

Member | Description
eprAll |
eprPageNumbers |
eprSelection |


%%PageItemTitle%%

C_GCommonDialog Object

ExtendedError Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ExtendedError() As Long

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

Color
AnyColor
FullOpen
DisableFullOpen
Owner
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBChooseColor Method

Syntax

Public Function VBChooseColor( _
   ByRef Color As Long, _
   Optional ByRef AnyColor As Boolean = True, _
   Optional ByRef FullOpen As Boolean = False, _
   Optional ByRef DisableFullOpen As Boolean = False, _
   Optional ByRef Owner As Long = -1, _
   Optional ByRef Flags As Long, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

Color
AnyColor
FullOpen
DisableFullOpen
Owner
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

CurFont
PrinterDC
Owner
Color
MinSize
MaxSize
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBChooseFont Method

Syntax

Public Function VBChooseFont( _
   ByRef CurFont As Font, _
   Optional ByRef PrinterDC As Long = -1, _
   Optional ByRef Owner As Long = -1, _
   Optional ByRef Color As Long = vbBlack, _
   Optional ByRef MinSize As Long = 0, _
   Optional ByRef MaxSize As Long = 0, _
   Optional ByRef Flags As Long = 0, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

CurFont
PrinterDC
Owner
Color
MinSize
MaxSize
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

sFile
See Also ActiveInstall Professional Send Feedback on this topic.

VBGetFileTitle Method

Syntax

Public Function VBGetFileTitle( _
   ByRef sFile As String _
) As String

Parameters

sFile

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

FileName
FileTitle
FileMustExist
MultiSelect
ReadOnly
HideReadOnly
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBGetOpenFileName Method

Syntax

Public Function VBGetOpenFileName( _
   ByRef FileName As String, _
   Optional ByRef FileTitle As String, _
   Optional ByRef FileMustExist As Boolean = True, _
   Optional ByRef MultiSelect As Boolean = False, _
   Optional ByRef ReadOnly As Boolean = False, _
   Optional ByRef HideReadOnly As Boolean = False, _
   Optional ByRef Filter As String = "All (*.*)| *.*", _
   Optional ByRef FilterIndex As Long = 1, _
   Optional ByRef InitDir As String, _
   Optional ByRef DlgTitle As String, _
   Optional ByRef DefaultExt As String, _
   Optional ByRef Owner As Long = -1, _
   Optional ByRef Flags As Long = 0, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

FileName
FileTitle
FileMustExist
MultiSelect
ReadOnly
HideReadOnly
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

FileName
FileTitle
FileMustExist
MultiSelect
ReadOnly
HideReadOnly
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
hInstance
TemplateName
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBGetOpenFileName2 Method

Syntax

Public Function VBGetOpenFileName2( _
   ByRef FileName As String, _
   Optional ByRef FileTitle As String, _
   Optional ByRef FileMustExist As Boolean = True, _
   Optional ByRef MultiSelect As Boolean = False, _
   Optional ByRef ReadOnly As Boolean = False, _
   Optional ByRef HideReadOnly As Boolean = False, _
   Optional ByRef Filter As String = "All (*.*)| *.*", _
   Optional ByRef FilterIndex As Long = 1, _
   Optional ByRef InitDir As String, _
   Optional ByRef DlgTitle As String, _
   Optional ByRef DefaultExt As String, _
   Optional ByRef Owner As Long = -1, _
   Optional ByRef Flags As Long = 0, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef hInstance As Long = 0, _
   Optional ByRef TemplateName As Long = 0, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

FileName
FileTitle
FileMustExist
MultiSelect
ReadOnly
HideReadOnly
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
hInstance
TemplateName
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

FileName
FileTitle
OverWritePrompt
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBGetSaveFileName Method

Syntax

Public Function VBGetSaveFileName( _
   ByRef FileName As String, _
   Optional ByRef FileTitle As String, _
   Optional ByRef OverWritePrompt As Boolean = True, _
   Optional ByRef Filter As String = "All (*.*)| *.*", _
   Optional ByRef FilterIndex As Long = 1, _
   Optional ByRef InitDir As String, _
   Optional ByRef DlgTitle As String, _
   Optional ByRef DefaultExt As String, _
   Optional ByRef Owner As Long = -1, _
   Optional ByRef Flags As Long, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

FileName
FileTitle
OverWritePrompt
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

FileName
FileTitle
OverWritePrompt
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
hInstance
TemplateName
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBGetSaveFileName2 Method

Syntax

Public Function VBGetSaveFileName2( _
   ByRef FileName As String, _
   Optional ByRef FileTitle As String, _
   Optional ByRef OverWritePrompt As Boolean = True, _
   Optional ByRef Filter As String = "All (*.*)| *.*", _
   Optional ByRef FilterIndex As Long = 1, _
   Optional ByRef InitDir As String, _
   Optional ByRef DlgTitle As String, _
   Optional ByRef DefaultExt As String, _
   Optional ByRef Owner As Long = -1, _
   Optional ByRef Flags As Long, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef hInstance As Long = 0, _
   Optional ByRef TemplateName As Long = 0, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

FileName
FileTitle
OverWritePrompt
Filter
FilterIndex
InitDir
DlgTitle
DefaultExt
Owner
Flags
Hook
hInstance
TemplateName
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

Owner
DisableMargins
DisableOrientation
DisablePaper
DisablePrinter
LeftMargin
MinLeftMargin
RightMargin
MinRightMargin
TopMargin
MinTopMargin
BottomMargin
MinBottomMargin
PaperSize
Orientation
PrintQuality
Units
Printer
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBPageSetupDlg Method

Syntax

Public Function VBPageSetupDlg( _
   Optional ByRef Owner As Long, _
   Optional ByRef DisableMargins As Boolean, _
   Optional ByRef DisableOrientation As Boolean, _
   Optional ByRef DisablePaper As Boolean, _
   Optional ByRef DisablePrinter As Boolean, _
   Optional ByRef LeftMargin As Long, _
   Optional ByRef MinLeftMargin As Long, _
   Optional ByRef RightMargin As Long, _
   Optional ByRef MinRightMargin As Long, _
   Optional ByRef TopMargin As Long, _
   Optional ByRef MinTopMargin As Long, _
   Optional ByRef BottomMargin As Long, _
   Optional ByRef MinBottomMargin As Long, _
   Optional ByRef PaperSize As EPaperSize = epsLetter, _
   Optional ByRef Orientation As eOrientation = eoPortrait, _
   Optional ByRef PrintQuality As EPrintQuality = epqDraft, _
   Optional ByRef Units As EPageSetupUnits = epsuInches, _
   Optional ByRef Printer As Object, _
   Optional ByRef Flags As Long, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

Owner
DisableMargins
DisableOrientation
DisablePaper
DisablePrinter
LeftMargin
MinLeftMargin
RightMargin
MinRightMargin
TopMargin
MinTopMargin
BottomMargin
MinBottomMargin
PaperSize
Value Description
epsLetter
epsLetterSmall
epsTabloid
epsLedger
epsLegal
epsStatement
epsExecutive
epsA3
epsA4
epsA4Small
epsA5
epsB4
epsB5
epsFolio
epsQuarto
eps10x14
eps11x17
epsNote
epsEnv9
epsEnv10
epsEnv11
epsEnv12
epsEnv14
epsCSheet
epsDSheet
epsESheet
epsEnvDL
epsEnvC3
epsEnvC4
epsEnvC5
epsEnvC6
epsEnvC65
epsEnvB4
epsEnvB5
epsEnvB6
epsEnvItaly
epsenvmonarch
epsEnvPersonal
epsFanfoldUS
epsFanfoldStdGerman
epsFanfoldLglGerman
epsUser
Orientation
Value Description
eoPortrait
eoLandscape
PrintQuality
Value Description
epqDraft
epqLow
epqMedium
epqHigh
Units
Value Description
epsuInches
epsuMillimeters
Printer
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

Owner
DisableMargins
DisableOrientation
DisablePaper
DisablePrinter
LeftMargin
MinLeftMargin
RightMargin
MinRightMargin
TopMargin
MinTopMargin
BottomMargin
MinBottomMargin
PaperSize
Orientation
PrintQuality
Units
Printer
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBPageSetupDlg2 Method

Syntax

Public Function VBPageSetupDlg2( _
   Optional ByRef Owner As Long, _
   Optional ByRef DisableMargins As Boolean, _
   Optional ByRef DisableOrientation As Boolean, _
   Optional ByRef DisablePaper As Boolean, _
   Optional ByRef DisablePrinter As Boolean, _
   Optional ByRef LeftMargin As Single, _
   Optional ByRef MinLeftMargin As Single, _
   Optional ByRef RightMargin As Single, _
   Optional ByRef MinRightMargin As Single, _
   Optional ByRef TopMargin As Single, _
   Optional ByRef MinTopMargin As Single, _
   Optional ByRef BottomMargin As Single, _
   Optional ByRef MinBottomMargin As Single, _
   Optional ByRef PaperSize As EPaperSize = epsLetter, _
   Optional ByRef Orientation As eOrientation = eoPortrait, _
   Optional ByRef PrintQuality As EPrintQuality = epqDraft, _
   Optional ByRef Units As EPageSetupUnits = epsuInches, _
   Optional ByRef Printer As Object, _
   Optional ByRef Flags As Long, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

Owner
DisableMargins
DisableOrientation
DisablePaper
DisablePrinter
LeftMargin
MinLeftMargin
RightMargin
MinRightMargin
TopMargin
MinTopMargin
BottomMargin
MinBottomMargin
PaperSize
Value Description
epsLetter
epsLetterSmall
epsTabloid
epsLedger
epsLegal
epsStatement
epsExecutive
epsA3
epsA4
epsA4Small
epsA5
epsB4
epsB5
epsFolio
epsQuarto
eps10x14
eps11x17
epsNote
epsEnv9
epsEnv10
epsEnv11
epsEnv12
epsEnv14
epsCSheet
epsDSheet
epsESheet
epsEnvDL
epsEnvC3
epsEnvC4
epsEnvC5
epsEnvC6
epsEnvC65
epsEnvB4
epsEnvB5
epsEnvB6
epsEnvItaly
epsenvmonarch
epsEnvPersonal
epsFanfoldUS
epsFanfoldStdGerman
epsFanfoldLglGerman
epsUser
Orientation
Value Description
eoPortrait
eoLandscape
PrintQuality
Value Description
epqDraft
epqLow
epqMedium
epqHigh
Units
Value Description
epsuInches
epsuMillimeters
Printer
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_GCommonDialog Object

hDC
PrintRange
DisablePageNumbers
FromPage
ToPage
DisableSelection
Copies
ShowPrintToFile
DisablePrintToFile
PrintToFile
Collate
PreventWarning
Owner
Printer
Flags
Hook
EventSink
See Also ActiveInstall Professional Send Feedback on this topic.

VBPrintDlg Method

Syntax

Public Function VBPrintDlg( _
   ByRef hDC As Long, _
   Optional ByRef PrintRange As EPrintRange = eprAll, _
   Optional ByRef DisablePageNumbers As Boolean, _
   Optional ByRef FromPage As Long = 1, _
   Optional ByRef ToPage As Long = &HFFFF, _
   Optional ByRef DisableSelection As Boolean, _
   Optional ByRef Copies As Integer, _
   Optional ByRef ShowPrintToFile As Boolean, _
   Optional ByRef DisablePrintToFile As Boolean = True, _
   Optional ByRef PrintToFile As Boolean, _
   Optional ByRef Collate As Boolean, _
   Optional ByRef PreventWarning As Boolean, _
   Optional ByRef Owner As Long, _
   Optional ByRef Printer As Object, _
   Optional ByRef Flags As Long, _
   Optional ByRef Hook As Boolean = False, _
   Optional ByRef EventSink As C_CommonDialog _
) As Boolean

Parameters

hDC
PrintRange
Value Description
eprAll
eprPageNumbers
eprSelection
DisablePageNumbers
FromPage
ToPage
DisableSelection
Copies
ShowPrintToFile
DisablePrintToFile
PrintToFile
Collate
PreventWarning
Owner
Printer
Flags
Hook
EventSink

See Also

C_GCommonDialog Object


%%PageItemTitle%%

C_HTTP_Post Members

C_HTTP_Post Object

For a list of all members defined in this module, see C_HTTP_Post members.

See Also

C_HTTP_Post Members


%%PageItemTitle%% $$Members$$

C_HTTP_Post Members

C_HTTP_Post Object Members

Public Methods

Public Method GetURLAsBytes
Public Method GetURLAsFile
Public Method GetURLAsString
Public Method Reset

Public Properties

Public Property CustomProxySettings
Public Property LastError
Public Property Password
Public Property PostItems
Public Property ProxyPort
Public Property ProxyServer
Public Property TimeOut
Public Property UseProxy
Public Property UserName

See Also

C_HTTP_Post Overview


%%PageItemTitle%%

C_HTTP_Post Object

CustomProxySettings Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CustomProxySettings() As Boolean

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

URL
See Also ActiveInstall Professional Send Feedback on this topic.

GetURLAsBytes Method

Syntax

Public Function GetURLAsBytes( _
   ByRef URL As String _
) As Variant

Parameters

URL

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

URL
BinaryFile
LocalFileName
See Also ActiveInstall Professional Send Feedback on this topic.

GetURLAsFile Method

Syntax

Public Function GetURLAsFile( _
   ByRef URL As String, _
   ByRef BinaryFile As Boolean, _
   ByRef LocalFileName As String _
) As Boolean

Parameters

URL
BinaryFile
LocalFileName

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

URL
See Also ActiveInstall Professional Send Feedback on this topic.

GetURLAsString Method

Syntax

Public Function GetURLAsString( _
   ByRef URL As String _
) As String

Parameters

URL

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

LastError Property

Property type

Read-write property

Syntax (Visual Basic)

Public LastError As String

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

Password Property

Property type

Read-write property

Syntax (Visual Basic)

Public Password As String

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

PostItems Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property PostItems() As Collection

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

ProxyPort Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProxyPort() As Long

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

ProxyServer Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ProxyServer() As String

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

Reset Method

Syntax

Public Sub Reset()

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

TimeOut Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property TimeOut() As Long

See Also

C_HTTP_Post Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

TransferTypeEnum Enumeration

Members

Member | Description
FTP |
HTTP |
HTTPS |


%%PageItemTitle%%

C_HTTP_Post Object

UseProxy Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property UseProxy() As Boolean

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Post Object

UserName Property

Property type

Read-write property

Syntax (Visual Basic)

Public UserName As String

See Also

C_HTTP_Post Object


%%PageItemTitle%%

C_HTTP_Transfer Members

C_HTTP_Transfer Object

For a list of all members defined in this module, see C_HTTP_Transfer members.

See Also

C_HTTP_Transfer Members


%%PageItemTitle%% $$Members$$

C_HTTP_Transfer Members

C_HTTP_Transfer Object Members

Public Methods

Public Method EncodeString
Public Method GetURL
Public Method GetURLToFile
Public Method InitialiseSession
Public Method Reset
Public Method TagClass
Public Method TagField
Public Method TerminateSession
Public Method TranslateErrorCode

Public Properties

Public Property Buffer
Public Property CustomProxySettings
Public Property PostData
Public Property PostItems
Public Property ProxyPort
Public Property ProxyServer
Public Property RequestMethod
Public Property StatusCode
Public Property StatusText
Public Property UseProxy

See Also

C_HTTP_Transfer Overview


%%PageItemTitle%%

C_HTTP_Transfer Object

Buffer Property

Property type

Read-write property

Syntax (Visual Basic)

Public Buffer As Variant

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

CustomProxySettings Property

Property type

Read-write property

Syntax (Visual Basic)

Public CustomProxySettings As Boolean

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

Source
See Also ActiveInstall Professional Send Feedback on this topic.

EncodeString Method

Syntax

Public Function EncodeString( _
   ByRef Source As String _
) As String

Parameters

Source

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

URL
DataType
RequiredStatus
See Also ActiveInstall Professional Send Feedback on this topic.

GetURL Method

Syntax

Public Function GetURL( _
   ByVal URL As String, _
   Optional ByRef DataType As itDataType = itString, _
   Optional ByRef RequiredStatus As String = "2*" _
) As Boolean

Parameters

URL
DataType
Value Description
itString
itBytes
RequiredStatus

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

URL
FileName
RequiredStatus
See Also ActiveInstall Professional Send Feedback on this topic.

GetURLToFile Method

Syntax

Public Function GetURLToFile( _
   ByVal URL As String, _
   ByVal FileName As String, _
   Optional ByRef RequiredStatus As String = "2*" _
) As Boolean

Parameters

URL
FileName
RequiredStatus

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

InitialiseSession Method

Syntax

Public Sub InitialiseSession()

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

itDataType Enumeration

Members

Member | Description
itString |
itBytes |


%%PageItemTitle%%

C_HTTP_Transfer Object

PostData Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property PostData() As String

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

PostItems Property

Property type

Read-write property

Syntax (Visual Basic)

Public PostItems As Collection

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

ProxyPort Property

Property type

Read-write property

Syntax (Visual Basic)

Public ProxyPort As Long

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

ProxyServer Property

Property type

Read-write property

Syntax (Visual Basic)

Public ProxyServer As String

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

RequestMethod Property

Property type

Read-write property

Syntax (Visual Basic)

Public RequestMethod As RequestMethodEnum

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

RequestMethodEnum Enumeration

Members

Member | Description
rmGet |
rmPost |
rmPut |


%%PageItemTitle%%

C_HTTP_Transfer Object

Reset Method

Syntax

Public Sub Reset()

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

StatusCode Property

Property type

Read-write property

Syntax (Visual Basic)

Public StatusCode As Long

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

StatusText Property

Property type

Read-write property

Syntax (Visual Basic)

Public StatusText As String

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

strTag
See Also ActiveInstall Professional Send Feedback on this topic.

TagClass Method

Syntax

Public Function TagClass( _
   ByVal strTag As String _
) As String

Parameters

strTag

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

strTag
See Also ActiveInstall Professional Send Feedback on this topic.

TagField Method

Syntax

Public Function TagField( _
   ByVal strTag As String _
) As String

Parameters

strTag

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

TerminateSession Method

Syntax

Public Sub TerminateSession()

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

lErrorCode
See Also ActiveInstall Professional Send Feedback on this topic.

TranslateErrorCode Method

Syntax

Public Function TranslateErrorCode( _
   ByVal lErrorCode As Long _
) As String

Parameters

lErrorCode

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_HTTP_Transfer Object

UseProxy Property

Property type

Read-write property

Syntax (Visual Basic)

Public UseProxy As Boolean

See Also

C_HTTP_Transfer Object


%%PageItemTitle%%

C_Resources Members

C_Resources Object

For a list of all members defined in this module, see C_Resources members.

See Also

C_Resources Members


%%PageItemTitle%% $$Members$$

C_Resources Members

C_Resources Object Members

Public Methods

Public Method ClearUp
Public Method GetResourceNames
Public Method GetResourceTypes
Public Method UnloadModule

Public Properties

Public Property File
Public Property hModule
Public Property IndexOfResourceType
Public Property ResourceName
Public Property ResourceNameCount
Public Property ResourceType
Public Property ResourceTypeCount
Public Property ResourceTypeName

See Also

C_Resources Overview


%%PageItemTitle%%

C_Resources Object

ClearUp Method

Syntax

Public Sub ClearUp()

See Also

C_Resources Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

CRStandardResourceTypeConstants Enumeration

Members

Member | Description
crCursor |
crBitmap |
crIcon |
crMenu |
crDialog |
crString |
crFontDir |
crFont |
crAccelerator |
crRCData |
crMessageTable |
crGroupCursor |
crGroupIcon |
crVersion |
crDlgInclude |
crPlugPlay |
crVXD |
crAniCursor |
crAniIcon |
crHTML |


%%PageItemTitle%%

C_Resources Object

File Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property File() As String

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

IIndex
See Also ActiveInstall Professional Send Feedback on this topic.

GetResourceNames Method

Syntax

Public Function GetResourceNames( _
   ByVal IIndex As Long _
) As Long

Parameters

IIndex

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

GetResourceTypes Method

Syntax

Public Function GetResourceTypes() As Long

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

hModule Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property hModule() As Long

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

eType
See Also ActiveInstall Professional Send Feedback on this topic.

IndexOfResourceType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property IndexOfResourceType( _
   ByRef eType As CRStandardResourceTypeConstants _
) As Long

Parameters

eType
Value Description
crCursor
crBitmap
crIcon
crMenu
crDialog
crString
crFontDir
crFont
crAccelerator
crRCData
crMessageTable
crGroupCursor
crGroupIcon
crVersion
crDlgInclude
crPlugPlay
crVXD
crAniCursor
crAniIcon
crHTML

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

iTypeIndex
iNameIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ResourceName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResourceName( _
   ByVal iTypeIndex As Long, _
   ByVal iNameIndex As Long _
) As Variant

Parameters

iTypeIndex
iNameIndex

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

iTypeIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ResourceNameCount Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResourceNameCount( _
   ByVal iTypeIndex As Long _
) As Long

Parameters

iTypeIndex

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

IIndex
See Also ActiveInstall Professional Send Feedback on this topic.

ResourceType Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResourceType( _
   ByVal IIndex As Long _
) As Variant

Parameters

IIndex

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

ResourceTypeCount Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResourceTypeCount() As Long

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

eType
See Also ActiveInstall Professional Send Feedback on this topic.

ResourceTypeName Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property ResourceTypeName( _
   ByVal eType As CRStandardResourceTypeConstants _
) As String

Parameters

eType
Value Description
crCursor
crBitmap
crIcon
crMenu
crDialog
crString
crFontDir
crFont
crAccelerator
crRCData
crMessageTable
crGroupCursor
crGroupIcon
crVersion
crDlgInclude
crPlugPlay
crVXD
crAniCursor
crAniIcon
crHTML

See Also

C_Resources Object


%%PageItemTitle%%

C_Resources Object

UnloadModule Method

Syntax

Public Sub UnloadModule()

See Also

C_Resources Object


%%PageItemTitle%%

C_ScrollBars Members

C_ScrollBars Object

For a list of all members defined in this module, see C_ScrollBars members.

See Also

C_ScrollBars Members


%%PageItemTitle%% $$Members$$

C_ScrollBars Members

C_ScrollBars Object Members

Public Methods

Public Method Create

Public Properties

Public Property CanBeFlat
Public Property Enabled
Public Property LargeChange
Public Property Max
Public Property Min
Public Property Orientation
Public Property SmallChange
Public Property Style
Public Property Value
Public Property Visible

Events

Public Event Change
Public Event Scroll

See Also

C_ScrollBars Overview


%%PageItemTitle%%

C_ScrollBars Object

CanBeFlat Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property CanBeFlat() As Boolean

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Change Event

Syntax

Public Event Change( _
   ByRef eBar As EFSScrollBarConstants1 _
)

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

hWndA
See Also ActiveInstall Professional Send Feedback on this topic.

Create Method

Syntax

Public Sub Create( _
   ByVal hWndA As Long _
)

Parameters

hWndA

See Also

C_ScrollBars Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFSOrientationConstants1 Enumeration

Members

Member | Description
efsoHorizontal |
efsoVertical |
efsoBoth |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFSScrollBarConstants1 Enumeration

Members

Member | Description
efsHorizontal |
efsVertical |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EFSStyleConstants1 Enumeration

Members

Member | Description
efsRegular |
efsEncarta |
efsFlat |


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Enabled Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Enabled( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Boolean

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

LargeChange Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property LargeChange( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Long

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Max Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Max( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Long

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Min Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Min( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Long

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

Orientation Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Orientation() As EFSOrientationConstants1

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Scroll Event

Syntax

Public Event Scroll( _
   ByRef eBar As EFSScrollBarConstants1 _
)

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

SmallChange Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SmallChange( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Long

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

Style Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Style() As EFSStyleConstants1

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Value Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Value( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Long

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_ScrollBars Object

eBar
See Also ActiveInstall Professional Send Feedback on this topic.

Visible Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Visible( _
   ByVal eBar As EFSScrollBarConstants1 _
) As Boolean

Parameters

eBar
Value Description
efsHorizontal
efsVertical

See Also

C_ScrollBars Object


%%PageItemTitle%%

C_Settings Members

C_Settings Object

For a list of all members defined in this module, see C_Settings members.

See Also

C_Settings Members


%%PageItemTitle%% $$Members$$

C_Settings Members

C_Settings Object Members

Public Methods

Public Method DeleteSetting
Public Method GetAllKeys
Public Method GetAllKeysEx
Public Method GetSetting
Public Method Init
Public Method SaveSetting

Public Properties

Public Property AppName
Public Property CompanyName
Public Property MainBranch
Public Property RootKey

See Also

C_Settings Overview


%%PageItemTitle%%

C_Settings Object

AppName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property AppName() As String

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

CompanyName Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property CompanyName() As String

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

Section
Key
See Also ActiveInstall Professional Send Feedback on this topic.

DeleteSetting Method

Syntax

Public Sub DeleteSetting( _
   ByRef Section As String, _
   Optional ByRef Key As String = "" _
)

Parameters

Section
Key

See Also

C_Settings Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EErrAppSettings Enumeration

Members

Member | Description
eErrAppSettings_InvalidAppName |
eErrAppSettings_InvalidCompanyName |
eErrAppSettings_InvalidMainBranch |
eErrAppSettings_InvalidRootKey |
eErrAppSettings_SaveSettingFailure |
eErrAppSettings_DeleteSettingFailure |
eErrAppSettings_GetAllKeysFailure |
eErrAppSettings_ComponentFailure |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ESettingsRoot Enumeration

Members

Member | Description
eSettingsRoot_HKeyCurrentUser |
eSettingsRoot_HKeyLocalMachine |


%%PageItemTitle%%

C_Settings Object

Section
Keys
See Also ActiveInstall Professional Send Feedback on this topic.

GetAllKeys Method

Syntax

Public Function GetAllKeys( _
   ByRef Section As String, _
   ByRef Keys() As String _
) As Boolean

Parameters

Section
Keys

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

Section
Keys
See Also ActiveInstall Professional Send Feedback on this topic.

GetAllKeysEx Method

Syntax

Public Sub GetAllKeysEx( _
   ByRef Section As String, _
   ByRef Keys() As String _
)

Parameters

Section
Keys

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

Section
Key
Default
See Also ActiveInstall Professional Send Feedback on this topic.

GetSetting Method

Syntax

Public Function GetSetting( _
   ByRef Section As String, _
   ByRef Key As String, _
   Optional ByRef Default As Variant = "" _
) As Variant

Parameters

Section
Key
Default

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

CompanyName
AppName
See Also ActiveInstall Professional Send Feedback on this topic.

Init Method

Syntax

Public Sub Init( _
   ByRef CompanyName As String, _
   ByRef AppName As String _
)

Parameters

CompanyName
AppName

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

MainBranch Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property MainBranch() As String

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

RootKey Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property RootKey() As ESettingsRoot

See Also

C_Settings Object


%%PageItemTitle%%

C_Settings Object

Section
Key
Setting
See Also ActiveInstall Professional Send Feedback on this topic.

SaveSetting Method

Syntax

Public Sub SaveSetting( _
   ByRef Section As String, _
   ByRef Key As String, _
   ByRef Setting As Variant _
)

Parameters

Section
Key
Setting

See Also

C_Settings Object


%%PageItemTitle%%

C_Splitter Members

C_Splitter Object

For a list of all members defined in this module, see C_Splitter members.

See Also

C_Splitter Members


%%PageItemTitle%% $$Members$$

C_Splitter Members

C_Splitter Object Members

Public Methods

Public Method SplitterFormMouseMove
Public Method SplitterFormMouseUp
Public Method SplitterMouseDown

Public Properties

Public Property Border
Public Property Orientation
Public Property SplitObject

See Also

C_Splitter Overview


%%PageItemTitle%%

C_Splitter Object

eBorderType
See Also ActiveInstall Professional Send Feedback on this topic.

Border Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Border( _
   ByVal eBorderType As ESplitBorderTypes _
) As Long

Parameters

eBorderType
Value Description
espbLeft
espbTop
espbRight
espbBottom

See Also

C_Splitter Object


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

eOrientationConstants Enumeration

Members

Member | Description
espVertical |
espHorizontal |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ESplitBorderTypes Enumeration

Members

Member | Description
espbLeft |
espbTop |
espbRight |
espbBottom |


%%PageItemTitle%%

C_Splitter Object

Orientation Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Orientation() As eOrientationConstants

See Also

C_Splitter Object


%%PageItemTitle%%

C_Splitter Object

SplitObject Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property SplitObject() As Object

See Also

C_Splitter Object


%%PageItemTitle%%

C_Splitter Object

x
y
See Also ActiveInstall Professional Send Feedback on this topic.

SplitterFormMouseMove Method

Syntax

Public Sub SplitterFormMouseMove( _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

x
y

See Also

C_Splitter Object


%%PageItemTitle%%

C_Splitter Object

x
y
See Also ActiveInstall Professional Send Feedback on this topic.

SplitterFormMouseUp Method

Syntax

Public Function SplitterFormMouseUp( _
   ByVal x As Long, _
   ByVal y As Long _
) As Boolean

Parameters

x
y

See Also

C_Splitter Object


%%PageItemTitle%%

C_Splitter Object

hwnd
x
y
See Also ActiveInstall Professional Send Feedback on this topic.

SplitterMouseDown Method

Syntax

Public Sub SplitterMouseDown( _
   ByVal hwnd As Long, _
   ByVal x As Long, _
   ByVal y As Long _
)

Parameters

hwnd
x
y

See Also

C_Splitter Object


%%PageItemTitle%%

M_API Members

M_API Standard Module

For a list of all members defined in this module, see M_API members.

See Also

M_API Members


%%PageItemTitle%% $$Members$$

M_API Members

M_API Standard Module Members

Public Methods

Public Method ClientRectToScreen
Public Method GET_X_LPARAM
Public Method GET_Y_LPARAM
Public Method GetClassNameEx
Public Method GetFileIcon
Public Method GetFileTypeName
Public Method GetProcAddress
Public Method GetWindowTextEx
Public Method HiByte
Public Method HiWord
Public Method IconToPicture
Public Method InIDE
Public Method LoByte
Public Method LoWord
Public Method MAKEINTRESOURCE
Public Method MAKELONG
Public Method MakeWord
Public Method Max
Public Method Min
Public Method NormalizeRect
Public Method PointInRect
Public Method PtrToStr
Public Method ScreenRectToClient
Public Method SetFileCreatedTime
Public Method SetFileModifedTime
Public Method StrToPtr
Public Method TranslateColor

See Also

M_API Overview


%%PageItemTitle%%

M_API Standard Module

hwnd
lpRect
See Also ActiveInstall Professional Send Feedback on this topic.

ClientRectToScreen Method

Syntax

Public Function ClientRectToScreen( _
   ByRef hwnd As Long, _
   ByRef lpRect As RECT _
) As Long

Parameters

hwnd
lpRect

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

CommonControlsEx UDT

UDT Members

Member | Type | Description
dwSize | Long |
dwICC | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

COPYDATASTRUCT UDT

UDT Members

Member | Type | Description
dwData | Long |
cbData | Long |
lpData | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

DELETEITEMSTRUCT UDT

UDT Members

Member | Type | Description
CtlType | Long |
CtlID | Long |
ItemID | Long |
hwndItem | Long |
ItemData | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

DRAWITEMSTRUCT UDT

UDT Members

Member | Type | Description
CtlType | Long |
CtlID | Long |
ItemID | Long |
itemAction | Long |
itemState | Long |
hwndItem | Long |
hDC | Long |
rcItem | RECT |
ItemData | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

DRAWTEXTPARAMS UDT

UDT Members

Member | Type | Description
cbSize | Long |
iTabLength | Long |
iLeftMargin | Long |
iRightMargin | Long |
uiLengthDrawn | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EGetIconTypeConstants Enumeration

Members

Member | Description
egitSmallIcon |
egitLargeIcon |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

FILETIME UDT

UDT Members

Member | Type | Description
dwLowDateTime | Long |
dwHighDateTime | Long |


%%PageItemTitle%%

M_API Standard Module

lParam
See Also ActiveInstall Professional Send Feedback on this topic.

GET_X_LPARAM Method

Syntax

Public Function GET_X_LPARAM( _
   ByRef lParam As Long _
) As Long

Parameters

lParam

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

lParam
See Also ActiveInstall Professional Send Feedback on this topic.

GET_Y_LPARAM Method

Syntax

Public Function GET_Y_LPARAM( _
   ByRef lParam As Long _
) As Long

Parameters

lParam

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

hwnd
See Also ActiveInstall Professional Send Feedback on this topic.

GetClassNameEx Method

Syntax

Public Function GetClassNameEx( _
   ByRef hwnd As Long _
) As String

Parameters

hwnd

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

sFile
EIconType
See Also ActiveInstall Professional Send Feedback on this topic.

GetFileIcon Method

Syntax

Public Function GetFileIcon( _
   ByVal sFile As String, _
   Optional ByVal EIconType As EGetIconTypeConstants = egitLargeIcon _
) As IPictureDisp

Parameters

sFile
EIconType
Value Description
egitSmallIcon
egitLargeIcon

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

sFile
See Also ActiveInstall Professional Send Feedback on this topic.

GetFileTypeName Method

Syntax

Public Function GetFileTypeName( _
   ByVal sFile As String _
) As String

Parameters

sFile

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

hProc
See Also ActiveInstall Professional Send Feedback on this topic.

GetProcAddress Method

Syntax

Public Function GetProcAddress( _
   ByVal hProc As Long _
) As Long

Parameters

hProc

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

hwnd
See Also ActiveInstall Professional Send Feedback on this topic.

GetWindowTextEx Method

Syntax

Public Function GetWindowTextEx( _
   ByRef hwnd As Long _
) As String

Parameters

hwnd

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

GUID UDT

UDT Members

Member | Type | Description
Data1 | Long |
Data2 | Integer |
Data3 | Integer |
Data4 | Byte |


%%PageItemTitle%%

M_API Standard Module

wParam
See Also ActiveInstall Professional Send Feedback on this topic.

HiByte Method

Syntax

Public Function HiByte( _
   ByVal wParam As Integer _
) As Integer

Parameters

wParam

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

dwValue
See Also ActiveInstall Professional Send Feedback on this topic.

HiWord Method

Syntax

Public Function HiWord( _
   ByVal dwValue As Long _
) As Long

Parameters

dwValue

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

hIcon
See Also ActiveInstall Professional Send Feedback on this topic.

IconToPicture Method

Syntax

Public Function IconToPicture( _
   ByVal hIcon As Long _
) As IPicture

Parameters

hIcon

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

InIDE Method

Syntax

Public Function InIDE() As Boolean

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

wParam
See Also ActiveInstall Professional Send Feedback on this topic.

LoByte Method

Syntax

Public Function LoByte( _
   ByVal wParam As Integer _
) As Integer

Parameters

wParam

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LOGFONT UDT

UDT Members

Member | Type | Description
lfHeight | Long |
lfWidth | Long |
lfEscapement | Long |
lfOrientation | Long |
lfWeight | Long |
lfItalic | Byte |
lfUnderline | Byte |
lfStrikeOut | Byte |
lfCharSet | Byte |
lfOutPrecision | Byte |
lfClipPrecision | Byte |
lfQuality | Byte |
lfPitchAndFamily | Byte |
lfFaceName | String |


%%PageItemTitle%%

M_API Standard Module

dwValue
See Also ActiveInstall Professional Send Feedback on this topic.

LoWord Method

Syntax

Public Function LoWord( _
   ByVal dwValue As Long _
) As Long

Parameters

dwValue

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVCOLUMN_Format Enumeration

Members

Member | Description
LVCFMT_LEFT |
LVCFMT_RIGHT |
LVCFMT_CENTER |
LVCFMT_JUSTIFYMASK |
LVCFMT_IMAGE |
LVCFMT_BITMAP_ON_RIGHT |
LVCFMT_COL_HAS_IMAGES |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVCOLUMN_Mask Enumeration

Members

Member | Description
LVCF_FMT |
LVCF_WIDTH |
LVCF_TEXT |
LVCF_SUBITEM |
LVCF_IMAGE |
LVCF_ORDER |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVCOLUMN UDT

UDT Members

Member | Type | Description
Mask | LVCOLUMN_Mask |
fmt | LVCOLUMN_Format |
cx | Long |
pszText | Long |
cchTextMax | Long |
iSubItem | Long |
iImage | Long |
iOrder | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVImageListTypes Enumeration

Members

Member | Description
LVSIL_NORMAL |
LVSIL_SMALL |
LVSIL_STATE |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVITEM_Mask Enumeration

Members

Member | Description
LVIF_TEXT |
LVIF_IMAGE |
LVIF_PARAM |
LVIF_STATE |
LVIF_INDENT |
LVIF_NORECOMPUTE |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVITEM_States Enumeration

Members

Member | Description
LVIS_FOCUSED |
LVIS_SELECTED |
LVIS_CUT |
LVIS_DROPHILITED |
LVIS_ACTIVATING |
LVIS_OVERLAYMASK |
LVIS_STATEIMAGEMASK |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVITEM UDT

UDT Members

Member | Type | Description
Mask | LVITEM_Mask |
iItem | Long |
iSubItem | Long |
State | LVITEM_States |
stateMask | LVITEM_States |
pszText | Long |
cchTextMax | Long |
iImage | Long |
lParam | Long |
iIndent | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

LVSetColumnWidthFlags Enumeration

Members

Member | Description
LVSCW_AUTOSIZE |
LVSCW_AUTOSIZE_USEHEADER |


%%PageItemTitle%%

M_API Standard Module

lID
See Also ActiveInstall Professional Send Feedback on this topic.

MAKEINTRESOURCE Method

Syntax

Public Function MAKEINTRESOURCE( _
   ByVal lID As Long _
) As String

Parameters

lID

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

wLow
wHi
See Also ActiveInstall Professional Send Feedback on this topic.

MAKELONG Method

Syntax

Public Function MAKELONG( _
   ByVal wLow As Long, _
   ByVal wHi As Long _
) As Long

Parameters

wLow
wHi

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

wLow
wHigh
See Also ActiveInstall Professional Send Feedback on this topic.

MakeWord Method

Syntax

Public Function MakeWord( _
   ByVal wLow As Integer, _
   ByVal wHigh As Integer _
) As Integer

Parameters

wLow
wHigh

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

param1
param2
See Also ActiveInstall Professional Send Feedback on this topic.

Max Method

Syntax

Public Function Max( _
   ByVal param1 As Long, _
   ByVal param2 As Long _
) As Long

Parameters

param1
param2

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

MEASUREITEMSTRUCT UDT

UDT Members

Member | Type | Description
CtlType | Long |
CtlID | Long |
ItemID | Long |
itemWidth | Long |
ItemHeight | Long |
ItemData | Long |


%%PageItemTitle%%

M_API Standard Module

param1
param2
See Also ActiveInstall Professional Send Feedback on this topic.

Min Method

Syntax

Public Function Min( _
   ByVal param1 As Long, _
   ByVal param2 As Long _
) As Long

Parameters

param1
param2

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

MINMAXINFO UDT

UDT Members

Member | Type | Description
ptReserved | POINTAPI |
ptMaxSize | POINTAPI |
ptMaxPosition | POINTAPI |
ptMinTrackSize | POINTAPI |
ptMaxTrackSize | POINTAPI |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

NMHDR UDT

UDT Members

Member | Type | Description
hwndFrom | Long |
idfrom | Long |
code | Long |


%%PageItemTitle%%

M_API Standard Module

lpRect
See Also ActiveInstall Professional Send Feedback on this topic.

NormalizeRect Method

Syntax

Public Sub NormalizeRect( _
   ByRef lpRect As RECT _
)

Parameters

lpRect

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

OSVERSIONINFO UDT

UDT Members

Member | Type | Description
dwOSVersionInfoSize | Long |
dwMajorVersion | Long |
dwMinorVersion | Long |
dwBuildNumber | Long |
dwPlatformId | Long |
szCSDVersion | String |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

PAINTSTRUCT UDT

UDT Members

Member | Type | Description
hDC | Long |
fErase | Long |
rcPaint | RECT |
fRestore | Long |
fIncUpdate | Long |
rgbReserved | Byte |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

PICTDESC UDT

UDT Members

Member | Type | Description
cbSize | Long |
picType | Long |
hImage | Long |
Data1 | Long |
Data2 | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

POINTAPI UDT

UDT Members

Member | Type | Description
X | Long |
Y | Long |


%%PageItemTitle%%

M_API Standard Module

lpPoint
lpRect
See Also ActiveInstall Professional Send Feedback on this topic.

PointInRect Method

Syntax

Public Function PointInRect( _
   ByRef lpPoint As POINTAPI, _
   ByRef lpRect As RECT _
) As Boolean

Parameters

lpPoint
lpRect

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

POINTS UDT

UDT Members

Member | Type | Description
X | Integer |
Y | Integer |


%%PageItemTitle%%

M_API Standard Module

lpsz
See Also ActiveInstall Professional Send Feedback on this topic.

PtrToStr Method

Syntax

Public Function PtrToStr( _
   ByVal lpsz As Long _
) As String

Parameters

lpsz

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

RECT UDT

UDT Members

Member | Type | Description
Left | Long |
Top | Long |
Right | Long |
Bottom | Long |


%%PageItemTitle%%

M_API Standard Module

hwnd
lpRect
See Also ActiveInstall Professional Send Feedback on this topic.

ScreenRectToClient Method

Syntax

Public Function ScreenRectToClient( _
   ByRef hwnd As Long, _
   ByRef lpRect As RECT _
) As Long

Parameters

hwnd
lpRect

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SCROLLINFO UDT

UDT Members

Member | Type | Description
cbSize | Long |
fMask | Long |
nMin | Long |
nMax | Long |
nPage | Long |
nPos | Long |
nTrackPos | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SECURITY_ATTRIBUTES UDT

UDT Members

Member | Type | Description
nLength | Long |
lpSecurityDescriptor | Long |
bInheritHandle | Long |


%%PageItemTitle%%

M_API Standard Module

sFileName
dDate
See Also ActiveInstall Professional Send Feedback on this topic.

SetFileCreatedTime Method

Syntax

Public Function SetFileCreatedTime( _
   ByVal sFileName As String, _
   ByVal dDate As Date _
) As Boolean

Parameters

sFileName
dDate

See Also

M_API Standard Module


%%PageItemTitle%%

M_API Standard Module

sFileName
dDate
See Also ActiveInstall Professional Send Feedback on this topic.

SetFileModifedTime Method

Syntax

Public Function SetFileModifedTime( _
   ByVal sFileName As String, _
   ByVal dDate As Date _
) As Boolean

Parameters

sFileName
dDate

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SHFILEINFO UDT

UDT Members

Member | Type | Description
hIcon | Long |
iIcon | Long |
dwAttributes | Long |
szDisplayName | String |
szTypeName | String |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

Size UDT

UDT Members

Member | Type | Description
cx | Long |
cy | Long |


%%PageItemTitle%%

M_API Standard Module

sz
See Also ActiveInstall Professional Send Feedback on this topic.

StrToPtr Method

Syntax

Public Function StrToPtr( _
   ByRef sz As String _
) As Long

Parameters

sz

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SYSTEMTIME UDT

UDT Members

Member | Type | Description
wYear | Integer |
wMonth | Integer |
wDayOfWeek | Integer |
wDay | Integer |
wHour | Integer |
wMinute | Integer |
wSecond | Integer |
wMilliseconds | Integer |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

tagMSG UDT

UDT Members

Member | Type | Description
hwnd | Long |
Message | Long |
wParam | Long |
lParam | Long |
time | Long |
pt | POINTAPI |


%%PageItemTitle%%

M_API Standard Module

clr
hPal
See Also ActiveInstall Professional Send Feedback on this topic.

TranslateColor Method

Syntax

Public Function TranslateColor( _
   ByVal clr As OLE_COLOR, _
   Optional ByRef hPal As Long = 0 _
) As Long

Parameters

clr
hPal

See Also

M_API Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

WIN32_FIND_DATA UDT

UDT Members

Member | Type | Description
dwFileAttributes | Long |
ftCreationTime | FILETIME |
ftLastAccessTime | FILETIME |
ftLastWriteTime | FILETIME |
nFileSizeHigh | Long |
nFileSizeLow | Long |
dwReserved0 | Long |
dwReserved1 | Long |
cFileName | String |
cAlternate | String |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

WINDOWPLACEMENT UDT

UDT Members

Member | Type | Description
Length | Long |
Flags | Long |
showCmd | Long |
ptMinPosition | POINTAPI |
ptMaxPosition | POINTAPI |
rcNormalPosition | RECT |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

WINDOWPOS UDT

UDT Members

Member | Type | Description
hwnd | Long |
hWndInsertAfter | Long |
X | Long |
Y | Long |
cx | Long |
cy | Long |
Flags | Long |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

WNDCLASS UDT

UDT Members

Member | Type | Description
Style | Long |
lpfnwndproc | Long |
cbClsextra | Long |
cbWndExtra2 | Long |
hInstance | Long |
hIcon | Long |
hCursor | Long |
hbrBackground | Long |
lpszMenuName | String |
lpszClassName | String |


%%PageItemTitle%%

M_CAB Members

M_CAB Standard Module

For a list of all members defined in this module, see M_CAB members.

See Also

M_CAB Members


%%PageItemTitle%% $$Members$$

M_CAB Members

M_CAB Standard Module Members

Public Methods

Public Method CabinetCallback
Public Method fFixPath
Public Method fMakePath
Public Method fSplitFile
Public Method SetCabFile

See Also

M_CAB Overview


%%PageItemTitle%%

M_CAB Standard Module

Context
Notification
Param1
Param2
See Also ActiveInstall Professional Send Feedback on this topic.

CabinetCallback Method

Syntax

Public Function CabinetCallback( _
   ByVal Context As Long, _
   ByVal Notification As Long, _
   ByRef Param1 As FileInCabinetInfo, _
   ByVal Param2 As Long _
) As Long

Parameters

Context
Notification
Param1
Param2

See Also

M_CAB Standard Module


%%PageItemTitle%%

M_CAB Standard Module

strPath
See Also ActiveInstall Professional Send Feedback on this topic.

fFixPath Method

Syntax

Public Function fFixPath( _
   ByRef strPath As String _
) As String

Parameters

strPath

See Also

M_CAB Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

FileInCabinetInfo UDT

UDT Members

Member | Type | Description
NameInCabinet | Long |
FileSize | Long |
Win32Error | Long |
DosDate | Integer |
DosTime | Integer |
DosAttribs | Integer |
FullTargetName | Byte |


%%PageItemTitle%%

M_CAB Standard Module

strPath
See Also ActiveInstall Professional Send Feedback on this topic.

fMakePath Method

Syntax

Public Function fMakePath( _
   ByRef strPath As String _
) As Boolean

Parameters

strPath

See Also

M_CAB Standard Module


%%PageItemTitle%%

M_CAB Standard Module

strFull
strPath
strFile
See Also ActiveInstall Professional Send Feedback on this topic.

fSplitFile Method

Syntax

Public Function fSplitFile( _
   ByVal strFull As String, _
   ByRef strPath As String, _
   ByRef strFile As String _
) As Variant

Parameters

strFull
strPath
strFile

See Also

M_CAB Standard Module


%%PageItemTitle%%

M_CAB Standard Module

cab
See Also ActiveInstall Professional Send Feedback on this topic.

SetCabFile Method

Syntax

Public Sub SetCabFile( _
   ByRef cab As C_CABExtractor _
)

Parameters

cab

See Also

M_CAB Standard Module


%%PageItemTitle%%

M_Common Members

M_Common Standard Module

For a list of all members defined in this module, see M_Common members.

See Also

M_Common Members


%%PageItemTitle%% $$Members$$

M_Common Members

M_Common Standard Module Members

Public Methods

Public Method ApiRaise
Public Method BrowseCallbackProc
Public Method BrowseForFolder
Public Method ButtonBorder
Public Method ComputerName
Public Method FrameBorder
Public Method GetComputerName
Public Method GetSafeArrayInfo
Public Method GetSpecialFolder
Public Method GetUserId
Public Method GetUserName
Public Method HiDWord
Public Method HighestDWord
Public Method InvalidHandleValue
Public Method IsSomething
Public Method IsValidHandle
Public Method IsWin98OrLater
Public Method IsWinNt
Public Method LastDllErrorMsg
Public Method LoBite
Public Method LoDWord
Public Method MakeBLOB
Public Method MakeDecimal
Public Method ParseURL
Public Method Pause
Public Method ProcAddress
Public Method PtrToData
Public Method PtrToObj
Public Method PtrToStrA
Public Method PtrToStrW
Public Method SetControlChildState
Public Method SetControlColor
Public Method SetControlState
Public Method ShellWait
Public Method SHGetPathFromIDList
Public Method SplitDecimal
Public Method SystemDirectory
Public Method ThinBorder
Public Method TickDiff
Public Method TrimNulls
Public Method WaitOnEvent
Public Method WaitOnEvents
Public Method WindowsDirectory
Public Method WinMajor
Public Method WNetGetUser

See Also

M_Common Overview


%%PageItemTitle%%

M_Common Standard Module

Number
Source
DescPrefix
HelpFile
HelpContext
NewLineCharacter
See Also ActiveInstall Professional Send Feedback on this topic.

ApiRaise Method

Syntax

Public Sub ApiRaise( _
   Optional ByVal Number As Long, _
   Optional ByVal Source As String, _
   Optional ByVal DescPrefix As String, _
   Optional ByVal HelpFile As String, _
   Optional ByVal HelpContext As Long, _
   Optional ByVal NewLineCharacter As String = vbCrLf _
)

Parameters

Number
Source
DescPrefix
HelpFile
HelpContext
NewLineCharacter

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

hwnd
uMsg
lParam
lpData
See Also ActiveInstall Professional Send Feedback on this topic.

BrowseCallbackProc Method

Syntax

Public Function BrowseCallbackProc( _
   ByVal hwnd As Long, _
   ByVal uMsg As Long, _
   ByVal lParam As Long, _
   ByVal lpData As Long _
) As Long

Parameters

hwnd
uMsg
lParam
lpData

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

BrowseFolderFlags Enumeration

Members

Member | Description
BIF_RETURNONLYFSDIRS |
BIF_DONTGOBELOWDOMAIN |
BIF_STATUSTEXT |
BIF_RETURNFSANCESTORS |
BIF_BROWSEFORCOMPUTER |
BIF_BROWSEFORPRINTER |


%%PageItemTitle%%

M_Common Standard Module

hwnd
TopFolder
Title
Flags
DefaultFolder
See Also ActiveInstall Professional Send Feedback on this topic.

BrowseForFolder Method

Syntax

Public Function BrowseForFolder( _
   ByVal hwnd As Long, _
   Optional ByVal TopFolder As ShellVirtualFolders = CSIDL_DESKTOP, _
   Optional ByVal Title As String = "Select folder", _
   Optional ByVal Flags As BrowseFolderFlags = BIF_RETURNONLYFSDIRS, _
   Optional ByVal DefaultFolder As String _
) As String

Parameters

hwnd
TopFolder
Value Description
CSIDL_FLAG_CREATE
CSIDL_FLAG_DONT_VERIFY
CSIDL_ADMINTOOLS
CSIDL_ALTSTARTUP
CSIDL_APPDATA
CSIDL_BITBUCKET
CSIDL_COMMON_ADMINTOOLS
CSIDL_COMMON_ALTSTARTUP
CSIDL_COMMON_APPDATA
CSIDL_COMMON_DESKTOPDIRECTORY
CSIDL_COMMON_DOCUMENTS
CSIDL_COMMON_FAVORITES
CSIDL_COMMON_PROGRAMS
CSIDL_COMMON_STARTMENU
CSIDL_COMMON_STARTUP
CSIDL_COMMON_TEMPLATES
CSIDL_CONTROLS
CSIDL_COOKIES
CSIDL_DESKTOP
CSIDL_DESKTOPDIRECTORY
CSIDL_DRIVES
CSIDL_FAVORITES
CSIDL_FONTS
CSIDL_HISTORY
CSIDL_INTERNET
CSIDL_INTERNET_CACHE
CSIDL_LOCAL_APPDATA
CSIDL_MYPICTURES
CSIDL_NETHOOD
CSIDL_NETWORK
CSIDL_PERSONAL
CSIDL_PRINTERS
CSIDL_PRINTHOOD
CSIDL_PROFILE
CSIDL_PROGRAM_FILES
CSIDL_PROGRAM_FILES_COMMON
CSIDL_PROGRAM_FILES_COMMONX86
CSIDL_PROGRAM_FILESX86
CSIDL_PROGRAMS
CSIDL_RECENT
CSIDL_SENDTO
CSIDL_STARTMENU
CSIDL_STARTUP
CSIDL_SYSTEM
CSIDL_SYSTEMX86
CSIDL_TEMPLATES
CSIDL_WINDOWS
Title
Flags
Value Description
BIF_RETURNONLYFSDIRS
BIF_DONTGOBELOWDOMAIN
BIF_STATUSTEXT
BIF_RETURNFSANCESTORS
BIF_BROWSEFORCOMPUTER
BIF_BROWSEFORPRINTER
DefaultFolder

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

BROWSEINFO UDT

UDT Members

Member | Type | Description
hOwner | Long |
pidlRoot | Long |
pszDisplayName | String |
lpszTitle | String |
ulFlags | Long |
lpfn | Long |
lParam | Long |
iImage | Long |


%%PageItemTitle%%

M_Common Standard Module

lHwnd
See Also ActiveInstall Professional Send Feedback on this topic.

ButtonBorder Method

Syntax

Public Function ButtonBorder( _
   ByVal lHwnd As Long _
) As Variant

Parameters

lHwnd

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

ComputerName Method

Syntax

Public Function ComputerName() As String

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lHwnd
See Also ActiveInstall Professional Send Feedback on this topic.

FrameBorder Method

Syntax

Public Function FrameBorder( _
   ByVal lHwnd As Long _
) As Variant

Parameters

lHwnd

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpBuffer
nSize
See Also ActiveInstall Professional Send Feedback on this topic.

GetComputerName Method

Syntax

Public Function GetComputerName( _
   ByRef lpBuffer As String, _
   ByRef nSize As Long _
) As Long

Parameters

lpBuffer
nSize

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

TheArray
ArrayInfo
See Also ActiveInstall Professional Send Feedback on this topic.

GetSafeArrayInfo Method

Syntax

Public Function GetSafeArrayInfo( _
   ByRef TheArray As Variant, _
   ByRef ArrayInfo As SAFEARRAY _
) As Boolean

Parameters

TheArray
ArrayInfo

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

CSIDL
See Also ActiveInstall Professional Send Feedback on this topic.

GetSpecialFolder Method

Syntax

Public Function GetSpecialFolder( _
   ByRef CSIDL As ShellVirtualFolders _
) As String

Parameters

CSIDL
Value Description
CSIDL_FLAG_CREATE
CSIDL_FLAG_DONT_VERIFY
CSIDL_ADMINTOOLS
CSIDL_ALTSTARTUP
CSIDL_APPDATA
CSIDL_BITBUCKET
CSIDL_COMMON_ADMINTOOLS
CSIDL_COMMON_ALTSTARTUP
CSIDL_COMMON_APPDATA
CSIDL_COMMON_DESKTOPDIRECTORY
CSIDL_COMMON_DOCUMENTS
CSIDL_COMMON_FAVORITES
CSIDL_COMMON_PROGRAMS
CSIDL_COMMON_STARTMENU
CSIDL_COMMON_STARTUP
CSIDL_COMMON_TEMPLATES
CSIDL_CONTROLS
CSIDL_COOKIES
CSIDL_DESKTOP
CSIDL_DESKTOPDIRECTORY
CSIDL_DRIVES
CSIDL_FAVORITES
CSIDL_FONTS
CSIDL_HISTORY
CSIDL_INTERNET
CSIDL_INTERNET_CACHE
CSIDL_LOCAL_APPDATA
CSIDL_MYPICTURES
CSIDL_NETHOOD
CSIDL_NETWORK
CSIDL_PERSONAL
CSIDL_PRINTERS
CSIDL_PRINTHOOD
CSIDL_PROFILE
CSIDL_PROGRAM_FILES
CSIDL_PROGRAM_FILES_COMMON
CSIDL_PROGRAM_FILES_COMMONX86
CSIDL_PROGRAM_FILESX86
CSIDL_PROGRAMS
CSIDL_RECENT
CSIDL_SENDTO
CSIDL_STARTMENU
CSIDL_STARTUP
CSIDL_SYSTEM
CSIDL_SYSTEMX86
CSIDL_TEMPLATES
CSIDL_WINDOWS

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

GetUserId Method

Syntax

Public Function GetUserId() As String

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpBuffer
nSize
See Also ActiveInstall Professional Send Feedback on this topic.

GetUserName Method

Syntax

Public Function GetUserName( _
   ByRef lpBuffer As String, _
   ByRef nSize As Long _
) As Long

Parameters

lpBuffer
nSize

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

vDecimal
See Also ActiveInstall Professional Send Feedback on this topic.

HiDWord Method

Syntax

Public Function HiDWord( _
   ByVal vDecimal As Variant _
) As Long

Parameters

vDecimal

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

vDecimal
See Also ActiveInstall Professional Send Feedback on this topic.

HighestDWord Method

Syntax

Public Function HighestDWord( _
   ByVal vDecimal As Variant _
) As Long

Parameters

vDecimal

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

Handle
See Also ActiveInstall Professional Send Feedback on this topic.

InvalidHandleValue Method

Syntax

Public Function InvalidHandleValue( _
   ByVal Handle As Long _
) As Boolean

Parameters

Handle

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

Object
See Also ActiveInstall Professional Send Feedback on this topic.

IsSomething Method

Syntax

Public Function IsSomething( _
   ByVal Object As Object _
) As Boolean

Parameters

Object

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

Handle
See Also ActiveInstall Professional Send Feedback on this topic.

IsValidHandle Method

Syntax

Public Function IsValidHandle( _
   ByVal Handle As Long _
) As Boolean

Parameters

Handle

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

IsWin98OrLater Method

Syntax

Public Function IsWin98OrLater() As Boolean

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

IsWinNt Method

Syntax

Public Function IsWinNt() As Boolean

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ITEMIDLIST UDT

UDT Members

Member | Type | Description
mkid | SHITEMID |


%%PageItemTitle%%

M_Common Standard Module

Number
NewLineCharacter
See Also ActiveInstall Professional Send Feedback on this topic.

LastDllErrorMsg Method

Syntax

Public Function LastDllErrorMsg( _
   Optional ByVal Number As Long, _
   Optional ByVal NewLineCharacter As String = vbCrLf _
) As String

Parameters

Number
NewLineCharacter

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

wParam
See Also ActiveInstall Professional Send Feedback on this topic.

LoBite Method

Syntax

Public Function LoBite( _
   ByVal wParam As Integer _
) As Byte

Parameters

wParam

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

vDecimal
See Also ActiveInstall Professional Send Feedback on this topic.

LoDWord Method

Syntax

Public Function LoDWord( _
   ByVal vDecimal As Variant _
) As Long

Parameters

vDecimal

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpBuffer
Params
See Also ActiveInstall Professional Send Feedback on this topic.

MakeBLOB Method

Syntax

Public Function MakeBLOB( _
   ByVal lpBuffer As Long, _
   Optional ByRef ParamArray Params() As Variant _
) As Long

Parameters

lpBuffer
Params

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

HighDword
LowDword
HighestDWord
DecimalPlaces
Signed
See Also ActiveInstall Professional Send Feedback on this topic.

MakeDecimal Method

Syntax

Public Function MakeDecimal( _
   ByVal HighDword As Long, _
   ByVal LowDword As Long, _
   Optional ByVal HighestDWord As Long, _
   Optional ByVal DecimalPlaces As Byte, _
   Optional ByVal Signed As Boolean _
) As Variant

Parameters

HighDword
LowDword
HighestDWord
DecimalPlaces
Signed

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

InputURL
OutProtocol
OutServer
OutSubPath
FileName
See Also ActiveInstall Professional Send Feedback on this topic.

ParseURL Method

Syntax

Public Function ParseURL( _
   ByVal InputURL As String, _
   Optional ByRef OutProtocol As String, _
   Optional ByRef OutServer As String, _
   Optional ByRef OutSubPath As String, _
   Optional ByRef FileName As String _
) As Boolean

Parameters

InputURL
OutProtocol
OutServer
OutSubPath
FileName

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

Milliseconds
WakeMask
lpAbort
See Also ActiveInstall Professional Send Feedback on this topic.

Pause Method

Syntax

Public Sub Pause( _
   ByVal Milliseconds As Long, _
   Optional ByVal WakeMask As QueueStatusFlags = QS_ALLINPUT, _
   Optional ByRef lpAbort As Long _
)

Parameters

Milliseconds
WakeMask
Value Description
QS_KEY
QS_MOUSEMOVE
QS_MOUSEBUTTON
QS_POSTMESSAGE
QS_TIMER
QS_PAINT
QS_SENDMESSAGE
QS_HOTKEY
QS_ALLPOSTMESSAGE
QS_MOUSE
QS_INPUT
QS_ALLEVENTS
QS_ALLINPUT
lpAbort

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpFunction
See Also ActiveInstall Professional Send Feedback on this topic.

ProcAddress Method

Syntax

Public Function ProcAddress( _
   ByVal lpFunction As Long _
) As Long

Parameters

lpFunction

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpData
DataType
Length
See Also ActiveInstall Professional Send Feedback on this topic.

PtrToData Method

Syntax

Public Function PtrToData( _
   ByVal lpData As Long, _
   ByVal DataType As VbVarType, _
   Optional ByVal Length As Long = -1 _
) As Variant

Parameters

lpData
DataType
Length

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpObject
See Also ActiveInstall Professional Send Feedback on this topic.

PtrToObj Method

Syntax

Public Function PtrToObj( _
   ByVal lpObject As Long _
) As Object

Parameters

lpObject

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpString
nBytes
See Also ActiveInstall Professional Send Feedback on this topic.

PtrToStrA Method

Syntax

Public Function PtrToStrA( _
   ByVal lpString As Long, _
   Optional ByVal nBytes As Long = -1 _
) As String

Parameters

lpString
nBytes

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpString
nBytes
See Also ActiveInstall Professional Send Feedback on this topic.

PtrToStrW Method

Syntax

Public Function PtrToStrW( _
   ByVal lpString As Long, _
   Optional ByVal nBytes As Long = -1 _
) As String

Parameters

lpString
nBytes

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

QueueStatusFlags Enumeration

Members

Member | Description
QS_KEY |
QS_MOUSEMOVE |
QS_MOUSEBUTTON |
QS_POSTMESSAGE |
QS_TIMER |
QS_PAINT |
QS_SENDMESSAGE |
QS_HOTKEY |
QS_ALLPOSTMESSAGE |
QS_MOUSE |
QS_INPUT |
QS_ALLEVENTS |
QS_ALLINPUT |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SAFEARRAY UDT

UDT Members

Member | Type | Description
cDims | Integer |
fFeatures | Integer |
cbElements | Long |
cLocks | Long |
pvData | Long |
rgsabound | SAFEARRAYBOUND |


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SAFEARRAYBOUND UDT

UDT Members

Member | Type | Description
cElements | Long |
lLbound | Long |


%%PageItemTitle%%

M_Common Standard Module

Control
IsEnabled
UnNest
LockInputOnly
See Also ActiveInstall Professional Send Feedback on this topic.

SetControlChildState Method

Syntax

Public Sub SetControlChildState( _
   ByVal Control As Control, _
   ByRef IsEnabled As Boolean, _
   Optional ByRef UnNest As Boolean = True, _
   Optional ByRef LockInputOnly As Boolean = True _
)

Parameters

Control
IsEnabled
UnNest
LockInputOnly

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

Control
IsEnabled
See Also ActiveInstall Professional Send Feedback on this topic.

SetControlColor Method

Syntax

Public Sub SetControlColor( _
   ByRef Control As Control, _
   ByRef IsEnabled As Boolean _
)

Parameters

Control
IsEnabled

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

Control
IsEnabled
LockInputOnly
See Also ActiveInstall Professional Send Feedback on this topic.

SetControlState Method

Syntax

Public Sub SetControlState( _
   ByVal Control As Control, _
   ByVal IsEnabled As Boolean, _
   Optional ByVal LockInputOnly As Boolean = True _
)

Parameters

Control
IsEnabled
LockInputOnly

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ShellVirtualFolders Enumeration

Members

Member | Description
CSIDL_FLAG_CREATE |
CSIDL_FLAG_DONT_VERIFY |
CSIDL_ADMINTOOLS |
CSIDL_ALTSTARTUP |
CSIDL_APPDATA |
CSIDL_BITBUCKET |
CSIDL_COMMON_ADMINTOOLS |
CSIDL_COMMON_ALTSTARTUP |
CSIDL_COMMON_APPDATA |
CSIDL_COMMON_DESKTOPDIRECTORY |
CSIDL_COMMON_DOCUMENTS |
CSIDL_COMMON_FAVORITES |
CSIDL_COMMON_PROGRAMS |
CSIDL_COMMON_STARTMENU |
CSIDL_COMMON_STARTUP |
CSIDL_COMMON_TEMPLATES |
CSIDL_CONTROLS |
CSIDL_COOKIES |
CSIDL_DESKTOP |
CSIDL_DESKTOPDIRECTORY |
CSIDL_DRIVES |
CSIDL_FAVORITES |
CSIDL_FONTS |
CSIDL_HISTORY |
CSIDL_INTERNET |
CSIDL_INTERNET_CACHE |
CSIDL_LOCAL_APPDATA |
CSIDL_MYPICTURES |
CSIDL_NETHOOD |
CSIDL_NETWORK |
CSIDL_PERSONAL |
CSIDL_PRINTERS |
CSIDL_PRINTHOOD |
CSIDL_PROFILE |
CSIDL_PROGRAM_FILES |
CSIDL_PROGRAM_FILES_COMMON |
CSIDL_PROGRAM_FILES_COMMONX86 |
CSIDL_PROGRAM_FILESX86 |
CSIDL_PROGRAMS |
CSIDL_RECENT |
CSIDL_SENDTO |
CSIDL_STARTMENU |
CSIDL_STARTUP |
CSIDL_SYSTEM |
CSIDL_SYSTEMX86 |
CSIDL_TEMPLATES |
CSIDL_WINDOWS |


%%PageItemTitle%%

M_Common Standard Module

PathName
WindowStyle
TimeoutValue
TimedOut
See Also ActiveInstall Professional Send Feedback on this topic.

ShellWait Method

Syntax

Public Function ShellWait( _
   ByVal PathName As String, _
   Optional ByVal WindowStyle As VbAppWinStyle = vbNormalFocus, _
   Optional ByVal TimeoutValue As Long = 0, _
   Optional ByRef TimedOut As Boolean _
) As Long

Parameters

PathName
WindowStyle
TimeoutValue
TimedOut

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

pidl
pszPath
See Also ActiveInstall Professional Send Feedback on this topic.

SHGetPathFromIDList Method

Syntax

Public Function SHGetPathFromIDList( _
   ByVal pidl As Long, _
   ByRef pszPath As String _
) As Long

Parameters

pidl
pszPath

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

SHITEMID UDT

UDT Members

Member | Type | Description
cb | Long |
abID | Byte |


%%PageItemTitle%%

M_Common Standard Module

vDecimal
LowDword
HighDword
HighestDWord
See Also ActiveInstall Professional Send Feedback on this topic.

SplitDecimal Method

Syntax

Public Sub SplitDecimal( _
   ByVal vDecimal As Variant, _
   ByRef LowDword As Long, _
   ByRef HighDword As Long, _
   Optional ByRef HighestDWord As Long _
)

Parameters

vDecimal
LowDword
HighDword
HighestDWord

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

SystemDirectory Method

Syntax

Public Function SystemDirectory() As String

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lHwnd
bState
See Also ActiveInstall Professional Send Feedback on this topic.

ThinBorder Method

Syntax

Public Function ThinBorder( _
   ByVal lHwnd As Long, _
   ByVal bState As Boolean _
) As Variant

Parameters

lHwnd
bState

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

TickStart
TickEnd
See Also ActiveInstall Professional Send Feedback on this topic.

TickDiff Method

Syntax

Public Function TickDiff( _
   ByVal TickStart As Currency, _
   ByVal TickEnd As Currency _
) As Long

Parameters

TickStart
TickEnd

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

InString
See Also ActiveInstall Professional Send Feedback on this topic.

TrimNulls Method

Syntax

Public Function TrimNulls( _
   ByRef InString As String _
) As String

Parameters

InString

See Also

M_Common Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

VARENUM Enumeration

Members

Member | Description
VT_EMPTY |
VT_NULL |
VT_I2 |
VT_I4 |
VT_R4 |
VT_R8 |
VT_CY |
VT_DATE |
VT_BSTR |
VT_DISPATCH |
VT_ERROR |
VT_BOOL |
VT_VARIANT |
VT_UNKNOWN |
VT_DECIMAL |
VT_I1 |
VT_UI1 |
VT_UI2 |
VT_UI4 |
VT_I8 |
VT_UI8 |
VT_INT |
VT_UINT |
VT_VOID |
VT_HRESULT |
VT_PTR |
VT_SAFEARRAY |
VT_CARRAY |
VT_USERDEFINED |
VT_LPSTR |
VT_LPWSTR |
VT_FILETIME |
VT_BLOB |
VT_STREAM |
VT_STORAGE |
VT_STREAMED_OBJECT |
VT_STORED_OBJECT |
VT_BLOB_OBJECT |
VT_CF |
VT_CLSID |
VT_VECTOR |
VT_ARRAY |
VT_BYREF |
VT_RESERVED |
VT_ILLEGAL |
VT_ILLEGALMASKED |
VT_TYPEMASK |


%%PageItemTitle%%

M_Common Standard Module

hEvent
TimeoutValue
WakeMask
Alertable
WaitValue
lpAbort
See Also ActiveInstall Professional Send Feedback on this topic.

WaitOnEvent Method

Syntax

Public Function WaitOnEvent( _
   ByVal hEvent As Long, _
   Optional ByVal TimeoutValue As Long = 15000, _
   Optional ByVal WakeMask As QueueStatusFlags = QS_ALLINPUT, _
   Optional ByVal Alertable As Boolean, _
   Optional ByRef WaitValue As Long, _
   Optional ByVal lpAbort As Long _
) As Long

Parameters

hEvent
TimeoutValue
WakeMask
Value Description
QS_KEY
QS_MOUSEMOVE
QS_MOUSEBUTTON
QS_POSTMESSAGE
QS_TIMER
QS_PAINT
QS_SENDMESSAGE
QS_HOTKEY
QS_ALLPOSTMESSAGE
QS_MOUSE
QS_INPUT
QS_ALLEVENTS
QS_ALLINPUT
Alertable
WaitValue
lpAbort

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpEvents
nEvents
TimeoutValue
WakeMask
WaitOnAll
Alertable
WaitValue
lpAbort
See Also ActiveInstall Professional Send Feedback on this topic.

WaitOnEvents Method

Syntax

Public Function WaitOnEvents( _
   ByVal lpEvents As Long, _
   Optional ByVal nEvents As Long = 1, _
   Optional ByVal TimeoutValue As Long = 15000, _
   Optional ByVal WakeMask As QueueStatusFlags = QS_ALLINPUT, _
   Optional ByVal WaitOnAll As Boolean, _
   Optional ByVal Alertable As Boolean, _
   Optional ByRef WaitValue As Long, _
   Optional ByVal lpAbort As Long _
) As Long

Parameters

lpEvents
nEvents
TimeoutValue
WakeMask
Value Description
QS_KEY
QS_MOUSEMOVE
QS_MOUSEBUTTON
QS_POSTMESSAGE
QS_TIMER
QS_PAINT
QS_SENDMESSAGE
QS_HOTKEY
QS_ALLPOSTMESSAGE
QS_MOUSE
QS_INPUT
QS_ALLEVENTS
QS_ALLINPUT
WaitOnAll
Alertable
WaitValue
lpAbort

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

WindowsDirectory Method

Syntax

Public Function WindowsDirectory() As String

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

WinMajor Method

Syntax

Public Function WinMajor() As Long

See Also

M_Common Standard Module


%%PageItemTitle%%

M_Common Standard Module

lpName
lpUserName
lpnLength
See Also ActiveInstall Professional Send Feedback on this topic.

WNetGetUser Method

Syntax

Public Function WNetGetUser( _
   ByVal lpName As String, _
   ByRef lpUserName As String, _
   ByRef lpnLength As Long _
) As Long

Parameters

lpName
lpUserName
lpnLength

See Also

M_Common Standard Module


%%PageItemTitle%%

M_MSIApi Members

M_MSIApi Standard Module

For a list of all members defined in this module, see M_MSIApi members.

See Also

M_MSIApi Members


%%PageItemTitle%% $$Members$$

M_MSIApi Members

M_MSIApi Standard Module Members

Public Methods

Public Method LPSTRtoVBString
Public Method MSICallBack
Public Method SetMSICallBack
Public Method SetUI
Public Method UnSetUI

Public Properties

Public Property OutputCount
Public Property Outputs

See Also

M_MSIApi Overview


%%PageItemTitle%%

M_MSIApi Standard Module

lPointer
See Also ActiveInstall Professional Send Feedback on this topic.

LPSTRtoVBString Method

Syntax

Public Function LPSTRtoVBString( _
   ByVal lPointer As Long _
) As String

Parameters

lPointer

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_MSIApi Standard Module

pvContext
iMessageType
szMessage
See Also ActiveInstall Professional Send Feedback on this topic.

MSICallBack Method

Syntax

Public Function MSICallBack( _
   ByVal pvContext As Long, _
   ByVal iMessageType As Long, _
   ByVal szMessage As Long _
) As Long

Parameters

pvContext
iMessageType
szMessage

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_MSIApi Standard Module

OutputCount Property

Property type

Read-write property

Syntax (Visual Basic)

Public OutputCount As Long

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_MSIApi Standard Module

Outputs Property

Property type

Read-write property

Syntax (Visual Basic)

Public Outputs As Output

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_MSIApi Standard Module

oC
See Also ActiveInstall Professional Send Feedback on this topic.

SetMSICallBack Method

Syntax

Public Function SetMSICallBack( _
   ByRef oC As C_MSIValidation _
) As Variant

Parameters

oC

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_MSIApi Standard Module

hwnd
See Also ActiveInstall Professional Send Feedback on this topic.

SetUI Method

Syntax

Public Function SetUI( _
   ByRef hwnd As Long _
) As Variant

Parameters

hwnd

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_MSIApi Standard Module

UnSetUI Method

Syntax

Public Function UnSetUI() As Variant

See Also

M_MSIApi Standard Module


%%PageItemTitle%%

M_WinInet Members

M_WinInet Standard Module

For a list of all members defined in this module, see M_WinInet members.

See Also

M_WinInet Members


%%PageItemTitle%% $$Members$$

M_WinInet Members

M_WinInet Standard Module Members

See Also

M_WinInet Overview


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

tWinInetDLLVersion UDT

UDT Members

Member | Type | Description
lMajorVersion | Long |
lMinorVersion | Long |


%%PageItemTitle%%

MExceptionHandler Members

MExceptionHandler Standard Module

For a list of all members defined in this module, see MExceptionHandler members.

See Also

MExceptionHandler Members


%%PageItemTitle%% $$Members$$

MExceptionHandler Members

MExceptionHandler Standard Module Members

Public Methods

Public Method ExceptionHandler
Public Method GetExceptionDescription
Public Method GetExceptionName
Public Method InstallExceptionHandler
Public Method RaiseAnException
Public Method UninstallExceptionHandler

See Also

MExceptionHandler Overview


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

EExceptionType Enumeration

Members

Member | Description
eExceptionType_AccessViolation |
eExceptionType_DataTypeMisalignment |
eExceptionType_Breakpoint |
eExceptionType_SingleStep |
eExceptionType_ArrayBoundsExceeded |
eExceptionType_FaultDenormalOperand |
eExceptionType_FaultDivideByZero |
eExceptionType_FaultInexactResult |
eExceptionType_FaultInvalidOperation |
eExceptionType_FaultOverflow |
eExceptionType_FaultStackCheck |
eExceptionType_FaultUnderflow |
eExceptionType_IntegerDivisionByZero |
eExceptionType_IntegerOverflow |
eExceptionType_PriviledgedInstruction |
eExceptionType_InPageError |
eExceptionType_IllegalInstruction |
eExceptionType_NoncontinuableException |
eExceptionType_StackOverflow |
eExceptionType_InvalidDisposition |
eExceptionType_GuardPageViolation |
eExceptionType_InvalidHandle |
eExceptionType_ControlCExit |


%%PageItemTitle%%

MExceptionHandler Standard Module

ExceptionPtrs
See Also ActiveInstall Professional Send Feedback on this topic.

ExceptionHandler Method

Syntax

Public Function ExceptionHandler( _
   ByRef ExceptionPtrs As EXCEPTION_POINTERS _
) As Long

Parameters

ExceptionPtrs

See Also

MExceptionHandler Standard Module


%%PageItemTitle%%

MExceptionHandler Standard Module

ExceptionType
See Also ActiveInstall Professional Send Feedback on this topic.

GetExceptionDescription Method

Syntax

Public Function GetExceptionDescription( _
   ByRef ExceptionType As EExceptionType _
) As String

Parameters

ExceptionType
Value Description
eExceptionType_AccessViolation
eExceptionType_DataTypeMisalignment
eExceptionType_Breakpoint
eExceptionType_SingleStep
eExceptionType_ArrayBoundsExceeded
eExceptionType_FaultDenormalOperand
eExceptionType_FaultDivideByZero
eExceptionType_FaultInexactResult
eExceptionType_FaultInvalidOperation
eExceptionType_FaultOverflow
eExceptionType_FaultStackCheck
eExceptionType_FaultUnderflow
eExceptionType_IntegerDivisionByZero
eExceptionType_IntegerOverflow
eExceptionType_PriviledgedInstruction
eExceptionType_InPageError
eExceptionType_IllegalInstruction
eExceptionType_NoncontinuableException
eExceptionType_StackOverflow
eExceptionType_InvalidDisposition
eExceptionType_GuardPageViolation
eExceptionType_InvalidHandle
eExceptionType_ControlCExit

See Also

MExceptionHandler Standard Module


%%PageItemTitle%%

MExceptionHandler Standard Module

ExceptionType
See Also ActiveInstall Professional Send Feedback on this topic.

GetExceptionName Method

Syntax

Public Function GetExceptionName( _
   ByRef ExceptionType As EExceptionType _
) As String

Parameters

ExceptionType
Value Description
eExceptionType_AccessViolation
eExceptionType_DataTypeMisalignment
eExceptionType_Breakpoint
eExceptionType_SingleStep
eExceptionType_ArrayBoundsExceeded
eExceptionType_FaultDenormalOperand
eExceptionType_FaultDivideByZero
eExceptionType_FaultInexactResult
eExceptionType_FaultInvalidOperation
eExceptionType_FaultOverflow
eExceptionType_FaultStackCheck
eExceptionType_FaultUnderflow
eExceptionType_IntegerDivisionByZero
eExceptionType_IntegerOverflow
eExceptionType_PriviledgedInstruction
eExceptionType_InPageError
eExceptionType_IllegalInstruction
eExceptionType_NoncontinuableException
eExceptionType_StackOverflow
eExceptionType_InvalidDisposition
eExceptionType_GuardPageViolation
eExceptionType_InvalidHandle
eExceptionType_ControlCExit

See Also

MExceptionHandler Standard Module


%%PageItemTitle%%

MExceptionHandler Standard Module

InstallExceptionHandler Method

Syntax

Public Sub InstallExceptionHandler()

See Also

MExceptionHandler Standard Module


%%PageItemTitle%%

MExceptionHandler Standard Module

ExceptionType
See Also ActiveInstall Professional Send Feedback on this topic.

RaiseAnException Method

Syntax

Public Sub RaiseAnException( _
   ByRef ExceptionType As EExceptionType _
)

Parameters

ExceptionType
Value Description
eExceptionType_AccessViolation
eExceptionType_DataTypeMisalignment
eExceptionType_Breakpoint
eExceptionType_SingleStep
eExceptionType_ArrayBoundsExceeded
eExceptionType_FaultDenormalOperand
eExceptionType_FaultDivideByZero
eExceptionType_FaultInexactResult
eExceptionType_FaultInvalidOperation
eExceptionType_FaultOverflow
eExceptionType_FaultStackCheck
eExceptionType_FaultUnderflow
eExceptionType_IntegerDivisionByZero
eExceptionType_IntegerOverflow
eExceptionType_PriviledgedInstruction
eExceptionType_InPageError
eExceptionType_IllegalInstruction
eExceptionType_NoncontinuableException
eExceptionType_StackOverflow
eExceptionType_InvalidDisposition
eExceptionType_GuardPageViolation
eExceptionType_InvalidHandle
eExceptionType_ControlCExit

See Also

MExceptionHandler Standard Module


%%PageItemTitle%%

MExceptionHandler Standard Module

UninstallExceptionHandler Method

Syntax

Public Sub UninstallExceptionHandler()

See Also

MExceptionHandler Standard Module


%%PageItemTitle%%

MUtil Members

MUtil Standard Module

For a list of all members defined in this module, see MUtil members.

See Also

MUtil Members


%%PageItemTitle%% $$Members$$

MUtil Members

MUtil Standard Module Members

Public Methods

Public Method Among
Public Method Array2Picture
Public Method BuildShortLongName
Public Method CenterForm
Public Method CenterFormOnForm
Public Method CreateDirTree
Public Method Decrypt
Public Method DoCommand
Public Method DriveSerial
Public Method Encrypt
Public Method ExtractCab2
Public Method ExtractCabOld
Public Method ExtractChannels
Public Method ExtractIcon
Public Method FixIdentifier
Public Method FixLength
Public Method FormatText
Public Method GenLRF
Public Method GetLanguageID
Public Method GetLocalizedValue
Public Method GetUIFontAndText
Public Method GetUniqueName
Public Method GetUniqueNumber
Public Method GetWIErrorString
Public Method GUID
Public Method HTMLEncode
Public Method IsAmoung
Public Method IsArrayValid
Public Method IsInProfile
Public Method IsInteger
Public Method IsLong
Public Method IsVersion
Public Method ListSelect
Public Method ListSelect2
Public Method MakeXPColor
Public Method NameGUID
Public Method ObjFromPtr
Public Method Picture2Array
Public Method RefCount
Public Method SetComboByText
Public Method SetLocalizedValue
Public Method SetRedraw
Public Method SmoothColor
Public Method SortItemCollection
Public Method SortItemCollectionPlus
Public Method SSInstalled
Public Method TestLic
Public Method ValidateError
Public Method VersionCompare
Public Method VersionCompare2
Public Method WIGUID
Public Method WindowsSerial

Public Properties

Public Property LIGHT_BUTTONFACE
Public Property Missing

See Also

MUtil Overview


%%PageItemTitle%%

MUtil Standard Module

vItem
avCompare
See Also ActiveInstall Professional Send Feedback on this topic.

Among Method

Syntax

Public Function Among( _
   ByVal vItem As Variant, _
   Optional ByRef ParamArray avCompare() As Variant _
) As Boolean

Parameters

vItem
avCompare

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

aBytes
See Also ActiveInstall Professional Send Feedback on this topic.

Array2Picture Method

Syntax

Public Function Array2Picture( _
   ByRef aBytes() As Byte _
) As StdPicture

Parameters

aBytes

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

sName
See Also ActiveInstall Professional Send Feedback on this topic.

BuildShortLongName Method

Syntax

Public Function BuildShortLongName( _
   ByRef sName As String _
) As String

Parameters

sName

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

frm
See Also ActiveInstall Professional Send Feedback on this topic.

CenterForm Method

Syntax

Public Sub CenterForm( _
   ByRef frm As Form _
)

Parameters

frm

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

frm
frm2
See Also ActiveInstall Professional Send Feedback on this topic.

CenterFormOnForm Method

Syntax

Public Sub CenterFormOnForm( _
   ByRef frm As Form, _
   ByRef frm2 As Form _
)

Parameters

frm
frm2

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

NewDirectory
See Also ActiveInstall Professional Send Feedback on this topic.

CreateDirTree Method

Syntax

Public Sub CreateDirTree( _
   ByRef NewDirectory As String _
)

Parameters

NewDirectory

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

strText
See Also ActiveInstall Professional Send Feedback on this topic.

Decrypt Method

Syntax

Public Function Decrypt( _
   ByVal strText As String _
) As String

Parameters

strText

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Command
See Also ActiveInstall Professional Send Feedback on this topic.

DoCommand Method

Syntax

Public Sub DoCommand( _
   ByRef Command As String _
)

Parameters

Command

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

DriveSerial Method

Syntax

Public Function DriveSerial() As Long

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

strText
See Also ActiveInstall Professional Send Feedback on this topic.

Encrypt Method

Syntax

Public Function Encrypt( _
   ByVal strText As String _
) As String

Parameters

strText

See Also

MUtil Standard Module


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

eVerCompareResult Enumeration

Members

Member | Description
eVerCompareResult_Unknown |
eVerCompareResult_BaseIsOlder |
everCompareResult_Equal |
eVerCompareResult_BaseIsNewer |


%%PageItemTitle%%

MUtil Standard Module

Path
Destination
See Also ActiveInstall Professional Send Feedback on this topic.

ExtractCab2 Method

Syntax

Public Sub ExtractCab2( _
   ByRef Path As String, _
   ByRef Destination As String _
)

Parameters

Path
Destination

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Path
Destination
See Also ActiveInstall Professional Send Feedback on this topic.

ExtractCabOld Method

Syntax

Public Sub ExtractCabOld( _
   ByRef Path As String, _
   ByRef Destination As String _
)

Parameters

Path
Destination

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Color
RedChannel
GreenChannel
BlueChannel
See Also ActiveInstall Professional Send Feedback on this topic.

ExtractChannels Method

Syntax

Public Function ExtractChannels( _
   ByVal Color As OLE_COLOR, _
   ByRef RedChannel As Long, _
   ByRef GreenChannel As Long, _
   ByRef BlueChannel As Long _
) As Boolean

Parameters

Color
RedChannel
GreenChannel
BlueChannel

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

sSourceFile
lIndex
sTargetFile
See Also ActiveInstall Professional Send Feedback on this topic.

ExtractIcon Method

Syntax

Public Function ExtractIcon( _
   ByRef sSourceFile As String, _
   ByRef lIndex As Long, _
   ByRef sTargetFile As String _
) As Boolean

Parameters

sSourceFile
lIndex
sTargetFile

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Val
See Also ActiveInstall Professional Send Feedback on this topic.

FixIdentifier Method

Syntax

Public Function FixIdentifier( _
   ByRef Val As String _
) As String

Parameters

Val

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Val
MaxLength
See Also ActiveInstall Professional Send Feedback on this topic.

FixLength Method

Syntax

Public Sub FixLength( _
   ByRef Val As String, _
   ByRef MaxLength As Integer _
)

Parameters

Val
MaxLength

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

sKey
See Also ActiveInstall Professional Send Feedback on this topic.

FormatText Method

Syntax

Public Function FormatText( _
   ByRef sKey As String _
) As Boolean

Parameters

sKey

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

sName
sCompany
sEMail
LicenseID
See Also ActiveInstall Professional Send Feedback on this topic.

GenLRF Method

Syntax

Public Function GenLRF( _
   ByRef sName As String, _
   ByRef sCompany As String, _
   ByRef sEMail As String, _
   ByRef LicenseID As String _
) As Variant

Parameters

sName
sCompany
sEMail
LicenseID

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

i
See Also ActiveInstall Professional Send Feedback on this topic.

GetLanguageID Method

Syntax

Public Function GetLanguageID( _
   ByRef i As aiLanguage _
) As String

Parameters

i
Value Description
aiLang1025Arabic
aiLang1027Catalan
aiLang1028Chinese
aiLang2052Chinese
aiLang1029Czech
aiLang1030Danish
aiLang1031German
aiLang1032Greek
aiLang1033English
aiLang3082Spanish
aiLang1061Estonian
aiLang1035Finnish
aiLang1036French
aiLang1037Hebrew
aiLang1038Hungarian
aiLang1040Italian
aiLang1041Japanese
aiLang1042Korean
aiLang1063Lithuanian
aiLang1062Latvian
aiLang1043Dutch
aiLang1044Norwegian
aiLang1045Polish
aiLang1046Portuguese
aiLang2070Portuguese
aiLang1048Romanian
aiLang1049Russian
aiLang1050Croatian
aiLang1051Slovak
aiLang1053Swedish
aiLang1054Thai
aiLang1055Turkish
aiLang1060Slovenian
aiLang1066Vietnamese
aiLang1069Basque

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

RecID
Table
Col
Lang
See Also ActiveInstall Professional Send Feedback on this topic.

GetLocalizedValue Method

Syntax

Public Function GetLocalizedValue( _
   ByRef RecID As String, _
   ByRef Table As String, _
   ByRef Col As String, _
   ByRef Lang As String _
) As String

Parameters

RecID
Table
Col
Lang

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

oDB
sTemp
oFont
oColor
See Also ActiveInstall Professional Send Feedback on this topic.

GetUIFontAndText Method

Syntax

Public Sub GetUIFontAndText( _
   ByRef oDB As Database, _
   ByRef sTemp As String, _
   ByRef oFont As StdFont, _
   ByRef oColor As OLE_COLOR _
)

Parameters

oDB
sTemp
oFont
oColor

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

oCol
Seed
See Also ActiveInstall Professional Send Feedback on this topic.

GetUniqueName Method

Syntax

Public Function GetUniqueName( _
   ByRef oCol As Object, _
   Optional ByVal Seed As String = "NewItem" _
) As String

Parameters

oCol
Seed

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

oCol
Seed
See Also ActiveInstall Professional Send Feedback on this topic.

GetUniqueNumber Method

Syntax

Public Function GetUniqueNumber( _
   ByRef oCol As CCollectionPlus, _
   Optional ByVal Seed As Integer = 0 _
) As Integer

Parameters

oCol
Seed

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

lError
See Also ActiveInstall Professional Send Feedback on this topic.

GetWIErrorString Method

Syntax

Public Function GetWIErrorString( _
   ByRef lError As Long _
) As String

Parameters

lError

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

GUID Method

Syntax

Public Function GUID() As String

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Text
See Also ActiveInstall Professional Send Feedback on this topic.

HTMLEncode Method

Syntax

Public Function HTMLEncode( _
   ByVal Text As String _
) As String

Parameters

Text

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

sSearch
sArray
See Also ActiveInstall Professional Send Feedback on this topic.

IsAmoung Method

Syntax

Public Function IsAmoung( _
   ByRef sSearch As String, _
   ByRef sArray() As String _
) As Boolean

Parameters

sSearch
sArray

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

vArray
See Also ActiveInstall Professional Send Feedback on this topic.

IsArrayValid Method

Syntax

Public Function IsArrayValid( _
   ByRef vArray As Variant _
) As Boolean

Parameters

vArray

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

oDir
See Also ActiveInstall Professional Send Feedback on this topic.

IsInProfile Method

Syntax

Public Function IsInProfile( _
   ByRef oDir As Directory _
) As Boolean

Parameters

oDir

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

V
See Also ActiveInstall Professional Send Feedback on this topic.

IsInteger Method

Syntax

Public Function IsInteger( _
   ByRef V As Variant _
) As Boolean

Parameters

V

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

V
See Also ActiveInstall Professional Send Feedback on this topic.

IsLong Method

Syntax

Public Function IsLong( _
   ByRef V As Variant _
) As Boolean

Parameters

V

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Version
See Also ActiveInstall Professional Send Feedback on this topic.

IsVersion Method

Syntax

Public Function IsVersion( _
   ByRef Version As String _
) As Boolean

Parameters

Version

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

LIGHT_BUTTONFACE Property

Property type

Read-write property

Syntax (Visual Basic)

Public LIGHT_BUTTONFACE As OLE_COLOR

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

ctl
lID
See Also ActiveInstall Professional Send Feedback on this topic.

ListSelect Method

Syntax

Public Sub ListSelect( _
   ByVal ctl As Control, _
   ByVal lID As Long _
)

Parameters

ctl
lID

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

ctl
sVal
See Also ActiveInstall Professional Send Feedback on this topic.

ListSelect2 Method

Syntax

Public Sub ListSelect2( _
   ByVal ctl As Control, _
   ByVal sVal As String _
)

Parameters

ctl
sVal

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

BaseColor
SelectionColor
Pressed
See Also ActiveInstall Professional Send Feedback on this topic.

MakeXPColor Method

Syntax

Public Function MakeXPColor( _
   Optional ByVal BaseColor As OLE_COLOR = vbButtonFace, _
   Optional ByVal SelectionColor As OLE_COLOR = vbHighlight, _
   Optional ByVal Pressed As Boolean = False _
) As OLE_COLOR

Parameters

BaseColor
SelectionColor
Pressed

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

vMissing
See Also ActiveInstall Professional Send Feedback on this topic.

Missing Property

Property type

Read-only property

Syntax (Visual Basic)

Public Property Missing( _
   Optional ByRef vMissing As Variant _
) As Variant

Parameters

vMissing

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

NameGUID Method

Syntax

Public Function NameGUID() As String

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

ptr
See Also ActiveInstall Professional Send Feedback on this topic.

ObjFromPtr Method

Syntax

Public Function ObjFromPtr( _
   ByVal ptr As Long _
) As Object

Parameters

ptr

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

oObj
aBytes
See Also ActiveInstall Professional Send Feedback on this topic.

Picture2Array Method

Syntax

Public Sub Picture2Array( _
   ByVal oObj As StdPicture, _
   ByRef aBytes() As Byte _
)

Parameters

oObj
aBytes

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

pUnkUR
See Also ActiveInstall Professional Send Feedback on this topic.

RefCount Method

Syntax

Public Function RefCount( _
   ByVal pUnkUR As IUnknown _
) As Long

Parameters

pUnkUR

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

oCBO
sText
See Also ActiveInstall Professional Send Feedback on this topic.

SetComboByText Method

Syntax

Public Function SetComboByText( _
   ByRef oCBO As ComboBox, _
   ByRef sText As String _
) As Boolean

Parameters

oCBO
sText

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

RecID
Table
Col
Lang
Value
See Also ActiveInstall Professional Send Feedback on this topic.

SetLocalizedValue Method

Syntax

Public Sub SetLocalizedValue( _
   ByRef RecID As String, _
   ByRef Table As String, _
   ByRef Col As String, _
   ByRef Lang As String, _
   ByRef Value As String _
)

Parameters

RecID
Table
Col
Lang
Value

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

ctl
bRedraw
See Also ActiveInstall Professional Send Feedback on this topic.

SetRedraw Method

Syntax

Public Sub SetRedraw( _
   ByVal ctl As Control, _
   ByVal bRedraw As Boolean _
)

Parameters

ctl
bRedraw

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

lColor
See Also ActiveInstall Professional Send Feedback on this topic.

SmoothColor Method

Syntax

Public Function SmoothColor( _
   ByRef lColor As OLE_COLOR _
) As OLE_COLOR

Parameters

lColor

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Col
strPropertyName
blnCompareNumeric
See Also ActiveInstall Professional Send Feedback on this topic.

SortItemCollection Method

Syntax

Public Function SortItemCollection( _
   ByRef Col As Collection, _
   ByRef strPropertyName As Variant, _
   Optional ByRef blnCompareNumeric As Boolean = False _
) As Collection

Parameters

Col
strPropertyName
blnCompareNumeric

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

Col
strPropertyName
blnCompareNumeric
See Also ActiveInstall Professional Send Feedback on this topic.

SortItemCollectionPlus Method

Syntax

Public Function SortItemCollectionPlus( _
   ByRef Col As CCollectionPlus, _
   ByRef strPropertyName As Variant, _
   Optional ByRef blnCompareNumeric As Boolean = False _
) As Collection

Parameters

Col
strPropertyName
blnCompareNumeric

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

SSInstalled Method

Syntax

Public Function SSInstalled() As Boolean

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

TestLic Method

Syntax

Public Function TestLic() As Variant

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

ctl
sMsg
See Also ActiveInstall Professional Send Feedback on this topic.

ValidateError Method

Syntax

Public Sub ValidateError( _
   ByVal ctl As Control, _
   ByVal sMsg As String _
)

Parameters

ctl
sMsg

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

V1
V2
See Also ActiveInstall Professional Send Feedback on this topic.

VersionCompare Method

Syntax

Public Function VersionCompare( _
   ByRef V1 As String, _
   ByRef V2 As String _
) As Long

Parameters

V1
V2

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

BaseVersion
CompareVersion
See Also ActiveInstall Professional Send Feedback on this topic.

VersionCompare2 Method

Syntax

Public Function VersionCompare2( _
   ByRef BaseVersion As String, _
   ByRef CompareVersion As String _
) As eVerCompareResult

Parameters

BaseVersion
CompareVersion

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

WIGUID Method

Syntax

Public Function WIGUID() As String

See Also

MUtil Standard Module


%%PageItemTitle%%

MUtil Standard Module

WindowsSerial Method

Syntax

Public Function WindowsSerial() As String

See Also

MUtil Standard Module


%%PageItemTitle%%

ucLink Members

ucLink Control

For a list of all members defined in this module, see ucLink members.

See Also

ucLink Members


%%PageItemTitle%% $$Members$$

ucLink Members

ucLink Control Members

Public Methods

Public Method Capture

Public Properties

Public Property Action
Public Property BackColor
Public Property BorderStyle
Public Property Caption
Public Property Enabled
Public Property Font
Public Property ForeColor
Public Property URL

Events

Public Event Click
Public Event DblClick
Public Event MouseDown
Public Event MouseMove
Public Event MouseUp
Public Event OnMouseOut
Public Event OnMouseOver
Public Event Resize

See Also

ucLink Overview


%%PageItemTitle%%

ucLink Control

Action Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Action() As ActionConstants

See Also

ucLink Control


%%PageItemTitle%%

ActiveInstall Professional Send Feedback on this topic.

ActionConstants Enumeration

Members

Member | Description
Custom |
Underline |
Bold |


%%PageItemTitle%%

ucLink Control

BackColor Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BackColor() As OLE_COLOR

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

BorderStyle Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property BorderStyle() As Integer

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Caption Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Caption() As String

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

pbValue
See Also ActiveInstall Professional Send Feedback on this topic.

Capture Method

Syntax

Public Sub Capture( _
   ByRef pbValue As Boolean _
)

Parameters

pbValue

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Click Event

Syntax

Public Event Click()

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

DblClick Event

Syntax

Public Event DblClick()

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Enabled Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Enabled() As Boolean

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Font Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property Font() As Font

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

ForeColor Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property ForeColor() As OLE_COLOR

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Button
Shift
x
y
See Also ActiveInstall Professional Send Feedback on this topic.

MouseDown Event

Syntax

Public Event MouseDown( _
   ByRef Button As Integer, _
   ByRef Shift As Integer, _
   ByRef x As Single, _
   ByRef y As Single _
)

Parameters

Button
Shift
x
y

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Button
Shift
x
y
See Also ActiveInstall Professional Send Feedback on this topic.

MouseMove Event

Syntax

Public Event MouseMove( _
   ByRef Button As Integer, _
   ByRef Shift As Integer, _
   ByRef x As Single, _
   ByRef y As Single _
)

Parameters

Button
Shift
x
y

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Button
Shift
x
y
See Also ActiveInstall Professional Send Feedback on this topic.

MouseUp Event

Syntax

Public Event MouseUp( _
   ByRef Button As Integer, _
   ByRef Shift As Integer, _
   ByRef x As Single, _
   ByRef y As Single _
)

Parameters

Button
Shift
x
y

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

OnMouseOut Event

Syntax

Public Event OnMouseOut()

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

OnMouseOver Event

Syntax

Public Event OnMouseOver()

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

Resize Event

Syntax

Public Event Resize()

See Also

ucLink Control


%%PageItemTitle%%

ucLink Control

URL Property

Property type

Read-write property

Syntax (Visual Basic)

Public Property URL() As String

See Also

ucLink Control


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Custom Tables Overview

Custom Tables are used to define and store custom data for use during your installation. In most cases, the primary advantage is the ability to author or consume custom actions which read configuration data from your custom tables. By leveraging this mechanism, you can achieve enterprise class reuse of code in your installations.

Custom Tables support the full definition and validation of data as defined by the Windows Installer SDK. This ensures that you can creat rich and powerful Custom tables that fully leverage the benefits of Windows Installer technology and package validation.

Note:

  • A maximum of 20 columns can be defined per table.
  • Data is fixed and uneffected by deleting and re-adding columns. For example, if you define a custom table with 5 columns and populate the columns with data, then delete and re-add the 5th column, the original data from that column will still be in tact. Data preserves it's ordinal column position, regardless of any column changes or deletions. In other words, deleting the second column does not move data from the third column to the second.
  • All data is entered as simple strings and is not validated until the project is built.


%%ItemTitle%%

ActiveInstall:

  • Launch Conditions
    - Overview
    - Managing
  • Upgrade Actions
    - Overview
    - Managing
  • System Searches
    - Overview
    - Managing
  • Custom Actions
    - Overview
    - Managing
  • INI File Modifications
    - Overview
    - Managing
  • Environment Variable Modifications
    - Overview
    - Managing
  • Move File Actions
    - Overview
    - Managing
  • Remove File Actions
    - Overview
    - Managing

Windows Installer:

  • Launch Condition Table Reference
  • Upgrade Table Reference
  • AppSearch Table Reference
  • Signature Table Reference
  • CompLocator Table Reference
  • IniLocator Table Reference
  • RegLocator Table Reference
  • DrLocator Table Reference
  • CCPSearch Table Reference
  • CustomAction Table Reference
  • IniFile Table Reference
  • RemoveIniFile Table Reference
  • Environment Table Reference
  • MoveFile Table Reference
  • RemoveFile Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Action Sequences Overview
  • Managing Action Sequences

Windows Installer:

  • Using A Sequence table
  • Standard Actions
  • InstallUISequence Table Reference
  • InstallExecuteSequence Table Reference
  • AdminExecuteSequence Table Reference
  • AdminUISequence Table Reference
  • AdvtExecuteSequence Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Action Strings Overview
  • Managing Action Strings

Windows Installer:

  • ActionText Table

How To:

Quick Tips:

  • Action Strings map to the Windows Installer "ActionText" table at build time.

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Associations Overview
  • Managing Associations

Windows Installer:

  • Extension Table
  • ProgId Table
  • MIME Table
  • Verb Table

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • COM Classes Overview
  • Managing COM Classes
  • Type Library Overview
  • Managing Type Libraries
  • Prog ID Overview
  • Managing Prog IDs

Windows Installer:

  • Class Table Reference
  • AppId Table Reference
  • TypeLib Table Reference
  • ProgId Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Control Strings Overview
  • Managing Control Strings

Windows Installer:

  • UIText Table

How To:

Quick Tips:

  • Control Strings map to the Windows Installer "UIText" table at build time.

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Custom Table Overview
  • Managing Custom Tables

Windows Installer:

  • Windows Installer DataTypes
  • _Validation Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Dialogs Overview
  • Managing Dialogs

Windows Installer:

  • Dialog Table Reference
  • Control Table Reference
  • ControlEvent Table Reference
  • EventMapping Table Reference
  • ControlCondition Table Reference
  • About the User Interface
  • Using the User Interface
  • User Interface Reference
  • Controls
  • Control Attributes
  • Control Events

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Features Overview
  • Managing Features
  • Components Overview
  • Managing Components

Windows Installer:

  • Organizing Application Into Components
  • Using Isolated Components
  • Using Qualified Components
  • Feature Table Reference
  • Condition Table Reference
  • FeatureComponents Table Reference
  • Component Table Reference
  • PublishComponent Table Reference
  • Isolated Component Table Reference

How To:

Quick Tips:

  • Properties do not need to be 'declared' in the Property Manager. The Property Manager simply provides a place to specify default values for Properties used in your installation.

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Files Overview
  • Managing Files
  • Directories Overview
  • Managing Directories

Windows Installer:

  • File Table Reference
  • Font Table Reference
  • SelfReg Table Reference
  • DuplicateFile Table Reference
  • Directory Table Reference
  • CreateFolder Table Reference
  • LockPermissions Table Reference
  • System Folders Property Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • ActiveInstall Product Overview

Windows Installer:

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Localization Overview
  • Managing Localization

Windows Installer:

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Merge Modules Overview
  • Managing Merge Modules

Windows Installer:

  • About Merge Modules
  • Using Merge Modules
  • ModuleSignature Table Reference
  • ModuleDependency Table Reference
  • ModuleExclusion Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Merge Module Configurable Options Overview
  • Managing Merge Module Configurable Options

Windows Installer:

  • About Configurable Merge Modules
  • Using Configurable Merge Modules
  • ModuleConfiguration Table Reference
  • ModuleSubstitution Table Reference
  • Semantic Types Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Merge Module Relationships Overview
  • Managing Merge Module Relationships

Windows Installer:

  • ModuleDependency Table Reference
  • ModuleExclusion Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Merge Module Substitutions Overview
  • Managing Merge Module Substitutions

Windows Installer:

  • About Configurable Merge Modules
  • Using Configurable Merge Modules
  • ModuleConfiguration Table Reference
  • ModuleSubstitution Table Reference
  • Semantic Types Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Message Strings Overview
  • Managing Message Strings

Windows Installer:

  • Windows Installer Error Messages
  • Returning Error Messages from Custom Actions
    Error Table

How To:

Quick Tips:

  • Message Strings map to the Windows Installer "Error" table at build time.
  • Not all Message Strings are error messages!

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • ODBC Data Sources Overview
  • Managing ODBC Data Sources
  • ODBC Drivers Overview
  • Managing ODBC Drivers
  • ODBC Translators Overview
  • Managing ODBC Translators

Windows Installer:

  • ODBCDataSource Table Reference
  • ODBCDriver Table Reference
  • ODBCTranslator Table Reference
  • ODBCSourceAttribute Table Reference
  • ODBCAttribute Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Path Variables Overview
  • Managing Path Variables

Windows Installer:

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Post-Build SQL Overview
  • Managing Post-Build SQL

Windows Installer:

  • Windows Installer SQL Syntax
  • SQL Examples
  • Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Properties Overview
  • Managing Properties

Windows Installer:

  • About Properties
  • Using Properties
  • Property Reference
  • Property Table

How To:

Quick Tips:

  • Properties do not need to be 'declared' in the Property Manager. The Property Manager simply provides a place to specify default values for Properties used in your installation.

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Registry Modification Overview
  • Managing Registry Modifications

Windows Installer:

  • Registry Table Reference
  • RemoveRegistry Table Reference
  • LockPermissions Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Build Configurations Overview
  • Managing Build Configurations
  • Product Configurations Overview
  • Managing Product Configurations

Windows Installer:

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Resources Overview
  • Managing Resources

Windows Installer:

  • Binary Table
  • Icon Table
  • _Streams Table

How To:

Quick Tips:

  • Resources map to either the Windows Installer "Binary", "Icon", and "_Streams" table at build time.

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Service Install Action Overview
  • Managing Service Install Actions
  • Service Control Action Overview
  • Managing Service Control Actions

Windows Installer:

  • ServiceInstall Table Reference
  • ServiceControl Table Reference

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall:

  • Shortcuts Overview
  • Managing Shortcuts

Windows Installer:

  • DISABLEADVTSHORTCUTS Property
  • Shortcut Table

How To:

Quick Tips:

Feedback:

Tell us what you think!


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Path Variable Selector Dialog

...


Dialog Details

Dialog Name:
Caption:
Vertical Position:
Horizontal Position:
Height:
Width:
First Control:
Default Control:
Cancel Control:
Is Error Dialog:

Options

Edit this Dialog

Feedback

Tell us what you think!


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Condition Data Type

Condition Data Type

The Condition data type is a text string containing a valid conditional statement that can be evaluated as true or false.

Summary of Conditional Statement Syntax

This table and bullets summarizes the syntax to use in conditional expressions. More information is given in following sections.

Item | Syntax
value | symbol | literal | integer
comparison-operator < | > | <= | >= | = | <>
term | value | value comparison-operator value | ( expression )|
Boolean-factor | term | NOT term
Boolean-term | Boolean-factor | Boolean-factor AND term
expression | Boolean-term | Boolean-term OR expression
symbol | property |
Symbol type | Prefix | Value
Installer property | (none) | Value of property (Property table).
Environment variable | .html">environment-variable | $component-action | ?component-state | &feature-action | !feature-state
  • Symbol names and values are case-sensitive.
  • Environment variable names are not case-sensitive.
  • Literal text must be enclosed between quotation marks ("text").
  • Non-existent property values are treated as empty strings.
  • Floating point numeric values are not supported.
  • Operators and precedence are the same as in the BASIC and SQL languages.
  • Arithmetic operators are not supported.
  • Parentheses can be used to override operator precedence.
  • Operators are not case-sensitive.
  • For string comparisons, a tilde " ~" prefixed to the operator performs a comparison that is not case-sensitive.
  • Comparison of an integer with a string or property value that cannot be converted to an integer is always msiEvaluateConditionFalse, except for the comparison operator "<>", which returns msiEvaluateConditionTrue.

Access Prefixes

The following table shows the prefixes to use to access various system and installer information for use in conditional expressions.

Value of environment variable.
Component table key $ Action state of the component.
Component table key ? Installed state of the component.
Feature table key & Action state of the feature.
Feature table key ! Installed state of the feature.

Logical Operators

The following table shows the logical operators in conditional expressions, in high to low precedence order.

Operator | Meaning
Not | Prefix unary operator; inverts state of following term.
And | TRUE if both terms are TRUE.
Or | TRUE if either or both terms are TRUE.
Xor | TRUE if either but not both terms are TRUE.
Eqv | TRUE if both terms are TRUE or both terms are FALSE.
Imp | TRUE if left term is FALSE or right term is TRUE.

Comparative Operators

The following table shows the comparison operators used in conditional expressions. These comparison operators can only occur between two values.

Operator Meaning
= TRUE if left value is equal to right value.
<> TRUE if left value is not equal to right value.
> TRUE if left value is greater than right value.
>= TRUE if left value is greater than or equal to right value.
< TRUE if left value is less than right value.
<= TRUE if left value is less than or equal to right value.

Substring Operators

The following table shows the substring operators used in conditional expressions. Substring operators can occur between two string values.

Operator Meaning
>< TRUE if left string contains the right string.
<< TRUE if left string starts with the right string.
>> TRUE if left string ends with the right string.

Bitwise Numeric Operators

The following table shows the bitwise numeric operators in conditional expressions. These operators can occur between two integer values.

Operator Meaning
>< Bitwise AND, TRUE if the left and right integers have any bits in common.
<< True if the high 16-bits of the left integer are equal to the right integer.
>> True if the low 16-bits of the left integer are equal to the right integer.

Feature and Component State Values

The following table shows where it is valid to use the feature and component operator symbols.

Operator <state> | Where this syntax is valid.
$component-action | Only in the sequence tables after the CostFinalize action.
&feature-action | Only in the sequence tables after the CostFinalize action.
!feature-state | Only in the sequence tables after the CostFinalize action.
?component-state | In the Condition table, in the Condition column of the Component table, and in the sequence tables, after the CostFinalize action.

The following table shows the feature and component state values used in conditional expressions. These states are not set until MsiSetInstallLevel is called, either directly or by the CostFinalize action.

State | Value | Meaning
INSTALLSTATE_UNKNOWN | -1 | No action to be taken on feature or component.
INSTALLSTATE_ADVERTISED | 1 | Advertised feature. This state is not available for components.
INSTALLSTATE_ABSENT | 2 | Feature or component not present.
INSTALLSTATE_LOCAL | 3 | Feature or component on local computer.
INSTALLSTATE_SOURCE | 4 | Feature or component run from source.

For example, the conditional expression "&MyFeature=3" evaluates to true only if MyFeature is changing from its current state to the state of being installed on the local computer, INSTALLSTATE_LOCAL.

Note that you should not depend upon the condition $Component1=3 to check whether Component1 is locally installed on the computer. This can fail if Component1 is installed by more than one product. After Component1 has been installed locally by product1, the installer evaluates the condition $Component1=3 as False during the installation of product2. This is because the installer determines the version of the component using the component's key path and marks the component for installation if its version is greater than or equal to the installed component.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Formatted Data Type

Formatted Data Type

The Formatted Data Type is a text string that is processed to resolve embedded property names, table keys, environment variable references, and other special substrings.

The following conventions are recognized to resolve the string:

  • Square brackets ([ ]) or curly braces ({ }) with no matching pair are left in the text.
  • If a substring of the form [propertyname] is encountered, it is replaced by the value of the property. If propertyname is not a valid property, then the substring is left unchanged.

    The square brackets may be iterated and the property names are resolved from inside out. For example, suppose the substring [[PropertyA]] appears in the text. First, the value of property PropertyA is retrieved. If the value is a valid property name, such as PropertyB, then the value of PropertyB is retrieved, and the entire substring [[PropertyA]] is substituted with the value of PropertyB. If PropertyA is not a valid property name, or if the value of PropertyA is not a valid property name, then the substring is blank.

  • If a substring of the form [%environmentvariable] is found, the value of the environment variable is substituted for the substring.
  • If a substring of the form [\x ] is found, it is replaced by the character x , where x is one character, without any further processing. Only the first character after the backslash is kept; everything else is removed. For example, to include a literal left bracket ([), use [\[]. The text [\[]Bracket Text[\]] resolves to [Bracket Text].
  • If a substring is enclosed in curly braces ( { }), and it contains no property names enclosed in square brackets ( [ ]), the substring is left unchanged, including the curly braces.
  • If a substring is enclosed in curly braces ( { }) and it contains one or more property names enclosed in square brackets ( [ ]) then, if all the property names are valid, the text (with the resolved substitutions) is displayed without the curly braces.
  • If a substring of the form [~] is found, it is replaced with the null character. This is used to author REG_MULTI_SZ character strings in the Registry table. Note that [~] is also used to append or prefix values to environment variables using the Environment table.
  • If a substring of the form [#filekey] is found, it is replaced by the full path of the file, with the value filekey used as a key into the File table. The value of [#filekey] remains blank and is not replaced by a path until the installer runs the CostInitialize action, FileCost action, and CostFinalize action. The value of [#filekey] depends upon the installation state of the component to which the file belongs. If the component run from the source, the value is the path to the source location of the file. If the component is run locally, the value is the path to the target location of the file after installation. If the component is absent, the path is blank. For more information about checking the installation state of components, see Checking the Installation of Features, Components, Files.
  • If a substring of the form [$componentkey] is found, it is replaced by the install directory of the component, with the value componentkey used as a key into the Component table. The value of [$componentkey] remains blank and is not replaced by a directory until the installer runs the CostInitialize action, FileCost action, and CostFinalize action. The value of [$componentkey] depends upon the installation state of the component and where it occurs. In the Value column of the Registry Table, this substring may refer to the action state or the requested action state of the component. In all other cases, this substring refers to the action state of component. For example, If the component is run from the source, the value is the source directory of the file. If the component is run locally, the value is the target directory after installation. If the component is absent, the value is left blank. Windows Installer tracks both the action and requested installation states of components. For example, if a component is already installed, it may have a requested state of local and an action state of NULL. For more information about checking the installation state of components, see Checking the Installation of Features, Components, Files.
  • Note that if a component is already installed, and is not reinstalled, removed, or moved during the current installation, the action state of the component is null and the string [$componentkey] evaluates to Null.
  • If a substring of the form [!filekey] is found, it is replaced by the full short path of the file, with the value filekey used as a key into the File table.

    This syntax is valid only when used in the Value column of the Registry or the IniFile tables. When used in other columns this syntax is treated the same as [#filekey] .


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Identifier Data Type

Identifier Data Type

The Identifier Data Type is comprised of any combination of letters, numbers periods, and underscores, but must begin with either a letter or an underscore.

Valid Examples:

  • MyIdentifier
  • _MyIdentifier
  • _123Identifier
  • _.NET

Invalid Examples:

  • My Identifier
  • 12
  • sales@activeinstall.com
  • .NET
  • Install!


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Integer Data Type

Integer Data Type

The Integer Data Type is a two-byte integer value. Unless otherwise restricted, the range of legal values is from –32,767 to +32,767.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Template Data Type

Template Data Type

The Template Data Type is comprised The Template data type is a text string that may contain properties that are enclosed in brackets [ ]. The template type allows all of the Formatted type formats, plus [1] where 1 is a number.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Views

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

Launch Conditions Overview | Managing Launch Conditions

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Launch Condition Samples

Feel free to use any of the following sample conditions in your own installation:

Condition | Description
(Version9X>=410) OR (VersionNT>=500) OR ((VersionNT=400) AND (ServicePackLevel>5)) | Requires Windows 98 or Greater or Windows 2000 or Greater or Windows NT 4.0 with SP6 or Greater
(Version9X>=410) OR (VersionNT>=400 AND Privileged) | Requires Windows 98 or Greater or Windows NT or Greater with Elevated Priveleges
(VersionNT>=501) | Requires Windows XP
((VersionNT=500) AND (ServicePackLevel>=3)) | Windows 2000 with SP3 or Greater
((VersionNT>=500) AND (MsiNTProductType=3)) | Requires Windows 2000 Server (Workstation is excluded)
((VersionNT>=400) AND (MsiNTProductType=2)) | Requires a Windows NT 4.0 or Greater DomainController
(PhysicalMemory>=64) | Requires 64MB or RAM or Greater
((ScreenX>=800) AND (ScreenY>=600)) | Requires 800x600 screen resolution.

See Also

Launch Conditions Overview | Managing Launch Conditions


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Managing Merge Module Substitutions

The Merge Module Substitutions Manager allows you to view and configure Merge Module Substitutions for use in your Merge Module projects.

Adding Merge Module Substitutions

  1. In the Project Explorer, click Merge Module Substitutions Manager to display the Merge Module Substitutions Manager view.
  2. Select Add... from the options panel or use the keyboard short <Insert> while this view is active to display the Merge Module Substitution Details Dialog.
  3. Enter details for this Merge Module Substitution as outlined in the Field Reference below.
  4. Click Save & Close on the dialog's toolbar.

Editing Merge Module Substitutions

Edit a Merge Module Substitution by simply double-clicking on a row in the Merge Module Substitutions Manager or by clicking the Edit button on the options panel.

Deleting Merge Module Substitutions

  1. In the Merge Module Substitutions Manager, select the row you would like to delete by using the Row Selector.
  2. Press the <Del> key on your keyboard, or click the Delete button on the options panel.

Merge Module Substitution Field Reference

The table below details each field that makes up a Merge Module Substitution record and provides a description of the usage of each field.

Field Name | Req'd | Description
Table | Y | Specifies the name of the Merge Module Table used in the Substitution.
Column | Y | Specifies the name of the Column used in the Substitution.
Row | Y | Specifies the Primary Key which uniquely identifies the row used in this Substitution. Multi-column keys are specified by delimiting the keys with semicolons (";"). Literal semicolons can be escaped with backslashes ("\") .
Value | Y | Specifies a string that provides a formatting template used with this Substitution. When a substitution string of the form "[=ItemA]" is encountered, the string, including the bracket characters, is replaced by the value for the Configurable Item "ItemA". At merge time, if the merge tool declines to provide a value for any item in a replacement string, the default value provided by the Configurable Item is substituted. If a string references a Configurable Item not present in the Merge Module, the merge fails.
Created | N/A | Indicates the date/time that this record was created. Read-Only.
Modified | N/A | Indicates the date/time that this record was last modified. Read-Only.
Author | N/A | Indicates the logged on user name of the user who created or modified this record. Read-Only.
Comments | N | Specifies user-defined comments for this record. Comments are strictly for the benefit of the user and and are not included in the build output.

Note:

  • Refer to the Windows Installer doumentation of Configurable Merge Modules for much more valuable information.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Merge Module Substitutions Overview

Merge Module Substitutions are used in conjunction with Configurable Items to define specific fields in the Merge Modules Database which are to have their values changed based on the value of one or more Configurable Items.

The Value field is used to define the entire value of the specified field. To allow the greatest flexibility possible, a special syntax is used to allow a field to be formatted with a mixture of plain text and one or more substituted values. For example, the value "My [=NAMETYPE] Name" indicates that the value provided by the Configurable item "NAMETYPE" will be used to relace "[=NAMETYPE]". If the value provided is "Middle", then the result is that the specified field will contain "My Middle Name".

Note:

  • Nested replacement tags are not allowed For example, "[=A[=B]]" is not allowed.


%%ItemTitle%%

Getting Started

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Welcome to ActiveInstall Help!

Welcome to ActiveInstall Professional Version 1.0!!!

Before you get started, please take a few minutes to read the following information to ensure you get the most out of ActiveInstall and that you know how to provide us with your valuable feedback and suggestions on how we can further improve our products. Check the "What's New?" topic to see what changes have been made since the last version, the "What Is..." topic to learn more about ActiveInstall, and the "Technical Support" topic to find out what to do when you need a little help!

Getting Started

Realizing that it can be difficult to get started, we have created a walkthrough that takes you through the process of creating a simple but functional installation. Use this as a starting point for evaluating ActiveInstall and you'll find it starting to make a whole lot more sense!

View the Walkthrough

Feedback

We need to hear from you not only when you have questions or run into problems, but also anytime you have any thoughts about the application. We'll take feedback whether it's good, bad or indifferent!

Tell us what you think by sending e-mail to feedback@activeinstall.com or by visiting our community Message Boards on our website at http://www.activeinstall.com.

See Also

Getting Started

Copyright © ActiveInstall Corp., 2002. All Rights Reserved.


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Advanced Settings

Custom Tables

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Custom Tables

Post-Build SQL

Control Strings are small snippets of localized strings used by the Windows Installer Engine when rendering text in controls which is not specified elsewhere.

Manage Post-Build SQL


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Merge Module Settings

Merge Module Relationships

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Merge Module Relationships

Merge Module Configurable Options

Control Strings are small snippets of localized strings used by the Windows Installer Engine when rendering text in controls which is not specified elsewhere.

Manage Merge Module Configurable Options

Merge Module Substitution

Message Strings provide a special formatting template used by Windows Installer when processing errors or special messages.

Manage Merge Module Substitutions


%%ItemTitle%%

Project Summary | Installer Settings | System Settings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Package Settings

Feature Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Action Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Resource Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Dialog Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Action Sequence Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Property Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Merge Module Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

See Also

Project Summary | Installer Settings | System Settings


%%ItemTitle%%

ActiveInstall Online Documentation Send Feedback on this topic.

Project Settings

Path Variable Manager

Path Variables are - well - variables that represent paths on your development system. If you plan to move your project or your projects source files around, then using Path Variables will be a great friend in minimizing the impact on your installation projects.

Manage Path Variables

Release Manager

The Release Manager view allows you to create and configure settings related to what is included in your project, and how it should be built.

Manage Releases

Localization Manager

The Localization Manager allows you to create and configure languages used in your project. This view also allows yo to manage localized strings for each language in your project.

Manage Localization


%%ItemTitle%%

Package Settings | Installer Settings | System Settings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

Project Summary

This page will display summary statistics for the current project.

Project Statistics

Features: 3

Components: 43

Files: 72

...

Current Alert Status:

No Alerts!

<Project Name> To Do List:

See Also

Package Settings | Installer Settings | System Settings


%%ItemTitle%%

Project Summary | Package Settings | Installer Settings

See Also ActiveInstall Online Documentation Send Feedback on this topic.

System Settings

File System Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

Shortcuts Manager

Control Strings are small snippets of localized strings used by the Windows Installer Engine when rendering text in controls which is not specified elsewhere.

Manage Control Strings

Associations Manager

Message Strings provide a special formatting template used by Windows Installer when processing errors or special messages.

Manage Message Strings

Registry Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

COM Resources Manager

Control Strings are small snippets of localized strings used by the Windows Installer Engine when rendering text in controls which is not specified elsewhere.

Manage Control Strings

ODBC Resources Manager

Message Strings provide a special formatting template used by Windows Installer when processing errors or special messages.

Manage Message Strings

System Service Manager

Action Strings are small snippets of text to be displayed in progress dialogs and written to the installation's log file for actions that take a long time to execute. The text displayed consists of the Action's description and optionally formatted data from the action.

Manage Action Strings

See Also

Project Summary | Package Settings | Installer Settings